clutter-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301
  1. %define clutter_version 1.6.10
  2. %define clutter_release 1%{?_dist_release}
  3. Name: clutter
  4. Version: %{clutter_version}
  5. Release: %{clutter_release}
  6. Summary: Open Source software library for creating rich graphical user interfaces
  7. Summary(ja): リッチなGUIを作成するためのオープンソースライブラリ
  8. Group: System Environment/Libraries
  9. License: LGPLv2+
  10. URL: http://www.clutter-project.org/
  11. Source0: http://www.clutter-project.org/sources/%{name}/1.6/%{name}-%{version}.tar.bz2
  12. # http://bugzilla.openedhand.com/show_bug.cgi?id=2100
  13. Patch0: Use-a-native-format-for-atlas-textures.patch
  14. # http://bugzilla.clutter-project.org/show_bug.cgi?id=2324
  15. Patch1: cogl-x11-Trap-glXDestroyPixmap.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Requires: gobject-introspection
  18. # FIXME to remove when all the bits have been merged into their
  19. # libraries
  20. BuildRequires: glib2-devel
  21. BuildRequires: mesa-libGL-devel
  22. BuildRequires: gdk-pixbuf2-devel
  23. BuildRequires: atk-devel
  24. BuildRequires: pkgconfig
  25. BuildRequires: pango-devel
  26. BuildRequires: libXdamage-devel
  27. BuildRequires: libXcomposite-devel
  28. BuildRequires: libXi-devel
  29. BuildRequires: gettext
  30. BuildRequires: gtk-doc
  31. BuildRequires: gobject-introspection-devel >= 0.9.5
  32. BuildRequires: json-glib-devel
  33. %description
  34. Clutter is an open source software library for creating fast,
  35. visually rich graphical user interfaces. The most obvious example
  36. of potential usage is in media center type applications.
  37. We hope however it can be used for a lot more.
  38. %description -l ja
  39. Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
  40. 最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
  41. しかしながら、我々はいろいろな分野で使用されることを願っています。
  42. %package devel
  43. Summary: Clutter development environment
  44. Summary(ja): Clutterの開発環境
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
  48. Requires: mesa-libGL-devel
  49. Requires: gobject-introspection-devel
  50. Requires: json-glib-devel
  51. %description devel
  52. Header files and libraries for building a extension library for the
  53. clutter
  54. %package doc
  55. Summary: Documentation for %{name}
  56. Summary(ja): %{name}用のドキュメント
  57. Group: Documentation
  58. Requires: %{name} = %{version}-%{release}
  59. %description doc
  60. Clutter is an open source software library for creating fast,
  61. visually rich graphical user interfaces. The most obvious example
  62. of potential usage is in media center type applications.
  63. We hope however it can be used for a lot more.
  64. This package contains documentation for clutter.
  65. %prep
  66. %setup -q
  67. #%patch0 -p0 -b .atlas-textures
  68. #%patch1 -p1 -b .glXDestroyPixmap
  69. %build
  70. #%configure --enable-gtk-doc \
  71. # --enable-introspection=yes \
  72. # --disable-silent-rules \
  73. # --enable-xinput \
  74. # --disable-static
  75. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  76. %configure $CONFIGFLAGS \
  77. --enable-introspection=yes \
  78. --disable-silent-rules \
  79. --enable-xinput \
  80. --disable-static
  81. # clutter git ships with some magic to put the git log in shipped tarballs
  82. # which gets listed in files; don't blow up if it's missing
  83. if ! test -f ChangeLog; then
  84. echo "Created from snapshot" > ChangeLog
  85. fi
  86. )
  87. make V=0
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. #make DESTDIR=$RPM_BUILD_ROOT install
  91. make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %files
  97. %defattr(-,root,root,-)
  98. %doc AUTHORS COPYING NEWS README
  99. %exclude %{_libdir}/*.la
  100. %{_libdir}/*.so.0
  101. %{_libdir}/*.so.0.*
  102. %{_libdir}/girepository-1.0/*.typelib
  103. %{_datadir}/locale/*/LC_MESSAGES/*
  104. %files devel
  105. %defattr(-, root, root)
  106. %doc ChangeLog
  107. %{_includedir}/*
  108. %{_libdir}/*.so
  109. %{_libdir}/pkgconfig/*.pc
  110. %{_datadir}/gir-1.0/*.gir
  111. %files doc
  112. %defattr(-, root, root)
  113. %{_datadir}/gtk-doc/html/clutter
  114. %{_datadir}/gtk-doc/html/cogl
  115. %{_datadir}/gtk-doc/html/cally
  116. %changelog
  117. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
  118. - new upstream release
  119. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
  120. - new upstream release
  121. * Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
  122. - new upstream release
  123. * Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
  124. - new upstream release
  125. - change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
  126. - add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
  127. - drop Patch0
  128. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  129. - new upstream release
  130. - drop Patch1
  131. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  132. - new upstream release
  133. - add BuildRequires: json-glib-devel
  134. - delete Requires: gir-repository
  135. - delete BuildRequires: gir-repository-devel
  136. - add Requires: json-glib-devel (devel package)
  137. - add Patch0, Patch1
  138. - fix %build
  139. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
  140. - rebuild with rpm-4.8.1 for pkg-config file
  141. * Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
  142. - new upstream release
  143. * Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
  144. - new upstream release
  145. * Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  146. - new upstream release
  147. - add configure option (--enable-xinput)
  148. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
  149. - new upstream release
  150. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  151. - new upstream release
  152. * Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  153. - new upstream release
  154. * Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  155. - new upstream release
  156. * Tue Dec 1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  157. - new upstream release
  158. - build for Vine Linux
  159. - add Summary(ja)
  160. - fix BuildRoot
  161. - remove Obsolete and Provides
  162. * Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
  163. - Update to 1.0.6
  164. * Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
  165. - Update to 1.0.4, update gobject-introspection requirement
  166. * Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
  167. - Update to 1.0.2
  168. * Sun Aug 1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
  169. - Move ChangeLog to -devel to save some space
  170. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
  171. - Drop the gir-repository-devel dep, which pulls a bunch of -devel
  172. onto the live cd
  173. * Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
  174. - Update to 1.0.0
  175. * Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
  176. - fix bz #507389
  177. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
  178. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  179. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
  180. - Update to 0.9.8
  181. * Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
  182. - Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
  183. introspection support to clutter (#512260)
  184. * Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
  185. - Update to 0.9.6
  186. * Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
  187. - Update to 0.9.4
  188. * Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
  189. - Update to 0.9.2
  190. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  192. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
  193. - Remove noarch from doc subpackage
  194. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
  195. - Added gtk-doc for cogl
  196. - Created doc subpackage
  197. * Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
  198. - Update to 0.8.6
  199. * Mon Oct 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
  200. - Update to 0.8.2
  201. - Removed clutter-0.8.0-clutter-fixed.patch
  202. * Sat Sep 6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
  203. - Update to 0.8.0
  204. - Added clutter-0.8.0-clutter-fixed.patch
  205. * Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
  206. - Update to 0.6.4
  207. * Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
  208. - Update to 0.6.2
  209. * Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
  210. - Update to 0.6.0
  211. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  212. - Autorebuild for GCC 4.3
  213. * Wed Oct 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
  214. - Update to 0.4.2
  215. * Mon Sep 3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
  216. - Update to 0.4.1
  217. * Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
  218. - Update to 0.3.1
  219. * Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
  220. - Update to 0.2.3
  221. * Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
  222. - Changed buildrequires and requires
  223. * Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
  224. - Fix .spec
  225. * Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
  226. - Fix .spec
  227. * Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
  228. - Initial RPM release