perl-Class-Singleton-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. Name: perl-Class-Singleton
  2. Version: 1.4
  3. Release: 6%{?_dist_release}
  4. Summary: Implementation of a "Singleton" class
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Class-Singleton/
  8. Source0: http://www.cpan.org/authors/id/A/AB/ABW/Class-Singleton-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. BuildRequires: perl(ExtUtils::MakeMaker)
  12. BuildRequires: perl(Test::More)
  13. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  14. %description
  15. This is the Class::Singleton module. A Singleton describes an object class
  16. that can have only one instance in any system. An example of a Singleton
  17. might be a print spooler or system registry. This module implements a
  18. Singleton class from which other classes can be derived. By itself, the
  19. Class::Singleton module does very little other than manage the
  20. instantiation of a single object. In deriving a class from
  21. Class::Singleton, your module will inherit the Singleton instantiation
  22. method and can implement whatever specific functionality is required.
  23. %prep
  24. %setup -q -n Class-Singleton-%{version}
  25. %build
  26. %{__perl} Makefile.PL INSTALLDIRS=vendor
  27. make %{?_smp_mflags}
  28. %install
  29. rm -rf $RPM_BUILD_ROOT
  30. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  31. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
  32. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
  33. %{_fixperms} $RPM_BUILD_ROOT/*
  34. %check
  35. make test
  36. %clean
  37. rm -rf $RPM_BUILD_ROOT
  38. %files
  39. %defattr(-,root,root,-)
  40. %doc Changes README
  41. %{perl_vendorlib}/*
  42. %{_mandir}/man3/*
  43. %changelog
  44. * Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-6
  45. - initial build for Vine Linux
  46. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-5
  47. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  48. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-4
  49. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  50. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.4-3
  51. - Rebuild for perl 5.10 (again)
  52. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4-2
  53. - rebuild for new perl
  54. * Mon Oct 15 2007 Steven Pritchard <steve@kspei.com> 1.4-1
  55. - Update to 1.4.
  56. - Update License tag.
  57. - Drop our copy of the license text.
  58. - Improve Summary.
  59. - Make description match cpanspec output.
  60. - BR Test::More.
  61. * Tue Apr 17 2007 Steven Pritchard <steve@kspei.com> 1.03-4
  62. - Use fixperms macro instead of our own chmod incantation.
  63. - BR ExtUtils::MakeMaker.
  64. * Sat Sep 16 2006 Steven Pritchard <steve@kspei.com> 1.03-3
  65. - Canonicalize Source0 URL.
  66. - Fix find option order.
  67. * Thu Sep 08 2005 Steven Pritchard <steve@kspei.com> 1.03-2
  68. - Fix permissions on Singleton.pm.
  69. * Wed Aug 31 2005 Steven Pritchard <steve@kspei.com> 1.03-1
  70. - Specfile autogenerated.