rubber-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. # sitelib for noarch packages, sitearch for others (remove the unneeded one)
  2. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  3. Name: rubber
  4. Version: 1.1
  5. Release: 1%{?_dist_release}
  6. Summary: An automated system for building LaTeX documents
  7. Group: Applications/Publishing
  8. License: GPL+
  9. URL: http://rubber.sourceforge.net/
  10. Source0: http://rubber.sourceforge.net/%{name}-%{version}.tar.gz
  11. Patch0: rubber-python26.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: python-devel texinfo
  15. Requires: texlive
  16. Requires(post): /sbin/install-info
  17. Requires(preun): /sbin/install-info
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. This is a building system for LaTeX documents. It is based on a routine that
  22. runs just as many compilations as necessary. The module system provides a
  23. great flexibility that virtually allows support for any package with no user
  24. intervention, as well as pre- and post-processing of the document. The
  25. standard modules currently provide support for bibtex, dvips, dvipdfm, pdftex,
  26. makeindex. A good number of standard packages are supported, including
  27. graphics/graphicx (with automatic conversion between various formats and
  28. Metapost compilation).
  29. %prep
  30. %setup -q
  31. %patch0 -p1
  32. for file in doc/man-fr/*; do
  33. iconv -f ISO88591 -t utf8 $file -o $file
  34. done
  35. %build
  36. %configure
  37. %{__make} %{?_smp_mflags}
  38. %install
  39. %{__rm} -fr %{buildroot}
  40. %{__python} setup.py install --root %{buildroot}
  41. %clean
  42. %{__rm} -fr %{buildroot}
  43. %post
  44. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  45. %preun
  46. if [ $1 = 0 ]; then
  47. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
  48. fi
  49. %files
  50. %defattr(-,root,root,-)
  51. %doc COPYING NEWS README
  52. %{_bindir}/*
  53. %{_datadir}/rubber
  54. %{_datadir}/info/*
  55. %{python_sitelib}/*
  56. %{_mandir}/man1/*.gz
  57. %{_mandir}/fr/man1/*.gz
  58. %changelog
  59. * Mon Oct 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1-1
  60. - initial build for Vine Linux
  61. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  62. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  63. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com>
  64. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  65. * Mon Dec 28 2009 Sergio Pascual <sergiopr@fedoraproject.org>
  66. - Adding virtual dependency on latex (bz #550792)
  67. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  68. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  69. * Mon Jun 15 2009 Sergio Pascual <sergiopr@fedoraproject.org>
  70. - Patch to remove a Deprecation Warning in Python 2.6 (bz #506053)
  71. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  73. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com>
  74. - Rebuild for Python 2.6
  75. * Wed Sep 17 2008 Sergio Pascual <sergiopr@fedoraproject.org>
  76. - ***
  77. * Wed Sep 17 2008 Sergio Pascual <sergiopr@fedoraproject.org>
  78. - Initial specfile