rust-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843
  1. %bcond_with bootstrap
  2. %bcond_with test
  3. %bcond_without clang
  4. %bcond_without bundled_libgit2
  5. %bcond_without bundled_libssh2
  6. # Some sub-packages are versioned independently of the rust compiler and runtime itself.
  7. # Also beware that if any of these are not changed in a version bump, then the release
  8. # number should still increase, not be reset to 1!
  9. %global rustc_version 1.38.0
  10. %global cargo_version %{rustc_version}
  11. %global rustfmt_version %{rustc_version}
  12. %global rls_version %{rustc_version}
  13. %global clippy_version %{rustc_version}
  14. %global llvm_major 9
  15. # The channel can be stable, beta, or nightly
  16. %{!?channel: %global channel stable}
  17. # Only x86_64 and i686 are Tier 1 platforms at this time.
  18. # https://forge.rust-lang.org/platform-support.html
  19. %global rust_arches x86_64 i686
  20. # To bootstrap from scratch, set the channel and date from src/stage0.txt
  21. # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
  22. # or nightly wants some beta-YYYY-MM-DD
  23. %global bootstrap_rust 1.37.0
  24. %global bootstrap_cargo 1.37.0
  25. %global bootstrap_channel %{bootstrap_rust}
  26. # Only the specified arches will use bootstrap binaries.
  27. %if %{with bootstrap}
  28. %global bootstrap_arches %%{rust_arches}
  29. %endif
  30. # We generally don't want llvm-static present at all, since llvm-config will
  31. # make us link statically. But we can opt in, e.g. to aid LLVM rebases.
  32. # FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
  33. # *want* static we'll have to force it with "llvm-config --link-static".
  34. # See also https://github.com/rust-lang/rust/issues/36854
  35. # The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
  36. %bcond_with llvm_static
  37. # We can also choose to just use Rust's bundled LLVM, in case the system LLVM
  38. # is insufficient. Rust currently requires LLVM 3.7+.
  39. %bcond_with bundled_llvm
  40. # LLDB only works on some architectures
  41. %ifarch %{arm} aarch64 %{ix86} x86_64
  42. # LLDB isn't available everywhere...
  43. %bcond_without lldb
  44. %else
  45. %bcond_with lldb
  46. %endif
  47. Name: rust
  48. Version: %{rustc_version}
  49. Release: 1%{?_dist_release}
  50. Summary: The Rust Programming Language
  51. License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
  52. # ^ written as: (rust itself) and (bundled libraries)
  53. URL: https://www.rust-lang.org
  54. ExclusiveArch: %{rust_arches}
  55. Vendor: Project Vine
  56. Distribution: Vine Linux
  57. %if "%{channel}" == "stable"
  58. %global rustc_package rustc-%{version}-src
  59. %else
  60. %global rustc_package rustc-%{channel}-src
  61. %endif
  62. Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
  63. # Get the Rust triple for any arch.
  64. %{lua: function rust_triple(arch)
  65. local abi = "gnu"
  66. if arch == "armv7hl" then
  67. arch = "armv7"
  68. abi = "gnueabihf"
  69. elseif arch == "ppc64" then
  70. arch = "powerpc64"
  71. elseif arch == "ppc64le" then
  72. arch = "powerpc64le"
  73. end
  74. return arch.."-unknown-linux-"..abi
  75. end}
  76. %global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
  77. %if %defined bootstrap_arches
  78. # For each bootstrap arch, add an additional binary Source.
  79. # Also define bootstrap_source just for the current target.
  80. %{lua: do
  81. local bootstrap_arches = {}
  82. for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
  83. table.insert(bootstrap_arches, arch)
  84. end
  85. local base = rpm.expand("https://static.rust-lang.org/dist"
  86. .."/rust-%{bootstrap_channel}")
  87. local target_arch = rpm.expand("%{_target_cpu}")
  88. for i, arch in ipairs(bootstrap_arches) do
  89. print(string.format("Source%d: %s-%s.tar.gz\n",
  90. i, base, rust_triple(arch)))
  91. if arch == target_arch then
  92. rpm.define("bootstrap_source "..i)
  93. end
  94. end
  95. end}
  96. %endif
  97. %ifarch %{bootstrap_arches}
  98. %global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
  99. %global local_rust_root %{_builddir}/%{bootstrap_root}/usr
  100. Provides: bundled(%{name}-bootstrap) = %{bootstrap_rust}
  101. %else
  102. BuildRequires: cargo >= %{bootstrap_cargo}
  103. BuildRequires: %{name} >= %{bootstrap_rust}
  104. BuildConflicts: %{name} > %{version}
  105. %global local_rust_root %{_prefix}
  106. %endif
  107. BuildRequires: cmake
  108. BuildRequires: make
  109. %if %{with clang}
  110. BuildRequires: clang
  111. BuildRequires: lld
  112. %else
  113. BuildRequires: gcc
  114. BuildRequires: gcc-c++
  115. %endif
  116. %if %{without bundled_libgit2}
  117. BuildRequires: libgit2-devel
  118. %endif
  119. %if %{without bundled_libssh2}
  120. BuildRequires: libssh2-devel
  121. %endif
  122. BuildRequires: ncurses-devel
  123. BuildRequires: openssl-devel
  124. BuildRequires: zlib-devel
  125. BuildRequires: python3
  126. BuildRequires: python3-rpm-macros
  127. BuildRequires: curl
  128. BuildRequires: curl-devel
  129. BuildRequires: xz-devel
  130. %if %{with bundled_llvm}
  131. BuildRequires: cmake
  132. BuildRequires: git
  133. Provides: bundled(llvm) = 6.0
  134. %else
  135. %if %defined llvm
  136. %global llvm_root %{_libdir}/%{llvm}
  137. %else
  138. %global llvm llvm
  139. %global llvm_root %{_prefix}
  140. %endif
  141. BuildRequires: %{llvm}-devel >= 7.0.0
  142. %if %{with llvm_static}
  143. BuildRequires: %{llvm}-static
  144. BuildRequires: libffi-devel
  145. %else
  146. # Make sure llvm-config doesn't see it.
  147. Requires: %{llvm}%{llvm_major}-libs
  148. BuildConflicts: %{llvm}-static
  149. %endif
  150. %endif
  151. # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
  152. BuildRequires: procps
  153. # debuginfo-gdb tests need gdb
  154. BuildRequires: gdb
  155. # TODO: work on unbundling these!
  156. Provides: bundled(jquery) = 2.1.4
  157. Provides: bundled(miniz) = 1.14
  158. # Virtual provides for folks who attempt "dnf install rustc"
  159. Provides: rustc = %{version}-%{release}
  160. Provides: rustc%{?_isa} = %{version}-%{release}
  161. # Always require our exact standard library
  162. Requires: %{name}-std-static%{?_isa} = %{version}-%{release}
  163. # The C compiler is needed at runtime just for linking. Someday rustc might
  164. # invoke the linker directly, and then we'll only need binutils.
  165. # https://github.com/rust-lang/rust/issues/11937
  166. Requires: /usr/bin/cc
  167. # ALL Rust libraries are private, because they don't keep an ABI.
  168. %global _privatelibs lib.*-[[:xdigit:]]*[.]so.*
  169. %global __provides_exclude ^(%{_privatelibs})$
  170. %global __requires_exclude ^(%{_privatelibs})$
  171. %global __provides_exclude_from ^%{_docdir}/.*$
  172. %global __requires_exclude_from ^%{_docdir}/.*$
  173. # While we don't want to encourage dynamic linking to Rust shared libraries, as
  174. # there's no stable ABI, we still need the unallocated metadata (.rustc) to
  175. # support custom-derive plugins like #[proc_macro_derive(Foo)]. But eu-strip is
  176. # very eager by default, so we have to limit it to -g, only debugging symbols.
  177. %if 0%{?fedora} >= 27
  178. # Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
  179. %global _find_debuginfo_opts --keep-section .rustc
  180. %else
  181. %global _find_debuginfo_opts -g
  182. %undefine _include_minidebuginfo
  183. %endif
  184. # Use hardening ldflags.
  185. %global rustflags -Clink-arg=-Wl,-z,relro,-z,now
  186. %if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
  187. # https://github.com/rust-lang/rust/issues/40717
  188. %global library_path $(%{llvm_root}/bin/llvm-config --libdir)
  189. %endif
  190. %description
  191. Rust is a systems programming language that runs blazingly fast, prevents
  192. segfaults, and guarantees thread safety.
  193. This package includes the Rust compiler and documentation generator.
  194. %package std-static
  195. Summary: Standard library for Rust
  196. %description std-static
  197. This package includes the standard libraries for building applications
  198. written in Rust.
  199. %package debugger-common
  200. Summary: Common debugger pretty printers for Rust
  201. BuildArch: noarch
  202. %description debugger-common
  203. This package includes the common functionality for %{name}-gdb and %{name}-lldb.
  204. %package gdb
  205. Summary: GDB pretty printers for Rust
  206. BuildArch: noarch
  207. Requires: gdb
  208. Requires: %{name}-debugger-common = %{version}-%{release}
  209. %description gdb
  210. This package includes the rust-gdb script, which allows easier debugging of Rust
  211. programs.
  212. %if %{with lldb}
  213. %package lldb
  214. Summary: LLDB pretty printers for Rust
  215. # It could be noarch, but lldb has limited availability
  216. #BuildArch: noarch
  217. Requires: lldb
  218. Requires: python-lldb
  219. Requires: %{name}-debugger-common = %{version}-%{release}
  220. %description lldb
  221. This package includes the rust-lldb script, which allows easier debugging of Rust
  222. programs.
  223. %endif
  224. %package doc
  225. Summary: Documentation for Rust
  226. # NOT BuildArch: noarch
  227. # Note, while docs are mostly noarch, some things do vary by target_arch.
  228. # Koji will fail the build in rpmdiff if two architectures build a noarch
  229. # subpackage differently, so instead we have to keep its arch.
  230. %description doc
  231. This package includes HTML documentation for the Rust programming language and
  232. its standard library.
  233. %package -n cargo
  234. Summary: Rust's package manager and build tool
  235. Version: %{cargo_version}
  236. # For tests:
  237. BuildRequires: git
  238. # Cargo is not much use without Rust
  239. Requires: rust
  240. %description -n cargo
  241. Cargo is a tool that allows Rust projects to declare their various dependencies
  242. and ensure that you'll always get a repeatable build.
  243. %package -n cargo-doc
  244. Summary: Documentation for Cargo
  245. Version: %{cargo_version}
  246. BuildArch: noarch
  247. # Cargo no longer builds its own documentation
  248. # https://github.com/rust-lang/cargo/pull/4904
  249. Requires: rust-doc = %{rustc_version}-%{release}
  250. %description -n cargo-doc
  251. This package includes HTML documentation for Cargo.
  252. %package -n rustfmt
  253. Summary: Tool to find and fix Rust formatting issues
  254. Version: %{rustfmt_version}
  255. Requires: cargo
  256. Obsoletes: rustfmt-preview < 1.0.0
  257. %description -n rustfmt
  258. A tool for formatting Rust code according to style guidelines.
  259. %package -n rls
  260. Summary: Rust Language Server for IDE integration
  261. Version: %{rls_version}
  262. Requires: rust-analysis
  263. # /usr/bin/rls is dynamically linked against internal rustc libs
  264. Requires: %{name} = %{rustc_version}-%{release}
  265. Obsoletes: rls-preview < 1.0.0
  266. %description -n rls
  267. The Rust Language Server provides a server that runs in the background,
  268. providing IDEs, editors, and other tools with information about Rust programs.
  269. It supports functionality such as 'goto definition', symbol search,
  270. reformatting, and code completion, and enables renaming and refactorings.
  271. %package -n clippy
  272. Summary: Lints to catch common mistakes and improve your Rust code
  273. Version: %{clippy_version}
  274. License: MPLv2.0
  275. Requires: cargo
  276. # /usr/bin/clippy-driver is dynamically linked against internal rustc libs
  277. Requires: %{name} = %{rustc_version}-%{release}
  278. Obsoletes: clippy-preview < 1.0.0
  279. %description -n clippy
  280. A collection of lints to catch common mistakes and improve your Rust code.
  281. %package src
  282. Summary: Sources for the Rust standard library
  283. BuildArch: noarch
  284. %description src
  285. This package includes source files for the Rust standard library. It may be
  286. useful as a reference for code completion tools in various editors.
  287. %package analysis
  288. Summary: Compiler analysis data for the Rust standard library
  289. Requires: rust-std-static = %{rustc_version}-%{release}
  290. %description analysis
  291. This package contains analysis data files produced with rustc's -Zsave-analysis
  292. feature for the Rust standard library. The RLS (Rust Language Server) uses this
  293. data to provide information about the Rust standard library.
  294. %prep
  295. %ifarch %{bootstrap_arches}
  296. %setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
  297. ./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
  298. --prefix=%{local_rust_root} --disable-ldconfig
  299. test -f '%{local_rust_root}/bin/cargo'
  300. test -f '%{local_rust_root}/bin/rustc'
  301. %endif
  302. %setup -q -n %{rustc_package}
  303. %if "%{python}" == "python3"
  304. sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
  305. %endif
  306. %if %without bundled_llvm
  307. rm -rf src/llvm-project/
  308. %endif
  309. # We never enable emscripten.
  310. rm -rf src/llvm-emscripten/
  311. # Remove other unused vendored libraries
  312. #rm -rf vendor/curl-sys/curl/
  313. rm -rf vendor/jemalloc-sys/jemalloc/
  314. rm -rf vendor/libz-sys/src/zlib/
  315. rm -rf vendor/lzma-sys/xz-*/
  316. rm -rf vendor/openssl-src/openssl/
  317. %if %{without bundled_libgit2}
  318. rm -rf vendor/libgit2-sys/libgit2/
  319. %endif
  320. %if %{without bundled_libssh2}
  321. rm -rf vendor/libssh2-sys/libssh2/
  322. %endif
  323. # This only affects the transient rust-installer, but let it use our dynamic xz-libs
  324. sed -i.lzma -e '/LZMA_API_STATIC/d' src/bootstrap/tool.rs
  325. # rename bundled license for packaging
  326. if [ -e vendor/backtrace-sys/src/libbacktrace/LICENSE ]; then
  327. cp -a vendor/backtrace-sys/src/libbacktrace/LICENSE{,-libbacktrace}
  328. fi
  329. %if %{with bundled_llvm} && 0%{?epel}
  330. mkdir -p cmake-bin
  331. ln -s /usr/bin/cmake cmake-bin/cmake
  332. %global cmake_path $PWD/cmake-bin
  333. %endif
  334. %if %{without bundled_llvm} && %{with llvm_static}
  335. # Static linking to distro LLVM needs to add -lffi
  336. # https://github.com/rust-lang/rust/issues/34486
  337. sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
  338. src/librustc_llvm/lib.rs
  339. %endif
  340. # The configure macro will modify some autoconf-related files, which upsets
  341. # cargo when it tries to verify checksums in those files. If we just truncate
  342. # that file list, cargo won't have anything to complain about.
  343. find vendor -name .cargo-checksum.json \
  344. -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
  345. %build
  346. %if %{without bundled_libgit2}
  347. export LIBGIT2_SYS_USE_PKG_CONFIG=1
  348. %endif
  349. %if %{without bundled_libssh2}
  350. export LIBSSH2_SYS_USE_PKG_CONFIG=1
  351. %endif
  352. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  353. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  354. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  355. # We're going to override --libdir when configuring to get rustlib into a
  356. # common path, but we'll fix the shared libraries during install.
  357. %global common_libdir %{_prefix}/lib
  358. %global rustlibdir %{common_libdir}/rustlib
  359. %ifarch x86_64
  360. %define enable_debuginfo --debuginfo-level=0 --debuginfo-level-std=2
  361. %else
  362. %define enable_debuginfo --debuginfo-level=0
  363. %endif
  364. %if %{with clang}
  365. export CC=clang
  366. export CXX=clang++
  367. export LDFLAGS="$LDFLAGS -fuse-ld=lld"
  368. export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
  369. %endif
  370. %configure \
  371. --disable-option-checking \
  372. --libdir=%{common_libdir} \
  373. --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
  374. --enable-local-rust --local-rust-root=%{local_rust_root} \
  375. %{!?with_bundled_llvm: --llvm-root=%{llvm_root} --disable-codegen-tests \
  376. %{!?with_llvm_static: --enable-llvm-link-shared } } \
  377. --disable-rpath \
  378. %{enable_debuginfo} \
  379. --enable-extended \
  380. --enable-vendor \
  381. --enable-verbose-tests \
  382. --set rust.codegen-units-std=1 \
  383. --release-channel=%{channel}
  384. RUST_BACKTRACE=1 %{__python3} ./x.py build
  385. %{__python3} ./x.py doc
  386. %install
  387. rm -rf %{buildroot}
  388. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  389. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  390. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  391. %if %{with clang}
  392. export CC=clang
  393. export CXX=clang++
  394. export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
  395. %endif
  396. DESTDIR=%{buildroot} ./x.py install
  397. #DESTDIR=%{buildroot} ./x.py install src
  398. # Make sure the shared libraries are in the proper libdir
  399. %if "%{_libdir}" != "%{common_libdir}"
  400. mkdir -p %{buildroot}%{_libdir}
  401. find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
  402. -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
  403. %endif
  404. # The shared libraries should be executable for debuginfo extraction.
  405. find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
  406. -exec chmod -v +x '{}' '+'
  407. # The libdir libraries are identical to those under rustlib/. It's easier on
  408. # library loading if we keep them in libdir, but we do need them in rustlib/
  409. # to support dynamic linking for compiler plugins, so we'll symlink.
  410. (cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
  411. find ../../../../%{_lib} -maxdepth 1 -name '*.so' |
  412. while read lib; do
  413. # make sure they're actually identical!
  414. cmp "$lib" "${lib##*/}"
  415. ln -v -f -s -t . "$lib"
  416. done)
  417. # Remove installer artifacts (manifests, uninstall scripts, etc.)
  418. find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
  419. # Remove backup files from %%configure munging
  420. find %{buildroot}%{rustlibdir} -type f -name '*.orig' -exec rm -v '{}' '+'
  421. # https://fedoraproject.org/wiki/Changes/Make_ambiguous_python_shebangs_error
  422. # We don't actually need to ship any of those python scripts in rust-src anyway.
  423. find %{buildroot}%{rustlibdir}/src -type f -name '*.py' -exec rm -v '{}' '+'
  424. # FIXME: __os_install_post will strip the rlibs
  425. # -- should we find a way to preserve debuginfo?
  426. # Remove unwanted documentation files (we already package them)
  427. # Remove unwanted documentation files (we already package them)
  428. rm -f %{buildroot}%{_docdir}/%{name}/README.md
  429. rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
  430. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE
  431. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
  432. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
  433. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-THIRD-PARTY
  434. rm -f %{buildroot}%{_docdir}/%{name}/*.old
  435. # Sanitize the HTML documentation
  436. find %{buildroot}%{_docdir}/%{name}/html -empty -delete
  437. find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
  438. # Create the path for crate-devel packages
  439. mkdir -p %{buildroot}%{_datadir}/cargo/registry
  440. # Cargo no longer builds its own documentation
  441. # https://github.com/rust-lang/cargo/pull/4904
  442. mkdir -p %{buildroot}%{_docdir}/cargo
  443. ln -sT ../rust/html/cargo/ %{buildroot}%{_docdir}/cargo/html
  444. %if %{without lldb}
  445. rm -f %{buildroot}%{_bindir}/rust-lldb
  446. rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
  447. %endif
  448. %if %{with bundled_llvm}
  449. rm -rf %{buildroot}/home
  450. %endif
  451. %check
  452. %if %{with test}
  453. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  454. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  455. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  456. %if %{with clang}
  457. export CC=clang
  458. export CXX=clang++
  459. export LD=ld.lld
  460. export RUSTFLAGS="$RUSTFLAGS -C linker=ld.lld -C link-arg=-fuse-ld=lld"
  461. %endif
  462. # The results are not stable on koji, so mask errors and just log it.
  463. %{__python} ./x.py test --no-fail-fast || :
  464. %{__python} ./x.py test --no-fail-fast cargo || :
  465. %{__python} ./x.py test --no-fail-fast clippy || :
  466. %{__python} ./x.py test --no-fail-fast rls || :
  467. %{__python} ./x.py test --no-fail-fast rustfmt || :
  468. %endif
  469. %post -p /sbin/ldconfig
  470. %postun -p /sbin/ldconfig
  471. %files
  472. %license COPYRIGHT LICENSE-APACHE LICENSE-MIT
  473. #license src/libbacktrace/LICENSE-libbacktrace
  474. %doc README.md
  475. %{_bindir}/rustc
  476. %{_bindir}/rustdoc
  477. %{_libdir}/*.so
  478. %{_mandir}/man1/rustc.1*
  479. %{_mandir}/man1/rustdoc.1*
  480. %dir %{rustlibdir}
  481. %dir %{rustlibdir}/%{rust_triple}
  482. %dir %{rustlibdir}/%{rust_triple}/lib
  483. %{rustlibdir}/%{rust_triple}/lib/*.so
  484. %{rustlibdir}/%{rust_triple}/codegen-backends/
  485. %exclude %{_bindir}/*miri
  486. %files std-static
  487. %dir %{rustlibdir}
  488. %dir %{rustlibdir}/%{rust_triple}
  489. %dir %{rustlibdir}/%{rust_triple}/lib
  490. %{rustlibdir}/%{rust_triple}/lib/*.rlib
  491. %files debugger-common
  492. %dir %{rustlibdir}
  493. %dir %{rustlibdir}/etc
  494. %{rustlibdir}/etc/debugger_*.py*
  495. %files gdb
  496. %{_bindir}/rust-gdb
  497. %{rustlibdir}/etc/gdb_*.py*
  498. %exclude %{_bindir}/rust-gdbgui
  499. %if %with lldb
  500. %files lldb
  501. %{_bindir}/rust-lldb
  502. %{rustlibdir}/etc/lldb_*.py*
  503. %endif
  504. %files doc
  505. %docdir %{_docdir}/%{name}
  506. %dir %{_docdir}/%{name}
  507. %dir %{_docdir}/%{name}/html
  508. %{_docdir}/%{name}/html/*/
  509. %{_docdir}/%{name}/html/*.html
  510. %{_docdir}/%{name}/html/*.css
  511. %{_docdir}/%{name}/html/*.ico
  512. %{_docdir}/%{name}/html/*.js
  513. %{_docdir}/%{name}/html/*.png
  514. %{_docdir}/%{name}/html/*.svg
  515. %{_docdir}/%{name}/html/*.woff
  516. %{_docdir}/%{name}/html/SourceSerifPro-LICENSE.md
  517. %license %{_docdir}/%{name}/html/*.txt
  518. %license %{_docdir}/%{name}/html/*.md
  519. %files -n cargo
  520. %license src/tools/cargo/LICENSE-APACHE src/tools/cargo/LICENSE-MIT src/tools/cargo/LICENSE-THIRD-PARTY
  521. %doc src/tools/cargo/README.md
  522. %{_bindir}/cargo
  523. %{_mandir}/man1/cargo*.1*
  524. %dir %{_sysconfdir}/bash_completion.d
  525. %{_sysconfdir}/bash_completion.d/cargo
  526. %dir %{_datadir}/zsh
  527. %dir %{_datadir}/zsh/site-functions
  528. %{_datadir}/zsh/site-functions/_cargo
  529. %dir %{_datadir}/cargo
  530. %dir %{_datadir}/cargo/registry
  531. %files -n cargo-doc
  532. %docdir %{_docdir}/cargo
  533. %dir %{_docdir}/cargo
  534. %{_docdir}/cargo/html
  535. %files -n rustfmt
  536. %{_bindir}/rustfmt
  537. %{_bindir}/cargo-fmt
  538. %doc src/tools/rustfmt/{README,CHANGELOG,Configurations}.md
  539. %license src/tools/rustfmt/LICENSE-{APACHE,MIT}
  540. %files -n rls
  541. %{_bindir}/rls
  542. %doc src/tools/rls/{README.md,COPYRIGHT,debugging.md}
  543. %license src/tools/rls/LICENSE-{APACHE,MIT}
  544. %files -n clippy
  545. %{_bindir}/cargo-clippy
  546. %{_bindir}/clippy-driver
  547. %doc src/tools/clippy/{README.md,CHANGELOG.md}
  548. %license src/tools/clippy/LICENSE*
  549. %files src
  550. %dir %{rustlibdir}
  551. %{rustlibdir}/src
  552. %files analysis
  553. %{rustlibdir}/%{rust_triple}/analysis/
  554. %changelog
  555. * Sat Sep 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.38.0-1
  556. - new upstream release.
  557. - erased "-preview" from the name of subpackages.
  558. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.30.1-1
  559. - new upstream release.
  560. - dropped Patch1.
  561. - added subpackages cargo, cargo-doc, rustformat-preview, rls-preview, clippy-preview and rust-analysis.
  562. * Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
  563. - Update to 1.23.0 (stable).
  564. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
  565. - initial build for Vine Linux.
  566. - Update to 1.23.0-beta.
  567. - built a bootstrap rpm.
  568. * Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
  569. - Update to 1.22.1.
  570. * Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
  571. - Update to 1.21.0.
  572. * Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
  573. - ABI fixes for ppc64 and s390x.
  574. * Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
  575. - Update to 1.20.0.
  576. - Add a rust-src subpackage.
  577. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
  578. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  579. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
  580. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  581. * Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
  582. - Use find-debuginfo.sh --keep-section .rustc
  583. * Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
  584. - Update to 1.19.0.
  585. * Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
  586. - Update to 1.18.0.
  587. * Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
  588. - Move shared libraries back to libdir and symlink in rustlib
  589. * Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
  590. - Update to 1.17.0.
  591. * Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
  592. - Make rust-lldb arch-specific to deal with lldb deps
  593. * Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
  594. - Limit rust-lldb arches
  595. * Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
  596. - Update to 1.16.0.
  597. - Use rustbuild instead of the old makefiles.
  598. - Update bootstrapping to include rust-std and cargo.
  599. - Add a rust-lldb subpackage.
  600. * Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
  601. - Update to 1.15.1.
  602. - Require rust-rpm-macros for new crate packaging.
  603. - Keep shared libraries under rustlib/, only debug-stripped.
  604. - Merge and clean up conditionals for epel7.
  605. * Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
  606. - Rebuild without bootstrap binaries.
  607. * Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
  608. - Update to 1.14.0.
  609. - Rewrite bootstrap logic to target specific arches.
  610. - Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
  611. * Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
  612. - Update to 1.13.0.
  613. - Use hardening flags for linking.
  614. - Split the standard library into its own package
  615. - Centralize rustlib/ under /usr/lib/ for multilib integration.
  616. * Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
  617. - Update to 1.12.1.
  618. * Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
  619. - Rebuild with LLVM 3.9.
  620. - Add ncurses-devel for llvm-config's -ltinfo.
  621. * Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
  622. - Rebuild with llvm-static, preparing for 3.9
  623. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
  624. - Rebuild with fixed eu-strip (rhbz1380961)
  625. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
  626. - Rebuild without bootstrap binaries.
  627. * Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
  628. - Bootstrap aarch64.
  629. - Use jemalloc's MALLOC_CONF to work around #36944.
  630. - Apply pr36933 to really disable armv7hl NEON.
  631. * Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
  632. - Protect .rustc from rpm stripping.
  633. * Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
  634. - Update to 1.12.0.
  635. - Always use --local-rust-root, even for bootstrap binaries.
  636. - Remove the rebuild conditional - the build system now figures it out.
  637. - Let minidebuginfo do its thing, since metadata is no longer a note.
  638. - Let rust build its own compiler-rt builtins again.
  639. * Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
  640. - Rebuild without bootstrap binaries.
  641. * Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
  642. - Bootstrap armv7hl, with backported no-neon patch.
  643. * Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
  644. - Update to 1.11.0.
  645. - Drop the backported patches.
  646. - Patch get-stage0.py to trust existing bootstrap binaries.
  647. - Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
  648. - Use --local-rust-root to make sure the right bootstrap is used.
  649. * Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
  650. - Rebuild without bootstrap binaries.
  651. * Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
  652. - Initial import into Fedora (#1356907), bootstrapped
  653. - Format license text as suggested in review.
  654. - Note how the tests already run in parallel.
  655. - Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
  656. - Don't let checks fail the whole build.
  657. - Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
  658. * Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
  659. - Update -doc directory ownership, and mark its licenses.
  660. - Package and declare licenses for libbacktrace and hoedown.
  661. - Set bootstrap_base as a global.
  662. - Explicitly require python2.
  663. * Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
  664. - Initial package, bootstrapped