perl-Authen-Krb5-Simple-vl.spec 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. %define real_name Authen-Krb5-Simple
  2. Summary: Basic user authentication using Kerberos 5
  3. Name: perl-%{real_name}
  4. Version: 0.43
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL+
  7. Group: Development/Libraries
  8. URL: http://search.cpan.org/dist/Authen-Krb5-Simple/
  9. Source: http://search.cpan.org/CPAN/authors/id/D/DS/DSTUART/Authen-Krb5-Simple-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  11. BuildRequires: perl
  12. BuildRequires: perl(ExtUtils::MakeMaker)
  13. BuildRequires: perl(Test::More)
  14. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  15. %description
  16. The Authen::Krb5::Simple module provides a means to authenticate a
  17. user/password using Kerberos 5 protocol. The module's authenticate function
  18. takes a username (or user@kerberos_realm) and a password, and authenticates
  19. that user using the local Kerberos 5 installation. It was initially created to
  20. allow perl scripts to perform authentication against a Microsoft Active
  21. Directory (AD) server configured to accept Kerberos client requests.
  22. It is important to note: This module only performs simple authentication. It
  23. does not get, grant, use, or retain any kerberos tickets. It will check user
  24. credentials against the Kerberos server (as configured on the local system)
  25. each time the authenticate method is called.
  26. %prep
  27. %setup -q -n %{real_name}-%{version}
  28. %build
  29. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  30. make %{?_smp_mflags}
  31. %install
  32. rm -rf %{buildroot}
  33. make pure_install DESTDIR=%{buildroot}
  34. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  35. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  36. %{_fixperms} %{buildroot}
  37. %check
  38. make test
  39. %clean
  40. rm -rf %{buildroot}
  41. %files
  42. %defattr(-, root, root, -)
  43. %doc Changes MANIFEST README
  44. %{perl_vendorarch}/*
  45. %{_mandir}/man3/*
  46. %changelog
  47. * Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.43-1
  48. - initial build for Vine Linux