unixODBC-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301
  1. Name: unixODBC
  2. Version: 2.3.5
  3. Release: 1%{?_dist_release}
  4. Summary: A complete ODBC Driver Manager for Linux
  5. Summary(ja): Linux 用 ODBC ドライバマネージャー
  6. Group: System Environment/Libraries
  7. # Programs are GPL, libraries are LGPL, except News Server library is GPL.
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://www.unixODBC.org/
  10. Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
  11. Source1: odbcinst.ini
  12. Source4: conffile.h
  13. Source5: README.dist
  14. Patch6: export-symbols.patch
  15. Patch8: so-version-bump.patch
  16. Patch9: keep-typedefs.patch
  17. Conflicts: iodbc
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
  20. BuildRequires: readline-devel
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. Install unixODBC if you want to access databases through ODBC.
  25. You will also need the mysql-connector-odbc package if you want to access
  26. a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
  27. %package devel
  28. Summary: Development files for programs which will use the unixODBC library.
  29. Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. %description devel
  33. The unixODBC package can be used to access databases through ODBC
  34. drivers. If you want to develop programs that will access data through
  35. ODBC, you need to install this package.
  36. %prep
  37. %setup -q
  38. %patch6 -p1
  39. %patch8 -p1
  40. %patch9 -p1
  41. chmod 0644 Drivers/MiniSQL/*.c
  42. chmod 0644 Drivers/nn/*.c
  43. chmod 0644 Drivers/template/*.c
  44. chmod 0644 doc/ProgrammerManual/Tutorial/*.html
  45. chmod 0644 doc/lst/*
  46. chmod 0644 include/odbcinst.h
  47. %build
  48. autoreconf -ivf
  49. # unixODBC 2.2.14 is not aliasing-safe
  50. CFLAGS="%{optflags} -fno-strict-aliasing"
  51. CXXFLAGS="$CFLAGS"
  52. export CFLAGS CXXFLAGS
  53. %configure --with-gnu-ld=yes --enable-threads=yes \
  54. --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
  55. # Get rid of the rpaths
  56. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  57. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  58. make all
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. make DESTDIR=$RPM_BUILD_ROOT install
  62. install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
  63. # multilib header hacks
  64. # we only apply this to known Red Hat multilib arches, per bug #181335
  65. case `uname -i` in
  66. i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
  67. mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
  68. rm -f unixodbc_conf.h
  69. sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
  70. install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
  71. ;;
  72. *)
  73. ;;
  74. esac
  75. # add some explanatory documentation
  76. cp %{SOURCE5} README.dist
  77. # remove obsolete Postgres drivers from the package (but not the setup code)
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
  79. # copy text driver documentation into main doc directory
  80. # currently disabled because upstream no longer includes text driver
  81. # mkdir -p doc/Drivers/txt
  82. # cp -pr Drivers/txt/doc/* doc/Drivers/txt
  83. # don't want to install doc Makefiles as docs
  84. find doc -name 'Makefile*' | xargs rm
  85. # we do not want to ship static libraries
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  87. # remove unpackaged files from the buildroot
  88. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  89. rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
  90. rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
  91. # initialize lists of .so files
  92. find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
  93. find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
  94. # move these to main package, they're often dlopened...
  95. for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
  96. do
  97. echo "%{_libdir}/$lib" >> base-so-list
  98. grep -v "/$lib$" devel-so-list > devel-so-list.x
  99. mv -f devel-so-list.x devel-so-list
  100. done
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %post -p /sbin/ldconfig
  104. %postun -p /sbin/ldconfig
  105. %files -f base-so-list
  106. %doc README COPYING AUTHORS ChangeLog NEWS doc
  107. %doc README.dist
  108. %config(noreplace) %{_sysconfdir}/odbc*
  109. %{_bindir}/odbcinst
  110. %{_bindir}/isql
  111. %{_bindir}/dltest
  112. %{_bindir}/iusql
  113. %{_bindir}/odbc_config
  114. %{_bindir}/slencheck
  115. %{_mandir}/man*/*
  116. %files devel -f devel-so-list
  117. %{_includedir}/*
  118. %changelog
  119. * Sat Jan 20 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.5-1
  120. - new upstream release.
  121. * Tue Jan 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
  122. - new upstream release.
  123. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
  124. - rebuilt with readline 6.3
  125. - removed kde-subpackage-related BuildRequires
  126. - added Japanese summary
  127. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  128. - new upstream release.
  129. - gui was discontinued in upstream.
  130. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
  131. - rebuild with VineSeed environment
  132. * Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
  133. - add --with-qt-includes option for configure
  134. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
  135. - updated to 2.2.14
  136. * Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
  137. - applied new versioning policy
  138. - removed *.la files from devel package
  139. * Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
  140. - updated to 2.2.12
  141. - rebuilt with new toolchain
  142. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
  143. - use installed libltdl
  144. - added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
  145. * Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
  146. - rebuilt with readline 5.1
  147. * Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
  148. - updated to 2.2.11
  149. - not libtoolize
  150. * Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
  151. - added Patch100 to fix typo in doc/Makefile.am from failure on compiling
  152. * Fri Jun 6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
  153. - source upgrade
  154. - remove patch (no need)
  155. - run libtoolize etc for VineSeed
  156. * Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
  157. - enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
  158. * Sun Feb 9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
  159. - source upgrade
  160. - change spec to build both VineSeed and Vine2.5/2.6
  161. - add patch from rawhide 2.2.3-6
  162. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
  163. - Requires: libjpeg (not libjpeg-6b)
  164. * Sun Oct 6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
  165. - source upgrade
  166. - add BuildPrereq: autoconf253 automake15
  167. - add PreReq: ldconfig
  168. - fix %files section and clean up spec
  169. - for unixODBC-kde package
  170. - add Requires: unixODBC = %{version}
  171. - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
  172. - delete .desktop files
  173. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
  174. - rebuild with KDE3
  175. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
  176. - updated unixODBC-2.2.0
  177. - fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
  178. * Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
  179. - remove -kde package on alpha
  180. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
  181. - Rebuild for Vine.
  182. * Sun Jun 24 2001 Than Ngo <than@redhat.com>
  183. - rebuild against qt-2.3.1, kde-2.1.x
  184. * Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
  185. - Better default odbcinst.ini
  186. - Minor cleanups
  187. * Wed Jun 6 2001 Trond Eivind Glomsrød <teg@redhat.com>
  188. - 2.0.7
  189. * Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
  190. - Fix for isql segfault on EOF/ctrl-d exit
  191. * Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  192. - 2.0.6
  193. - add patch for 64 bit archs (dword shouldn't be "long int")
  194. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  195. - rebuild
  196. * Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  197. - 1.8.13
  198. * Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
  199. - enable GUI now that we have KDE compiled with the standard
  200. compiler
  201. - move the applnk entries to the KDE package
  202. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  203. - add the missing shared libs to the non-devel package
  204. * Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
  205. - 1.8.12 fixes problems with the postgresql driver
  206. * Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
  207. - disable KDE subpackage to avoid the mess that is C++ binary
  208. compatibility
  209. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  210. - automatic rebuild
  211. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
  212. - improved QTDIR detection
  213. * Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  214. - 1.8.10
  215. - use %%{_tmppath}
  216. - update URL
  217. - including two missing libraries
  218. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  219. - 1.8.9
  220. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  221. - adopted for Winston, changed to Red Hat packaging standards
  222. * Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
  223. - added a unixODBC-devel RPM to the group, added KDE links and icons to system
  224. - all of which came from recommendations from Fredrick Meunier
  225. - <Fredrick.Meunier@computershare.com.au>
  226. * Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
  227. - unixODBC-1.8.7
  228. - moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.