openssl-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 10
  3. %define version 1.0.1c
  4. %define release 1%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source3: ca-bundle.crt
  12. Source5: make-dummy-cert
  13. # Source6: openssl-%{version}.pc
  14. Patch0: openssl-1.0.0-soversion.patch
  15. Patch2: openssl-1.0.0-rpm_opt.patch
  16. Patch4: openssl-1.0.0-enginesdir.patch
  17. Patch5: openssl-0.9.8j-version-add-engines.patch
  18. # security fix
  19. # nothing ;-)
  20. License: BSDish
  21. Group: System Environment/Libraries
  22. URL: http://www.openssl.org/
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: perl, sed
  25. BuildRequires: zlib-devel, krb5-devel
  26. Requires: mktemp
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. Packager: daisuke, iwamoto
  30. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  31. %description
  32. The OpenSSL certificate management tool and the shared libraries that
  33. provide various cryptographic algorithms and protocols.
  34. %package devel
  35. Summary: OpenSSL libraries and development headers.
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. Requires: krb5-devel
  39. %description devel
  40. The static libraries and include files needed to compile apps
  41. with support for various the cryptographic algorithms and protocols
  42. supported by OpenSSL.
  43. Patches for many networking apps can be found at:
  44. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  45. %package static
  46. Summary: Libraries for static linking of applications which will use OpenSSL
  47. Group: Development/Libraries
  48. Requires: %{name}-devel = %{version}-%{release}
  49. %description static
  50. OpenSSL is a toolkit for supporting cryptography. The openssl-static
  51. package contains static libraries needed for static linking of
  52. applications which support various cryptographic algorithms and
  53. protocols.
  54. %package perl
  55. Summary: OpenSSL scripts which require Perl.
  56. Group: Applications/Internet
  57. Requires: perl
  58. Requires: %{name} = %{version}-%{release}
  59. %description perl
  60. Perl scripts provided with OpenSSL for converting certificates and keys
  61. from other formats to those used by OpenSSL.
  62. ## to build compat32 for x86_64 architecture support
  63. %package -n compat32-%{name}
  64. Summary: Secure Sockets Layer Toolkit
  65. Group: System Environment/Libraries
  66. Requires: %{name} = %{version}-%{release}
  67. %description -n compat32-%{name}
  68. The OpenSSL certificate management tool and the shared libraries that
  69. provide various cryptographic algorithms and protocols.
  70. %package -n compat32-%{name}-devel
  71. Summary: OpenSSL libraries and development headers.
  72. Group: Development/Libraries
  73. Requires: compat32-%{name} = %{version}-%{release}
  74. Requires: compat32-krb5-devel
  75. %description -n compat32-%{name}-devel
  76. The static libraries and include files needed to compile apps
  77. with support for various the cryptographic algorithms and protocols
  78. supported by OpenSSL.
  79. %prep
  80. %setup -q -n openssl-%{version}
  81. %patch0 -p1 -b .soversion
  82. %patch2 -p1 -b .rpm_opt
  83. %patch4 -p1 -b .enginesdir
  84. %patch5 -p1 -b .version-add-engines
  85. # security fix
  86. # nothing ;-)
  87. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  88. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  89. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  90. chmod 644 doc/ssleay.txt
  91. # Link the configuration header to the one we're going to make.
  92. ln -sf ../../crypto/opensslconf.h include/openssl/
  93. %build
  94. PATH=${PATH}:${PWD}/bin
  95. TOPDIR=${PWD}
  96. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  97. # Modify the various perl scripts to reference perl in the right location.
  98. perl util/perlpath.pl `dirname %{__perl}`
  99. # Generate a table with the compile settings for my perusal.
  100. touch Makefile
  101. make TABLE PERL=%{__perl}
  102. # Figure out which flags we want to use.
  103. # default
  104. sslarch=%{_os}-%{_target_cpu}
  105. #
  106. %ifarch %ix86
  107. sslarch=linux-elf
  108. if ! echo %{_target} | grep -q i686 ; then
  109. sslflags="no-asm 386"
  110. fi
  111. %endif
  112. %ifarch sparcv9
  113. sslarch=linux-sparcv9
  114. sslflags=no-asm
  115. %endif
  116. %ifarch sparc64
  117. sslarch=linux64-sparcv9
  118. sslflags=no-asm
  119. %endif
  120. %ifarch alpha alphaev56 alphaev6 alphaev67
  121. sslarch=linux-alpha-gcc
  122. %endif
  123. %ifarch s390 sh3eb sh4eb
  124. sslarch="linux-generic32 -DB_ENDIAN"
  125. %endif
  126. %ifarch s390x
  127. sslarch="linux64-s390x"
  128. %endif
  129. %ifarch %{arm} sh3 sh4
  130. sslarch=linux-generic32
  131. %endif
  132. # ia64/x86_64/ppc\ppc64 are OK by default.
  133. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  134. # usable on all platforms. The Configure script already knows to use -fPIC and
  135. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  136. ./Configure \
  137. --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
  138. zlib-dynamic enable-camellia enable-seed enable-tlsext \
  139. enable-rfc3779 enable-cms enable-md2 \
  140. --enginesdir=%{_libdir}/openssl/engines \
  141. --with-krb5-flavor=MIT --with-krb5-dir=/usr \
  142. shared ${sslarch}
  143. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  144. # marked as not requiring an executable stack.
  145. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  146. make depend
  147. make all build-shared
  148. # Generate hashes for the included certs.
  149. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  150. export LD_LIBRARY_PATH
  151. make rehash build-shared
  152. # Verify that what was compiled actually works.
  153. make -C test apps tests
  154. # Relink the main binary to get it dynamically linked.
  155. rm apps/openssl
  156. make all build-shared
  157. %install
  158. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  159. # Install OpenSSL.
  160. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  161. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  162. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  163. # added for lib64
  164. # mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  165. mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
  166. # mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  167. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  168. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  169. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  170. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  171. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  172. chmod 755 ${lib}
  173. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  174. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  175. done
  176. # install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  177. # Install a makefile for generating keys and self-signed certs, and a script
  178. # for generating them on the fly.
  179. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
  180. install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
  181. install -m644 $RPM_SOURCE_DIR/make-dummy-cert $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
  182. # Make sure we actually include the headers we built against.
  183. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  184. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  185. install -m644 include/openssl/`basename ${header}` ${header}
  186. fi
  187. done
  188. # Rename man pages so that they don't conflict with system man pages. We used
  189. # to change the file extensions, but that only prevents file conflicts. The
  190. # man viewer still can't select either of the two unless we physically change
  191. # the directory.
  192. for section in 1 2 3 4 5 6 7 8 ; do
  193. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  194. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  195. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  196. fi
  197. done
  198. # Pick a CA script.
  199. pushd $RPM_BUILD_ROOT%{_datadir}/ssl/misc
  200. mv CA.sh CA
  201. popd
  202. # Install root CA stuffs.
  203. cat %{SOURCE3} > ca-bundle.crt
  204. install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
  205. ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
  206. # Fix libdir.
  207. #sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
  208. # sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
  209. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
  210. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
  211. # cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
  212. # $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
  213. # rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
  214. %clean
  215. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  216. %files
  217. %defattr(-,root,root)
  218. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  219. %doc doc/README doc/c-indentation.el doc/openssl.txt
  220. %doc doc/openssl_button.html doc/openssl_button.gif
  221. %doc doc/ssleay.txt
  222. %dir %{_datadir}/ssl
  223. %{_datadir}/ssl/certs
  224. %{_datadir}/ssl/cert.pem
  225. %{_datadir}/ssl/misc/CA
  226. %{_datadir}/ssl/misc/c_*
  227. %{_datadir}/ssl/private
  228. %config(noreplace) %{_datadir}/ssl/openssl.cnf
  229. %attr(0755,root,root) %{_bindir}/openssl
  230. %attr(0755,root,root) /%{_lib}/*.so.*
  231. %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  232. %attr(0755,root,root) %dir %{_mandir}/man1*
  233. %attr(0644,root,root) %{_mandir}/man1*/*
  234. %attr(0755,root,root) %dir %{_mandir}/man5*
  235. %attr(0644,root,root) %{_mandir}/man5*/*
  236. %attr(0755,root,root) %dir %{_mandir}/man7*
  237. %attr(0644,root,root) %{_mandir}/man7*/*
  238. %files devel
  239. %defattr(-,root,root)
  240. %{_prefix}/include/openssl
  241. %exclude %{_libdir}/lib*.a
  242. %attr(0755,root,root) %{_libdir}/*.so
  243. %attr(0755,root,root) %dir %{_mandir}/man3*
  244. %attr(0644,root,root) %{_mandir}/man3*/*
  245. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  246. %files static
  247. %defattr(-,root,root)
  248. %attr(0644,root,root) %{_libdir}/*.a
  249. %files perl
  250. %defattr(-,root,root)
  251. %attr(0755,root,root) %{_bindir}/c_rehash
  252. %attr(0755,root,root) %dir %{_mandir}/man1*
  253. %attr(0644,root,root) %{_mandir}/man1*/*.pl*
  254. %{_datadir}/ssl/misc/*.pl
  255. # %{_datadir}/ssl/misc/tsget
  256. %doc apps/tsget
  257. ## to build compat32 for x86_64 architecture support
  258. %if %{build_compat32}
  259. %files -n compat32-%{name}
  260. %defattr(-,root,root)
  261. %attr(0755,root,root) /%{_lib}/*.so.*
  262. %files -n compat32-%{name}-devel
  263. %defattr(-,root,root)
  264. %exclude %{_libdir}/lib*.a
  265. %attr(0755,root,root) %{_libdir}/*.so
  266. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  267. %endif
  268. %post -p /sbin/ldconfig
  269. %postun -p /sbin/ldconfig
  270. %post -n compat32-%{name} -p /sbin/ldconfig
  271. %postun -n compat32-%{name} -p /sbin/ldconfig
  272. %changelog
  273. * Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
  274. - update to 1.0.1c
  275. - enable configure options:
  276. enable-camellia enable-seed enable-tlsext enable-rfc3779
  277. enable-cms enable-md2
  278. - remove no-asm option from ai64/x86_64/ppc/ppc64/i686
  279. - generate a table with the compile settings before configure
  280. * Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
  281. - new upstream release with security fix (CVE-2012-0050)
  282. * Fri Jan 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
  283. - new upstream release with security fix
  284. (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
  285. * Wed Sep 7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
  286. - new upstream release with security fix (CVE-2011-3207, 3210)
  287. * Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
  288. - rebuild with krb5-libs 1.8
  289. * Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
  290. - new upstream release with security fix
  291. * Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
  292. - use upstream openssl.pc instead of vine original one (SOURCE6)
  293. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
  294. - move tsget to docs to delete dependency perl(WWW::Curl::Easy)
  295. * Sat Jan 1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
  296. - add R: krb5-devel into devel pkg
  297. - add R: compat32-krb5-devel into compat32-devel pkg
  298. * Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
  299. - new upstream release 1.0.0x
  300. - separate static libs into static package
  301. - change configure options
  302. - change so version 10
  303. - add tsget into perl package
  304. - update all patches
  305. * Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
  306. - fix changelog typo...
  307. * Tue Dec 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
  308. - new upstream release with security fix (CVE-2010-4180)
  309. * Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
  310. - new upstream release with security fix (CVE-2010-3864)
  311. - drop patches included in new release
  312. - update patch4
  313. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  314. - add patch12 for fix CVE-2009-3555 (renegotiation)
  315. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  316. - add patch11 for fix CVE-2009-4355 (memory leak)
  317. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  318. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  319. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  320. - removed unnecessary %%if %{build_compat32} statements
  321. - removed lib*.a from devel package
  322. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  323. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  324. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  325. - new upstream release with security fix (CVE-2008-5077)
  326. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  327. - new upstream release
  328. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  329. - new upstream release
  330. - new versioning policy
  331. * Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  332. - new upstream release
  333. - drop patch10,20 which is merged in upstream
  334. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  335. - add security patch in advance for CVE-2007-5135
  336. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  337. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  338. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  339. - add security patch for CVE-2007-3108
  340. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  341. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  342. - new upstream release
  343. * Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  344. - update (fix) openssl.pc <BTS:437>
  345. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  346. - new upstream release (with security fix)
  347. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  348. - new upstream release
  349. - add patch2 to use RPM_OPT macro
  350. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  351. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  352. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  353. - added compat32-* packages for x86_64 architecture support
  354. - added openssl-0.9.7i.Configure-compat32.patch
  355. - changed '/lib' to '/%{_lib}'
  356. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  357. - new upstream release
  358. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  359. - rebuild on VineSeed
  360. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  361. - added a security patch from Gentoo.
  362. - Patch1: openssl-0.9.7c-tempfile.patch
  363. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  364. - sslarch for ppc was missing... added.
  365. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  366. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  367. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  368. - new upstream version
  369. - clean up of spec file
  370. -- removed old patches
  371. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  372. - new upstream release
  373. - SECURITY fix.
  374. - http://www.openssl.org/news/secadv_20040317.txt
  375. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  376. - new upstream release
  377. - [Security fix]
  378. - Vulnerabilities in ASN.1 parsing
  379. http://www.openssl.org/news/secadv_20030930.txt
  380. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  381. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  382. - add openssl.pc for pkgconfig
  383. * Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  384. - New upstream version
  385. - dropped patch10, 11
  386. -- merged upstream version
  387. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  388. - rebuild for VineSeed
  389. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  390. - [Security Fix]
  391. - Timing-based attacks on RSA keys
  392. http://www.openssl.org/news/secadv_20030317.txt
  393. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  394. http://www.openssl.org/news/secadv_20030317.txt
  395. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  396. - new upstream release 0.9.6i
  397. - [Security Fix]
  398. - build for Vine Linux 2.6 errata
  399. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  400. - new upstream release 0.9.6h
  401. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  402. - new upstream release 0.9.6g
  403. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  404. - SECURITY: CAN-2002-0659 fixed
  405. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  406. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  407. - update asn patch to fix accidental reversal of a logic check
  408. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  409. - update asn patch to reduce chance that compiler optimization will remove
  410. one of the added tests
  411. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  412. - rebuild
  413. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  414. - add patch to fix ASN.1 vulnerabilities
  415. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  416. - rename spec file name
  417. - SECURITY: CA-2002-23 fixed
  418. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  419. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  420. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  421. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  422. - added ${PATH} in LD_LIBRARY_PATH
  423. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  424. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  425. - remove --no-<cipher>
  426. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  427. - add Patch10 for mipsel shared ( Configure )
  428. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  429. - build for Vine Linux
  430. - use openssl-engine-0.9.6b.tar.gz
  431. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  432. - update to 0.9.6b
  433. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  434. - move .so symlinks back to %%{_libdir}
  435. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  436. - move shared libraries to /lib (#38410)
  437. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  438. - switch to engine code base
  439. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  440. - add a script for creating dummy certificates
  441. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  442. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  443. - add s390x support
  444. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  445. - change two memcpy() calls to memmove()
  446. - don't define L_ENDIAN on alpha
  447. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  448. - make subpackages depend on the main package
  449. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  450. - adjust the hobble script to not disturb symlinks in include/ (fix from
  451. Joe Orton)
  452. * Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  453. - drop the m2crypo patch we weren't using
  454. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  455. - configure using "shared" as well
  456. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  457. - update to 0.9.6a
  458. - use the build-shared target to build shared libraries
  459. - bump the soversion to 2 because we're no longer compatible with
  460. our 0.9.5a packages or our 0.9.6 packages
  461. - drop the patch for making rsatest a no-op when rsa null support is used
  462. - put all man pages into <section>ssl instead of <section>
  463. - break the m2crypto modules into a separate package
  464. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  465. - use BN_LLONG on s390
  466. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  467. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  468. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  469. - move c_rehash to the perl subpackage, because it's a perl script now
  470. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  471. - update to 0.9.6
  472. - enable MD2
  473. - use the libcrypto.so and libssl.so targets to build shared libs with
  474. - bump the soversion to 1 because we're no longer compatible with any of
  475. the various 0.9.5a packages circulating around, which provide lib*.so.0
  476. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  477. - change hobble-openssl for disabling MD2 again
  478. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  479. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  480. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  481. apps built against a version of the library without it
  482. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  483. - disable some inline assembly, which on x86 is Pentium-specific
  484. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  485. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  486. - fix s390 patch
  487. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  488. - added support s390
  489. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  490. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  491. - add the CA.pl man page to the perl subpackage
  492. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  493. - always build with -mcpu=ev5 on alpha
  494. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  495. - add a symlink from cert.pem to ca-bundle.crt
  496. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  497. - add a ca-bundle file for packages like Samba to reference for CA certificates
  498. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  499. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  500. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  501. - add unzip as a buildprereq (#17662)
  502. - update m2crypto to 0.05-snap4
  503. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  504. - fix some issues in building when it's not installed
  505. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  506. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  507. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  508. - add Richard Henderson's patch for BN on ia64
  509. - clean up the changelog
  510. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  511. - fix the building of python modules without openssl-devel already installed
  512. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  513. - byte-compile python extensions without the build-root
  514. - adjust the makefile to not remove temporary files (like .key files when
  515. building .csr files) by marking them as .PRECIOUS
  516. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  517. - break out python extensions into a subpackage
  518. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  519. - tweak the makefile some more
  520. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  521. - disable MD2 support
  522. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  523. - disable MDC2 support
  524. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  525. - tweak the disabling of RC5, IDEA support
  526. - tweak the makefile
  527. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  528. - strip binaries and libraries
  529. - rework certificate makefile to have the right parts for Apache
  530. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  531. - use %%{_perl} instead of /usr/bin/perl
  532. - disable alpha until it passes its own test suite
  533. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  534. - move the passwd.1 man page out of the passwd package's way
  535. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  536. - update to 0.9.5a, modified for U.S.
  537. - add perl as a build-time requirement
  538. - move certificate makefile to another package
  539. - disable RC5, IDEA, RSA support
  540. - remove optimizations for now
  541. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  542. - Bero told me to move the Makefile into this package
  543. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  544. - add lib*.so symlinks to link dynamically against shared libs
  545. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  546. - update to 0.9.5
  547. - run ldconfig directly in post/postun
  548. - add FAQ
  549. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  550. - Fix build on non-x86 platforms
  551. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  552. - move /usr/share/ssl/* from -devel to main package
  553. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  554. - inital packaging
  555. - changes from base:
  556. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  557. - handle RPM_OPT_FLAGS