xinetd-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575
  1. %define _use_internal_dependency_generator 0
  2. %define __find_requires %{SOURCE99}
  3. Summary: A secure replacement for inetd.
  4. Name: xinetd
  5. Version: 2.3.15
  6. Release: 1%{?_dist_release}
  7. License: Distributable (BSD-like)
  8. Group: System Environment/Daemons
  9. Source: http://www.xinetd.org/xinetd-%{version}.tar.gz
  10. Source1: xinetd.init
  11. Source2: xinetd.conf
  12. Source3: xinetd-inetdconvert
  13. Source4: xinetd-ttime
  14. Source5: xinetd-utime
  15. Source6: xinetd-tdtime
  16. Source7: xinetd-udtime
  17. Source8: xinetd-echo
  18. Source9: xinetd-uecho
  19. Source10: xinetd-chargen
  20. Source11: xinetd-uchargen
  21. Source12: xinetd.sysconf
  22. Source13: xinetd-services
  23. Source99: filter-requires-xinetd.sh
  24. Patch0: xinetd-2.3.11-pie.patch
  25. Patch1: xinetd-2.3.13-libwrap.patch
  26. Requires(pre): chkconfig initscripts
  27. Requires: initscripts setup fileutils
  28. BuildRequires: tcp_wrappers
  29. URL: http://www.xinetd.org/
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. Provides: inetd
  32. %description
  33. Xinetd is a secure replacement for inetd, the Internet services
  34. daemon. Xinetd provides access control for all services based on the
  35. address of the remote host and/or on time of access and can prevent
  36. denial-of-access attacks. Xinetd provides extensive logging, has no
  37. limit on the number of server arguments, and lets you bind specific
  38. services to specific IP addresses on your host machine. Each service
  39. has its own specific configuration file for Xinetd; the files are
  40. located in the /etc/xinetd.d directory.
  41. %prep
  42. %setup -q
  43. #%patch0 -p0 -b .pie
  44. #%patch1 -p1 -b .libwrap
  45. #%patch2 -p1 -b .tcp_rpc
  46. %build
  47. libtoolize --copy --force
  48. %configure --with-loadavg --with-inet6 --with-libwrap
  49. make
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  53. mkdir -p $RPM_BUILD_ROOT/%{_mandir}
  54. %makeinstall DAEMONDIR=$RPM_BUILD_ROOT/usr/sbin MANDIR=$RPM_BUILD_ROOT/%{_mandir}
  55. mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d/
  56. install -m 755 %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/xinetd
  57. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/etc/xinetd.conf
  58. install -m 755 %SOURCE3 $RPM_BUILD_ROOT/usr/sbin/inetdconvert
  59. install -m 644 %SOURCE4 $RPM_BUILD_ROOT/etc/xinetd.d/time
  60. install -m 644 %SOURCE5 $RPM_BUILD_ROOT/etc/xinetd.d/time-udp
  61. install -m 644 %SOURCE6 $RPM_BUILD_ROOT/etc/xinetd.d/daytime
  62. install -m 644 %SOURCE7 $RPM_BUILD_ROOT/etc/xinetd.d/daytime-udp
  63. install -m 644 %SOURCE8 $RPM_BUILD_ROOT/etc/xinetd.d/echo
  64. install -m 644 %SOURCE9 $RPM_BUILD_ROOT/etc/xinetd.d/echo-udp
  65. install -m 644 %SOURCE10 $RPM_BUILD_ROOT/etc/xinetd.d/chargen
  66. install -m 644 %SOURCE11 $RPM_BUILD_ROOT/etc/xinetd.d/chargen-udp
  67. install -m 644 %SOURCE13 $RPM_BUILD_ROOT/etc/xinetd.d/services
  68. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/itox*
  69. rm -f $RPM_BUILD_ROOT/usr/sbin/itox
  70. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/xconv.pl*
  71. rm -f $RPM_BUILD_ROOT/usr/sbin/xconv.pl
  72. rm -f $RPM_BUILD_ROOT/%{_mandir}/*.3
  73. mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
  74. install -m 644 %SOURCE12 $RPM_BUILD_ROOT/etc/sysconfig/xinetd
  75. %clean
  76. rm -rf $RPM_BUILD_ROOT
  77. %post
  78. if [ $1 = 1 ]; then
  79. /sbin/chkconfig --add xinetd
  80. fi
  81. %preun
  82. if [ $1 = 0 ]; then
  83. /sbin/service xinetd stop > /dev/null 2>&1
  84. /sbin/chkconfig --del xinetd
  85. fi
  86. %postun
  87. if [ $1 -ge 1 ]; then
  88. /sbin/service xinetd condrestart >/dev/null 2>&1
  89. fi
  90. %files
  91. %defattr(-,root,root)
  92. %doc INSTALL CHANGELOG COPYRIGHT README xinetd/sample.conf
  93. %config(noreplace) /etc/xinetd.conf
  94. %config(noreplace) /etc/sysconfig/xinetd
  95. %{_sbindir}/xinetd
  96. %{_sbindir}/inetdconvert
  97. %{_mandir}/*/*
  98. %config /etc/rc.d/init.d/xinetd
  99. %config(noreplace) /etc/xinetd.d/*
  100. %changelog
  101. * Sat Apr 06 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3.15-1
  102. - new upstream release
  103. - deleted Patch2 (upstream merged)
  104. - fixed date in %%changelog
  105. * Wed Apr 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.14-3
  106. - add BuildRequires: tcp_wrappers
  107. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.14-2
  108. - rebuild for Vine 6
  109. * Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.14-1vl5
  110. - applied new versioning policy
  111. * Sun Nov 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.3.14-0vl2
  112. - fix dependencies ([VineSeed:11559,12368], <bts:398>)
  113. - remove Conflicts: inetd
  114. - add Provides: inetd
  115. * Wed Mar 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.14-0vl1
  116. - new upstream release
  117. - drop patch1
  118. - remove Provides: inetd
  119. * Sun Feb 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.13-2vl3
  120. - remove Obosletes: inetd, add Conflicts: inetd
  121. * Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl2
  122. - rebuild
  123. * Sat Sep 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl1
  124. - build for VineSeed
  125. - remove Epoch
  126. - remove patch0
  127. - remove Requires: filesystem >= 2.0.1
  128. - remove BuildRequires: glibc-devel (included in build-essential)
  129. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  130. - rebuilt
  131. * Thu Jan 29 2004 Jay Fenlason <fenlason@redhat.com> 2.3.13-1
  132. - Upgrade to new upstream version, which obsoletes most patches.
  133. - Add new tcp_rpc patch, to turn on the nolibwrap flag on tcp rpc services,
  134. since libwrap cannot be used on them.
  135. * Sun Dec 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  136. - use new technology to filter python dep for inetdconvert instead
  137. of changing the -x bit on file permissions
  138. * Wed Nov 12 2003 Jay Fenlason <fenlason@redhat.com> 2.3.12-3
  139. - build in HEAD for pre FC-2
  140. - merge from xinetd-3E-branch to fix bugzilla #103009
  141. also includes:
  142. New upstream version, which obsoletes most of my patches
  143. Remove %{_mandir}/man8/xconv.pl* fixing #90730
  144. Remove the servers service, which was removed from 2.3.12
  145. Change localization: instead of using en_US in /etc/rc.d/init.d/xinetd
  146. (overriding the system default and preventing any customization),
  147. /etc/sysconfig/xinetd sets XINETD_LANG, which is either a locale to use
  148. or the word "none", which causes all locale environment variables to be
  149. cleared before xinetd is started. This fixes #91403
  150. #77724 was fixed by the upgrade to 2.3.12
  151. include post 2.3.12 patch from upstream (originally by
  152. Matthias Andree <ma+xi@dt.e-technik.uni-dortmund.de>) to add a new
  153. "libwrap" parameter.
  154. This closes bugs (#91555,#91135,#77724) by making xinetd's behavior
  155. documented and user-configurable.
  156. Removed the old libwrap/TCP/wait patch. If anyone actually cares,
  157. they can add "flags = NOLIBWRAP" to the configuration of TCP/wait
  158. services to get the old behavior.
  159. Mark /etc/sysconfig/xinetd as a config file in xinetd.spec
  160. Add pie support
  161. * Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  162. - allow compiling without tcp_wrappers
  163. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  164. - rebuilt
  165. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  166. - rebuilt
  167. * Fri Feb 21 2003 Jay Fenlason <fenlason@redhat.com> 2.3.10-5
  168. - Merge various patches from xinetd-CVS, since 2.3.11 won't be
  169. out in time for our Red Hat Linux release. One improves range checking
  170. on file descriptors. (A potential security problem.) Another
  171. fixes bugzilla #84840: tcpmux doesn't work at all. A third improves
  172. error checking on tcpmux service entries. The last improves error
  173. checking on service startup.
  174. * Tue Feb 11 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-4
  175. - rebuild
  176. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-3
  177. - rebuild
  178. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  179. - rebuilt
  180. * Tue Jan 7 2003 Jay Fenlason <fenlason.redhat.com> 2.3.10-1
  181. - Fix #81770, #80612, #79219, #79274: New upstream version
  182. - May also fix #79085, #78903, #78699, #77781, #77760, #76727
  183. - ... #73805, #60049, #58881, #58855
  184. - Fix #79999: remove xinetd-ipv6 executable
  185. - Fix #82021: changed preun to turn off the server
  186. - try to Fix #74198 by quoting "${NETWORKING}" in xinetd.init
  187. * Tue Dec 10 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-6
  188. - Fix Service startup script to check for id=0
  189. * Tue Nov 19 2002 Bill Nottingham <notting@redhat.com> 2.3.7-5
  190. - add new stream_wait patch (#74696)
  191. * Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-4
  192. - Fix Service Descriptions
  193. * Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-3
  194. - Fix #77710 Fix Service Descriptions
  195. * Thu Aug 15 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 2.3.7-2
  196. - Fix #71506 (mixed internal services)
  197. * Mon Aug 12 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.7-1
  198. - 2.3.7 - this fixes #70504
  199. * Mon Aug 5 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-6
  200. - Initscript fixes (#70730)
  201. * Wed Jul 17 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-5
  202. - Add patch for improved cross compiling (#55927)
  203. * Wed Jul 3 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-4
  204. - #67701
  205. * Wed Jun 26 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5=3
  206. - Fix maks for access control (#65743)
  207. - some fixes for config file parsing
  208. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  209. - automated rebuild
  210. * Thu May 30 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-1
  211. - 2.3.5
  212. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  213. - automated rebuild
  214. * Mon Apr 22 2002 Trond Eivind Glomsr綬d <teg@redhat.com>
  215. - 2.3.4 final (bah, never announced... has been out for 3 weeks)
  216. * Thu Apr 4 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.8
  217. - Add a patch to avoid fam haunting the system
  218. * Tue Apr 2 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.7
  219. - Add patch from Alex Larson in order not to use tcp_wrappers on tcp/wait -
  220. they'd always be 0.0.0.0
  221. * Thu Mar 28 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.6
  222. - 2002-03-26. 2.3.4 final RSN
  223. * Fri Mar 1 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.5
  224. - 2002-02-28-1
  225. * Sun Jan 6 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.4
  226. - 2002-01-04
  227. - Update URLs
  228. * Fri Dec 14 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.3
  229. - 2001-12-13
  230. * Mon Dec 3 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.2
  231. - 2001-12-03 (fixes #57001, #55738)
  232. * Fri Nov 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.1
  233. - 2001-11-29, which fixes #56487
  234. - Add configuration files for the xinetd internal services listing
  235. current servers and services. It's off by default, and restricted
  236. to localhost when enabled (#52707)
  237. - Use SIGHUP for configuration reload (change in program)
  238. * Wed Aug 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.3-1
  239. - 2.3.3
  240. - parser patch now obsolete
  241. * Thu Aug 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.2-1
  242. - 2.3.2, which contains the memory overwrite patch,
  243. the audit fixes, the conn_free patch and the filelog patch.
  244. - Fix handling of rpc_version with ranges (like "1-2") (#51737)
  245. * Wed Aug 15 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-7
  246. - Don't apply the skipjunk patch anymore - xinetd now skips files with ".",
  247. which include .rpmsave etc.
  248. - fix memory overwrite bug in env.c:grow()
  249. * Mon Aug 13 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-6
  250. - conn_free was called twice...
  251. - add cps = 25 30 to xinetd.conf. Thus, if a service has many
  252. connections (25 in a 1 second period), it will be disabled
  253. for 30 seconds. Without this, 10 connections to a service in
  254. a second would permanently disable the service (#49122)
  255. * Thu Aug 9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-5
  256. - add the patch from "Solar Designer"'s audit
  257. * Thu Aug 9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-4
  258. - Make it handle stop and status when IPv6 is enabled (#49621)
  259. * Mon Jul 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  260. - Add IPv6 support - separate binary, invoked if
  261. NETWORKING_IPV6 is set (#49621)
  262. - Make inetdconvert handle the "/usr/sbin/in.telnetd in.telnetd"
  263. scenario of inetd (#46449)
  264. * Tue Jul 3 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  265. - redo skipjunkfile patch
  266. * Fri Jun 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  267. - 2.3.0
  268. * Thu Jun 21 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  269. - 2.1.8.9pre16
  270. * Mon Jun 4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  271. - Remove explicit dependancy on initscripts version
  272. * Sun May 20 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  273. - 2.1.8.9pre15, which should fix wait=yes with tcp (linuxconf is
  274. the only program I know of using this)
  275. - fix some problems with UDP internal services (#38669)
  276. - make /etc/xinetd.conf noreplace
  277. * Wed Apr 25 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  278. - Add the tcp wait=yes patch from the xinetd version in a different tree
  279. * Wed Apr 4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  280. - Add /etc/sysconfig/xinetd so users can add extra options (#34321)
  281. * Tue Feb 27 2001 Preston Brown <pbrown@redhat.com>
  282. - noreplace the xinetd.d files
  283. * Mon Feb 5 2001 Preston Brown <pbrown@redhat.com>
  284. - built against newer tcp_wrappers that fixes name resolution problem (#16949)
  285. * Mon Feb 5 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  286. - Patch from nalin@redhat.com for terminating the environment variables properly
  287. * Tue Jan 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  288. - remove PID from log_on_failure flags (#22687)
  289. * Tue Jan 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  290. - improve gettextization
  291. - add "UNLISTED" to the internal udp services (#24279)
  292. * Thu Jan 18 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  293. - 2.1.8.9pre14
  294. * Wed Jan 17 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
  295. - gettextize
  296. * Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
  297. - remove python dependency.
  298. * Tue Dec 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  299. - remove RECORD from xinetd.conf for security reasons
  300. (no known holes, but better safe than sorry #22687)
  301. * Mon Dec 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  302. - unset a couple of environment variables(HOME,MAIL) in the initscript.
  303. This should avoid problems like bug #21663
  304. * Fri Dec 01 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  305. - rebuild
  306. * Tue Nov 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  307. - 2.1.8.9pre13, which should fix #19355
  308. - changes to initscript - set all locale environment variables
  309. to en_US, as the server doesn't know what locale the client
  310. expects and error messages can otherwise be confusing
  311. (partially #20566)
  312. * Thu Nov 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  313. - fix mismatch in documentation vs. reality, introduced
  314. when we changed the behaviour of the access control
  315. to use server names (#20567)
  316. * Tue Oct 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  317. - obsolete netkit-base, which was inetd's home until 6.2
  318. * Thu Oct 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  319. - 2.1.8.9pre12, which has a new "-stayalive" option so
  320. xinetd stays alive even if no services are enabled.
  321. - use the above in the initscript (#18819)
  322. * Tue Oct 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  323. - 2.1.8.9pre11, which includes the previous bugfixes.
  324. - don't convert the internal services, include
  325. such files with xinetd (#17331, #18899)
  326. * Mon Oct 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  327. - Add patch to fix segfault problem (#18686)
  328. * Fri Oct 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  329. - apply patch from nalin@redhat.com for handling tcp
  330. connections with wait=yes properly
  331. * Tue Sep 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  332. - add explicit dependency on a modern version of initscripts
  333. (#17533)
  334. * Wed Aug 30 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  335. - 2.1.8.9pre10 - remove tcpwrapper and pidfile patches,
  336. as they are now in.
  337. - change default startup position to 56, so it
  338. starts after bind (#17047)
  339. * Thu Aug 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  340. - use the server name not the service name for libwrap
  341. checking (#16516). The new way was better, but
  342. this is sacrificed so old systems will continue to work
  343. and the documentation for tcp_wrappers can be correct.
  344. * Wed Aug 16 2000 Than Ngo <than@redhat.com>
  345. - fix initscript, test network file before source it (Bug #16247)
  346. * Tue Aug 15 2000 Trond Eivind Glomsr綬d <teg@redhat.com
  347. - make the pidfile 0644, not 0300 (#16256)
  348. * Tue Aug 08 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  349. - added support for "-pidfile" option (#15531)
  350. * Fri Aug 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  351. - added patch to ignore .rpmsave, .rpmorig, .rpmnew, ~
  352. suffixed files (#15304)
  353. * Thu Aug 03 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  354. - 2.1.8.9pre9, old patches are now integrated.
  355. * Wed Aug 02 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  356. - fix converting of "wait" argument (#13884)
  357. - remove tcpd and /usr/sbin/tcpd from inetd.conf services
  358. before converting - xinetd is linked against tcp_wrappers
  359. * Mon Jul 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  360. - fix linuxconf restart problem (#14856)
  361. - fix conditional restart
  362. - mark /etc/xinetd.conf as a configuration file
  363. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  364. - um, we *need* to prereq /etc/init.d
  365. * Mon Jul 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  366. - Don't require /etc/init.d
  367. * Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
  368. - rebuild
  369. * Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  370. - fix the sections of the man pages (#14244)
  371. * Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  372. - remove itox, as it wouldn't do the right thing with our
  373. configuration
  374. - same with xconv.pl
  375. - some changes to the installation process
  376. * Mon Jul 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  377. - move initscript back to /etc/rc.d/init.d
  378. * Fri Jul 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  379. - change process name in init file
  380. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  381. - automatic rebuild
  382. * Fri Jul 7 2000 Nalin Dahyabhai <nalin@redhat.com>
  383. - start the daemon with the "-reuse" flag
  384. * Thu Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  385. - "Prereq:", not "Requires:" for /etc/init.d
  386. * Wed Jul 05 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  387. - require /etc/init.d
  388. * Wed Jul 5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  389. - upper the number of instances to 60
  390. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  391. - fix a memory-allocation bug
  392. * Wed Jun 28 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  393. - 2.1.8.9pre8
  394. * Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  395. - moved to /etc/init.d
  396. * Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  397. - changed specfile and initfile to implement conditional
  398. restart
  399. * Sun Jun 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  400. - 2.1.8.9pre7
  401. - now obsoletes inetd
  402. - use %%{_tmppath}
  403. * Sun Jun 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  404. - 2.1.8.9pre6
  405. - added converter script which can convert specified or
  406. remaing uncoverted services
  407. - use %%{_mandir}
  408. - removed +x on xinetd.conf
  409. * Wed May 24 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  410. - 2.1.8.9pre4
  411. - authpriv patch no longer needed
  412. * Tue May 23 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  413. - /etc/xinetd.d is now part of the filesystem package
  414. - more fixes to xinetd.init
  415. * Mon May 22 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  416. - fixed some obvious bugs in xinetd.init
  417. - added a default xinetd.conf
  418. - patched xinetd to understand LOG_AUTHPRIV
  419. * Fri May 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
  420. - updated version
  421. - removed a define %ver (we already have %version)
  422. - removed some extra CFLAGS declarations
  423. - added configuration directory, /etc/xinetd.d
  424. * Mon Feb 21 2000 Tim Powers <timp@redhat.com>
  425. - fixed broken postun sections, should have been *preun*
  426. - fixed broken gzip of manpages
  427. * Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  428. - 2.1.8.8p8
  429. - Fix the init script (Bug #7277)
  430. - remove our patches (no longer required)
  431. * Tue Sep 21 1999 Bill Nottingham <notting@redhat.com>
  432. - add -lnsl
  433. * Tue Sep 7 1999 Tim Powers <timp@redhat.com>
  434. - modification top install routine
  435. * Mon Jul 26 1999 Tim Powers <timp@redhat.com>
  436. - updated source to 2.1.8.6b6
  437. - built for 6.1
  438. * Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
  439. - update to 2.1.8.6b5
  440. - build for PowerTools
  441. * Mon Jan 11 1999 Bill Nottingham <notting@redhat.com>
  442. - update to 2.1.8.5p2
  443. * Tue Dec 1 1998 Bill Nottingham <notting@redhat.com>
  444. - intial build