foomatic-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658
  1. %define dbver_rel 4.0
  2. %define dbver_snap 20140104
  3. %define enginever 4.0.9
  4. %define filtersver 4.0.17
  5. Summary: Foomatic printer database.
  6. Name: foomatic
  7. Version: %{enginever}
  8. Release: 1%{?_dist_release}
  9. License: GPL
  10. Group: System Environment/Libraries
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop, daisuke, machino
  14. Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
  15. Source1: http://www.linuxprinting.org/download/foomatic/foomatic-filters-%{filtersver}.tar.gz
  16. Source2: http://www.linuxprinting.org/download/foomatic/foomatic-db-%{dbver_rel}-%{dbver_snap}.tar.gz
  17. # Use libdir.
  18. Patch1: foomatic-filters-libdir.patch
  19. Patch2: foomatic-db-engine-libdir.patch
  20. # Handle non-UTF-8 encodings in imported PPD files.
  21. Patch15: foomatic-bad-utf8.patch
  22. Url: http://www.linuxprinting.org
  23. Requires: perl >= 5.12.3
  24. Requires: %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
  25. Requires: hplip
  26. BuildRequires: perl >= 5.12.3
  27. BuildRequires: libxml2-devel
  28. BuildRequires: ghostscript-devel
  29. BuildRequires: autoconf, automake
  30. BuildRequires: mpage
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  32. Provides: perl(Foomatic::GrovePath)
  33. # For 'rm' and '/sbin/service' in post
  34. Requires(pre): coreutils initscripts
  35. Obsoletes: foomatic-db < 4.0.0
  36. Obsoletes: foomatic-ppd < 4.0.0
  37. Obsoletes: foomatic-ppd-gimp-print < 4.0.0
  38. Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0.0
  39. Obsoletes: foomatic-ppd-omni < 4.0.0
  40. # We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
  41. Conflicts: ghostscript < 7.05
  42. %description
  43. Foomatic is a comprehensive, spooler-independent database of printers,
  44. printer drivers, and driver descriptions. It contains utilities to
  45. generate driver description files and printer queues for CUPS, LPD,
  46. LPRng, and PDQ using the database. There is also the possibility to
  47. read the PJL options out of PJL-capable laser printers and take them
  48. into account at the driver description file generation.
  49. There are spooler-independent command line interfaces to manipulate
  50. queues (foomatic-configure) and to print files/manipulate jobs
  51. (foomatic printjob).
  52. The site http://www.linuxprinting.org/ is based on this database.
  53. %prep
  54. %setup -q -c -a 1 -a 2
  55. #pushd foomatic-filters-%{filtersver}
  56. #%patch1 -p1 -b .libdir
  57. #popd
  58. pushd foomatic-db-engine-%{enginever}
  59. chmod a+x mkinstalldirs
  60. #%patch2 -p1 -b .libdir
  61. #%patch15 -p1
  62. popd
  63. pushd foomatic-db-%{dbver_snap}
  64. cd db/source
  65. # For gutenprint printers, use gutenprint-ijs-simplified.5.2.
  66. perl -pi -e 's,>gutenprint<,>gutenprint-ijs-simplified.5.2<,' printer/*.xml
  67. # Remove references to foo2zjs, foo2oak, foo2hp and foo2qpdl (bug #208851).
  68. # Also foo2lava, foo2kyo, foo2xqx (bug #438319).
  69. for x in zjs oak hp qpdl lava kyo xqx
  70. do
  71. find printer -name '*.xml' |xargs grep -l "<driver>foo2${x}"|xargs rm -vf
  72. rm -f driver/foo2${x}.xml opt/foo2${x}-*
  73. done
  74. # Same for m2300w/m2400w
  75. find printer -name '*.xml' |xargs grep -l '<driver>m2[34]00w<'|xargs rm -vf
  76. rm -f driver/m2300w.xml driver/m2400w.xml opt/m2300w-*
  77. # Same for all these.
  78. for x in drv_x125 ml85p pbm2lwxl pbmtozjs bjc800j
  79. do
  80. find printer -name '*.xml' |xargs grep -l "<driver>${x}</driver>"|xargs rm -vf
  81. rm -vf driver/${x}.xml opt/${x}-*
  82. done
  83. popd
  84. %build
  85. export LIB_CUPS=%{_libdir}/cups
  86. export CUPS_BACKENDS=%{_libdir}/cups/backend
  87. export CUPS_FILTERS=%{_libdir}/cups/filter
  88. export CUPS_PPDS=%{_datadir}/cups/model
  89. pushd foomatic-filters-%{filtersver}
  90. %configure
  91. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  92. INSTALLDIRS=vendor
  93. popd
  94. pushd foomatic-db-engine-%{enginever}
  95. %configure --disable-xmltest
  96. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  97. INSTALLDIRS=vendor defaults
  98. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  99. INSTALLDIRS=vendor
  100. popd
  101. pushd foomatic-db-%{dbver_snap}
  102. %configure
  103. make %{_smp_mflags} PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS" \
  104. INSTALLDIRS=vendor
  105. popd
  106. %install
  107. rm -rf %{buildroot}
  108. pushd foomatic-filters-%{filtersver}
  109. eval `perl '-V:installvendorlib' '-V:installvendorarch'`
  110. mkdir -p %{buildroot}/$installvendorlib
  111. echo %{buildroot}
  112. make DESTDIR=%{buildroot} PREFIX=%{_prefix} \
  113. INSTALLDIRS=vendor \
  114. INSTALLVENDORLIB=$installvendorlib \
  115. INSTALLVENDORARCH=$installvendorarch \
  116. install-main install-cups
  117. popd
  118. pushd foomatic-db-engine-%{enginever}
  119. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  120. INSTALLDIRS=vendor \
  121. INSTALLVENDORLIB=$installvendorlib \
  122. INSTALLVENDORARCH=$installvendorarch \
  123. install
  124. popd
  125. pushd foomatic-db-%{dbver_snap}
  126. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  127. INSTALLDIRS=vendor \
  128. INSTALLVENDORLIB=$installvendorlib \
  129. INSTALLVENDORARCH=$installvendorarch \
  130. install
  131. popd
  132. # Remove ghostscript UPP drivers that are gone in 7.07
  133. rm -f %buildroot%{_datadir}/foomatic/db/source/driver/{bjc6000a1,PM760p,PM820p,s400a1,sharp,Stc670pl,Stc670p,Stc680p,Stc760p,Stc777p,Stp720p,Stp870p}.upp.xml
  134. # Remove drivers with no command line.
  135. pushd foomatic-db-engine-%{enginever}
  136. perl -Ilib ./foomatic-cleanupdrivers %buildroot%{_datadir}/foomatic
  137. popd
  138. # Update any old-style printer IDs still left around.
  139. echo '#!/usr/bin/perl -pi' > convert-printerids.pl
  140. sed -e 's|^\(.*\) \(.*\)$|s,printer/\1,printer/\2,g;|' \
  141. %{buildroot}%{_datadir}/foomatic/db/oldprinterids \
  142. >> convert-printerids.pl
  143. chmod a+x convert-printerids.pl
  144. ./convert-printerids.pl %{buildroot}%{_datadir}/foomatic/db/source/{opt,driver}/*.xml
  145. find %{buildroot}%{_datadir}/foomatic/db/source/ -type f | xargs chmod 0644
  146. # Use relative, not absolute, symlink for CUPS filter.
  147. ln -sf ../../../bin/foomatic-rip %{buildroot}%{_libdir}/cups/filter/foomatic-rip
  148. mkdir %{buildroot}%{_datadir}/foomatic/db/source/PPD/Custom
  149. mkdir -p %{buildroot}%{_var}/cache/foomatic
  150. echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
  151. # Remove things we don't ship.
  152. rm -rf %{buildroot}%{_libdir}/perl5/site_perl \
  153. %{buildroot}%{_libdir}/ppr \
  154. %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample
  155. find %{buildroot} -name .packlist -o -name '*.xml.*' | xargs rm -f
  156. %post
  157. /bin/rm -f /var/cache/foomatic/*
  158. # restart the print server if it is running now
  159. /sbin/service lpd condrestart >/dev/null 2>&1
  160. /sbin/service cups condrestart >/dev/null 2>&1
  161. exit 0
  162. %clean
  163. rm -fr %buildroot $RPM_BUILD_DIR/%{name}
  164. %files
  165. %defattr(-,root,root)
  166. %doc --parents */README */USAGE */ChangeLog
  167. %dir %{_sysconfdir}/foomatic
  168. %config(noreplace) %{_sysconfdir}/foomatic/filter.conf
  169. %config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
  170. %{_bindir}/*
  171. %{_sbindir}/*
  172. %{perl_vendorlib}/Foomatic
  173. %{_libdir}/cups/backend/*
  174. %{_libdir}/cups/driver/*
  175. %{_libdir}/cups/filter/*
  176. %{_datadir}/foomatic
  177. %{_datadir}/cups/model/foomatic-db-ppds
  178. %{_mandir}/*/*
  179. %{_var}/cache/foomatic
  180. %changelog
  181. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
  182. - new upstream release.
  183. * Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
  184. - added hplip and coreutils to "Requires:".
  185. - removed hpijs and fileutils from "Requires:".
  186. * Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  187. - new upstream release.
  188. - dropped Source3 (no longer provided by upstream).
  189. - updated Patch2.
  190. * Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
  191. - rebuild with perl 5.12.3
  192. * Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
  193. - add Requires: hpijs
  194. * Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  195. - new upstream release
  196. * Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
  197. - new upstream release.
  198. - applied some patches from Fedora development.
  199. - remove subpackages.
  200. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  201. - applied new versioning policy
  202. - used rpm macros: %%perl_sitelib %%perl_sitearch
  203. - added foomatic-db-engine-3.1-20050411-combo-xml.patch
  204. - added foomatic-db-engine-3.1-20050411-perl-data.patch
  205. - fixed permission of %%{_datadir}/foomatic/db
  206. * Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
  207. - add BuildRequires: libxml2-devel, mpage, Omni
  208. - use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
  209. - run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
  210. - not create ppd-omni package if omni support is disabled
  211. * Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
  212. - updated foomatic-db to 20050411
  213. - updated foomatic-db-engine to 3.1-20050411
  214. - updated foomatic-db-hpijs to 1.5-20050411
  215. - updated foomatic-filters to 3.1-20050411
  216. * Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
  217. - updated foomatic-db to 20050112
  218. - updated foomatic-db-engine to 3.1-20050112
  219. - updated foomatic-db-hpijs to 1.5-20050112
  220. * Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
  221. - updated foomatic-db to 20041220
  222. - updated foomatic-db-hpijs to 1.5-20041220
  223. * Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
  224. - updated foomatic-db to 20040919
  225. - updated foomatic-db-engine to 3.0.2
  226. - updated foomatic-db-hpijs to 1.5-20040919
  227. - updated foomatic-filters to 3.0.2
  228. * Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
  229. - update foomatic-db to 20040526
  230. - update foomatic-db-hpijs to 1.5-20040526
  231. * Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
  232. - sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
  233. ppd-gimp-print-ijs
  234. - add Requires: to ppd-* subpackages.
  235. * Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
  236. - new upstream version
  237. -- Omni-printers-0.9.1
  238. -- gimp-print-foomatic-db-4.2.6
  239. - foomatic.spec -> foomatic-vl.spec
  240. * Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
  241. - new upstream version
  242. -- foomatic-filters-3.0.1
  243. -- foomatic-db-engine-3.0.1
  244. -- foomatic-db-20040219
  245. -- foomatic-db-hpijs-1.5-20040219
  246. * Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
  247. - new upstream version
  248. -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
  249. -- defined filterver
  250. - dropped patch101
  251. * Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
  252. - new upstream cvs version(foomatic-3.0.1rc2)
  253. -- foomatic-db-20040125
  254. -- foomatic-db-engine-3.0.1rc2
  255. -- foomatic-db-hpijs-1.5-20040125
  256. -- foomatic-filters-3.0.1rc2
  257. - added patch101
  258. -- tests diris null in foomatic-filters-3.0.1rc2
  259. * Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
  260. - new upstream cvs version
  261. -- foomatic-db-20040123
  262. -- foomatic-db-engine-3.0-20040123
  263. -- foomatic-db-hpijs-1.5-20040123
  264. -- foomatic-filters-3.0-20040123
  265. - dropped old patches
  266. * Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
  267. - built on perl-5.8.2
  268. * Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
  269. - separated foomatic-db package included xml files
  270. * Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
  271. - added description of ppd sub package
  272. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
  273. - separated foomatic-ppd package included PPD files
  274. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
  275. - new upstream version
  276. -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
  277. -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
  278. - dropped patches
  279. -- foomatic-filters-path.patch(patch0)
  280. -- foomatic-2.0.2-fontpath.patch(patch3)
  281. - updated patches
  282. -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
  283. -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
  284. -- foomatic-filters-3.0-20031109-vine.patch (patch100)
  285. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
  286. - built on perl-5.8.1
  287. - fixed install section in spec file
  288. * Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
  289. - fix some bugs of foomatic-filters.
  290. A
  291. * Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
  292. - new upstream version
  293. -- rewrote spec file
  294. -- added some patches from rawhide(foomatic-3.0.0-5)
  295. - enable cups support
  296. * Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
  297. - imported some patches from foomatic-2.0.2-18
  298. -- added foomatic-2.0.2-psc2210.patch
  299. -- added foomatic-2.0.2-duplex184.patch
  300. * Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
  301. - imported foomatic-2.0.2-15
  302. * Tue Feb 4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
  303. - Update data-generators to CVS.
  304. * Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
  305. - Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
  306. * Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
  307. - Pacify printers that don't understand duplex (bug #82385).
  308. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
  309. - rebuilt
  310. * Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
  311. - Add autodetect info for HP DeskJet 656C. It doesn't really do
  312. IEEE 1284 IDs, but since it's a USB device we can figure out it's
  313. manufacturer and model anyway.
  314. * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
  315. - Set GS_FONTPATH in gs wrapper (bug #81410).
  316. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
  317. - use internal dep generator.
  318. * Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
  319. - Add several device IDs.
  320. * Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
  321. - Update Omni printers to 0.7.2.
  322. - No longer need Omni badxml patch.
  323. * Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
  324. - don't use rpms internal dep generator
  325. * Fri Dec 6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
  326. - Omni XML wasn't well-formed.
  327. * Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
  328. - Update gimp-print data.
  329. - Add 'generic postscript' model.
  330. * Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
  331. - Update Omni printers to 0.7.1.
  332. * Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
  333. - Fix file manifest for perl modules.
  334. - Add autodetect information for HP DeskJet 990C.
  335. * Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
  336. - 2.0.2.
  337. - No longer need 67973, 970c patches.
  338. - Remove cups-drivers-* packages (no longer needed).
  339. - Remove files not shipped. Ship filter.conf.
  340. - Conditionally restart cups.
  341. - Use libdir.
  342. - Don't put things in site_perl; use vendor_perl instead (bug #73528).
  343. * Fri Aug 9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
  344. - Fix autodetect information for HPDJ970C.
  345. * Thu Aug 8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
  346. - For gimp-print, use the Ghostscript stp driver in preference to the
  347. IJS interface.
  348. * Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
  349. - Quieten scriptlets.
  350. * Fri Jul 5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
  351. - Fix autodetect information for HPLJ2100/2100M.
  352. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
  353. - automated rebuild
  354. * Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
  355. - Omni 0.7.0 printers.
  356. * Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
  357. - Update to CVS.
  358. - Remove some more explicit perl dependencies that are picked up
  359. automatically.
  360. * Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
  361. - Remove explicit perl-Storable dependency; it should be perl(Storable),
  362. and that is picked up automatically.
  363. * Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
  364. - Fix release number.
  365. - Drop gen-ppds from the file manifest---use foomatic-compiledb instead
  366. (bug #63622).
  367. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  368. - automated rebuild
  369. * Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
  370. - Remove ghostscript UPP drivers that are gone in 7.05.
  371. * Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
  372. - Update to CVS.
  373. - Updated requirements.
  374. - Updated path and libdir patches.
  375. - Drop hpijs 1.0.2 patch.
  376. - foomatic-datafile has moved to %%{_bindir}.
  377. - Update gimp-print data to 4.2.1.
  378. - Update Omni printer data to 0.6.1.
  379. * Thu Apr 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
  380. - Fix the hpijs option data too (bug #62587).
  381. * Wed Apr 3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
  382. - Back off to 1.0.2 for hpijs driver data (bug #62587).
  383. * Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
  384. - Update to CVS.
  385. * Wed Mar 6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
  386. - Update to CVS.
  387. - Patches no longer needed: conffile, sys, cachedir, fd0.
  388. - Adapted path patch.
  389. * Tue Mar 5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
  390. - Fix bug #58319.
  391. - Drop dbg patch.
  392. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
  393. - Fix file lists.
  394. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
  395. - Fix %post scriplet bug (bug #59942).
  396. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
  397. - Rebuild in new environment.
  398. * Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
  399. - Merge cups-drivers. No epoch needed.
  400. - Require perl-URI.
  401. * Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
  402. - Cache fix.
  403. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
  404. - Don't ship backup files.
  405. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
  406. - Rebuild to pick up new perl installsitelib.
  407. * Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
  408. - Fix a thinko in DB.pl.
  409. * Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
  410. - Update to CVS.
  411. - No longer need the cachedir patch.
  412. - Fix config file path.
  413. - Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
  414. * Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
  415. - Update to CVS.
  416. - Patches no longer needed: prepend, fd3.
  417. - Use RPM_OPT_FLAGS.
  418. - Allow non-root users to use foomatic-datafile (bug #58956).
  419. * Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
  420. - added Provides: perl(Foomatic::GrovePath)
  421. * Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
  422. - Update to CVS.
  423. - Updated Omni printers to those in Omni 0.5.1.
  424. - Updated patches: prepend, fd3.
  425. - Patches no longer needed: utf8, lpdomatic.
  426. - Added gimp-print (formerly stp) foomatic db info, and removed the old
  427. stp.xml file.
  428. - Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
  429. * Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
  430. - REALLY fix PCL fixup code (bug #55909, others).
  431. - PreReq fileutils, initscripts (bug #56984).
  432. - Fix prepends in lpdomatic (bug #57371).
  433. - Run foomatic-cleanupdrivers during install, to remove driver entries
  434. with no command line.
  435. - Put lpdomatic in /usr/sbin again.
  436. - Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
  437. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
  438. - re-imported from upstream to fix some perl fixup code on pcl printers.
  439. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
  440. - fix the rest of the quoting issues with foomatic-combo-xml with the patch
  441. - foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
  442. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
  443. - respin to pull in latest foomatic database, fixes:
  444. - properly use the cache in relation to foomatic-combo-xml's output
  445. - fix _some_ of the quoting issues with calling foomatic-combo-xml
  446. * Wed Dec 5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
  447. - respin to pull in latest foomatic database, fixes:
  448. - droping half of a large job
  449. - -Mutf8 added to the upstream filters
  450. - miscelaneous printer db updates
  451. * Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
  452. - added Requires: fileutils for the 'rm' in post
  453. * Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
  454. - /var/chache => /var/cache, doh!
  455. * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
  456. - fix %%post scriptlet
  457. * Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
  458. - changed the patch to use the -Mutf8 command line option,
  459. - and to restart the printserver, after rebuilding the settings.
  460. * Fri Nov 9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
  461. - grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
  462. - pragma. Without it, they break on _some_ of their options.
  463. * Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
  464. - patched lpdomatic to prepend PostScript options in the _right_ place.
  465. * Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
  466. - zap the foomatic cache on install
  467. * Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
  468. - rolled to pull in latest information.
  469. - added Omni printers to the printer list.
  470. * Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
  471. - rolled to pull in an ia64 fix to foomatic-combo-xml.c
  472. * Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
  473. - rolled to pull in foomatic fixes to foomatic-combo-xml.c
  474. * Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
  475. - upgraded to latest foomatic, we now have fast overview generation!
  476. - this means that there is no prebuilt overview file.
  477. * Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
  478. - WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
  479. - It is now fast enough that there is no real benifit to precompiling.
  480. - NOTE: this forces the package to stop being noarched.
  481. * Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
  482. - fresh pull, maybe it fixes the build errors.
  483. * Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
  484. - did a fresh database pull, which contains the old japanese printers as well.
  485. - removed japanese hack.
  486. * Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
  487. - Add Japanese printer entry.
  488. * Mon Aug 6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
  489. - move the cache back to /var, sigh.
  490. * Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
  491. - made foomatic pre-compute its db
  492. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
  493. - imported from mandrake.
  494. * Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
  495. - Added job listing/removal/manipulation and queue control to
  496. foomatic-printjob
  497. - Support for printing multiple copies with PDQ
  498. * Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
  499. - Included the cupsomatic filter script
  500. - When a queue is set up, default options can be set now
  501. - Help messages of foomatic-configure and foomatic-printjob cleaned up.
  502. * Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
  503. - Many bugfixes in "foomatic-printjob".
  504. - "foomatic-configure" adds the Foomatic config file directory automatically
  505. to the search paths of PDQ.
  506. - Printing a help page under PDQ was broken.
  507. * Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
  508. - BuildRequires: perl-devel
  509. * Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
  510. - initial release.
  511. - Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
  512. - Patch applied which flushes the memory cache regularly, otherwise
  513. foomatic-configure would hang when the Foomatic data of GIMP-Print is
  514. installed.