texlive-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777
  1. # -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %global _use_internal_dependency_generator 0
  4. %global __find_provides %{SOURCE99}
  5. %global __find_requires %{SOURCE98}
  6. %global texlivesrcver 20150521
  7. #% global tlptexlivesrcver 20140507
  8. Summary: The TeX text formatting system
  9. Summary(ja): TeX 文書整形システム
  10. Name: texlive
  11. Version: 2015
  12. Release: 5%{?_dist_release}
  13. License: distributable
  14. Group: Applications/Publishing
  15. URL: http://www.tug.org/texlive/
  16. ## original TeX Live source
  17. Source: http://ftp.tug.org/texlive/Images/test/%{name}-%{texlivesrcver}-source.tar.xz
  18. # Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
  19. ## snapshot
  20. # $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
  21. # $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
  22. # Source: %{name}-source-%{texlivesrcver}.tar.xz
  23. # ## tlptexlive: pmetapost
  24. # Source1: http://www.preining.info/software/build-tlptexlive-%{tlptexlivesrcver}.zip
  25. Source2: http://www.tug.org/texlive/updmap-kanji.html
  26. ## our updmap{,-hdr}.cfg from collection-basic 20140524
  27. # NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
  28. Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
  29. Source7: updmap.cfg.texlive-%{texlivesrcver}
  30. ## desktop files
  31. Source11: texdoctk.desktop
  32. Source98: find-requires-texlive.sh
  33. ## find library sonames for libkpathsea, libptexenc, and libsynctex
  34. Source99: find-provides-texlive.sh
  35. ######
  36. # TeX patches
  37. ######
  38. ## vine
  39. Patch0: reautoconf-parallel.diff
  40. #Patch1: texlive-%{texlivesrcver}-vine.patch
  41. Patch2: texlive-%{texlivesrcver}-texmfcnf-vine.patch
  42. Patch3: texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
  43. #Patch4: texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
  44. #Patch10: texlive-%{texlivesrcver}-pxdvik-vine.patch
  45. ## security
  46. Requires: perl-Tk perl-Tk-TableMatrix
  47. Requires: ghostscript >= 8.71
  48. Requires: nkf
  49. Requires(post,postun): fontconfig
  50. Requires(post): ed mktemp
  51. Requires(post): vutils >= 7.1
  52. %{!?with_firstbuild:Requires: texlive-common = %{version}}
  53. BuildRequires: autoconf >= 2.68
  54. BuildRequires: bison flex
  55. BuildRequires: bzip2-devel
  56. BuildRequires: cairo-devel >= 1.12
  57. BuildRequires: fontconfig-devel
  58. BuildRequires: freetype2-devel >= 2.1.10
  59. BuildRequires: gd-devel
  60. BuildRequires: libjpeg-devel
  61. BuildRequires: libpng-devel >= 1.6
  62. BuildRequires: ncurses-devel
  63. BuildRequires: nkf
  64. BuildRequires: openssl-devel
  65. BuildRequires: pixman-devel >= 0.18
  66. #BuildRequires: poppler-devel >= 0.26
  67. BuildRequires: xorg-x11-devel
  68. BuildRequires: zlib-devel
  69. ## use distro's libpaper
  70. #BuildRequires: libpaper-devel >= 1.1.24-2
  71. ## do not xdvi(k)
  72. #BuildRequires: XOrg-devel
  73. #BuildRequires: openMotif-devel
  74. ## needs to build pxdvi
  75. #BuildRequires: t1lib-devel
  76. BuildRequires: texlive-vtlpkg = %{version}
  77. Buildroot: %{_tmppath}/%{name}-%{version}-root
  78. Vendor: Project Vine
  79. Distribution: Vine Linux
  80. Packager: munepi
  81. %description
  82. The TeX Live software distribution offers a complete TeX system for a
  83. variety of Unix, Macintosh, Windows and other platforms. It
  84. encompasses programs for editing, typesetting, previewing and printing
  85. of TeX documents in many different languages, and a large collection
  86. of TeX macros and font libraries.
  87. The distribution includes extensive general documentation about TeX,
  88. as well as the documentation for the included software packages.
  89. %description -l ja
  90. TeX Live ソフトウェアディストリビューションは、
  91. さまざまな Unix, Macintosh, Windows、および
  92. 他のプラットホームに対して完全な TeX システムを提供します。
  93. 多くの異なった言語を含む TeX ドキュメントの
  94. 編集、組版、閲覧、印刷するためのプログラム、
  95. そして、TeX マクロやフォントライブラリの大きなコレクションを
  96. 同梱しています。
  97. このディストリビューションは
  98. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  99. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  100. %package doc
  101. Summary: TeX Live: Documentation files of %{name}
  102. Group: Applications/Publishing
  103. Requires: %{name} = %{version}-%{release}
  104. BuildArch: noarch
  105. %description doc
  106. This package contains documentation files of %{name}.
  107. %package -n libkpathsea
  108. Summary: path search library for the TeX Live
  109. Summary(ja): TeX Live 用パス検索ライブラリ
  110. Group: System Environment/Libraries
  111. %description -n libkpathsea
  112. This package includes runtime part of the Kpathsea library.
  113. %package -n libkpathsea-devel
  114. Summary: path search libary and header files for the TeX Live
  115. Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
  116. Group: Development/Libraries
  117. Requires: libkpathsea = %{version}-%{release}
  118. %description -n libkpathsea-devel
  119. This package includes static library and header files of the Kpathsea library.
  120. %package -n libptexenc
  121. Summary: Kanji code convert library for Japanese pTeX
  122. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
  123. Group: System Environment/Libraries
  124. Requires: libkpathsea = %{version}-%{release}
  125. %description -n libptexenc
  126. This package includes runtime part of the ptexenc library.
  127. %package -n libptexenc-devel
  128. Summary: Kanji code convert library and header files for Japanese pTeX
  129. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
  130. Group: Development/Libraries
  131. Requires: libptexenc = %{version}-%{release}
  132. %description -n libptexenc-devel
  133. This package includes header files of the ptexenc library.
  134. %package -n libsynctex
  135. Summary: SyncTeX library
  136. Group: System Environment/Libraries
  137. %description -n libsynctex
  138. This package includes the runtime part of SyncTeX library.
  139. %package -n libsynctex-devel
  140. Summary: SyncTeX header files
  141. Group: Development/Libraries
  142. Requires: libsynctex = %{version}-%{release}
  143. %description -n libsynctex-devel
  144. This package includes the header files of SyncTeX library.
  145. %prep
  146. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  147. %setup -q -n %{name}-%{texlivesrcver}-source
  148. # %setup -q -n %{name}-source-%{texlivesrcver}
  149. %patch0 -p0 -b .parallel
  150. # %patch1 -p1 -b .vine
  151. %patch2 -p1 -b .vine
  152. %patch3 -p1 -b .vine
  153. # %patch4 -p1 -b .vine
  154. # ## Applying tlptexlive that provides pxdvi(k) and pmpost
  155. # echo "applying patches"
  156. # cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
  157. # echo $p | grep '^#' >/dev/null || \
  158. # patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
  159. # done
  160. ## Avoid pollution from internal libraries.
  161. #,paper,poppler,xpdf
  162. %__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,t1lib,unzip,zlib} || exit 1
  163. ./reautoconf || exit 1
  164. %build
  165. set -x
  166. unset TEXINPUTS || :
  167. unset HOME || :
  168. export CFLAGS="$RPM_OPT_FLAGS" \
  169. CXXFLAGS="$RPM_OPT_FLAGS" \
  170. LANG=C
  171. PREFIX=$(pwd)/work
  172. TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
  173. TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
  174. TL_CONFIGURE_ARGS=" \
  175. --disable-multiplatform \
  176. --disable-native-texlive-build \
  177. --with-banner-add=\"/Vine Linux\" \
  178. --enable-shared --disable-static \
  179. --enable-compiler-warnings=max \
  180. --without-cxx-runtime-hack \
  181. \
  182. --with-system-xpdf=no --with-system-poppler=no \
  183. --with-system-gd \
  184. --with-system-t1lib \
  185. --with-system-libpng \
  186. --with-system-zlib \
  187. --with-system-freetype2 \
  188. --with-system-pixman \
  189. --with-system-cairo \
  190. --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
  191. --with-pic \
  192. \
  193. --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
  194. --disable-xdvik \
  195. --disable-dvi2tty \
  196. --disable-t1utils --disable-psutils --disable-detex \
  197. --disable-dvipng --disable-lcdf-typetools \
  198. "
  199. export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
  200. TL_MAKE=%__make ./Build || exit 1
  201. %install
  202. ## prepare %%install session
  203. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  204. ## copy inst directory to /usr
  205. %__mkdir_p %{buildroot}
  206. %__cp -a inst %{buildroot}%{_prefix} || exit 1
  207. %ifarch x86_64
  208. %__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
  209. %endif
  210. if [ -f %{buildroot}%{_libdir}/kpathsea/c-auto.h ]; then
  211. %__mv %{buildroot}%{_libdir}/kpathsea/c-auto.h \
  212. %{buildroot}%{_includedir}/kpathsea/c-auto.h || exit 1
  213. %__rm -r %{buildroot}%{_libdir}/kpathsea || exit 1
  214. fi
  215. ## make some fundamental texmf trees
  216. %__mkdir_p %{buildroot}%{_tl_texmfvine}
  217. %__mkdir_p %{buildroot}%{_tl_texmfdist}
  218. %__mkdir_p %{buildroot}%{_tl_texmflocal}
  219. %__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
  220. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}
  221. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  222. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
  223. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
  224. cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
  225. The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
  226. distribution wide.
  227. You must not do any changes in this directory.
  228. EOF
  229. cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
  230. The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
  231. You should not use this directory to manage any other packages because
  232. we Project Vine use this directory to manage non-CTAN packages, some
  233. enhancement packages and so on.
  234. EOF
  235. cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
  236. The directory %{_tl_texmflocal} is the texmf tree of the system wide.
  237. If you are a privileged user of this system,
  238. you can use this directory to manage your local packages.
  239. EOF
  240. ## our texmf-dist/web2c/updmap{,-hdr}.cfg
  241. %__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
  242. %__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
  243. %__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
  244. ## our map files for dvipdfmx
  245. %__mkdir_p %{buildroot}%{_tl_aliasttfdir}
  246. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
  247. for x in ptex uptex otf otf-up; do
  248. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
  249. done
  250. for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
  251. touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
  252. done
  253. ## desktop things
  254. %__mkdir_p %{buildroot}%{_datadir}/applications
  255. # %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
  256. %__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
  257. # for created fonts
  258. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  259. # %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
  260. # %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
  261. ## set executable bit for the library
  262. %__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
  263. %__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
  264. # configure ConTeXt
  265. for x in context luatools texexec texmfstart; do
  266. %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
  267. done
  268. for x in contextjit; do
  269. %__sed -i -e 's|luajittex --luaonly|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; luajittex --luaonly|' %{buildroot}%{_bindir}/${x} || exit 1
  270. done
  271. # touch ghosts
  272. touch %{buildroot}%{_tl_texmfvine}/ls-R
  273. touch %{buildroot}%{_tl_texmfdist}/ls-R
  274. touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
  275. touch %{buildroot}%{_tl_texmfsysvar}/ls-R
  276. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
  277. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
  278. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
  279. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
  280. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
  281. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
  282. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
  283. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
  284. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
  285. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
  286. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
  287. #touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
  288. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
  289. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
  290. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
  291. ## remove unpackaging files
  292. find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
  293. find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
  294. %__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
  295. find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
  296. find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
  297. %__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
  298. %__rm -f %{buildroot}%{_infodir}/*
  299. ## use external packages
  300. %__rm %{buildroot}/usr/bin/latexmk || exit 1
  301. ### Files list
  302. find %{buildroot} -type f -or -type l | \
  303. %__sed -e "s|%{buildroot}||g" | \
  304. %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
  305. %__grep -v "%{_includedir}" | \
  306. %__grep -v "%{_libdir}" | \
  307. %__grep -v "%{_infodir}" | \
  308. %__sed -e "s|.*ls-R$|%ghost &|" \
  309. -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
  310. -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
  311. -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
  312. -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
  313. -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
  314. -e "s|.*\.cnf$|%config(noreplace) &|" \
  315. -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
  316. -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
  317. -e "s|^.*/updmap/$|%config &|" \
  318. -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
  319. -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
  320. -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
  321. -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
  322. -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
  323. -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
  324. -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
  325. -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
  326. -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
  327. -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
  328. -e "s|%{_mandir}/.*|&*|" \
  329. > %{_builddir}/filelist.full
  330. find %{buildroot}%{_tl_texmfvine}* -type d | \
  331. %__sed -e "s|^%{buildroot}|%dir |" \
  332. -e "s|$|/|" >> %{_builddir}/filelist.full
  333. ## subpackages
  334. %__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
  335. cat %{_builddir}/filelist.doc \
  336. %{_builddir}/filelist.full | \
  337. sort | uniq -u > %{_builddir}/filelist.tmp
  338. %__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
  339. %clean
  340. %__rm -rf %{buildroot}
  341. %pretrans
  342. rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013 -e 2014
  343. [ $? -eq 1 ] && exit 0
  344. _trans_time=$(date +%Y%m%d)
  345. echo "Running some transitional processes on your TeX system ... "
  346. x=(
  347. /usr/share/texmf-local
  348. /usr/share/texmf-var
  349. /usr/share/texmf-config
  350. )
  351. for dir in ${x[@]}; do
  352. _trans_dir=${dir}.${_trans_time}.rpmorig
  353. [ -d ${_trans_dir}.old ] && \
  354. echo -n " " && \
  355. echo "Found ${_trans_dir}.old: " && \
  356. echo -n " " && \
  357. %__rm -rvf ${_trans_dir}.old
  358. [ -d ${_trans_dir} ] && \
  359. echo -n " " && \
  360. echo "Found ${_trans_dir}: " && \
  361. echo -n " " && \
  362. %__mv -v ${_trans_dir} ${_trans_dir}.old
  363. [ -d ${dir} ] && \
  364. echo -n " " && \
  365. echo "Found ${dir}: " && \
  366. echo -n " " && \
  367. %__mv -v ${dir} ${_trans_dir}
  368. done
  369. echo "done."
  370. %postun
  371. if [ "$1" = 0 ]; then
  372. %__rm -rf %{_tl_vartexfonts}
  373. fi
  374. exit 0
  375. %post
  376. %_tl_touch_run texhash
  377. %_tl_touch_run updmap
  378. %_tl_touch_run mtxrun
  379. %_tl_touch_run fmtutil
  380. exit 0
  381. %posttrans
  382. %__mkdir_p %{_tl_vartexfonts}
  383. %__chmod 1777 %{_tl_vartexfonts}
  384. ## create our map files {ptex,uptex,otf,otf-up}-vine.map
  385. ( %{_tl_exec_upddeffont} ) ||:
  386. %{_tl_exec_texhash}
  387. %{_tl_exec_mtxrun}
  388. %{_tl_exec_updmap}
  389. %{_tl_exec_fmtutil}
  390. exit 0
  391. %post -n libkpathsea
  392. /sbin/ldconfig
  393. # for x in kpathsea tds web2c; do
  394. # /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
  395. # done
  396. # %preun -n libkpathsea
  397. # if [ "$1" = 0 ]; then
  398. # for x in kpathsea tds web2c; do
  399. # /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
  400. # done
  401. # fi
  402. %postun -n libkpathsea
  403. /sbin/ldconfig
  404. %post -n libptexenc
  405. /sbin/ldconfig
  406. %postun -n libptexenc
  407. /sbin/ldconfig
  408. %triggerin -- ghostscript
  409. %__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
  410. if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
  411. %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  412. elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
  413. %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  414. fi
  415. %_tl_touch_run texhash
  416. exit 0
  417. %files -f %{_builddir}/filelist.full
  418. %defattr(-,root,root)
  419. %{_libdir}/libtexlua52.so.*
  420. %{_libdir}/libtexluajit.so.*
  421. %dir %{_tl_aliasttfdir}
  422. %attr(1777,root,root) %dir %{_tl_vartexfonts}
  423. # %config %{_sysconfdir}/cron.daily/texlive.cron
  424. %exclude %{_includedir}/texlua52/*.h
  425. %exclude %{_includedir}/texlua52/*.hpp
  426. %exclude %{_includedir}/texluajit/*.h
  427. %exclude %{_includedir}/texluajit/*.hpp
  428. %exclude %{_libdir}/libtexlua52.so
  429. %exclude %{_libdir}/libtexluajit.so
  430. %exclude %{_libdir}/pkgconfig/texlua52.pc
  431. %exclude %{_libdir}/pkgconfig/texluajit.pc
  432. %files doc -f %{_builddir}/filelist.doc
  433. %defattr(-,root,root)
  434. %files -n libkpathsea
  435. %defattr(-,root,root)
  436. %{_libdir}/libkpathsea.so.*
  437. # %{_infodir}/kpathsea.info*
  438. %files -n libkpathsea-devel
  439. %defattr(-,root,root)
  440. %{_libdir}/libkpathsea.so
  441. %dir %{_includedir}/kpathsea
  442. %{_includedir}/kpathsea/*.h
  443. %{_libdir}/pkgconfig/kpathsea.pc
  444. %files -n libptexenc
  445. %defattr(-,root,root)
  446. %{_libdir}/libptexenc.so.*
  447. %files -n libptexenc-devel
  448. %defattr(-,root,root)
  449. %{_libdir}/libptexenc.so
  450. %dir %{_includedir}/ptexenc
  451. %{_includedir}/ptexenc/*.h
  452. %{_libdir}/pkgconfig/ptexenc.pc
  453. %files -n libsynctex
  454. %defattr(-,root,root)
  455. %{_libdir}/libsynctex.so.*
  456. %files -n libsynctex-devel
  457. %defattr(-,root,root)
  458. %{_libdir}/libsynctex.so
  459. %dir %{_includedir}/synctex
  460. %{_includedir}/synctex/*.h
  461. %{_libdir}/pkgconfig/synctex.pc
  462. %changelog
  463. * Thu Jan 21 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-5
  464. - fixed some development files
  465. * Tue Jan 12 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-4
  466. - reverted to texlive-20150521-source (TeX Live 2015)
  467. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-3
  468. - texlive-source-20160110 (TeX Live 2016/dev)
  469. * Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
  470. - texlive-source-20150523 (TeX Live 2015/pretest)
  471. - configure ConTeXt/LuaTeX+LuaJIT
  472. * Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
  473. - texlive-source-20150426 (TeX Live 2015/pretest)
  474. * Tue Dec 30 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
  475. - texlive-source-20141230 (TeX Live 2015/dev)
  476. * Thu Jul 3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
  477. - texlive-source-20140525 + tlptexlive 20140507
  478. - dropped texlive-20140524-vine.patch: built with libpng >= 1.6
  479. * Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
  480. - upgrade to TeX Live 2014
  481. - texlive-source-20140524 + tlptexlive 20140507
  482. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
  483. - rebuild with poppler-0.24.5
  484. * Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
  485. - rebuilt
  486. * Fri Nov 1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
  487. - texlive-source-20131101 2014/dev + tlptexlive 20130815
  488. - added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
  489. * Mon Oct 7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
  490. - updated texlive-20131002-texmfcnf-vine.patch:
  491. texmf.cnf (shell_escape_commands): added some programs
  492. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
  493. - texlive-source-20131002 2014/dev + tlptexlive 20130815
  494. - defined %%global __find_requires find-requires-texlive.sh
  495. - dropped unused dependencies of Requires
  496. * Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
  497. - texlive-source-20130919 2014/dev + tlptexlive 20130815
  498. - correct some scripts of README.vine for each texmf trees
  499. * Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
  500. - upgrade to TeX Live 2013
  501. - texlive-source-20130823 2014/dev + tlptexlive 20130815
  502. - dropped Requires: jvf
  503. * Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
  504. - update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
  505. - fixed duplicated lw35 for updmap.pl
  506. - updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
  507. * Sat Mar 9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
  508. - touch the map files generated by updmap-sys
  509. * Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
  510. - fixed Source7: updmap.cfg.texlive-20120701
  511. (upto /etc/texmf/web2c/updmap.cfg)
  512. - fixex %%triggerin -- ghostscript
  513. - replaced %%exec_texhash with %%touch_run texhash
  514. * Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  515. - TeX Live 2012 + tlptexlive 20121107
  516. * Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
  517. - drop BR: poppler-devel temporaly
  518. - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
  519. * Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
  520. - build with poppler-0.18.4
  521. - remove tlmgr
  522. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
  523. - updated to tl11supp-120120
  524. - run %%{exec_fmtutil} at %%post when upgrading
  525. * Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
  526. - updated to tl11supp-111214
  527. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  528. - added BuildRequires: texlive-common
  529. - Babel needs docstrip.tex, which is contained in texlive-collection-latex
  530. - check japanese.ldf
  531. - updated tl11supp-111120-vine.patch
  532. - added the following options to $$TL_CONFIGURE_ARGS:
  533. --disable-detex
  534. --disable-dvipng
  535. --disable-lcdf-typetools
  536. - remove some files of asymptote
  537. - remove a man file of latexmk
  538. - remove man files of lcdf-typetools
  539. - remove man files of dvipng
  540. - remove a man file of detex
  541. * Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  542. - added find-provides-texlive.sh and set it to %%__find_provides
  543. - use to find library sonames for libkpathsea and libptexenc
  544. - added cmex.enc (%%{SOURCE110})
  545. - do not install cmex.enc in our TDS, yet
  546. - removed some unused directories in texmf/fonts/map
  547. - removed man files of lcdf-typetools
  548. - moved texdoc{,tk} and its related files to texlive-doc
  549. * Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  550. - TeX Live 2011 + tl11supp-111120
  551. * Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
  552. - make the directory VARTEXFONTS (%%posttrans)
  553. - dropped %%triggerpostun -- texlive < 2009-17vl6
  554. * Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
  555. - fixed ptexlive-20100711-dvipdfmx-vine.patch
  556. - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
  557. * Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
  558. - added %%pre to avoid conflictions of texmf-{config,var}
  559. * Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
  560. - dropped Requires: texlive-common
  561. - added perl-Tk-TableMatrix
  562. - supported texdoctk
  563. - removed broken symbolic links in /usr/bin
  564. - for each these symbolic links, the package of its real file/path
  565. should be its owner.
  566. * Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
  567. - added %%triggerpostun -- texlive < 2009-17vl6
  568. - make the directory VARTEXFONTS
  569. * Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
  570. - fixed %%dir VARTEXFONTS around in %%files
  571. - dropped BuildRequires: t1utils
  572. * Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
  573. - updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
  574. - changed VARTEXFONTS to /var/lib/texmf/fonts
  575. * Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
  576. - fixed updmap.cfg
  577. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
  578. - dropped Requires: texlive-macros
  579. * Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
  580. - updated ptexlive-20100711-pxdvik-vine.patch
  581. and added texlive-20091107-xdvik-vine.patch
  582. - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
  583. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
  584. - supported Vine Linux 5
  585. - for vl5, changed a requirement of Japanese VF package
  586. - added Requires: texlive-jvf = 2009 (vl5)
  587. - dropped dependencies of Provides:/Obsoletes: tags
  588. - merged these dependencies in texlive-common-vl.spec
  589. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
  590. - rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
  591. * Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
  592. - applied some security patches from Debian
  593. - texlive-2009-CVE-2010-0827.patch
  594. - texlive-2009-CVE-2010-1440.patch
  595. - applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
  596. - applied texlive-2009-luatexdir-libpoppler-0.12.patch
  597. based on texlive-2009-pdftexdir-libpoppler-0.12.patch
  598. - fixed some dependencies
  599. * Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
  600. - added BuildArch: noarch in %%package doc
  601. - removed some comment-out sentences
  602. * Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
  603. - separeted texmf-dist to texlive-common package
  604. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
  605. - unpacked texlive-20091107-source.tar.xz
  606. - babel is available now
  607. - applied eptex-100420 and some patches:
  608. - eptex-100420-vine.patch
  609. - eptex-100420-patch1.diff
  610. * Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  611. - updated ptexlive-20100711
  612. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  613. - customized updmap.cfg to correspond installed fonts
  614. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  615. - fixed insttexfont()
  616. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  617. - added jvf of MORISAWA basic 5 fonts
  618. - added cm-super, mathdesign in fntlst
  619. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  620. - define insttexfont() in %%install
  621. - copy almost compatible tetex-3.0
  622. * Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  623. - ptexlive-20090322 + TeXLive 2009
  624. - added BuildRequires: openssl-devel
  625. * Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
  626. - ptexlive-20091009 + TeXLive 2008