inkscape-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. Name: inkscape
  2. Summary: A Vector Drawing Application
  3. Summary(ja): ベクター描画アプリケーション
  4. Version: 0.92.3
  5. Release: 1%{?_dist_release}
  6. Group: Applications/Graphics
  7. License: GPLv2+
  8. URL: https://launchpad.net/inkscape
  9. Source0: https://launchpad.net/inkscape/%{version}.x/%{version}/+download/inkscape-%{version}.tar.bz2
  10. # # to fix compile error with poppler>=0.58
  11. # Patch1000: poppler-0.58.x.patch
  12. # Patch1001: poppler-0.58.x-autotools.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gtk2-devel >= 2.8.0
  15. BuildRequires: gnome-vfs2-devel >= 2.0
  16. BuildRequires: libxml2-devel >= 2.6.11
  17. BuildRequires: libxslt-devel >= 1.0.15
  18. BuildRequires: gc-devel >= 6.4
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: libsigc++-devel >= 2.0.12
  21. BuildRequires: gtkmm2-devel >= 2.8.0
  22. BuildRequires: libpng-devel >= 1.2.0
  23. BuildRequires: libwpg-devel
  24. BuildRequires: libexif-devel
  25. BuildRequires: libjpeg-turbo-devel
  26. BuildRequires: perl-XML-Parser
  27. BuildRequires: lcms2-devel
  28. BuildRequires: poppler-devel >= 0.14.2
  29. BuildRequires: pango-devel, cairo-devel
  30. BuildRequires: gsl-devel
  31. BuildRequires: libboost-devel
  32. BuildRequires: popt-devel
  33. BuildRequires: ImageMagick-c++-devel
  34. BuildRequires: dos2unix
  35. BuildRequires: automake autoconf
  36. Requires: python-lxml
  37. Requires: perl-XML-RegExp
  38. Requires: perl-XML-DOM
  39. Requires: perl-XML-XQL
  40. # the package requires libperl.so, so it also has to require this:
  41. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  42. # Filter out perl requires and provides
  43. # XXX: For now _all_
  44. %global __perl_provides %{nil}
  45. %global __perl_requires %{nil}
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. %description
  49. Inkscape is a SVG based generic vector-drawing program for
  50. Linux/Unix/Windows/Mac.
  51. %description -l ja
  52. Inkscape は SVG ベースの汎用ベクトル描画プログラムです。
  53. Linux/Unix/Windows/Mac で動作します。
  54. %prep
  55. %setup -q -n %{name}-%{version}
  56. # %patch1000 -p1
  57. # %patch1001 -p1
  58. # https://bugs.launchpad.net/inkscape/+bug/314381
  59. # A couple of files have executable bits set,
  60. # despite not being executable
  61. find . -name '*.cpp' | xargs chmod -x
  62. find . -name '*.h' | xargs chmod -x
  63. find share/extensions -name '*.py' | xargs chmod -x
  64. # Fix end of line encodings
  65. dos2unix -k -q share/extensions/*.py
  66. %build
  67. ./autogen.sh
  68. export CXXFLAGS="$RPM_OPT_FLAGS -std=c++11"
  69. %configure \
  70. --with-python \
  71. --with-gnome-vfs \
  72. --with-inkjar \
  73. --enable-lcms2 \
  74. --enable-poppler-cairo \
  75. --disable-strict-build
  76. make %{?_smp_mflags}
  77. %install
  78. rm -rf %{buildroot}
  79. make install DESTDIR=$RPM_BUILD_ROOT
  80. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  81. %find_lang %{name}
  82. %clean
  83. rm -rf %{buildroot}
  84. %post
  85. /sbin/ldconfig
  86. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  87. %postun
  88. if [ $1 -eq 0 ] ; then
  89. update-desktop-database -q &> /dev/null
  90. touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
  91. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  92. fi
  93. %posttrans
  94. update-desktop-database -q &> /dev/null
  95. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  96. %files -f %{name}.lang
  97. %defattr(-, root, root)
  98. %doc AUTHORS COPYING ChangeLog NEWS README
  99. %{_bindir}/inkscape
  100. %{_bindir}/inkview
  101. %{_datadir}/appdata/inkscape.appdata.xml
  102. %{_datadir}/applications/*.desktop
  103. %{_datadir}/icons/hicolor/*
  104. %{_datadir}/inkscape
  105. %{_mandir}/man1/*
  106. %{_mandir}/*/man1/*
  107. %changelog
  108. * Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 0.92.3-1
  109. - updated to 0.92.3
  110. - drop Patch1000,1001
  111. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92.2-1
  112. - updated to 0.92.2
  113. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
  114. - rebuild with gcc-5.4.0
  115. * Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
  116. - rebuild with poppler-0.43.0
  117. * Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
  118. - update to 0.91
  119. - remove old patches
  120. - add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
  121. * Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
  122. - rebuild with ImageMagick-6.9.1.1
  123. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
  124. - rebuilt with libwpd 0.3.0
  125. - added Patch14 to build with libwpd 0.3.0
  126. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
  127. - rebuild with poppler-0.26.2
  128. * Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
  129. - new upstream release
  130. - add BuildRequires: libwpg-devel
  131. - remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  132. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
  133. - rebuild with poppler-0.24.5
  134. - add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  135. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
  136. - rebuild with ImageMagick-6.8.7.5
  137. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
  138. - rebuild with poppler-0.24.2
  139. * Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
  140. - rebuild with ImageMagick-6.8.6.8
  141. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
  142. - new upstream release
  143. - remove Patch0 (inkscape-0.48.2-poppler_020.patch)
  144. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
  145. - rebuild with poppler-0.20.4
  146. - add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
  147. - change BuildRequires: lcms2-devel instead of lcms-devel
  148. * Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
  149. - new upstream release
  150. * Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
  151. - rebuild with ImageMagick-6.7.5.10
  152. * Sat Feb 4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
  153. - new upstream release
  154. * Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
  155. - add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
  156. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
  157. - new upstream release
  158. - built with poppler-0.16.3
  159. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
  160. - rebuild with poppler-0.14.2
  161. - add BuildRequires: popt-devel, ImageMagick-c++-devel
  162. * Sun Oct 3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
  163. - new upstream release
  164. - rebuilt with ImageMagick-6.6.4.8
  165. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
  166. - added Patch0 for building with poppler-0.12.2+
  167. - rebuilt with new toolchain and ImageMagick-6.6.1.5
  168. - removed BR: libgnomeprint-devel, libgnomeprintui-devel
  169. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
  170. - rebuild with poppler-0.12.1
  171. * Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
  172. - new upstream release
  173. - add BR: libboost-devel
  174. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
  175. - update to 0.47pre2
  176. - drop obsolete patches
  177. - add BR: gsl-devel
  178. * Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
  179. - rebuild with poppler-0.10.2
  180. * Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
  181. - add Patch[1-6]
  182. * Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
  183. - added inkscape-0.46-poppler-0.8.3.patch
  184. - spec in utf-8
  185. - added option %%{?_smp_mflags} at make
  186. * Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
  187. - new upstream release
  188. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
  189. - rebuild with new environment/toolchain
  190. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
  191. - new upstream release
  192. * Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
  193. - add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
  194. - update required version of gtk2-devel
  195. * Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
  196. - new upstream release
  197. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
  198. - new upstream release
  199. * Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
  200. - new upstream release
  201. * Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
  202. - new upstream release
  203. * Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
  204. - new upstream release
  205. * Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
  206. - new upstream release
  207. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
  208. - new upstream release
  209. - add Japanese summary and description
  210. - fixed dependancy of libsigc++12 to libsigc++ >= 2.0
  211. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
  212. - fixed dependancy of libsigc++ to libsigc++12
  213. - fixed %files section
  214. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
  215. - rebuild for Vine Linux
  216. - s/Copyright/License/
  217. - added Requires and BuildRequires
  218. * Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
  219. - Removing _libdir and TODO, updating description
  220. * Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
  221. - Fix up the spec file for current release
  222. * Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
  223. - Update to 0.2.6
  224. * Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
  225. - Update to 0.2.5
  226. - Changed SPEC to benefit from macros