nspluginwrapper-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # Compile as a debug package
  3. %define make_debug_package 0
  4. # What gecko we use
  5. %define gecko_flavour "mozilla"
  6. %define plugin_config_version 1.9
  7. %define plugin_config_name plugin-config-%{plugin_config_version}
  8. %define plugin_config_binary plugin-config
  9. # Excluded plugins (separated by ':')
  10. %define exclude_list "libtotem*:libjavaplugin*:gecko-mediaplayer*:mplayerplug-in*:librhythmbox*:packagekit*:libnsISpicec*"
  11. # Target defines
  12. %if "%{_target_cpu}" == "i386"
  13. %define target_bits 32
  14. %endif
  15. %if "%{_target_cpu}" == "i586"
  16. %define target_bits 32
  17. %endif
  18. %if "%{_target_cpu}" == "i686"
  19. %define target_bits 32
  20. %endif
  21. %if "%{_target_cpu}" == "ppc"
  22. %define target_bits 32
  23. %endif
  24. %if "%{_target_cpu}" == "x86_64"
  25. %define target_bits 64
  26. %endif
  27. %if "%{_target_cpu}" == "ppc64"
  28. %define target_bits 64
  29. %endif
  30. # Define libraries for 32/64 arches
  31. %define lib32 lib
  32. %define lib64 lib64
  33. %define libdir32 /usr/lib
  34. %define libdir64 /usr/lib64
  35. # define nspluginswrapper libdir (invariant, including libdir)
  36. %define pkgdir32 %{libdir32}/%{name}
  37. %define pkgdir64 %{libdir64}/%{name}
  38. # define mozilla plugin dir and back up dir for 32-bit browsers
  39. %define pluginsourcedir32 %{libdir32}/mozilla/plugins
  40. %define plugindir32 %{libdir32}/mozilla/plugins-wrapped
  41. # define mozilla plugin dir and back up dir for 64-bit browsers
  42. %define pluginsourcedir64 %{libdir64}/mozilla/plugins
  43. %define plugindir64 %{libdir64}/mozilla/plugins-wrapped
  44. %define build_dir objs-%{target_bits}
  45. %if "%{target_bits}" == "32"
  46. %define lib %{lib32}
  47. %define libdir %{libdir32}
  48. %define pkgdir %{pkgdir32}
  49. %define plugindir %{plugindir32}
  50. %define pluginsourcedir %{pluginsourcedir32}
  51. %else
  52. %define lib %{lib64}
  53. %define libdir %{libdir64}
  54. %define pkgdir %{pkgdir64}
  55. %define plugindir %{plugindir64}
  56. %define pluginsourcedir %{pluginsourcedir64}
  57. %endif
  58. Summary: A compatibility layer for Netscape 4 plugins
  59. Name: nspluginwrapper
  60. Version: 1.3.0
  61. Release: 4%{?_dist_release}
  62. Source0: http://gwenole.beauchesne.info/projects/nspluginwrapper/files/%{name}-%{version}%{?svndate:-%{svndate}}.tar.bz2
  63. Source1: %{plugin_config_name}.tar.gz
  64. Source2: plugin-config.sh.in
  65. Source3: %{name}.sh.in
  66. Patch1: nspluginwrapper-1.3.0-make.patch
  67. Patch2: nspluginwrapper-1.3.0-configure.patch
  68. Patch3: nspluginwrapper-1.3.0-directory.patch
  69. Patch4: nspluginwrapper-20090625-fix-npident-array-sending.patch
  70. Patch5: nspluginwrapper-1.3.0-inst.patch
  71. Patch6: nspluginwrapper-1.3.0-compiz.patch
  72. Patch7: nspluginwrapper-1.3.0-comp.patch
  73. Patch8: nspluginwrapper-1.3.0-silent.patch
  74. Patch9: nspluginwrapper-1.3.0-timeout.patch
  75. Patch10: npplayer-xid.patch
  76. Patch11: nspluginwrapper-1.3.0-racecond.patch
  77. Patch100: plugin-config-setuid.patch
  78. Patch101: plugin-config-umask.patch
  79. Patch102: plugin-config-print.patch
  80. Patch103: plugin-config-native.patch
  81. Patch104: plugin-config-time-check.patch
  82. License: GPLv2+
  83. Group: Applications/Internet
  84. URL: http://gwenole.beauchesne.info/projects/nspluginwrapper/
  85. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  86. Provides: %{name} = %{version}-%{release}
  87. #Requires: mozilla-filesystem
  88. %ifarch x86_64
  89. Requires: compat32-%{name} = %{version}-%{release}
  90. %endif
  91. BuildRequires: pkgconfig gtk2-devel glib2-devel nspr-devel
  92. BuildRequires: libX11-devel libXt-devel cairo-devel pango-devel curl-devel
  93. BuildRequires: gecko-devel
  94. ExclusiveArch: %{ix86} x86_64 ppc
  95. %description
  96. nspluginwrapper makes it possible to use Netscape 4 compatible plugins
  97. compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
  98. This package consists in:
  99. * npviewer: the plugin viewer
  100. * npwrapper.so: the browser-side plugin
  101. * nspluginplayer: stand-alone NPAPI plugin player
  102. * mozilla-plugin-config: a tool to manage plugins installation and update
  103. ## to build compat32 for x86_64 architecture support
  104. %package -n compat32-%{name}
  105. Summary: A compatibility layer for Netscape 4 plugins
  106. Group: System Environment/Libraries
  107. %description -n compat32-%{name}
  108. nspluginwrapper makes it possible to use Netscape 4 compatible plugins
  109. compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
  110. This package consists in:
  111. * npviewer: the plugin viewer
  112. * npwrapper.so: the browser-side plugin
  113. * nspluginplayer: stand-alone NPAPI plugin player
  114. * mozilla-plugin-config: a tool to manage plugins installation and update
  115. %prep
  116. %setup -q -a 1
  117. # Installation & build patches
  118. %patch1 -p1 -b .make
  119. %patch2 -p1 -b .conf
  120. %patch3 -p1 -b .dir
  121. %patch4 -p0 -b .array
  122. %patch5 -p1 -b .inst
  123. %patch6 -p1 -b .compiz
  124. %patch7 -p1 -b .comp
  125. %patch8 -p1 -b .silent
  126. %patch9 -p1 -b .timeout
  127. %patch10 -p1 -b .xid
  128. %patch11 -p1 -b .racecond
  129. # Plugin-config patches
  130. pushd %plugin_config_name
  131. %patch100 -p2
  132. %patch101 -p2 -b .umask
  133. %patch102 -p2 -b .print
  134. %patch103 -p2 -b .native
  135. %patch104 -p2 -b .time
  136. popd
  137. %build
  138. # Build wrapper
  139. # set the propper built options
  140. %if %{make_debug_package}
  141. %if "%{target_bits}" == "64"
  142. export CFLAGS="-g -m64 -DDEBUG"
  143. %else
  144. export CFLAGS="-g -m32 -DDEBUG"
  145. %endif
  146. %else
  147. export CFLAGS="$RPM_OPT_FLAGS"
  148. %endif
  149. # set the propper built options
  150. %if "%{target_bits}" == "64"
  151. export LDFLAGS="-m64 -L%{libdir64}"
  152. %else
  153. export LDFLAGS="-m32 -L%{libdir32}"
  154. %endif
  155. mkdir %{build_dir}
  156. pushd %{build_dir}
  157. ../configure \
  158. --prefix=%{_prefix} \
  159. --target-cpu=%{_target_cpu} \
  160. --pkgdir=%{name} \
  161. --pkglibdir=%{pkgdir} \
  162. --with-lib32=%{lib32} \
  163. --with-lib64=%{lib64} \
  164. --with-base-lib=%{lib} \
  165. --with-base-libdir=%{libdir} \
  166. --viewer-paths=%{pkgdir} \
  167. --with-x11-prefix=/usr \
  168. --with-gecko=%{gecko_flavour} \
  169. --enable-viewer \
  170. --viewer-paths="%{pkgdir32}:%{pkgdir64}"\
  171. --disable-biarch
  172. %__make
  173. popd
  174. #Build plugin configuration utility
  175. pushd %{plugin_config_name}
  176. ./configure --prefix=%{_prefix} --libdir=%{_libdir} CFLAGS="$RPM_OPT_FLAGS"
  177. %__make
  178. popd
  179. %install
  180. %__rm -rf $RPM_BUILD_ROOT
  181. %__mkdir_p $RPM_BUILD_ROOT%{_bindir}
  182. %__mkdir_p $RPM_BUILD_ROOT%{plugindir}
  183. %__mkdir_p $RPM_BUILD_ROOT%{pluginsourcedir}
  184. %__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  185. %__make -C %{build_dir} install DESTDIR=$RPM_BUILD_ROOT
  186. ln -s %{pkgdir}/npwrapper.so $RPM_BUILD_ROOT/%{plugindir}/npwrapper.so
  187. # Install plugin-config utility
  188. pushd %{plugin_config_name}
  189. DESTDIR=$RPM_BUILD_ROOT %__make install
  190. popd
  191. cd $RPM_BUILD_ROOT%{_bindir}
  192. %__mv %{plugin_config_binary} $RPM_BUILD_ROOT/%{pkgdir}
  193. cd -
  194. %__rm -rf $RPM_BUILD_ROOT/usr/doc/plugin-config
  195. cat %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
  196. chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
  197. cat %{SOURCE3} | %{__sed} -e "s|EXCLUDE_LIST|%{exclude_list}|g" \
  198. > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  199. chmod 644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  200. # set up nsplugin player starting script
  201. %{__cat} > $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer << EOF
  202. export MOZ_PLUGIN_PATH=%{pluginsourcedir}
  203. %{pkgdir}/npplayer "$@"
  204. EOF
  205. chmod 755 $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer
  206. # Remove conflicting files
  207. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginplayer
  208. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginwrapper
  209. ## <mozilla-filesystem>
  210. %__mkdir_p $RPM_BUILD_ROOT/usr/{lib,%{_lib}}/mozilla/{plugins,extensions}
  211. %__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/mozilla/extensions
  212. %__mkdir_p $RPM_BUILD_ROOT/etc/skel/.mozilla/{plugins,extensions}
  213. ## </mozilla-filesystem>
  214. %clean
  215. %__rm -rf $RPM_BUILD_ROOT
  216. %post
  217. /usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
  218. %preun
  219. if [ "$1" == "0" ]; then
  220. /usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
  221. fi;
  222. %files
  223. %defattr(-,root,root)
  224. %doc README COPYING NEWS
  225. %dir %{pkgdir}
  226. %dir %{plugindir}
  227. %{pkgdir}/%{plugin_config_binary}
  228. %{pkgdir}/npconfig
  229. %{pkgdir}/npwrapper.so
  230. %{pkgdir}/npviewer.bin
  231. %{pkgdir}/npviewer.sh
  232. %{pkgdir}/npviewer
  233. %{pkgdir}/npplayer
  234. %{pkgdir}/libxpcom.so
  235. %{pkgdir}/libnoxshm.so
  236. %{pkgdir}/nspluginplayer
  237. %{plugindir}/npwrapper.so
  238. %{_bindir}/mozilla-plugin-config
  239. %config %{_sysconfdir}/sysconfig/%{name}
  240. ## <mozilla-filesystem>
  241. /usr/lib*/mozilla
  242. %{_datadir}/mozilla
  243. /etc/skel/.mozilla
  244. ## </mozilla-filesystem>
  245. ## to build compat32 for x86_64 architecture support
  246. %if %{build_compat32}
  247. %files -n compat32-%{name}
  248. %defattr(-,root,root)
  249. %dir %{pkgdir}
  250. %dir %{plugindir}
  251. %{pkgdir}/%{plugin_config_binary}
  252. %{pkgdir}/npconfig
  253. %{pkgdir}/npwrapper.so
  254. %{pkgdir}/npviewer.bin
  255. %{pkgdir}/npviewer.sh
  256. %{pkgdir}/npviewer
  257. %{pkgdir}/npplayer
  258. %{pkgdir}/libxpcom.so
  259. %{pkgdir}/libnoxshm.so
  260. %{pkgdir}/nspluginplayer
  261. %{plugindir}/npwrapper.so
  262. %endif
  263. %changelog
  264. * Fri Apr 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-4
  265. - added spice-xpi to ignored plugins
  266. - applied some improvement patches from Fedora rawhide
  267. * Wed Mar 09 2011 Peter Hatina <phatina@redhat.coom> 1.3.0-18
  268. - Race condition patch
  269. * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
  270. - fixed patch for rhbz#523273
  271. * Mon Nov 15 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-3
  272. - applied some improvement patches from Fedora rawhide
  273. * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
  274. - fixed patch for rhbz#523273
  275. * Tue Jun 29 2010 Martin Stransky <stransky@redhat.com> 1.3.0-13
  276. - Changed RPM timeout to 10 second, should prevent
  277. long browser hangs.
  278. - Disabled debug outputs in normal build.
  279. * Mon Jun 28 2010 Martin Stransky <stransky@redhat.com> 1.3.0-12
  280. - Fixed rhbz#523273 - wrapped plugins not getting updated
  281. * Fri Dec 4 2009 Martin Stransky <stransky@redhat.com> 1.3.0-10
  282. - added Compiz workaround (#542424)
  283. * Tue Nov 10 2009 Martin Stransky <stransky@redhat.com> 1.3.0-9
  284. - added NULL check (#531669)
  285. * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-7
  286. - NPIdentifiers fix by Tristan Schmelcher (Google)
  287. * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-6
  288. - Package kit plugin is ignored now (#511385)
  289. * Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
  290. - changed Group to System Environment/Libraries
  291. * Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.0-1
  292. - initial release
  293. - ported from Fedora development package
  294. * Tue Mar 03 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-5
  295. - Really Fix x86 32bit build (#488308)
  296. * Sun Mar 01 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-4
  297. - Fix x86 32bit build
  298. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  299. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  300. * Thu Jan 9 2009 Martin Stransky <stransky@redhat.com> 1.3.0-2
  301. - Fixed multilib conflicts
  302. * Thu Jan 8 2009 Martin Stransky <stransky@redhat.com> 1.3.0-1
  303. - Updated to 1.3.0 and removed some fedora build patches
  304. * Tue Dec 02 2008 Warren Togami <wtogami@redhat.com> 1.1.8-2
  305. - fix-invalid-RPC-after-NPP_Destroy fixes a crasher
  306. * Mon Dec 1 2008 Martin Stransky <stransky@redhat.com> 1.1.8-1
  307. - Updated to 1.1.8
  308. - Removed already upstreamed patches
  309. * Wed Nov 12 2008 Martin Stransky <stransky@redhat.com> 1.1.4-1
  310. - Updated to 1.1.4
  311. - Consolidated build patches
  312. * Wed Oct 22 2008 Martin Stransky <stransky@redhat.com> 1.1.2-4
  313. - Fixed #449338 - mozilla-plugin-config segfaults with -v argument
  314. * Tue Oct 21 2008 Martin Stransky <stransky@redhat.com> 1.1.2-3
  315. - Removed event patch, it blocks X events and breaks Adobe pdf plugin
  316. - Removed event limit in xt_event_polling_timer_callback
  317. * Fri Oct 17 2008 Martin Stransky <stransky@redhat.com> 1.1.2-2
  318. - added umask to plugin config (#463736)
  319. * Thu Oct 16 2008 Martin Stransky <stransky@redhat.com> 1.1.2-1
  320. - updated to 1.1.12
  321. - added librhythmbox* to ignored plugins (#467187)
  322. - removed debug prints (#467090)
  323. * Mon Oct 06 2008 Warren Togami <wtogami@redhat.com> 1.1.0-11
  324. - Unrevert patch from -7 because Warren was wrong
  325. - Concurrent rpc_method_invoke() patch
  326. * Fri Oct 03 2008 Warren Togami <wtogami@redhat.com> 1.1.0-10
  327. - Revert libcurl requires because it was done in an incorrect way
  328. - Revert patch from -7 because it made things worse
  329. * Tue Sep 30 2008 Martin Stransky <stransky@redhat.com> 1.1.0-7
  330. - Updated fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
  331. * Wed Sep 17 2008 Martin Stransky <stransky@redhat.com> 1.1.0-6
  332. - Added libcurl to requires (#460988)
  333. * Mon Aug 04 2008 Martin Stransky <stransky@redhat.com> 1.1.0-5
  334. - Added fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
  335. * Mon Jul 21 2008 Martin Stransky <stransky@redhat.com> 1.1.0-4
  336. - Removed gecko-libs from requieres (it's not needed now)
  337. * Tue Jul 18 2008 Martin Stransky <stransky@redhat.com> 1.1.0-3
  338. - Enabled experimental stand-alone plugin player
  339. * Tue Jul 15 2008 Martin Stransky <stransky@redhat.com> 1.1.0-2
  340. - Fixed build warnings in our patches
  341. * Tue Jul 8 2008 Martin Stransky <stransky@redhat.com> 1.1.0-1
  342. - update to latest upstream version (1.1.0)
  343. * Mon May 5 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-28
  344. - link pluginwrapper with stdc++ lib
  345. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 0.9.91.5-27
  346. - mozilla-filesystem now owns the plugin source dir
  347. * Tue Mar 11 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-26
  348. - /etc/sysconfig/nspluginwrapper marked as config file
  349. - exclude some player plugins
  350. * Mon Mar 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-25
  351. - updated the sleep patch
  352. * Thu Mar 06 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-24
  353. - added experimental patch for #426968 - nspluginwrapper wakes up too much
  354. * Tue Feb 26 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-23
  355. - merged exclude patch with main tarball
  356. - fixed #431095 - Typo in mozilla-plugin-config verbose output
  357. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.91.5-22
  358. - Autorebuild for GCC 4.3
  359. * Mon Jan 21 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-21
  360. - fixed #426618 - gcjwebplugin error: Failed to run
  361. (added to ignored plugins)
  362. * Mon Jan 14 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-20
  363. - fixed #426176 - Orphaned npviewer.bin processes
  364. * Thu Jan 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-19
  365. - xulrunner rebuild
  366. - fixed build script, added gthread-2.0
  367. * Mon Dec 24 2007 Warren Togami <wtogami@redhat.com> 0.9.91.5-18
  368. - Make nsviewer.bin initialized for multithreading, fixes #360891
  369. * Tue Dec 20 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-17
  370. - disabled xpcom support - it causes more troubles than advantages
  371. * Tue Dec 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-16
  372. - spec fixes
  373. - fixed xulrunner support
  374. * Mon Dec 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-15
  375. - updated configure script - gecko selection
  376. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-14
  377. - enabled xpcom support
  378. - added fix for #393541 - scripts will never fail
  379. * Fri Nov 23 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-13
  380. - rebuilt against xulrunner
  381. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-12
  382. - more fixes from review by security standards team
  383. * Wed Oct 31 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-11
  384. - added fixes from review by security standards team
  385. * Fri Oct 26 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-10
  386. - mozilla-plugin-config can be run by normal user now
  387. * Wed Oct 24 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-9
  388. - Updated config utility - removes dangling symlinks and
  389. wrapped plugins
  390. * Tue Oct 23 2007 Jeremy Katz <katzj@redhat.com> 0.9.91.5-8
  391. - Rebuild against new firefox
  392. * Mon Oct 15 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-7
  393. - added a fix for #281061 - gnash fails when wrapped, works when native
  394. * Wed Oct 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-6
  395. - removed possibble deadlock during plugin restart
  396. * Tue Oct 9 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-5
  397. - fixed browser crashes (#290901)
  398. * Mon Oct 1 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-4
  399. - quit the plugin when browser crashes (#290901)
  400. * Fri Sep 21 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-3
  401. - added original plugin dir to the package
  402. * Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-2
  403. - added upstream patches - RPC error handling and plugin restart
  404. * Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-1
  405. - update to the latest upstream
  406. * Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-19
  407. - converted rpc error handling code to a thread-safe variant
  408. - added a time limit to plugin restart
  409. * Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-18
  410. - implemented plugin restart (#251530)
  411. * Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-17
  412. - fixed an installation script (#251698)
  413. * Mon Aug 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-16
  414. - fixed plugins check
  415. - minor spec fixes
  416. * Fri Aug 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-15
  417. - removed mozembeded dependency
  418. - excluded totem plugins from wrapping
  419. - xpcom support is optional now
  420. * Thu Aug 9 2007 Christopher Aillon <caillon@redhat.com> 0.9.91.4-14
  421. - Rebuild against newer gecko
  422. * Wed Aug 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-13
  423. - removed unsafe plugins probe
  424. - added agruments to mozilla-plugin-config
  425. * Tue Aug 7 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-12
  426. - removed fake libxpcom
  427. * Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-11
  428. - added gecko dependency
  429. - added plugin configuration utility
  430. * Fri Aug 3 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-10
  431. - fixed totem-complex plugin wrapping
  432. * Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-9
  433. - added plugin dirs
  434. * Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-8
  435. - added switch for creating debug packages
  436. * Thu Jul 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-7
  437. - integrated with firefox / seamonkey
  438. * Tue Jul 11 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-6
  439. - added new options to the configuration utility
  440. - modified along new plug-ins concept
  441. * Thu Jun 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-5
  442. - updated nspluginsetup script
  443. - added support for x86_64 plug-ins
  444. * Thu Jun 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-4
  445. - added ppc arch
  446. - silenced installation scripts
  447. - moved configuration to /etc/sysconfig
  448. * Thu Jun 12 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-3
  449. - updated nspluginsetup script and package install/uninstall scripts
  450. - added cross-compilation support
  451. - removed binaries stripping
  452. * Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-2
  453. - added BuildRequires - pkgconfig, gtk2-devel, glib, libXt-devel
  454. * Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-1
  455. - initial build