elogind-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202
  1. %define pkg_version 241.3
  2. %define pkg_release 2%{?_dist_release}
  3. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  4. Name: elogind
  5. Summary: The systemd project's "logind", extracted to a standalone package
  6. Summary(ja): systemdプロジェクトのlogindを単独で動作するようにしたソフトウェア
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPL2/LGPL2.1
  10. Group: System Environment/Base
  11. URL: https://wiki.gentoo.org/wiki/Elogind
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: tomop
  15. Source0: https://github.com/elogind/elogind/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  16. Source1: elogind.init
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: util-linux
  19. Requires: polkit
  20. Requires: dbus
  21. Requires: elogind-libs = %{version}-%{release}
  22. BuildRequires: meson
  23. BuildRequires: ninja
  24. BuildRequires: gperf
  25. BuildRequires: audit-libs-devel
  26. BuildRequires: libacl-devel
  27. BuildRequires: libblkid-devel
  28. BuildRequires: libcap-devel
  29. BuildRequires: libmount-devel
  30. BuildRequires: libxcrypt-devel
  31. BuildRequires: dbus-devel
  32. BuildRequires: eudev-libudev-devel
  33. BuildRequires: glib2-devel
  34. BuildRequires: pam-devel
  35. BuildRequires: pkgconfig
  36. BuildRequires: python3-devel
  37. BuildRequires: libxslt
  38. BuildRequires: docbook-style-xsl
  39. %description
  40. elogind is the systemd project's logind, extracted to a standalone package. It's designed for users who prefer a non-systemd init system, but still want to use popular software such as KDE/Wayland or GNOME that otherwise hard-depends on systemd.
  41. %description -l ja
  42.  eloginは、systemdプロジェクトのlogindを単体で抽出したものです。これは
  43. systemdを利用していないシステム上で、KDE、Wayland、GNOMEのようにsystemd
  44. に強く依存しているソフトウェアを使用したいユーザのために設計されています。
  45. %package libs
  46. Summary: shared libraries for elogind
  47. Summary(ja): eloginのための共有ライブラリファイル
  48. Group: System Environment/Libraries
  49. %description libs
  50. This package contains shared libraries for elogind
  51. %description libs -l ja
  52.  このパッケージにはeloginを用いた開発のための共有ライブラリファイル
  53. が含まれています。
  54. %package devel
  55. Summary: headers and libraries for elogind
  56. Summary(ja): eloginを用いた開発のためのヘッダ・ライブラリファイル
  57. Group: Development/Libraries
  58. Requires: elogind-libs = %{version}-%{release}
  59. %description devel
  60. This package contains headers and libraries for elogind
  61. %description devel -l ja
  62.  このパッケージにはeloginを用いた開発のためのヘッダ・ライブラリファイル
  63. が含まれています。
  64. %package -n compat32-elogind-libs
  65. Summary: shared libraries for elogind
  66. Summary(ja): eloginのための共有ライブラリファイル
  67. Group: System Environment/Libraries
  68. %description -n compat32-elogind-libs
  69. This package contains shared libraries for elogind
  70. %description -n compat32-elogind-libs -l ja
  71.  このパッケージにはeloginを用いた開発のための共有ライブラリファイル
  72. が含まれています。
  73. %prep
  74. %autosetup -p1
  75. %build
  76. export LANG=ja_JP.UTF-8
  77. %meson
  78. %meson_build
  79. %install
  80. export LANG=ja_JP.UTF-8
  81. %{__rm} -rf %{buildroot}
  82. %meson_install
  83. install -m755 -d %{buildroot}%{_initdir}
  84. install -m755 %{SOURCE1} %{buildroot}%{_initdir}/%{name}
  85. rm -f %{buildroot}/%{_lib}/libelogind.so
  86. ln -s ../../%{_lib}/libelogind.so.0 %{buildroot}%{_libdir}/libelogind.so
  87. perl -pi -e 's|^libdir=.*$|libdir=%{_libdir}|' %{buildroot}%{_libdir}/pkgconfig/libelogind.pc
  88. rm -rf %{buildroot}%{_datadir}/factory
  89. %find_lang %{name}
  90. %check
  91. export LANG=ja_JP.UTF-8
  92. %meson_test
  93. %clean
  94. %{__rm} -rf %{buildroot}
  95. %post
  96. /sbin/chkconfig --add elogind
  97. %preun
  98. if [ $1 -eq 0 ]; then
  99. /sbin/chkconfig elogind off
  100. /sbin/chkconfig --add elogind
  101. fi
  102. %post libs
  103. /sbin/ldconfig
  104. %postun libs
  105. /sbin/ldconfig
  106. %files -f %{name}.lang
  107. %defattr(-,root,root)
  108. %license LICENSE*
  109. %doc NEWS README
  110. %config(noreplace) %{_sysconfdir}/elogind/logind.conf
  111. %config(noreplace) %{_sysconfdir}/pam.d/elogind-user
  112. %{_initdir}/elogind
  113. /bin/*
  114. %{_bindir}/*
  115. /lib/elogind
  116. /lib/udev/rules.d/*
  117. /%{_lib}/security/*
  118. %{_datadir}/dbus-1/system-services/*
  119. %{_datadir}/dbus-1/system.d/*
  120. %{_datadir}/polkit-1/actions/*
  121. %dir %{_datadir}/zsh
  122. %{_datadir}/zsh/site-functions/*
  123. %dir %{_datadir}/bash-completion
  124. %dir %{_datadir}/bash-completion/completions
  125. %{_datadir}/bash-completion/completions/*
  126. %{_mandir}/man1/*
  127. %{_mandir}/man5/*
  128. %{_mandir}/man7/*
  129. %{_mandir}/man8/*
  130. %files libs
  131. /%{_lib}/*.so.*
  132. %files devel
  133. %defattr(-,root,root)
  134. %{_libdir}/libelogind.so
  135. %{_includedir}/elogind
  136. %{_libdir}/pkgconfig/libelogind.pc
  137. %{_mandir}/man3/*
  138. %if %{build_compat32}
  139. %files -n compat32-elogind-libs
  140. /%{_lib}/*.so.*
  141. %endif
  142. %changelog
  143. * Sat May 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 241.3-2
  144. - added a initscript.
  145. * Fri May 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 241.3-1
  146. - new upstream release.
  147. - dropped Patch0: fixed in upstream.
  148. - added BR:libxcrypt-devel.
  149. - fixed %%post and %%postun scripts.
  150. - added BR:audit-libs-devel.
  151. - added BR:dbus-devel.
  152. - added BR:glib2-devel.
  153. * Sun Jan 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-3
  154. - added compat32-elogind-libs.
  155. * Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-2
  156. - separated libs.
  157. - built manuals.
  158. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 239.3-1
  159. - initial build for Vine Linux.