gtkwave-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471
  1. Summary: Waveform Viewer
  2. Summary(ja): 波形ビューワ
  3. Name: gtkwave
  4. Version: 3.3.7
  5. Release: 4%{?_dist_release}
  6. License: GPLv2+
  7. Group: Applications/Engineering
  8. URL: http://gtkwave.sourceforge.net/
  9. Source0: http://gtkwave.sourceforge.net/gtkwave-%{version}.tar.gz
  10. Source1: gtkwave.desktop
  11. Source2: gtkwave-16.png
  12. Source3: gtkwave-32.png
  13. Source4: gtkwave-48.png
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk2-devel
  16. BuildRequires: bzip2-devel
  17. BuildRequires: Judy-devel
  18. %if %{?_dist_release} != "vl4" && %{?_dist_release} != "vl5"
  19. BuildRequires: xz-devel
  20. %endif
  21. BuildRequires: zlib-devel
  22. BuildRequires: gperf
  23. BuildRequires: flex
  24. BuildRequires: desktop-file-utils
  25. BuildRequires: tk
  26. BuildRequires: tcl >= 8.4
  27. %description
  28. GTKWave is a waveform viewer that can view VCD files produced by most Verilog
  29. simulation tools, as well as LXT files produced by certain Verilog simulation
  30. tools.
  31. %prep
  32. %setup -q -n gtkwave-%{version}%{?prerel}
  33. %{__cp} -p .gtkwaverc gtkwaverc.sample
  34. %build
  35. %configure \
  36. --disable-dependency-tracking \
  37. %if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
  38. --disable-xz \
  39. %endif
  40. --enable-judy
  41. make %{?_smp_mflags}
  42. %install
  43. %{__rm} -rf %{buildroot}
  44. make install \
  45. DESTDIR=%{buildroot} \
  46. pkgdatadir=%{_docdir}/gtkwave-%{version} \
  47. INSTALL="%{__install} -p"
  48. # Icons and desktop entry
  49. /usr/bin/desktop-file-install --vendor "" \
  50. --dir %{buildroot}%{_datadir}/applications \
  51. %{SOURCE1}
  52. %{__install} -D -m 644 -p %{SOURCE2} %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
  53. %{__install} -D -m 644 -p %{SOURCE3} %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
  54. %{__install} -D -m 644 -p %{SOURCE4} %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
  55. # Include extra docs
  56. for extradoc in \
  57. gtkwaverc.sample \
  58. ANALOG_README.TXT \
  59. CHANGELOG.TXT \
  60. GNU.TXT \
  61. LICENSE.TXT \
  62. MIT.TXT \
  63. SYSTEMVERILOG_README.TXT
  64. do
  65. %{__install} -p -m 644 ${extradoc} %{buildroot}%{_docdir}/gtkwave-%{version}/
  66. done
  67. %clean
  68. %{__rm} -rf %{buildroot}
  69. %post
  70. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  71. %postun
  72. if [ $1 -eq 0 ] ; then
  73. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  74. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  75. fi
  76. %posttrans
  77. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  78. %files
  79. %defattr(-,root,root,-)
  80. %doc %{_docdir}/gtkwave-%{version}/
  81. %{_bindir}/evcd2vcd
  82. %{_bindir}/fst2vcd
  83. %{_bindir}/ghwdump
  84. %{_bindir}/gtkwave
  85. %{_bindir}/lxt2miner
  86. %{_bindir}/lxt2vcd
  87. %{_bindir}/rtlbrowse
  88. %{_bindir}/shmidcat
  89. %{_bindir}/twinwave
  90. %{_bindir}/vcd2fst
  91. %{_bindir}/vcd2lxt
  92. %{_bindir}/vcd2lxt2
  93. %{_bindir}/vcd2vzt
  94. %{_bindir}/vermin
  95. %{_bindir}/vzt2vcd
  96. %{_bindir}/vztminer
  97. %{_datadir}/applications/gtkwave.desktop
  98. %{_datadir}/icons/hicolor/16x16/apps/gtkwave.png
  99. %{_datadir}/icons/hicolor/32x32/apps/gtkwave.png
  100. %{_datadir}/icons/hicolor/48x48/apps/gtkwave.png
  101. %{_mandir}/man1/evcd2vcd.1*
  102. %{_mandir}/man1/fst2vcd.1*
  103. %{_mandir}/man1/ghwdump.1*
  104. %{_mandir}/man1/gtkwave.1*
  105. %{_mandir}/man1/lxt2miner.1*
  106. %{_mandir}/man1/lxt2vcd.1*
  107. %{_mandir}/man1/rtlbrowse.1*
  108. %{_mandir}/man1/shmidcat.1*
  109. %{_mandir}/man1/twinwave.1*
  110. %{_mandir}/man1/vcd2fst.1*
  111. %{_mandir}/man1/vcd2lxt.1*
  112. %{_mandir}/man1/vcd2lxt2.1*
  113. %{_mandir}/man1/vcd2vzt.1*
  114. %{_mandir}/man1/vermin.1*
  115. %{_mandir}/man1/vzt2vcd.1*
  116. %{_mandir}/man1/vztminer.1*
  117. %{_mandir}/man5/gtkwaverc.5*
  118. %changelog
  119. * Tue Jun 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-4
  120. - BR: tk instead of /usr/include/tcl.h /usr/include/tk.h
  121. (Thanks to takemikaduchi-san)
  122. * Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-3
  123. - added --disable-xz at Vine Linux 5
  124. * Sun Jun 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.7-2
  125. - Initial build for Vine Linux
  126. * Sun Jun 6 2010 Paul Howarth <paul@city-fan.org> 3.3.7-1
  127. - update to 3.3.7 (general bug and compiler warning fixes)
  128. - -n option not needed in desktop file
  129. * Tue May 4 2010 Paul Howarth <paul@city-fan.org> 3.3.6-1
  130. - update to 3.3.6 (see CHANGELOG.TXT for details)
  131. - add desktop file and icons based on Mandriva package
  132. - BR: desktop-file-utils
  133. - add scriptlets to update icon cache
  134. - no longer need to fix permissions of lzma wrapper code
  135. * Sat Mar 20 2010 Paul Howarth <paul@city-fan.org> 3.3.5-1
  136. - update to 3.3.5 (see CHANGELOG.TXT for details)
  137. - add Judy-devel buildreq for improved memory usage efficiency
  138. * Mon Mar 8 2010 Paul Howarth <paul@city-fan.org> 3.3.4-1
  139. - update to 3.3.4 (see CHANGELOG.TXT for details)
  140. * Fri Feb 19 2010 Paul Howarth <paul@city-fan.org> 3.3.3-1
  141. - update to 3.3.3
  142. - drop upstreamed dlopen linking patch
  143. - drop obsolete helper apps mvl2lxt, mvl2vcd, tex2vcd and tla2vcd
  144. * Mon Feb 15 2010 Paul Howarth <paul@city-fan.org> 3.3.2-2
  145. - fix FTBFS due to missing -ldl linking for dlopen function (#565173)
  146. * Tue Jan 5 2010 Paul Howarth <paul@city-fan.org> 3.3.2-1
  147. - update to 3.3.2 (speed up operation on networked filesystems)
  148. * Sat Dec 26 2009 Paul Howarth <paul@city-fan.org> 3.3.0-1
  149. - update to 3.3.0
  150. - added tk support
  151. - bundled old liblzma replaced by system xz (add BR: xz-devel)
  152. - tcl/tk support require Fedora >= 2 or RHEL >= 4 (tcl 8.4)
  153. * Fri Sep 4 2009 Paul Howarth <paul@city-fan.org> 3.2.3-1
  154. - update to 3.2.3
  155. - fix permissions in bundled liblzma for debuginfo
  156. * Thu Aug 6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-3
  157. - drop patch for #515672, not needed with gcc 4.4.1-4
  158. * Thu Aug 6 2009 Paul Howarth <paul@city-fan.org> 3.2.2-2
  159. - add patch to work around #515672 (internal compiler error on PPC)
  160. * Wed Aug 5 2009 Paul Howarth <paul@city-fan.org> 3.2.2-1
  161. - update to 3.2.2 (new tools evcd2vcd/fst2vcd/vcd2fst)
  162. - drop print-to-file patch, no longer needed
  163. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-2.1
  164. - rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  165. * Wed Jul 15 2009 Paul Howarth <paul@city-fan.org> 3.2.1-2
  166. - add upstream patch for crash on print to file (#511858)
  167. * Tue Apr 14 2009 Paul Howarth <paul@city-fan.org> 3.2.1-1
  168. - update to 3.2.1
  169. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 3.2.0-1.1
  170. - rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  171. * Tue Feb 17 2009 Paul Howarth <paul@city-fan.org> 3.2.0-1
  172. - update to 3.2.0
  173. * Mon Feb 2 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.2.RC5
  174. - update to 3.2.0RC5
  175. * Fri Jan 29 2009 Paul Howarth <paul@city-fan.org> 3.2.0-0.1.RC4
  176. - update to 3.2.0RC4 (#481264)
  177. - new upstream URLs
  178. - buildreq /usr/include/tcl.h for embedded tcl support
  179. * Thu Aug 21 2008 Paul Howarth <paul@city-fan.org> 3.1.13-1
  180. - update to 3.1.13
  181. * Mon Jul 14 2008 Paul Howarth <paul@city-fan.org> 3.1.12-1
  182. - update to 3.1.12
  183. * Thu Jun 19 2008 Paul Howarth <paul@city-fan.org> 3.1.11-1
  184. - update to 3.1.11
  185. * Thu May 15 2008 Paul Howarth <paul@city-fan.org> 3.1.10-1
  186. - update to 3.1.10
  187. * Tue Apr 22 2008 Paul Howarth <paul@city-fan.org> 3.1.9-1
  188. - update to 3.1.9
  189. * Mon Apr 7 2008 Paul Howarth <paul@city-fan.org> 3.1.8-1
  190. - update to 3.1.8
  191. * Tue Mar 25 2008 Paul Howarth <paul@city-fan.org> 3.1.7-1
  192. - update to 3.1.7
  193. * Wed Feb 27 2008 Paul Howarth <paul@city-fan.org> 3.1.6-1
  194. - update to 3.1.6
  195. * Fri Feb 1 2008 Paul Howarth <paul@city-fan.org> 3.1.4-1
  196. - update to 3.1.4
  197. * Tue Jan 15 2008 Paul Howarth <paul@city-fan.org> 3.1.3-1
  198. - update to 3.1.3
  199. * Wed Jan 2 2008 Paul Howarth <paul@city-fan.org> 3.1.2-1
  200. - update to 3.1.2
  201. * Fri Sep 28 2007 Paul Howarth <paul@city-fan.org> 3.1.1-1
  202. - update to 3.1.1
  203. * Tue Sep 4 2007 Paul Howarth <paul@city-fan.org> 3.1.0-1
  204. - update to 3.1.0
  205. * Fri Aug 24 2007 Paul Howarth <paul@city-fan.org> 3.0.30-3
  206. - clarify license as GPL, version 2 or later
  207. * Fri Jul 27 2007 Paul Howarth <paul@city-fan.org> 3.0.30-1
  208. - update to 3.0.30
  209. * Fri Jun 8 2007 Paul Howarth <paul@city-fan.org> 3.0.29-1
  210. - update to 3.0.29
  211. - spec file much-simplified as gtkwave is now fully autotooled
  212. - try to retain upstream timestamps as far as possible
  213. - use parallel make
  214. * Tue May 1 2007 Paul Howarth <paul@city-fan.org> 3.0.28-1
  215. - update to 3.0.28
  216. - update source URL to master source
  217. * Mon Apr 30 2007 Paul Howarth <paul@city-fan.org> 3.0.27-1
  218. - update to 3.0.27
  219. - rename "vertex" to "vermin" to avoid conflict with Vertex 3D Model Assembler
  220. (http://wolfpack.twu.net/Vertex/index.html)
  221. * Fri Apr 20 2007 Paul Howarth <paul@city-fan.org> 3.0.26-1
  222. - update to 3.0.26
  223. * Wed Apr 11 2007 Paul Howarth <paul@city-fan.org> 3.0.25-1
  224. - update to 3.0.25
  225. * Thu Apr 5 2007 Paul Howarth <paul@city-fan.org> 3.0.24-1
  226. - update to 3.0.24
  227. * Tue Mar 20 2007 Paul Howarth <paul@city-fan.org> 3.0.23-1
  228. - update to 3.0.23
  229. * Mon Feb 26 2007 Paul Howarth <paul@city-fan.org> 3.0.22-1
  230. - update to 3.0.22
  231. * Mon Feb 5 2007 Paul Howarth <paul@city-fan.org> 3.0.21-1
  232. - update to 3.0.21
  233. * Wed Jan 24 2007 Paul Howarth <paul@city-fan.org> 3.0.20-1
  234. - update to 3.0.20
  235. * Tue Jan 2 2007 Paul Howarth <paul@city-fan.org> 3.0.19-1
  236. - update to 3.0.19
  237. * Tue Dec 5 2006 Paul Howarth <paul@city-fan.org> 3.0.18-1
  238. - update to 3.0.18
  239. * Tue Nov 28 2006 Paul Howarth <paul@city-fan.org> 3.0.17-1
  240. - update to 3.0.17
  241. * Tue Nov 14 2006 Paul Howarth <paul@city-fan.org> 3.0.16-1
  242. - update to 3.0.16
  243. * Mon Oct 30 2006 Paul Howarth <paul@city-fan.org> 3.0.15-1
  244. - update to 3.0.15
  245. * Wed Oct 18 2006 Paul Howarth <paul@city-fan.org> 3.0.14-1
  246. - update to 3.0.14
  247. * Mon Oct 9 2006 Paul Howarth <paul@city-fan.org> 3.0.13-1
  248. - update to 3.0.13
  249. * Tue Oct 3 2006 Paul Howarth <paul@city-fan.org> 3.0.12-2
  250. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  251. * Fri Sep 22 2006 Paul Howarth <paul@city-fan.org> 3.0.12-1
  252. - update to 3.0.12
  253. - create dummy libz/libbz2 Makefile.in files to ensure that config.h gets
  254. generated
  255. * Thu Sep 14 2006 Paul Howarth <paul@city-fan.org> 3.0.11-1
  256. - update to 3.0.11
  257. * Mon Aug 21 2006 Paul Howarth <paul@city-fan.org> 3.0.10-1
  258. - update to 3.0.10
  259. * Fri Aug 11 2006 Paul Howarth <paul@city-fan.org> 3.0.9-1
  260. - update to 3.0.9
  261. - tarball is now .tar.gz rather than .tgz
  262. * Mon Aug 7 2006 Paul Howarth <paul@city-fan.org> 3.0.8-1
  263. - update to 3.0.8
  264. - new program and manpage: shmidcat
  265. * Fri Jul 21 2006 Paul Howarth <paul@city-fan.org> 3.0.7-1
  266. - update to 3.0.7
  267. - new program and manpage: twinwave
  268. * Mon Jul 17 2006 Paul Howarth <paul@city-fan.org> 3.0.6-1
  269. - update to 3.0.6
  270. * Wed Jun 28 2006 Paul Howarth <paul@city-fan.org> 3.0.5-1
  271. - update to 3.0.5
  272. - new program and manpage: ghwdump
  273. * Fri Jun 2 2006 Paul Howarth <paul@city-fan.org> 3.0.4-1
  274. - update to 3.0.4
  275. * Tue May 30 2006 Paul Howarth <paul@city-fan.org> 3.0.3-1
  276. - update to 3.0.3
  277. * Sun May 28 2006 Paul Howarth <paul@city-fan.org> 3.0.2-2
  278. - adding missing buildreq flex
  279. * Wed May 10 2006 Paul Howarth <paul@city-fan.org> 3.0.2-1
  280. - update to 3.0.2
  281. * Tue May 9 2006 Paul Howarth <paul@city-fan.org> 3.0.1-1
  282. - update to 3.0.1
  283. * Tue May 2 2006 Paul Howarth <paul@city-fan.org> 3.0.0-1
  284. - update to 3.0.0
  285. - add examples directory as %%doc
  286. - add new buildreq gperf
  287. - tweak Makefile.in edits to handle Makefiles under contrib/
  288. - add new binaries rtlbrowse and vertex
  289. - add new manpages for rtlbrowse, vertex, and gtkwaverc
  290. - %%{_mandir} no longer needs to be created manually
  291. - configure script now accepts --libdir
  292. * Tue Mar 7 2006 Paul Howarth <paul@city-fan.org> 1.3.86-1
  293. - update to 1.3.86
  294. * Mon Feb 27 2006 Paul Howarth <paul@city-fan.org> 1.3.85-1
  295. - update to 1.3.85
  296. * Tue Feb 21 2006 Paul Howarth <paul@city-fan.org> 1.3.84-1
  297. - update to 1.3.84
  298. - INSTALL now called INSTALL.TXT
  299. * Thu Feb 16 2006 Paul Howarth <paul@city-fan.org> 1.3.83-2
  300. - rebuild
  301. * Tue Jan 31 2006 Paul Howarth <paul@city-fan.org> 1.3.83-1
  302. - update to 1.3.83
  303. * Thu Jan 19 2006 Paul Howarth <paul@city-fan.org> 1.3.82-1
  304. - update to 1.3.82
  305. * Tue Dec 13 2005 Paul Howarth <paul@city-fan.org> 1.3.81-1
  306. - update to 1.3.81
  307. * Sun Nov 27 2005 Paul Howarth <paul@city-fan.org> 1.3.80-1
  308. - update to 1.3.80
  309. * Wed Nov 23 2005 Paul Howarth <paul@city-fan.org> 1.3.79-2
  310. - fix file permissions in debuginfo package
  311. * Mon Nov 21 2005 Paul Howarth <paul@city-fan.org> 1.3.79-1
  312. - update to 1.3.79
  313. * Wed Nov 9 2005 Paul Howarth <paul@city-fan.org> 1.3.78-1
  314. - update to 1.3.78
  315. * Tue Nov 8 2005 Paul Howarth <paul@city-fan.org> 1.3.77-1
  316. - update to 1.3.77
  317. - GHDL ghw support now included upstream, so remove patches
  318. * Mon Nov 7 2005 Paul Howarth <paul@city-fan.org> 1.3.76-3
  319. - clean up for Fedora Extras:
  320. - don't support GTK1 builds
  321. - unconditionally remove buildroot in %%clean and %%install
  322. - remove redundant glib2-devel buildreq
  323. - add dist tag
  324. * Mon Nov 7 2005 Thomas Sailer <t.sailer@alumni.ethz.ch> - 1.3.76-2
  325. - add GHDL ghw support
  326. * Thu Oct 27 2005 Paul Howarth <paul@city-fan.org> 1.3.76-1
  327. - update to 1.3.76
  328. * Thu Oct 13 2005 Paul Howarth <paul@city-fan.org> 1.3.73-1
  329. - update to 1.3.73
  330. * Mon Oct 10 2005 Paul Howarth <paul@city-fan.org> 1.3.72-1
  331. - update to 1.3.72
  332. * Fri Oct 7 2005 Paul Howarth <paul@city-fan.org> 1.3.71-1
  333. - update to 1.3.71
  334. * Thu Sep 15 2005 Paul Howarth <paul@city-fan.org> 1.3.70-1
  335. - update to 1.3.70
  336. - new program tla2vcd (with manpage)
  337. * Mon Sep 5 2005 Paul Howarth <paul@city-fan.org> 1.3.69-1
  338. - update to 1.3.69
  339. - honour %%{optflags}
  340. - use system bzip and zlib libraries
  341. * Fri Sep 2 2005 Paul Howarth <paul@city-fan.org> 1.3.68-1
  342. - update to 1.3.68
  343. * Wed Aug 25 2005 Paul Howarth <paul@city-fan.org> 1.3.67-1
  344. - update to 1.3.67
  345. * Wed Aug 10 2005 Paul Howarth <paul@city-fan.org> 1.3.64-1
  346. - update to 1.3.64
  347. - new programs lxt2miner & vztminer (with manpages)
  348. * Tue Jul 26 2005 Paul Howarth <paul@city-fan.org> 1.3.63-1
  349. - update to 1.3.63
  350. * Mon Jul 11 2005 Paul Howarth <paul@city-fan.org> 1.3.62-1
  351. - update to 1.3.62
  352. * Thu Apr 21 2005 Paul Howarth <paul@city-fan.org> 1.3.58-1
  353. - update to 1.3.58
  354. - include sample .gtkwaverc in doc area
  355. - update URL to point to new project home page
  356. * Wed Apr 13 2005 Paul Howarth <paul@city-fan.org> 1.3.57-1
  357. - update to 1.3.57
  358. - add support for building with gtk version 1 (build using: --without gtk2)
  359. * Tue Apr 12 2005 Paul Howarth <paul@city-fan.org> 1.3.56-1
  360. - initial RPM build