xchat-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555
  1. # Nobody likely uses this so we disable it
  2. %define with_tclplugin 0
  3. %define name xchat
  4. %define version 2.8.6
  5. %define release 5%{?_dist_release}
  6. Summary: GTK2 based graphical IRC client
  7. Summary(ja): GTK2 ベースのグラフィカル IRC クライアント
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Group: Applications/Internet
  12. License: GPL
  13. URL: http://www.xchat.org/
  14. Source0: http://www.xchat.org/files/source/2.0/xchat-%{version}.tar.bz2
  15. Patch10: http://xchat.org/files/source/2.8/patches/xc286-smallfixes.diff
  16. # Vine
  17. #Source100: xchat-2.4.5-ja.po
  18. Patch100: http://takuo.jp/junk/xchat/99_plus.dpatch
  19. Patch110: http://takuo.jp/junk/xchat/99_x_dialog.dpatch
  20. Patch200: xchat-2.8.6_defaultserver-vine.patch
  21. Patch201: xchat-2.8.6-x86_64.patch
  22. # xchat MUST have the version of perl installed which was used to compile
  23. # it, or else the embeded perl interpreter will break.
  24. Requires: %(perl -le 'use Config; print $Config{archlibexp}')
  25. BuildRequires: glib2-devel >= 2.2.0
  26. BuildRequires: gtk2-devel >= 2.2.0
  27. BuildRequires: bison >= 1.35
  28. BuildRequires: gettext, sed
  29. BuildRequires: perl, python-devel, openssl-devel, pkgconfig
  30. BuildRequires: autoconf
  31. BuildRequires: GConf2-devel
  32. BuildRequires: dbus-devel >= 1.0
  33. BuildRequires: tcl
  34. Requires(post): GConf2 >= 2.14
  35. Requires(preun): GConf2 >= 2.14
  36. Buildroot: %{_tmppath}/%{name}-%{version}-root
  37. %description
  38. X-Chat is an easy to use graphical IRC chat client for the X Window
  39. System.
  40. %description -l ja
  41. X-ChatはGTK2ベースのXウィンドウシステム用のIRCクライアントです。
  42. %prep
  43. %setup -q
  44. %patch10 -p1
  45. %patch100 -p1 -b .plus
  46. %patch110 -p1 -b .dialog
  47. %patch200 -p1 -b .servlist
  48. %patch201 -p1 -b .x86_64
  49. sed -i -e 's/#define GTK_DISABLE_DEPRECATED//g' src/fe-gtk/*.c
  50. %build
  51. touch NEWS ABOUT-NLS
  52. libtoolize --copy --force
  53. aclocal
  54. automake
  55. autoconf
  56. # Remove CVS files from source dirs so they're not installed into doc dirs.
  57. find . -name CVS -type d | xargs rm -rf
  58. export CFLAGS="$RPM_OPT_FLAGS $(perl -MExtUtils::Embed -e ccopts)"
  59. export LDFLAGS=$(perl -MExtUtils::Embed -e ldopts)
  60. if pkg-config openssl ; then
  61. export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
  62. export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
  63. export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
  64. fi
  65. %configure --disable-textfe \
  66. --enable-openssl \
  67. --enable-python \
  68. --disable-spell \
  69. %if %{with_tclplugin}
  70. --enable-tcl \
  71. %endif
  72. --enable-ipv6
  73. make %{?_smp_mflags}
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. make DESTDIR=$RPM_BUILD_ROOT install
  77. # Remove unwanted stuff
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/xchat/plugins/*.la
  80. #rm -f $RPM_BUILD_ROOT%{_datadir}/applications/xchat.desktop
  81. #rm -f $RPM_BUILD_ROOT/etc/X11/applnk/Internet/xchat.desktop
  82. %find_lang %name
  83. %files -f %{name}.lang
  84. %defattr(-,root,root)
  85. %doc README ChangeLog
  86. %{_sysconfdir}/gconf/schemas/*
  87. %{_bindir}/xchat
  88. %{_libdir}/xchat/plugins/*.so
  89. %{_datadir}/applications/xchat.desktop
  90. %{_datadir}/dbus-1/services/*
  91. %{_datadir}/pixmaps/*
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post
  95. # Install schema
  96. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  97. gconftool-2 --makefile-install-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  98. %pre
  99. if [ "$1" -gt 1 -a -f "/etc/gconf/schemas/apps_xchat_url_handler.schemas" ]; then
  100. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  101. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  102. fi
  103. %preun
  104. if [ "$1" -eq 0 ]; then
  105. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  106. gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
  107. fi
  108. %changelog
  109. * Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-5
  110. - rebuild with openssl-1.0.0c
  111. - add BuildRequires: tcl
  112. - add Patch201 (xchat-2.8.6-x86_64.patch)
  113. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.6-4
  114. - rebuilt with python-2.6.4-3
  115. * Tue Nov 03 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-3
  116. - updated Patch200 (Vine channel's default encoding to UTF-8)
  117. * Wed Apr 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-2
  118. - rebuilt with gtk2-2.16.0
  119. - don't #define GTK_DISABLE_DEPRECATED (fixes build against current GTK+)
  120. - add Patch200 (set default server connection for Vine people)
  121. - TODO: update ja.po
  122. * Mon Sep 01 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-1
  123. - updated to 2.8.6
  124. - drop/add patches
  125. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-1
  126. - new versioning policy
  127. - rebuilt with perl-5.10.0
  128. - spec in UTF-8
  129. * Tue Jan 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-0vl1
  130. - updated to 2.8.4 with updated plus patch and upstream patches (14-16)
  131. * Tue Jun 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.2-0vl1
  132. - updated to 2.8.2 with plus patch
  133. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.8-0vl4
  134. - rebuild with dbus-1.0
  135. * Wed Nov 29 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.8-0vl3
  136. - build without libsexy.
  137. * Thu Nov 23 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl2
  138. - added Patch10 and Patch20 for possible crashes under certain environments
  139. * Thu Oct 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl1
  140. - updated to 2.6.8 with plus patch
  141. * Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl1
  142. - new upstream release
  143. - updated ja.po
  144. - added Patch1 from http://www.xchat.org/files/source/2.4/patches/
  145. - added Patches from Fedora
  146. * Sun May 15 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-3
  147. - Prevent interception of down arrow during Input Method (#144588 tagoh)
  148. * Thu Apr 14 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-2
  149. - fix plugins on lib64 (#113188 Ville Skytta)
  150. * Tue Jan 4 2005 Christopher Aillon <caillon@redhat.com> 1:2.4.1-2
  151. - Add Dan Reed's CTCP patch to support multiline messages (#136545)
  152. * Tue Aug 17 2004 Daniel Reed <djr@redhat.com> 1:2.4.0-2
  153. - #125846 Change xchat.desktop names to "IRC"
  154. * Sun Jan 09 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
  155. - rebuild with perl-5.8.6-0vl2
  156. * Tue Jul 6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl3
  157. - rebuild with perl-5.8.2-0vl2
  158. - updated ja.po
  159. * Mon Jun 21 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl2
  160. - resume othersview patch (Patch21)
  161. * Sun Jun 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl1
  162. - new upstream release
  163. - updated Patch10
  164. - dropped unneeded patches
  165. - updated ja.po
  166. * Fri Nov 7 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl5
  167. - build with perl-5.8.2
  168. * Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl4
  169. - build with perl-5.8.1
  170. - change spec file's encoding: shift_jis -> euc-jp
  171. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl3
  172. - add ja.po
  173. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl2
  174. - add patch21 from debian to support othersview.
  175. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl1
  176. - build for Vine Linux based on rawhide
  177. - some parts is merged with Vine Linux 1.8.10-0vl2
  178. * Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.10-0vl2
  179. - rebuilt against gnome-libs-1.4.2-0vl2 (for db1/db4 matters)
  180. - add BuildRequires: automake14, autoconf213
  181. - modified source10 (openprojects has been renamed to freenode)
  182. * Tue Aug 13 2002 IWAI Masaharu <iwai@alib.jp> 1.8.10-0vl1
  183. - upstream update
  184. - updated plus patch
  185. - moved xchat.desktop to %%{_sysconfdir}/X11/applnk/Internet by upstream
  186. * Thu Jul 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl3
  187. - use source10 instead of patch10 for server list
  188. - default server for #VineUsers changed to OpenProjects Network's
  189. * Wed Mar 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl2
  190. - now with 1.8.8 plus patch
  191. * Sat Mar 16 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.8-0vl1
  192. - upstream release
  193. - updated vine-serverlist.patch
  194. - stop to apply plus patch
  195. ( xchat-1.8.4 has the security hole... )
  196. * Tue Oct 2 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl3
  197. - removed backup files for %%patch0 in Document Directory
  198. * Sun Sep 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.4-0vl2
  199. - updated to 1.8.4 release with plus patch :-)
  200. * Sun Sep 30 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl1
  201. - upstream release
  202. * Mon Sep 3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  203. - 1.8.3-0vl1
  204. - upstream release
  205. - add xchat-text
  206. - add docs: COPYING FAQ plugins/* scripts-perl/* scripts-python/*
  207. * Fri Aug 3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
  208. - 1.8.2-0vl1
  209. - upstream release
  210. * Sat Jul 21 2001 <iwaim@cc.mbn.or.jp>
  211. - 1.8.1-0vl1
  212. - upstream release
  213. - modified server.vine patch
  214. * Sun Jul 15 2001 <sagami@vinelinux.org>
  215. - 1.6.4.1-0vl3: prefix -> _prefix
  216. - OLD_PO_FILE_INPUT=yes to build with new gettext
  217. - use %%{find_lang}
  218. * Wed Apr 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  219. - 1.6.4.1-0vl2
  220. - fix CFLAGS for e-paned
  221. * Tue Feb 6 2001 Takuo KITAME <kitame@northeye.org>
  222. - 1.6.3.1-0vl1
  223. - New upstream release
  224. * Tue Oct 31 2000 Jun Nishii <jun@vinelinux.org>
  225. - 1.5.9.4-0vl1
  226. - This is the first release of xchat-plus.
  227. * Mon Jul 3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  228. - added w3m patch
  229. * Wed Apr 12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  230. - updated to 1.4.2
  231. * Thu Mar 14 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  232. - updated to 1.4.1
  233. - separated ja_nls patch to more_ja_nls and libjcode patches.
  234. * Sat Mar 04 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  235. - modified mb_fix patch for cut & paste.
  236. * Fri Feb 11 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  237. - updated to 1.4.0
  238. * Wed Feb 2 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  239. - updated to 1.3.13
  240. * Mon Jan 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  241. - modified mb_fix patch
  242. * Wed Jan 5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  243. - updated to 1.3.10
  244. * Wed Dec 8 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  245. - updated to 1.3.8
  246. - added mb_fix patch
  247. * Tue Nov 9 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
  248. - update to 1.3.6
  249. * Sun Oct 17 1999 Jun NISHII <jun@flatout.org>
  250. - merge ja-patch
  251. * Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-7
  252. - Added back BuildRequires autoconf, and call autoconf prior to ./configure
  253. as it seems to make xchat build successfully. Have not bothered to figure
  254. out why calling autoconf is needed. Something for a rainy day.
  255. * Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-6
  256. - Removed gnome-libs BuildRequires as it is bogus now
  257. - Removed autoconf BuildRequires and usage, as it should be unneeded
  258. - Added new BuildRequires on gettext, bison >= 1.35, glib2-devel >= 2.0.3,
  259. gtk2-devel >= 2.0.3, /bin/sed (#91676 - Warren Togami)
  260. - Removed dead patches: xchat-1.8.9-perlcrypt.patch, xchat-1.8.9-korean-fontset.patch
  261. * Wed May 21 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-5
  262. - Removed xchat.desktop file, as it was earlier replacedwith a patch
  263. - Converted xchat-2.0.2-redhat-desktop-file.patch to be UTF-8 clean now,
  264. instead of the various random legacy mix of encodings it was, updating
  265. the following: es, ko, uk, zh_TW
  266. * Tue May 20 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-4
  267. - Replace explicit perl package name-epoch-version Requires added in 2.0.2-3
  268. with a more robust and generic solution of querying perl for the archlibexp
  269. dir during building, and requiring it instead
  270. * Tue May 20 2003 Bill Nottingham <notting@redhat.com> 2.0.2-3
  271. - rebuild against new (old?) perl, add epoch to dependency
  272. * Sat May 17 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-1
  273. - Updated to new xchat 2.0.2 based on GTK2
  274. - Dropped unneeded patches xchat-1.8.1-konqueror.patch,
  275. xchat-1.8.4-fix-USE_GNOME.patch
  276. - Updated xchat-2.0.2-freenode.patch to refer to Openprojects.net
  277. - Removed doc/xchat.sgml doc/*.html scripts-python scripts-perl from %%doc
  278. - Added xchat-2.0.2-redhat-desktop-file.patch to patch the supplied xchat
  279. desktop file, instead of replacing it and trying to stay in sync
  280. - Added xchat-2.0.2-lib64-cleanup-for-python.patch which fixes build problems
  281. on lib64 archs, and replaces xchat-multilib.patch
  282. - Added with_tclplugin macro and default it to disabled
  283. * Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-8
  284. - Added xchat-1.8.11-nickall.patch which was written by Fabio Olive Leite,
  285. sent to me by Rik van Riel
  286. * Wed Feb 19 2003 Bill Nottingham <notting@redhat.com> 1.8.11-7
  287. - ship single desktop in %{_datadir}/applications, not /etc/X11/applnk
  288. * Fri Jan 31 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-6
  289. - Added xchat-1.8.11-freenode.patch to rename all openprojects.net entries
  290. to freenode.net in the default server list. Patch courtesy of Dan Burcaw
  291. from bug (#81704)
  292. * Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-5
  293. - Removed double .desktop file (#81874,82315)
  294. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.8.11-4
  295. - rebuilt
  296. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-3
  297. - Add bugfix from xchat.org xc1811fixststint.diff
  298. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-2
  299. - Remove CVS files from source dirs so they're not installed into doc dirs.
  300. * Tue Jan 7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-1
  301. - Update to xchat 1.8.11 bugfix release, fixes various runtime crashes
  302. - Remove now included patches: xchat-1.8.10-urlhandler-open-in-new-tab.patch,
  303. xchat-1.8.10-beep-beep-beep.patch
  304. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.8.10-13
  305. - Pick up OpenSSL configuration from pkgconfig, if available
  306. - Add openssl-devel and pkgconfig as buildreqs
  307. * Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.8.10-12
  308. - Fix broken libpython path on multilibbed systems (patch13)
  309. - _smp_mflags
  310. * Tue Nov 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-11
  311. - Added xchat-1.8.10-urlhandler-open-in-new-tab.patch to offer the option of
  312. opening a URL in a new tab of an existing browser window rather than a new
  313. window
  314. * Sat Nov 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-10
  315. - Added BuildRequires: python-devel to hopefully pick up a missing dep
  316. causing package build failure in timp's nightly builds.
  317. - Removed dead patches
  318. - Updated package summary and description to be more user friendly by
  319. rewording, and removing scary words like GNOME, GTK and other irrelevance
  320. * Wed Nov 13 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-9
  321. - Made sure {_sysconfdir}/X11/applnk/Internet/xchat.desktop gets packaged
  322. - Removed some conditional weirdness in %%files list. This may break xchat
  323. erratum releases on Red Hat Linux 7.x. May need to be fixed in future.
  324. * Fri Aug 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-7
  325. - Added Requires line so that xchat requires the exact version of perl
  326. be installed, that was used to compile it, since the embedded perl
  327. interpreter will break, if you upgrade perl
  328. * Thu Aug 15 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-6
  329. - Fix Bill's beep beep beep bug (#71651)
  330. * Wed Aug 14 2002 Jonathan Blandford <jrb@redhat.com> 1.8.10-5
  331. - actually install the desktop file.
  332. * Fri Aug 9 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-3
  333. - Added http://xchat.org/files/source/1.8/patches/xc1810fixme.diff to fix
  334. bug with using /ME in a /QUERY window. (#71179)
  335. * Wed Aug 7 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-2
  336. - Updated to xchat 1.8.10 to fix a few bugs where a remote ircd could cause
  337. the xchat client to crash. This is a bugfix only release.
  338. * Tue Aug 6 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-10
  339. - Added Korean fontset support to fix bug (#69771)
  340. * Mon Aug 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-9
  341. - Enabled python scripting which was somehow disabled somewhere along the
  342. line by default in upstream sources, and we missed catching it. (#70816)
  343. * Sun Aug 4 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-8
  344. - Created new-style net-xchat.desktop file (#69541)
  345. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.9-7
  346. - automated rebuild
  347. * Tue Jun 18 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-6
  348. - updated the package description
  349. - Added CFLAGS and LDFLAGS export vars before configure to fix rpath problem
  350. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  351. - automated rebuild
  352. * Mon May 20 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-2
  353. - Updated to xchat 1.8.9
  354. * Mon Apr 8 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-5
  355. - Re-enabled GNOME support due to user complaints of pixmaps missing, key
  356. bindings, and other fairly important features no longer working.
  357. * Tue Mar 27 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-4
  358. - Disabled GNOME support since it doesn't seem too useful anyways, and forces
  359. all xchat users to install GNOME libs even if they use KDE. (#59626)
  360. - Updated URL and source lines in spec.
  361. * Wed Mar 6 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-1
  362. - Updated to xchat 1.8.8
  363. * Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-6
  364. - Built in new buildroot
  365. * Tue Feb 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-5
  366. - Added xchat-1.8.7-use-sysconf-to-detect-cpus.patch to use glibc's sysconf()
  367. to detect the number of processors available.
  368. * Mon Feb 4 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-4
  369. - Enabled IPv6 support as per the request for enhancement (#52124)
  370. * Thu Jan 24 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-3
  371. - Rebuilt in new build environment
  372. * Thu Jan 10 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-2
  373. - Updated to xchat 1.8.7
  374. - New release fixes security vulnerability in CTCP reply
  375. - Built erratum for all supported releases (1.8.7-1.62.0, 1.8.7-1.70.0,
  376. 1.8.7-1.71.0, 1.8.7-1.72.0)
  377. - Removed konqueror patch as it is integrated now.
  378. * Sat Jan 5 2002 Mike A. Harris <mharris@redhat.com> 1.8.6-2
  379. - Enabled ssl support with --enable-openssl
  380. - Also built releases 1.72.0, 1.71.0, 1.70.0, 1.62.0 for erratum release
  381. * Mon Dec 10 2001 Mike A. Harris <mharris@redhat.com> 1.8.6-1
  382. - Updated to xchat 1.8.6
  383. * Tue Nov 13 2001 Mike A. Harris <mharris@redhat.com> 1.8.5-1
  384. - Updated to xchat 1.8.5
  385. - Added f to rm -r in install and clean sections
  386. * Sun Oct 7 2001 Mike A. Harris <mharris@redhat.com> 1.8.4-1
  387. - Updated to 1.8.4, now using tar.bz2
  388. - Removed kanjiconv-fix patch as it is integrated now
  389. - Added xchat-1.8.4-fix-USE_GNOME.patch to fix simple ifdef USE_GNOME typo
  390. * Fri Jul 13 2001 Akira TAGOH <tagoh@redhat.com> 1.8.1-2
  391. - fixed check locale.
  392. - don't save kanji_conv.
  393. always check locale. however anyone can change the option from
  394. the settings menu.
  395. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  396. - upgrade to 1.8.1
  397. - remove autoconnect patch since it's upstream
  398. - remove japanese patch, upstream seems to have applied
  399. parts of it and changelog says there's upstream support.
  400. (this patch was pretty huge to maintain in an SRPM anyway...)
  401. - put scripts-python scripts-perl in docs bug #28521
  402. - remove patch to include locale.h, gone upstream
  403. - upgrade konqueror patch
  404. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  405. - nevermind, BuildRequires gnome-libs, that should
  406. close #48923
  407. * Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
  408. - fix file list to not include absolute path "/usr/share/..."
  409. no idea how that ever worked at all. closes #48923
  410. * Mon Jun 25 2001 Karsten Hopp <karsten@redhat.de>
  411. - use konqueror, not kfmclient on URLs
  412. * Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  413. - langify
  414. - use %%{_tmppath}
  415. - make it compile
  416. * Tue Feb 13 2001 Akira TAGOH <tagoh@redhat.com>
  417. - Added Japanese patch.
  418. * Tue Feb 13 2001 Havoc Pennington <hp@redhat.com>
  419. - patch that may fix autoconnections (bug 27093)
  420. * Mon Jan 22 2001 Havoc Pennington <hp@redhat.com>
  421. - 1.6.3
  422. - remove patch to desktop file (Internet->Application), seems to
  423. have gone upstream
  424. * Sat Dec 9 2000 Havoc Pennington <hp@redhat.com>
  425. - Remove security fix which has been merged upstream
  426. - upgrade to 1.6.1
  427. * Sat Aug 19 2000 Havoc Pennington <hp@redhat.com>
  428. - Don't use /bin/sh to interpret URLs from the net
  429. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  430. - Updated Epoch
  431. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  432. - automatic rebuild
  433. * Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
  434. - Install HTML docs
  435. * Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
  436. - fix desktop entry
  437. * Fri May 19 2000 Havoc Pennington <hp@redhat.com>
  438. - rebuild for the Winston tree, update to 1.4.2