gnome-sharp2-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189
  1. %define mono_dir %(/usr/bin/monodir)
  2. %define _name gnome-sharp
  3. Summary: .Net Language Bindings for Gnome
  4. Summary(ja): Mono 用 GNOME バインディング
  5. Name: gnome-sharp2
  6. Version: 2.24.1
  7. Release: 7%{?_dist_release}
  8. License: GNU General ublic License (GPL), GNU Library General Public License v. 2.0 and 2.1 (LGPL)
  9. Group: Development/Libraries
  10. URL: http://gtk-sharp.sf.net
  11. Source: %{_name}-%{version}.tar.bz2
  12. Patch2: gnome-sharp-find_gtkhtml_ver.patch
  13. Patch3: gnome-sharp-2.24.1-TestXfer.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk-sharp2 gtk-sharp2-gapi
  16. BuildRequires: librsvg2-devel
  17. BuildRequires: mono-devel monodoc
  18. BuildRequires: vte-devel gtkhtml3-devel
  19. BuildRequires: libSM-devel
  20. %define env_options export MONO_SHARED_DIR=/tmp
  21. %description
  22. This package contains Mono bindings for Gnome.
  23. %package -n gnome-sharp2-complete
  24. Group: Development/Libraries
  25. Summary: GTK+ and GNOME bindings for Mono (virtual package)
  26. Requires: art-sharp2 = %{version}-%{release}
  27. Requires: gconf-sharp2 = %{version}-%{release}
  28. Requires: gnome-sharp2 = %{version}-%{release}
  29. Requires: gnome-vfs-sharp2 = %{version}-%{release}
  30. #Requires: glib-sharp2 >= 2.10.3
  31. %description -n gnome-sharp2-complete
  32. Gtk# is a library that allows you to build fully native graphical GNOME
  33. applications using Mono. Gtk# is a binding to GTK+, the cross platform
  34. user interface toolkit used in GNOME. It includes bindings for Gtk,
  35. Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas. (Virtual
  36. package which depends on all gtk-sharp2 subpackages)
  37. %package -n gnome-vfs-sharp2
  38. Summary: Mono bindings for gnomevfs
  39. Group: Development/Libraries
  40. Requires: gnome-vfs2
  41. %description -n gnome-vfs-sharp2
  42. This package contains Mono bindings gnomevfs.
  43. %package -n art-sharp2
  44. Summary: Mono bindings for libart
  45. Group: Development/Libraries
  46. Requires: libart_lgpl
  47. %description -n art-sharp2
  48. This package contains Mono bindings for libart.
  49. %package -n gconf-sharp2
  50. Summary: Mono bindings for gconf
  51. Group: Development/Libraries
  52. %description -n gconf-sharp2
  53. This package contains Mono bindings for gconf and gconf peditors.
  54. %prep
  55. %setup -q -n %{_name}-%{version}
  56. %patch3 -p1 -b .TestXfer
  57. autoreconf -f -i
  58. %build
  59. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  60. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  61. %configure \
  62. --libexecdir=%{_prefix}/lib \
  63. --enable-debug
  64. make
  65. %install
  66. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  67. %makeinstall
  68. ## remove unuse files
  69. rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
  70. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
  71. rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %files -n gnome-sharp2-complete
  75. %defattr(-, root, root)
  76. ## This is the 'base' package so we put the common dirs of all in this package
  77. # Otherwise, this package doesn't get created!
  78. %dir %{mono_dir}/gtk-sharp-2.0
  79. %dir %{_prefix}/lib/gtk-sharp-2.0
  80. %files -n gnome-sharp2
  81. %defattr(-,root,root)
  82. %{_libdir}/libgnomesharpglue-2.so
  83. %{_libdir}/pkgconfig/gnome-sharp-2.0.pc
  84. %{mono_dir}/gac/*gnome-sharp
  85. %{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
  86. %{_datadir}/gapi-2.0/gnome-api.xml
  87. %files -n gnome-vfs-sharp2
  88. %defattr(-,root,root)
  89. %{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
  90. %{mono_dir}/gac/*gnome-vfs-sharp
  91. %{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
  92. %{_datadir}/gapi-2.0/gnome-vfs-api.xml
  93. %files -n art-sharp2
  94. %defattr(-,root,root)
  95. %{_libdir}/pkgconfig/art-sharp-2.0.pc
  96. %{mono_dir}/gac/*art-sharp
  97. %{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
  98. %{_datadir}/gapi-2.0/art-api.xml
  99. %files -n gconf-sharp2
  100. %defattr(-, root, root)
  101. %{_bindir}/gconfsharp2-schemagen
  102. %{_libdir}/pkgconfig/gconf-sharp-2.0.pc
  103. %{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
  104. %{mono_dir}/gac/*gconf-sharp
  105. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
  106. # Other distros place these in gnome-sharp2??
  107. %{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
  108. %{mono_dir}/gac/*gconf-sharp-peditors
  109. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
  110. %changelog
  111. * Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-7
  112. - add BuildRequires: libSM-devel
  113. * Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-6
  114. - added gnome-sharp-2.24.1-TestXfer.patch
  115. - rebuilt with mono-2.8
  116. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.1-5
  117. - build with rpm-4.8.1-1 for pkg-config file
  118. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
  119. - rebuilt with new environment
  120. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
  121. - rebuilt with latest rpm to update mono-dependencies
  122. - dropt BR: libgnomedb-devel
  123. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
  124. - changed Group to Development/Libraries
  125. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
  126. - updated to 2.24.1
  127. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
  128. - initial build for VineSeed
  129. - updated gnome-sharp2 to 2.20.0
  130. - added japanese summary
  131. - applied vine versioning policy
  132. - spec in utf-8
  133. * Thu Apr 24 2008 wberrier@suse.de
  134. - Update to 2.12.1
  135. * Bugfix in GLib ref management for Gnome.Program crash in
  136. gnome-sharp
  137. * Thu Apr 3 2008 wberrier@novell.com
  138. - Can now build 2.16 and 2.20 from the same spec
  139. - Update to 2.20.0
  140. - Updated bindings to coincide with gtk# 2.12
  141. - Removed bindings: gtkhtml#, rsvg#, and vte#
  142. * Wed Mar 26 2008 wberrier@novell.com
  143. - Update to 2.16.1
  144. - Allow storage of empty lists in gconf
  145. - Bug fixes:
  146. - [GConf] Impossible to set empty list values (bnc#325516)
  147. - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
  148. * Tue Jul 3 2007 wberrier@suse.de
  149. - Initial package of gnome-sharp2 2.16.0
  150. - (Split from gtk-sharp 2.8.3)