perl-Class-Load-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174
  1. %define perl_bootstrap 1
  2. Name: perl-Class-Load
  3. Version: 0.18
  4. Release: 2%{?_dist_release}
  5. Summary: A working (require "Class::Name") and more
  6. Group: Development/Libraries
  7. License: GPL+ or Artistic
  8. URL: http://search.cpan.org/dist/Class-Load/
  9. Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Class-Load-%{version}.tar.gz
  10. BuildArch: noarch
  11. # ===================================================================
  12. # Module build requirements
  13. # ===================================================================
  14. BuildRequires: perl(ExtUtils::MakeMaker)
  15. # ===================================================================
  16. # Module requirements
  17. # ===================================================================
  18. #BuildRequires: perl(base)
  19. #BuildRequires: perl(Carp)
  20. #BuildRequires: perl(Data::OptList)
  21. #BuildRequires: perl(Module::Implementation) >= 0.04
  22. #BuildRequires: perl(Module::Runtime) >= 0.012
  23. #BuildRequires: perl(Package::Stash) >= 0.14
  24. #BuildRequires: perl(strict)
  25. #BuildRequires: perl(Try::Tiny)
  26. #BuildRequires: perl(warnings)
  27. # ===================================================================
  28. # Runtime requirements
  29. # ===================================================================
  30. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  31. # Also requires core module perl(Exporter) via a "use base" construct
  32. %description
  33. require EXPR only accepts Class/Name.pm style module names, not Class::Name.
  34. How frustrating! For that, we provide load_class 'Class::Name'.
  35. It's often useful to test whether a module can be loaded, instead of throwing
  36. an error when it's not available. For that, we provide
  37. try_load_class 'Class::Name'.
  38. Finally, sometimes we need to know whether a particular class has been loaded.
  39. Asking %%INC is an option, but that will miss inner packages and any class for
  40. which the filename does not correspond to the package name. For that, we
  41. provide is_class_loaded 'Class::Name'.
  42. %prep
  43. %setup -q -n Class-Load-%{version}
  44. %build
  45. perl Makefile.PL INSTALLDIRS=vendor
  46. make %{?_smp_mflags}
  47. %install
  48. make pure_install DESTDIR=%{buildroot}
  49. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  50. find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
  51. %{_fixperms} %{buildroot}
  52. %check
  53. #make test %{!?perl_bootstrap:RELEASE_TESTING=1}
  54. %files
  55. %doc Changes LICENSE README
  56. %{perl_vendorlib}/Class/
  57. %{_mandir}/man3/Class::Load.3pm*
  58. %changelog
  59. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.18-2
  60. - rebuild with perl-5.16
  61. * Sat Feb 18 2012 Paul Howarth <paul@city-fan.org> - 0.18-1
  62. - Update to 0.18:
  63. - Require Package::Stash ≥ 0.14 (CPAN RT#75095)
  64. * Sun Feb 12 2012 Paul Howarth <paul@city-fan.org> - 0.17-1
  65. - Update to 0.17:
  66. - Require Module::Runtime 0.012, which has a number of useful bug fixes
  67. - A bug in Class::Load caused test failures when Module::Runtime 0.012 was
  68. used with Perl 5.8.x (CPAN RT#74897)
  69. * Thu Feb 9 2012 Paul Howarth <paul@city-fan.org> - 0.15-1
  70. - Update to 0.15:
  71. - Small test changes to accomodate latest version of Module::Implementation
  72. - BR: at least version 0.04 of perl(Module::Implementation)
  73. * Tue Feb 7 2012 Paul Howarth <paul@city-fan.org> - 0.14-1
  74. - Update to 0.14:
  75. - Use Module::Implementation to handle loading the XS or PP versions of the
  76. code; using this module fixes a few bugs
  77. - Under taint mode, setting an implementation in the
  78. CLASS_LOAD_IMPLEMENTATION env var caused a taint error
  79. - An invalid value in the CLASS_LOAD_IMPLEMENTATION env var is now detected
  80. and reported immediately; no attempt is made to load an invalid
  81. implementation
  82. - BR: perl(Module::Implementation)
  83. - BR: perl(base), perl(Carp), perl(strict) and perl(warnings) for completeness
  84. - Drop version requirement for perl(Package::Stash), no longer present upstream
  85. - Drop explicit runtime dependencies, no longer needed
  86. - Don't BR: perl(Class::Load::XS) or perl(Pod::Coverage::Moose) if we're
  87. bootstrapping
  88. - Don't run the release tests when bootstrapping as the Pod coverage test will
  89. fail in the absence of Pod::Coverage::Moose
  90. * Tue Jan 10 2012 Paul Howarth <paul@city-fan.org> - 0.13-2
  91. - Fedora 17 mass rebuild
  92. * Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 0.13-1
  93. - Update to 0.13:
  94. - Fix some bugs with our use of Try::Tiny, which could cause warnings on some
  95. systems where Class::Load::XS wasn't installed (CPAN RT#72345)
  96. - BR: perl(Test::Without::Module)
  97. * Tue Oct 25 2011 Paul Howarth <paul@city-fan.org> - 0.12-1
  98. - Update to 0.12:
  99. - Require Module::Runtime ≥ 0.011, which fixes problems with Catalyst under
  100. Perl 5.8 and 5.10
  101. - Add versioned runtime dependencies for Module::Runtime and Package::Stash
  102. * Wed Oct 5 2011 Paul Howarth <paul@city-fan.org> - 0.11-1
  103. - Update to 0.11:
  104. - Don't accept package names that start with a digit
  105. - Rewrite some of the guts to use Module::Runtime rather than reimplementing
  106. its functionality
  107. - BR: perl(Module::Runtime) ≥ 0.009
  108. - Drop all support for older distributions as required module
  109. Module::Runtime ≥ 0.009 will not be available prior to F-16
  110. * Tue Sep 6 2011 Paul Howarth <paul@city-fan.org> - 0.10-1
  111. - Update to 0.10:
  112. - Fix is_class_loaded to ignore $ISA (but still look for @ISA) when trying to
  113. determine whether a class is loaded
  114. - Lots of internals cleanup
  115. - BR: perl(Package::Stash) ≥ 0.32 and perl(Try::Tiny)
  116. - Update patches to apply cleanly
  117. * Tue Aug 16 2011 Paul Howarth <paul@city-fan.org> - 0.08-1
  118. - Update to 0.08:
  119. - The previous version was missing a prereq declaration for Data::OptList
  120. (CPAN RT#70285)
  121. - This release by DROLSKY -> update source URL
  122. - Package new documentation: LICENSE and README
  123. - Add build requirements for new release tests and run them:
  124. - perl(Pod::Coverage::Moose)
  125. - perl(Test::CPAN::Changes)
  126. - perl(Test::EOL)
  127. - perl(Test::NoTabs)
  128. - perl(Test::Pod)
  129. - perl(Test::Pod::Coverage)
  130. - perl(Test::Requires)
  131. - perl(Test::Spelling) and aspell-en
  132. - Add patch for building with ExtUtils::MakeMaker < 6.30
  133. - Add patch for building with Test::More < 0.88
  134. - Add patch for building without Test::Requires
  135. - Add patch for fixing spell checker word list
  136. - Don't try to run the POD Coverage test if we don't have Pod::Coverage::Moose
  137. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
  138. - Perl mass rebuild
  139. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  141. * Tue Dec 21 2010 Paul Howarth <paul@city-fan.org> - 0.06-3
  142. - Drop explicit dependency on core module perl(Exporter) (#656408)
  143. * Tue Nov 23 2010 Paul Howarth <paul@city-fan.org> - 0.06-2
  144. - Sanitize spec for Fedora submission
  145. * Mon Nov 22 2010 Paul Howarth <paul@city-fan.org> - 0.06-1
  146. - Initial RPM version