R-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628
  1. %define pkg_name R
  2. %define pkg_version 3.5.3
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: A language for data analysis and graphics
  5. Summary(ja): データ解析・グラフィック化の言語
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv2
  10. Group: Applications/Edutainment
  11. URL: http://www.r-project.org
  12. Source0: https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
  13. # Patch0: R-release.diff.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: gcc-gfortran libgfortran
  17. BuildRequires: texinfo
  18. %if %{?_dist_release} == "vl6"
  19. BuildRequires: R-pcre-devel
  20. BuildRequires: tcl85-devel tk85-devel
  21. %endif
  22. %if %{?_dist_release} >= "vl7"
  23. BuildRequires: pcre2-devel
  24. BuildRequires: tcl-devel tk-devel
  25. %endif
  26. BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
  27. BuildRequires: readline-devel ncurses-devel
  28. BuildRequires: zlib-devel bzip2-devel xz-devel
  29. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  30. BuildRequires: cairo-devel pango-devel
  31. BuildRequires: libicu-devel
  32. BuildRequires: curl-devel
  33. BuildRequires: blas-devel
  34. BuildRequires: texlive-common
  35. BuildRequires: texlive-collection-basic
  36. BuildRequires: texlive-collection-latexextra
  37. BuildRequires: texlive-collection-fontsextra
  38. %if %{?_dist_release} == "vl6"
  39. BuildRequires: texlive-collection-texinfo
  40. %endif
  41. %if %{?_dist_release} >= "vl7"
  42. BuildRequires: texlive-collection-plaingeneric
  43. BuildRequires: texlive-collection-fontsrecommended
  44. %endif
  45. BuildRequires: java-devel
  46. Requires: gcc-gfortran
  47. Requires: libgfortran
  48. Requires: libicu
  49. %if %{?_dist_release} == "vl6"
  50. Requires: tcl85 tk85
  51. Requires: R-pcre
  52. %endif
  53. %if %{?_dist_release} >= "vl7"
  54. Requires: tcl tk
  55. Requires: pcre2
  56. Obsoletes: tcl85 tk85
  57. Obsoletes: R-pcre
  58. %endif
  59. Requires: blas
  60. Requires: openblas-Rblas
  61. Obsoletes: R-devel < %{version}-%{release}
  62. Vendor: Project Vine
  63. Distribution: Vine Linux
  64. Packager: ara_t
  65. %description
  66. 'GNU S' - A language and environment for statistical computing and
  67. graphics. R is similar to the award-winning S system, which was
  68. developed at Bell Laboratories by John Chambers et al. It provides
  69. a wide variety of statistical and graphical techniques (linear and
  70. nonlinear modelling, statistical tests, time series analysis,
  71. classification, clustering, ...).
  72. R is designed as a true computer language with control-flow
  73. constructions for iteration and alternation, and it allows users to
  74. add additional functionality by defining new functions.
  75. For computationally intensive tasks, C, C++ and Fortran code
  76. can be linked and called at run time.
  77. %description -l ja
  78. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  79. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  80. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  81. 幅広い統計解析・視覚化手法を提供する。
  82. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  83. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  84. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  85. 使用することができる。
  86. %package -n libRmath
  87. Summary: standalone math library from the R project
  88. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  89. Group: System Environment/Libraries
  90. %description -n libRmath
  91. A standalone library of mathematical and statistical functions derived
  92. from the R project. This packages provides the shared libRmath library.
  93. %description -l ja -n libRmath
  94. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  95. 共有ライブラリを提供する。
  96. %package -n libRmath-devel
  97. Summary: standalone math library from the R project
  98. Summary(ja): libRmathの開発ライブラリ
  99. Group: Development/Libraries
  100. Requires: libRmath = %{version}-%{release}
  101. %description -n libRmath-devel
  102. A standalone library of mathematical and statistical functions derived
  103. from the R project. This packages provides the header files.
  104. %description -l ja -n libRmath-devel
  105. libRmathのヘッダファイル(Rmath.h)
  106. %package -n libRmath-static
  107. Summary: Static R Standalone math library
  108. Summary(ja): libRmath の静的ライブラリ
  109. Group: Development/Libraries
  110. Requires: libRmath-devel = %{version}-%{release}
  111. %description -n libRmath-static
  112. A standalone library of mathematical and statistical functions derived
  113. from the R project. This package provides the static libRmath library.
  114. %prep
  115. %{__rm} -rf ${RPM_BUILD_ROOT}
  116. %setup -q
  117. # %patch0 -p1
  118. cat > R.desktop <<EOF
  119. [Desktop Entry]
  120. Name=GNU R
  121. Comment=A language for data analysis and graphics
  122. TryExec=/usr/bin/R
  123. Exec=/usr/bin/R
  124. Icon=/usr/share/icons/logo.jpg
  125. Terminal=true
  126. Type=Application
  127. Categories=Education;Science;
  128. StartupNotify=false
  129. EOF
  130. %build
  131. export R_PDFVIEWER="%{_bindir}/xdg-open"
  132. export R_PRINTCMD="lpr"
  133. export R_BROWSER="%{_bindir}/xdg-open"
  134. %if %{?_dist_release} == "vl6"
  135. export LD_LIBRARY_PATH=%{_libdir}/R/lib
  136. %endif
  137. %{configure} --enable-R-shlib --with-tcltk \
  138. --with-blas="-lblas" \
  139. %if %{?_dist_release} == "vl6"
  140. --with-tcl-config=%{_libdir}/tclConfig85.sh \
  141. --with-tk-config=%{_libdir}/tkConfig85.sh \
  142. CPPFLAGS="-I%{_libdir}/R/include" \
  143. LDFLAGS="-L%{_libdir}/R/lib"
  144. %endif
  145. %{__make} %{?_smp_mflags}
  146. pushd src/nmath/standalone
  147. %{__make} %{?_smp_mflags}
  148. popd
  149. %{__make} pdf
  150. %install
  151. %{make_install}
  152. %{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
  153. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  154. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  155. # Remove libRblas.so
  156. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/R/lib/libRblas.so
  157. # Install libRmath files
  158. pushd src/nmath/standalone
  159. %{make_install}
  160. popd
  161. %{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  162. echo "%{_libdir}/R/lib" > \
  163. ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  164. # Fix lication of R_HOME_DIR in shell wrapper
  165. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  166. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  167. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  168. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  169. > ${RPM_BUILD_ROOT}%{_bindir}/R
  170. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  171. # add R into menu
  172. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
  173. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
  174. %{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
  175. %{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
  176. # move manuals
  177. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  178. %{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
  179. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
  180. # make symlink for libblas.so.3 (No need to use blas-devel)
  181. pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
  182. %{__ln_s} %{_libdir}/libblas.so.3 libblas.so
  183. popd
  184. %check
  185. %{__make} check
  186. %clean
  187. %{__rm} -rf ${RPM_BUILD_ROOT}
  188. %post -p %{_syssbindir}/ldconfig
  189. %preun
  190. if [ "$1" = "0" ]
  191. then
  192. %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
  193. %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
  194. fi
  195. %postun -p %{_syssbindir}/ldconfig
  196. %post -n libRmath -p %{_syssbindir}/ldconfig
  197. %postun -n libRmath -p %{_syssbindir}/ldconfig
  198. %files
  199. %defattr(-, root, root)
  200. %{_bindir}/R
  201. %{_bindir}/Rscript
  202. %{_libdir}/R
  203. %{_datadir}/applications/*
  204. %{_datadir}/icons/*
  205. %{_mandir}/man1/*
  206. %{_docdir}/%{name}-%{version}
  207. %{_sysconfdir}/ld.so.conf.d/*
  208. %files -n libRmath
  209. %defattr(-, root, root)
  210. %{_libdir}/libRmath.so
  211. %files -n libRmath-devel
  212. %defattr(-, root, root)
  213. %{_libdir}/pkgconfig/*.pc
  214. %{_includedir}/Rmath.h
  215. %files -n libRmath-static
  216. %defattr(-, root, root)
  217. %{_libdir}/libRmath.a
  218. %changelog
  219. * Mon Mar 11 2019 Toshiaki Ara <ara_t@384.jp> 3.5.3-1
  220. - update to 3.5.3
  221. * Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
  222. - rebuild with gfortran-8.2.0
  223. * Thu Dec 20 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-1
  224. - update to 3.5.2
  225. * Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
  226. - update to 3.5.1
  227. * Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
  228. - add Requires: openblas-Rblas
  229. - change using system blas
  230. * Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
  231. - update to 3.5.0
  232. - drop Patch 1 and 2
  233. * Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
  234. - updated to 3.4.4
  235. - add Obsoletes: tcl85 tk85 R-pcre for VineSeed
  236. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
  237. - rebuild under icu-60.2
  238. * Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
  239. - Updated to 3.4.3
  240. * Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
  241. - Updated to 3.4.2
  242. - change download URL
  243. * Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
  244. - left %%{_libdir}/R/doc
  245. * Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
  246. - Updated to 3.4.1
  247. - rebuild under R-pcre (pcre-8.39) for Vine6
  248. - add Requires: gcc-gfortran
  249. - change to BuildRequires: texlive-collection-plaingeneric
  250. - delete unnecessary descriptions
  251. * Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
  252. - Updated to 3.4.0
  253. - add Patch1 and Patch2 to avoid 'make check' error
  254. - add export TZ="Asia/Tokyo" to avoid 'make check' error
  255. - delete descrption about info
  256. * Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
  257. - Updated to 3.3.3
  258. * Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
  259. - use tcl-8.5/tk-8.5 for Vine6.5
  260. - BuildRequires to tcl85-devel/tk85-devel
  261. - Requires to tcl85/tk85
  262. * Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
  263. - merge SPEC file for Vine6
  264. - drop devel package
  265. - move PDF manuals to /usr/share/doc/R-%%{version}
  266. - revert logo of menu item to logo.jpg
  267. * Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
  268. - Updated to 3.3.2
  269. * Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
  270. - Updated to 3.3.1
  271. - delete BuildRequires: texlive-collection-lang*
  272. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
  273. - add BuildRequires: texlive-collection-lang*
  274. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
  275. - Updated to 3.3.0
  276. - add BuildRequires: pcre-devel xz-devel
  277. - change logo of menu item to Rlogo.svg
  278. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
  279. - correct SPEC file
  280. * Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
  281. - Updated to 3.2.4-revised
  282. * Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
  283. - Updated to 3.2.4
  284. - fixed build error in src/extra/xz
  285. * Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
  286. - add BuildRequires: curl-devel
  287. - add BuildRequires: libgomp
  288. * Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
  289. - Updated to 3.2.3
  290. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
  291. - rebuild with icu-56.1
  292. * Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
  293. - Updated to 3.2.2
  294. * Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
  295. - add configure options: --with-tcltk
  296. - add BuildRequires: tcl-devel tk-devel
  297. - add Requires: tcl tk
  298. * Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
  299. - Updated to 3.2.1
  300. * Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
  301. - add "LIBS=-lbz2" to configure option
  302. * Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
  303. - Updated to 3.2.0
  304. * Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
  305. - Updated to 3.1.3
  306. - added BuildRequires: texlive-collection-fontsextra for Vine6
  307. - changed option "make check-all" to "make check"
  308. - to avoid error in checking of mgcv package
  309. - changed orders of BuildRequires
  310. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  311. - rebuild with icu-54.1
  312. * Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
  313. - Updated to 3.1.2
  314. * Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
  315. - Updated to 3.1.1
  316. - add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
  317. * Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
  318. - add patch (2014-04-26)
  319. * Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
  320. - Updated to 3.1.0
  321. * Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
  322. - Updated to 3.0.3
  323. * Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
  324. - rebuild current VineSeed
  325. - add patch (2014-01-06)
  326. * Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
  327. - add Requires: libicu
  328. * Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
  329. - combine spec files Vine6 and VineSeed
  330. - correct the days of the week in changelog
  331. * Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  332. - delete BuildRequires: texlive-collection-texinfo
  333. - add BuildRequires: texlive-collection-plainextra
  334. - add BuildRequires: texlive-collection-latexextra
  335. - add BuildRequires: texlive-collection-fontsrecommended
  336. - for VineSeed
  337. * Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  338. - Updated to 3.0.2
  339. * Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
  340. - Updated to 3.0.1
  341. - add BuildRequires: java-1.6.0-openjdk-devel
  342. * Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
  343. - Updated to 3.0.0
  344. * Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
  345. - Updated to 2.15.3
  346. - use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
  347. - use BuildRequires ncurses-devel instead of libtermcap-devel
  348. * Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
  349. - Updated to 2.15.2
  350. * Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
  351. - changed group to Applications/Edutainment
  352. - added R to menu
  353. * Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
  354. - Updated to 2.15.1
  355. * Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
  356. - Updated to 2.15.0
  357. * Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
  358. - Updated to 2.14.2
  359. * Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
  360. - Updated to 2.14.1
  361. * Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
  362. - Updated to 2.14.0
  363. - add BuildRequires: texlive-collection-fontsextra
  364. * Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
  365. - Updated to 2.13.2
  366. - add BuildRequires: texlive-common
  367. - use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
  368. - removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
  369. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
  370. - synchronized to VinePlus/5 package
  371. * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
  372. - Updated to 2.13.1
  373. * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
  374. - Updated to 2.13.0
  375. * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
  376. - Updated to 2.12.2
  377. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  378. - add BuildRequires: libicu-devel
  379. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  380. - synchronized to VinePlus/5 package
  381. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  382. - Updated to 2.12.1
  383. - added --enable-R-shlib option to %%configure
  384. - added static subpackage
  385. - use BR: texlive instead of tetex on VineSeed
  386. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  387. - rebuilt with rpm-4.8.1 for pkg-config
  388. * Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  389. - recompiled because tcl/tk were not linked
  390. * Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  391. - Updated to 2.11.0
  392. - added Requires: libgfortran
  393. * Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  394. - Updated to 2.10.1
  395. * Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  396. - patched to 2.10.0
  397. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  398. - spec in UTF-8
  399. * Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  400. - Updated to 2.10.0
  401. * Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  402. - Updated to 2.9.2
  403. - deleted BuildRequires: lapack-devel blas-devel
  404. - rewrote SPEC file
  405. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  406. - Updated to 2.5.1
  407. - added BuildRequires: gcc-gfortran for VineSeed
  408. - added BuildRequires: lapack-devel blas-devel
  409. - fixed %preun script
  410. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  411. - Updated to 2.4.1
  412. - Added INFO option
  413. - Exclude Japanese Rprofile.site
  414. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  415. - Updated to 2.4.0
  416. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  417. - Added optimization flags
  418. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  419. - Packaged for VineLinux3.2
  420. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  421. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  422. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  423. - Packaged for VineLinux3.2
  424. - Slipped texinfo
  425. - Fixed preun error
  426. - Preset Japanese fonts
  427. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  428. - Packaged for VineLinux3.2
  429. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  430. - Restored CAPABILITIES file lost in 2.2.1beta
  431. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  432. - Configure uses --without-blas by default.
  433. - Install pdf manuals.
  434. - All toplevel documentation files are installed into _libdir/R
  435. as they may be required by R (qv note on AUTHORS and THANKS below).
  436. - Legacy scripts for rebuilding package indices removed.
  437. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  438. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  439. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  440. - The files AUTHORS and THANKS need to be installed into _libdir/R
  441. as they are required by the function contributors(). Previously
  442. they were installed only as documentation files.
  443. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  444. - Corrected date error in SPEC file.
  445. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  446. - Dropped support for Red Hat boxed set.
  447. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  448. including support for shared R library.
  449. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  450. with the default optimization flags, so there is a temporary work-around.
  451. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  452. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  453. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  454. - Install R-data.info file as well.
  455. - Make info processing conditional on texinfo version, not platform release,
  456. so that if a new enough version is installed, we will build and install info.
  457. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  458. - Built R 2.1.0. R now supports internationalization, so the patch
  459. to set the locale to "C" is now dropped.
  460. - install.packages() exits gracefully with a helpful message if
  461. the file INSTALL is not present, so this is now included in the
  462. R-devel package.
  463. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  464. - Added support for Scientific Linux (http://www.scientificlinux.org)
  465. A distribution based on RHEL. Thanks to Jon Peatfield.
  466. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  467. - Fixed file ownership in R-devel and libRmath packages
  468. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  469. - R-devel package is now a stub package with no files, except a documentation
  470. file (RPM won't accept sub-packages with no files). R now conflicts
  471. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  472. - Created libRmath subpackage with shared library.
  473. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  474. - Created R-devel and libRmath-devel subpackages
  475. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  476. - Built R 2.0.1
  477. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  478. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  479. gives "lpr".
  480. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  481. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  482. - Info support is now conditional on the macro Rinfo, which is only
  483. defined for Fedora 1 and 2.
  484. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  485. - Built R 2.0.0
  486. - There is no longer a BUGS file, so this is not installed as a
  487. documentation file.