gpac-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368
  1. #% global svndate 20111217
  2. %define with_static 1
  3. Name: gpac
  4. Summary: MPEG-4 multimedia framework
  5. Version: 0.5.2
  6. Release: 2%{?svndate:.svn%svndate}%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://gpac.sourceforge.net/
  10. Source0: https://github.com/gpac/gpac/archive/v%{version}.tar.gz
  11. #Source0: gpac-%{svndate}.tar.bz2
  12. #Source9: gpac-snapshot-vine.sh
  13. Patch2: gpac-0.4.6-amr.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. Obsoletes: %{name} < %{version}, %{name}-libs < %{version}
  16. Obsoletes: %{name}-devel < %{version}
  17. Obsoletes: %{name}-devel-static < %{version}
  18. Requires: %{name}-libs = %{version}-%{release}
  19. BuildRequires: ImageMagick
  20. BuildRequires: SDL-devel
  21. BuildRequires: librsvg2-devel >= 2.5.0
  22. BuildRequires: libGLU-devel
  23. BuildRequires: freeglut-devel
  24. BuildRequires: freetype2-devel >= 2.1.4
  25. BuildRequires: libjpeg-devel
  26. BuildRequires: libpng-devel >= 1.2.5
  27. BuildRequires: libxml2-devel
  28. BuildRequires: openssl-devel
  29. #BuildRequires: openjpeg-devel
  30. BuildRequires: pulseaudio-libs-devel
  31. BuildRequires: zlib-devel
  32. BuildRequires: libogg-devel libvorbis-devel libtheora-devel
  33. BuildRequires: libXt-devel
  34. BuildRequires: libXpm-devel
  35. BuildRequires: libXv-devel
  36. #BuildRequires: wxGTK-devel
  37. %{?_with_mozilla:BuildRequires: gecko-devel}
  38. #BuildRequires: doxygen
  39. BuildRequires: desktop-file-utils
  40. %{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
  41. # *-devel packages provided by other self-build-* should only be listed
  42. # in self-build-%{name}.spec as PreReq.
  43. #BuildRequires: a52dec-devel
  44. #BuildRequires: faad2-devel
  45. #BuildRequires: libmad-devel
  46. #BuildRequires: xvidcore-devel >= 1.0.0
  47. ##BuildRequires: ffmpeg-devel
  48. %description
  49. GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
  50. from scratch in ANSI C. The original development goal is to provide a clean,
  51. small and flexible alternative to the MPEG-4 Systems reference software.
  52. GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
  53. X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
  54. MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
  55. for MP4 and 3GPP(2) files and many tools for scene descriptions
  56. (MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
  57. %package libs
  58. Summary: Library for %{name}
  59. Group: System Environment/Libraries
  60. %description libs
  61. The %{name}-libs package contains library for %{name}.
  62. %package devel
  63. Summary: Development libraries and files for %{name}
  64. Group: Development/Libraries
  65. Requires: %{name}-libs = %{version}-%{release}
  66. %description devel
  67. Development libraries and files for gpac.
  68. %if %{with_static}
  69. %package devel-static
  70. Summary: Development libraries and files for %{name}
  71. Group: Development/Libraries
  72. Requires: %{name}-devel = %{version}-%{release}
  73. %description devel-static
  74. Static library for gpac.
  75. %endif
  76. %prep
  77. %setup -q
  78. ## remove extra_libs directory
  79. %__rm -rf extra_libs
  80. %patch2 -p1 -b .amr
  81. ## kwizart - enable dynamic mode - hardcoded with patch2
  82. # define SONAME number from the first number of gpac version.
  83. #define soname libgpac.so.0
  84. #sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
  85. # Fix encoding warnings
  86. %__cp -p Changelog Changelog.origine
  87. iconv -f ISO-8859-1 -t UTF8 Changelog.origine > Changelog
  88. touch -r Changelog.origine Changelog
  89. %__rm -rf Changelog.origine
  90. %__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
  91. iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine > doc/ipmpx_syntax.bt
  92. touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
  93. %__rm -rf doc/ipmpx_syntax.bt.origine
  94. # executable ./configure
  95. chmod +x configure
  96. %build
  97. %configure \
  98. --extra-cflags="$RPM_OPT_FLAGS -fPIC -DPIC -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
  99. --X11-path=%{_prefix} \
  100. --libdir=%{_lib} \
  101. --disable-oss-audio \
  102. %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
  103. %{?_with_amr:--enable-amr} \
  104. --disable-static \
  105. --use-js=no \
  106. \
  107. --disable-wx \
  108. ;
  109. #Avoid mess with setup.h
  110. %__cp -p config.h include/gpac
  111. # Parallele build will fail
  112. %__make all
  113. %__make sggen
  114. # ## kwizart - build doxygen doc for devel
  115. # pushd doc
  116. # doxygen
  117. # popd
  118. %install
  119. %__rm -rf $RPM_BUILD_ROOT
  120. %__make DESTDIR=$RPM_BUILD_ROOT install install-lib INSTFLAGS="-p"
  121. #Install generated sggen binaries
  122. #MPEG4 SVG X3D
  123. for b in MPEG4 X3D; do
  124. pushd applications/generators/${b}
  125. %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
  126. popd
  127. done
  128. #config.h like but not only
  129. #Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
  130. %__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
  131. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
  132. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
  133. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
  134. %__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
  135. %clean
  136. %__rm -rf $RPM_BUILD_ROOT
  137. %post libs -p /sbin/ldconfig
  138. %postun libs -p /sbin/ldconfig
  139. %files
  140. %defattr(-,root,root,-)
  141. %doc AUTHORS BUGS Changelog COPYING README TODO
  142. %{_bindir}/MP4*
  143. %{_bindir}/*Gen
  144. %{_datadir}/gpac/
  145. %{_mandir}/man1/*.1.*
  146. %files libs
  147. %defattr(-,root,root)
  148. %{_libdir}/libgpac.so.*
  149. %{_libdir}/gpac/
  150. %files devel
  151. %doc doc/CODING_STYLE doc/ipmpx_syntax.bt
  152. %defattr(-,root,root)
  153. %{_includedir}/gpac/
  154. %{_libdir}/libgpac.so
  155. %if %{with_static}
  156. %files devel-static
  157. %defattr(-,root,root,-)
  158. %{_libdir}/libgpac_static.a
  159. %else
  160. %exclude %{_libdir}/libgpac_static.a
  161. %endif
  162. %changelog
  163. * Sat Jul 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
  164. - rebuilt
  165. * Mon Mar 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2-1
  166. - new upstream release
  167. - remove Patch1 (gpac-0.5.0-libdir.patch)
  168. * Fri Jan 2 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-5
  169. - rebuilt
  170. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.0-4
  171. - remove BuildRequires: xmlrpc-epi-devel
  172. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
  173. - added Obsoletes: %{name} < %{version} and so on.
  174. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
  175. - rebuild
  176. * Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
  177. - new upstream release
  178. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
  179. - rebuild
  180. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
  181. - update snapshot svn20111217
  182. - removed upstreamed/obsolated patches
  183. * Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
  184. - rebuilt with internal openjpeg
  185. - added --use-openjpeg=local in configure options
  186. - added --enable-pic in configure options
  187. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
  188. - rebuild
  189. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
  190. - removed doxygen support
  191. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
  192. - change release to sync with self-build-gpac
  193. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
  194. - rebuild
  195. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
  196. - added --use-js=no in configure
  197. - added devel-static subpackage
  198. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
  199. - change release to sync with self-build-gpac
  200. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
  201. - change release to sync with self-build-gpac
  202. * Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
  203. - applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
  204. - corrected default %%defattr
  205. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
  206. - dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
  207. - rebuilt with ffmpeg-devel by self-build-ffmpeg
  208. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
  209. - initial build based on RPM Fusion
  210. - without Osmo4 and its plugins for Mozilla browsers
  211. - added --disable-wx in configure options
  212. - included %%{_libdir}/libgpac_static.a in devel subpackage
  213. * Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
  214. - Fix -devel doc timestamp which leads to multilib conflict
  215. ( RPM Fusion #270 )
  216. * Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
  217. - Fix for ppc64
  218. * Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
  219. - Update to 0.4.5 (final)
  220. - Drop upstreamed patches - Rewrite some
  221. - Add More BR.
  222. - Conditionalize --with mozilla amr
  223. * Mon Sep 8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
  224. - Fix for Large File Support (was livna #2075 )
  225. * Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
  226. - Enable devel-static
  227. - Conditionalize Osmo4 (buggy).
  228. - Clean the spec
  229. * Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
  230. - Update to 20080217.
  231. - Split libs.
  232. - Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
  233. - Add openjpeg-devel missing BR
  234. - Static patching instead of dyn patch when possible.
  235. - Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
  236. - Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
  237. - Exclude static lib
  238. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
  239. - Use %%{smp_mflags}
  240. - Oops, we're actually 0.4.5
  241. - Fix gpac so filenames
  242. - Only install nposmozilla when %%{with_firefox} is set
  243. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
  244. - Update to 20080211cvs
  245. - Disable osmozilla, doesn't build with xulrunner
  246. - Fix builds with gcc 4.3
  247. * Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
  248. - Rebuild for rawhide
  249. * Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
  250. - Update to v4.4
  251. * Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
  252. - Update to cvs 20070526
  253. - Enable conditional build ( 3gpp firefox )
  254. * Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
  255. - Update to cvs 20070411
  256. * Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
  257. - Update to 20061208
  258. - Uses firefox-devel (since fc6!)
  259. - Drop tutorial
  260. - Use version-DEV-date with libgpac.so
  261. - Disabled osmozilla
  262. - Fix soname
  263. - Enabled gprof
  264. * Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
  265. - gpac snapshot.sh
  266. - Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
  267. - TODO: - no-soname make option for libgpac.so
  268. - static lib in devel - needed ?
  269. - osmozilla - xpt link problem.
  270. - Osmo4: segmentation fault on exit.
  271. - MP4Client: segmentation fault on launch.
  272. - The program 'Osmo4' received an X Window System error:
  273. "The error was 'BadMatch (invalid parameter attributes)'.
  274. (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
  275. - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
  276. * Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
  277. - Update to 0.4.2cvs20061017
  278. - Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
  279. - Enable mozilla plugin: osmozilla.
  280. - Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
  281. - Provide documentation html in doc .
  282. - Provide tutorial from http://www.wildamerica.com/pages/Marty.html
  283. - Various corrections.
  284. * Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
  285. - lib64 fixes
  286. * Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
  287. - initial package