colord-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230
  1. %bcond_with firstbuild
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: Color daemon
  4. Name: colord
  5. Version: 0.1.23
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Daemons
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://gitorious.org/colord
  10. Source0: http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
  11. BuildRequires: dbus-devel
  12. BuildRequires: docbook-utils
  13. BuildRequires: gettext
  14. BuildRequires: glib2-devel
  15. BuildRequires: intltool
  16. BuildRequires: lcms2-devel
  17. BuildRequires: libgudev1-devel
  18. BuildRequires: libgusb-devel
  19. BuildRequires: polkit-devel
  20. BuildRequires: sane-devel
  21. BuildRequires: sqlite3-devel
  22. %{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
  23. Requires: shared-color-profiles
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: Takemikaduchi
  27. %description
  28. colord is a low level system activated daemon that maps color devices
  29. to color profiles in the system context.
  30. %package devel
  31. Summary: Development package for %{name}
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: glib2-devel
  35. Requires: dbus-devel
  36. Requires: lcms2-devel
  37. %description devel
  38. Files for development with %{name}.
  39. # compat32
  40. %package -n compat32-%{name}
  41. Summary: Color daemon
  42. Group: System Environment/Daemons
  43. Requires: %{name} = %{version}-%{release}
  44. %description -n compat32-%{name}
  45. colord is a low level system activated daemon that maps color devices
  46. to color profiles in the system context.
  47. %package -n compat32-%{name}-devel
  48. Summary: Development package for %{name}
  49. Group: Development/Libraries
  50. Requires: compat32-%{name} = %{version}-%{release}
  51. %description -n compat32-%{name}-devel
  52. Files for development with %{name}.
  53. %prep
  54. %setup -q
  55. %build
  56. %configure \
  57. --disable-static \
  58. --disable-rpath \
  59. --disable-examples \
  60. --disable-dependency-tracking
  61. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  62. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  63. make %{?_smp_mflags}
  64. %install
  65. make install DESTDIR=$RPM_BUILD_ROOT
  66. # Remove static libs and libtool archives.
  67. find %{buildroot} -name '*.la' -exec rm -f {} ';'
  68. find %{buildroot} -name '*.a' -exec rm -f {} ';'
  69. # databases
  70. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
  71. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
  72. %find_lang %{name}
  73. %post -p /sbin/ldconfig
  74. %postun -p /sbin/ldconfig
  75. %post -n compat32-%{name} -p /sbin/ldconfig
  76. %postun -n compat32-%{name} -p /sbin/ldconfig
  77. %files -f %{name}.lang
  78. %defattr(-,root,root,-)
  79. %doc README AUTHORS NEWS COPYING
  80. %{_libexecdir}/colord
  81. %dir %{_localstatedir}/lib/colord
  82. %{_bindir}/*
  83. %{_sysconfdir}/bash_completion.d/colormgr-completion.bash
  84. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
  85. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.colord-sane.conf
  86. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
  87. %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
  88. %{_datadir}/dbus-1/interfaces/org.freedesktop.colord.sane.xml
  89. %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
  90. %{_datadir}/dbus-1/system-services/org.freedesktop.colord-sane.service
  91. %{_datadir}/man/man1/*.1.gz
  92. %{_libdir}/libcolord.so.*
  93. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
  94. %config %{_sysconfdir}/colord.conf
  95. /lib/udev/rules.d/*.rules
  96. %dir %{_datadir}/color/icc/colord
  97. %{_datadir}/color/icc/colord/*.ic?
  98. %{_libdir}/colord-sensors
  99. %{_libexecdir}/colord-sane
  100. %ghost %{_localstatedir}/lib/colord/*.db
  101. %files devel
  102. %defattr(-,root,root,-)
  103. %{_includedir}/colord-1
  104. %{_libdir}/libcolord.so
  105. %{_libdir}/pkgconfig/colord.pc
  106. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
  107. # compat32
  108. %if %{build_compat32}
  109. %files -n compat32-%{name}
  110. %defattr(-,root,root,-)
  111. %{_libdir}/libcolord.so.*
  112. %files -n compat32-%{name}-devel
  113. %defattr(-,root,root,-)
  114. %{_libdir}/libcolord.so
  115. %endif
  116. %changelog
  117. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.23-1
  118. - new upstream release
  119. - change BuildRequires: libgusb-devel instead of libusb1-devel
  120. - add BuildRequires: gobject-introspection-devel
  121. * Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.21-1
  122. - new upstream release
  123. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.19-1
  124. - new upstream release
  125. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.18-1
  126. - new upstream release
  127. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.15-1
  128. - new upstream release
  129. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.14-1
  130. - new upstream release
  131. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.13-1
  132. - new upstream release
  133. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.12-1
  134. - new upstream release
  135. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.11-1
  136. - new upstream release
  137. - create compat32 sub packages
  138. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.10-1
  139. - initial build for Vine Linux
  140. * Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
  141. - New upstream version
  142. * Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
  143. - New upstream version
  144. * Fri Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
  145. - New upstream version
  146. - Add a webcam device kind
  147. - Add a timestamp when making profiles default
  148. - Add support for reading and writing ICC profile metadata
  149. - Allow the client to pass file descriptors out of band to CreateProfile
  150. - Prettify the device vendor and model names
  151. - Split out the sensors into runtime-loadable shared objects
  152. - Provide some GIO async variants for the methods in CdClient
  153. - Ensure GPhoto2 devices get added to the device list
  154. * Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
  155. - New upstream version.
  156. - Create /var/lib/colord at buildtime not runtime for SELinux
  157. - Ensure profiles with embedded profile checksums are parsed correctly
  158. - Move the colorimeter rules to be run before 70-acl.rules
  159. - Stop watching the client when the sensor is finalized
  160. - Ensure the source is destroyed when we unref CdUsb to prevent a crash
  161. - Only enable the volume mount tracking when searching volumes
  162. * Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
  163. - Own /var/lib/colord and /var/lib/colord/*.db
  164. * Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
  165. - New upstream version.
  166. * Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
  167. - New upstream version.
  168. * Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
  169. - New upstream version.
  170. * Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
  171. - New upstream version.
  172. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  174. * Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
  175. - Rebuild in the vain hope koji isn't broken today.
  176. * Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
  177. - New upstream version.
  178. * Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
  179. - Initial version for Fedora package review.