docbook-style-xsl-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326
  1. Name: docbook-style-xsl
  2. Version: 1.77.1
  3. Release: 1%{?_dist_release}
  4. Group: Applications/Text
  5. Summary: Norman Walsh's XSL stylesheets for DocBook XML.
  6. Summary(ja): DocBook XML用 XSLスタイルシート
  7. License: Copyright only
  8. URL: http://docbook.sourceforge.net/projects/xsl/
  9. Source0: http://downloads.sourceforge.net/docbook/docbook-xsl-%{version}.tar.bz2
  10. Source1: %{name}.Makefile
  11. Source2: http://downloads.sourceforge.net/docbook/docbook-xsl-doc-%{version}.tar.bz2
  12. # Avoid proportional-column-width for passivetex (bug #176766).
  13. Patch1: docbook-xsl-pagesetup.patch
  14. # Hard-code the margin-left work around to expect passivetex (bug #113456).
  15. Patch2: docbook-xsl-marginleft.patch
  16. # fix of #161619 - adjustColumnWidths now available
  17. Patch3: docbook-xsl-newmethods.patch
  18. # change a few non-constant expressions to constant - needed for passivetex(#366441)
  19. Patch4: docbook-xsl-non-constant-expressions.patch
  20. # added fixes for passivetex extension and list-item-body(#161371)
  21. Patch5: docbook-xsl-list-item-body.patch
  22. #workaround missing mandir section problem (#727251)
  23. Patch6: docbook-xsl-mandir.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildArch: noarch
  26. Provides: docbook-xsl = %{version}
  27. Requires: docbook-dtd-xml
  28. # xml-common was using /usr/share/xml until 0.6.3-8.
  29. Requires: xml-common >= 0.6.3-8
  30. # required because of usage of /usr/bin/xmlcatalog
  31. Requires(post): libxml2 >= 2.4.8
  32. Requires(postun): libxml2 >= 2.4.8
  33. # PassiveTeX before 1.21 can't handle the newer stylesheets.
  34. Conflicts: passivetex < 1.21
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. %description
  38. These XSL stylesheets allow you to transform any DocBook XML document to
  39. other formats, such as HTML, FO, and XHMTL. They are highly customizable.
  40. %description -l ja
  41. この XSL スタイルシートを使って, さまざまな DocBook XML 形式のドキュメント
  42. を HTML や FO や XHTML などの他のフォーマットに変換することができます.
  43. %prep
  44. %setup -q -n docbook-xsl-%{version}
  45. pushd ..
  46. tar jxf %{SOURCE2}
  47. popd
  48. %patch1 -p1 -b .pagesetup
  49. %patch2 -p1 -b .marginleft
  50. %patch3 -p1 -b .newmethods
  51. %patch4 -p1 -b .nonconstant
  52. %patch5 -p1 -b .listitembody
  53. %patch6 -p1 -b .mandir
  54. cp %{SOURCE1} Makefile
  55. # fix of non UTF-8 files rpmlint warnings
  56. for fhtml in $(find ./doc -name '*.html' -type f)
  57. do
  58. iconv -f ISO-8859-1 -t UTF-8 "$fhtml" -o "$fhtml".tmp
  59. mv -f "$fhtml".tmp "$fhtml"
  60. sed -i 's/charset=ISO-8859-1/charset=UTF-8/' "$fhtml"
  61. done
  62. for f in $(find -name "*'*")
  63. do
  64. mv -v "$f" $(echo "$f" | tr -d "'")
  65. done
  66. %build
  67. %install
  68. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  69. DESTDIR=$RPM_BUILD_ROOT
  70. make install BINDIR=$DESTDIR%{_bindir} DESTDIR=$DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
  71. cp -a VERSION.xsl $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}/VERSION.xsl
  72. ln -s xsl-stylesheets-%{version} \
  73. $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets
  74. # Don't ship the extensions (bug #177256).
  75. rm -rf $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets/extensions/*
  76. %clean
  77. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  78. %post
  79. CATALOG=%{_sysconfdir}/xml/catalog
  80. %{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
  81. "http://docbook.sourceforge.net/release/xsl/%{version}" \
  82. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  83. %{_bindir}/xmlcatalog --noout --add "rewriteURI" \
  84. "http://docbook.sourceforge.net/release/xsl/%{version}" \
  85. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  86. %{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
  87. "http://docbook.sourceforge.net/release/xsl/current" \
  88. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  89. %{_bindir}/xmlcatalog --noout --add "rewriteURI" \
  90. "http://docbook.sourceforge.net/release/xsl/current" \
  91. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  92. %postun
  93. # remove entries only on removal of package
  94. if [ "$1" = 0 ]; then
  95. CATALOG=%{_sysconfdir}/xml/catalog
  96. %{_bindir}/xmlcatalog --noout --del \
  97. "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
  98. fi
  99. %files
  100. %defattr (-,root,root)
  101. %doc BUGS README TODO doc
  102. %{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
  103. %{_datadir}/sgml/docbook/xsl-stylesheets
  104. %changelog
  105. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.77.1-1
  106. - new upstream release
  107. - add Patch6 (docbook-xsl-mandir.patch) from fedora
  108. - update Source1 (%{name}.Makefile)
  109. - update following patches from fedora
  110. - Patch1 (docbook-xsl-pagesetup.patch)
  111. - Patch2 (docbook-xsl-marginleft.patch)
  112. - Patch3 (docbook-xsl-newmethods.patch)
  113. - update spec file based on fedora package
  114. * Tue Jun 5 2012 Ondrej Vasik <ovasik@redhat.com> 1.77.1-2
  115. - ship VERSION.xsl file (#829014)
  116. * Tue Jun 5 2012 Ondrej Vasik <ovasik@redhat.com> 1.77.1-1
  117. - new stable upstream release 1.77.1
  118. - defuzz patches
  119. * Tue Sep 6 2011 Ondrej Vasik <ovasik@redhat.com> 1.76.1-4
  120. - revert previous change, workaround the mandir links issue
  121. in buildroot (#727251)
  122. * Mon Aug 29 2011 Ondrej Vasik <ovasik@redhat.com> 1.76.1-3
  123. - make man.output.in.separate.dir "on" by default (#727251)
  124. * Tue Nov 02 2010 Ondrej Vasik <ovasik@redhat.com> 1.76.1-1
  125. - new upstream release 1.76.1
  126. * Mon Sep 06 2010 Ondrej Vasik <ovasik@redhat.com> 1.76.0-1
  127. - new upstream release 1.76.0
  128. * Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 1.76.1-1
  129. - new upstream release
  130. - add Vendor and Distribution tags
  131. * Sun Mar 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.75.3-6
  132. - updated based on FC 1.75.3-5
  133. * Fri Dec 18 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.3-5
  134. - comment patches purpose
  135. - License Copyright only
  136. * Mon May 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.0-1
  137. - New upstream release 1.75.0
  138. - update marginleft patch
  139. * Mon Feb 23 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.2-2
  140. - updated Makefile: do ship .svg images(#486849), xsl
  141. stylesheets for website, xhtml-1_1, docbook -> epub
  142. convertor
  143. * Wed Feb 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-7
  144. - fix broken varlistentry (#479683)
  145. * Mon Feb 02 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-6
  146. - fix improper localization for rtl languages, thanks
  147. Muayyad Alsadi(#475077)
  148. * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-5
  149. - fix xsl stylesheets for rtl languages(#475077)
  150. * Fri Dec 12 2008 Ondrej Vasik <ovasik@redhat.com> 1.74.0-4
  151. - Author_Group "<orgname>" merged between "<surname>"
  152. and "<surname>" (#473019)
  153. * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-3
  154. - Rediffed all patches to work with patch --fuzz=0
  155. * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-2
  156. - Tiny changes in docbook-xsl-newmethods.patch to work with xalan
  157. (#452867)
  158. * Fri Dec 14 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-9
  159. - added fixes for passivetex extension and list-item-body
  160. (#161371)
  161. * Mon Dec 03 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-6
  162. - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
  163. documentation for nonpassivetex processing(#307001)
  164. * Tue Nov 27 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-5
  165. - convert all html files in doc to UTF-8 in prep
  166. (latest rpmlint gives warnings)
  167. - no longer using release in style-xsl dir(#389231)
  168. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.73.2-5vl5
  169. - applied new versioning policy, spec in utf-8
  170. * Fri Jan 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73.2-5vl1
  171. - updated to 1.73.2 based on Fedora development
  172. * Tue Dec 11 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-4
  173. - remove entries from xmlcatalog only on removal of package
  174. (required because of the last change with droping release
  175. -caused drop of catalog entries during update)
  176. * Wed Dec 05 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-3
  177. - change a few non-constant expressions to constant that
  178. could now be handled by passivetex(#366441)
  179. - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
  180. documentation for nonpassivetex processing(#307001)
  181. (use passivetex.extensions = 1 option in param.xsl for
  182. processing with passivetex)
  183. * Fri Sep 7 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-2
  184. - Added PreReq of libxml2(#253962)
  185. * Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72.0-3vl1
  186. - updated to 1.72.0 based on Fedora development
  187. * Mon Jun 18 2007 Ondrej Vasik <ovasik@redhat.com> 1.72.0-3
  188. - patch fixing #161619 taken from upstream
  189. * Tue Jan 23 2007 Tim Waugh <twaugh@redhat.com> 1.72.0-1
  190. - 1.72.0.
  191. * Fri Jan 19 2007 Tomas Mraz <tmraz@redhat.com> 1.71.1-2
  192. - Add new wordml and especially highlighting (which is referenced
  193. from html) subdirs to Makefile.
  194. * Tue Jan 24 2006 Tim Waugh <twaugh@redhat.com> 1.69.1-5
  195. - Don't ship docsrc/* (bug #177256).
  196. - Don't ship the extensions (bug #177256).
  197. * Sun Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.69.1-1vl1
  198. - updated to 1.69.1 based on Fedora development
  199. * Sun Dec 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.67.2-2vl1
  200. - updated to 1.67.2 based on Fedora development
  201. * Wed Dec 8 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-2
  202. - Prevent expressions in passivetex output from index.xsl (bug #142229).
  203. * Thu Dec 2 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-1
  204. - No longer need nbsp or listblock patches.
  205. * Tue Jan 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl2
  206. - patch from Fedora 1.64.1-6
  207. * Tue Jan 20 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-6
  208. - Fix last margin-left fix (bug #113456).
  209. - Reduce instances of itemized/ordered lists having misalignments.
  210. * Sun Jan 18 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-5
  211. - And another (bug #113456).
  212. * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-4
  213. - Fixed another instance of bug #113456 in lists layout.
  214. * Wed Jan 14 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-3
  215. - Hard-code the margin-left work around to expect passivetex (bug #113456).
  216. * Mon Jan 5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl1
  217. - based on Fedora 1.64.1-2
  218. - fixed Japanese summary
  219. * Sat May 24 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.61.1-1vl1
  220. - based on Redhat Rawhide 1.61.1-1
  221. - add Japanese summary and description
  222. * Tue Feb 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60.1-0vl1
  223. - upstream release
  224. * Tue Nov 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-2vl1
  225. - based on Redhat Rawhide 1.57.0-2
  226. * Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-0vl1
  227. - 1.57.0
  228. * Tue Sep 24 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.55.0-0vl3
  229. - Rebuilded for Vine Linux (add PreReq: docbook-dtd412-xml)
  230. - based on rawhide 1.50.0 and source updated 1.55.0
  231. - use better macros
  232. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  233. - automated rebuild
  234. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  235. - automated rebuild
  236. * Wed May 1 2002 Tim Waugh <twaugh@redhat.com> 1.50.0-1
  237. - 1.50.0.
  238. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.49-1
  239. - 1.49.
  240. - Rebuild in new environment.
  241. * Fri Feb 1 2002 Tim Waugh <twaugh@redhat.com> 1.48-4
  242. - Put URIs instead of pathnames in the XML catalog.
  243. * Thu Jan 17 2002 Tim Waugh <twaugh@redhat.com> 1.48-3
  244. - Back to /usr/share/sgml.
  245. * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.48-2
  246. - automated rebuild
  247. * Mon Jan 7 2002 Tim Waugh <twaugh@redhat.com> 1.48-1
  248. - 1.48.
  249. * Sat Dec 8 2001 Tim Waugh <twaugh@redhat.com> 1.47-2
  250. - Conflict with PassiveTeX before 1.11.
  251. * Tue Oct 16 2001 Tim Waugh <twaugh@redhat.com> 1.47-1
  252. - 1.47-experimental.
  253. * Tue Oct 9 2001 Tim Waugh <twaugh@redhat.com> 1.45-2
  254. - Fix unversioned symlink.
  255. * Mon Oct 8 2001 Tim Waugh <twaugh@redhat.com> 1.45-1
  256. - XML Catalog entries.
  257. - Move files to /usr/share/xml.
  258. * Mon Oct 1 2001 Tim Waugh <twaugh@redhat.com> 1.45-0.1
  259. - 1.45.
  260. - Built for Red Hat Linux.
  261. * Tue Jun 26 2001 Chris Runge <crunge@pobox.com>
  262. - 1.40
  263. * Fri Jun 09 2001 Chris Runge <crunge@pobox.com>
  264. - added extensions and additional doc
  265. - bin added to doc; the Perl files are for Win32 Perl and so need some
  266. conversion first
  267. * Fri Jun 08 2001 Chris Runge <crunge@pobox.com>
  268. - Initial RPM (based on docbook-style-dsssl RPM)
  269. - note: no catalog right now (I don't know how to do it; and not sure why
  270. it is necessary)