epiphany-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388
  1. # gecko backend was removed 2.27.0
  2. %define with_gecko 0
  3. %define with_webkit 1
  4. %define gecko_version 1.9.1
  5. %define webkit_version 1.7.92
  6. ExclusiveArch: %ix86 ppc x86_64 alpha
  7. Summary: GNOME web browser based on Gecko/WebKit
  8. Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
  9. Name: epiphany
  10. Version: 3.6.0
  11. Release: 1%{?_dist_release}
  12. License: GPL
  13. Group: Applications/Internet
  14. URL: http://www.gnome.org/projects/epiphany/
  15. Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.6/%{name}-%{version}.tar.xz
  16. Patch1: epiphany-2.26.2-gecko191.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: gnome-icon-theme >= 2.30.0
  19. %if %{with_gecko}
  20. Requires: gecko-libs
  21. %endif
  22. Requires(post,postun): shared-mime-info
  23. %if %{with_gecko}
  24. BuildRequires: gecko-devel-unstable >= %{gecko_version}
  25. %endif
  26. %if %{with_webkit}
  27. BuildRequires: WebKit3-gtk-devel >= %{webkit_version}
  28. %endif
  29. BuildRequires: glib2-devel >= 2.31.2
  30. BuildRequires: gtk3-devel >= 3.3.14
  31. BuildRequires: libxml2-devel >= 2.6.12
  32. BuildRequires: libxslt-devel >= 1.1.7
  33. BuildRequires: libnotify-devel >= 0.4.0
  34. BuildRequires: libsoup-devel >= 2.37.1
  35. BuildRequires: gnome-desktop3-devel >= 2.91.2
  36. BuildRequires: libSM-devel
  37. BuildRequires: libgnome-keyring-devel
  38. BuildRequires: gcr-devel >= 3.5.5
  39. BuildRequires: gobject-introspection-devel
  40. BuildRequires: gsettings-desktop-schemas-devel
  41. BuildRequires: sqlite3-devel
  42. BuildRequires: seed-devel
  43. BuildRequires: nss-devel
  44. BuildRequires: avahi-gobject-devel
  45. BuildRequires: iso-codes
  46. BuildRequires: yelp-tools
  47. Vendor: Project Vine
  48. Distribution: Vine Linux
  49. %description
  50. epiphany is a simple GNOME web browser based on the Mozilla rendering
  51. engine
  52. %description -l ja
  53. epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
  54. ウェブブラウザです。
  55. %package devel
  56. Summary: Epipany development environment
  57. Summary(ja): Epipany の開発環境
  58. Group: Development/Libraries
  59. Requires: %{name} = %{version}-%{release}
  60. Requires: pkgconfig
  61. %description devel
  62. Header files and libraries for building a extension library for the
  63. epipany.
  64. %prep
  65. %setup -q
  66. #patch1 -p1
  67. %build
  68. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
  69. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  70. %configure \
  71. %if %{with_gecko}
  72. --with-gecko=libxul-embedding \
  73. %endif
  74. %if %{with_webkit}
  75. --with-engine=webkit \
  76. %endif
  77. --enable-zeroconf \
  78. --enable-network-manager \
  79. --without-ca-file \
  80. --enable-introspection=yes \
  81. --enable-seed
  82. %__make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  86. make install DESTDIR=$RPM_BUILD_ROOT
  87. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  88. %find_lang %{name} --with-gnome
  89. rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
  90. %postun
  91. if [ $1 -eq 0 ] ; then
  92. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  93. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  94. fi
  95. %posttrans
  96. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  97. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %files -f %{name}.lang
  101. %defattr(-,root,root,-)
  102. %doc AUTHORS ChangeLog* COPYING* NEWS README
  103. %{_bindir}/epiphany
  104. %{_bindir}/ephy-profile-migrator
  105. %{_libdir}/girepository-1.0/*.typelib
  106. %if %{with_gecko}
  107. %{_libdir}/epiphany
  108. %endif
  109. #{_datadir}/pygtk/*/defs/*
  110. %{_datadir}/GConf/gsettings/*.convert
  111. %{_datadir}/applications/*.desktop
  112. %{_datadir}/epiphany
  113. %{_datadir}/glib-2.0/schemas/*.xml
  114. %{_datadir}/dbus-1/services/*
  115. %{_mandir}/man1/epiphany.1*
  116. %files devel
  117. %defattr(-,root,root,-)
  118. %{_includedir}/%{name}
  119. %{_libdir}/pkgconfig/*.pc
  120. %{_datadir}/aclocal/*
  121. %{_datadir}/gir-1.0/*.gir
  122. %{_datadir}/gtk-doc/html/*
  123. %changelog
  124. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  125. - new upstream release
  126. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  127. - change BuildRequires: yelp-tools instead of gnome-doc-utils
  128. - add BuildRequires: gcr-devel
  129. * Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  130. - new upstream release
  131. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  132. - new upstream release
  133. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  134. - new upstream release
  135. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  136. - new upstream release
  137. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  138. - new upstream release
  139. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  140. - new upstream release
  141. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
  142. - new upstream release
  143. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
  144. - new upstream release
  145. - add BuildRequires: gsettings-desktop-schemas
  146. - create -devel sub package
  147. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.6-1
  148. - new upstream release
  149. - remove BuildRequires: gir-repository-devel
  150. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
  151. - rebuilt with rpm-4.8.1 for pkg-config
  152. * Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  153. - new upstream release
  154. - add BuildRequires: gobject-introspection-devel, seed-devel
  155. - add configure option (--enable-introspection=yes, --enable-seed)
  156. * Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  157. - new upstream release
  158. - add BuildRequires: gobject-introspection-devel, gir-repository-devel
  159. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  160. - add configure option (--without-ca-file)
  161. - remove unrecognized configure option (--with-engine)
  162. * Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  163. - new upstream release
  164. - added BR: libICE-devel, libSM-devel and gnome-keyring-devel
  165. * Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  166. - new upstream release
  167. * Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  168. - run gtk-update-icon-cache in %%post/postun script.
  169. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  170. - new upstream release
  171. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  172. - rebuild with gecko-1.9.1
  173. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  174. - new upstream release
  175. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  176. - new upstream release
  177. - build with xulrunner-1.9.0.7
  178. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  179. - new upstream release
  180. * Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
  181. - build with gecko-1.9.0.3 instead of WebKit.
  182. - WebKit port is unstable yet.
  183. - enable zeroconf, NetworkManager support
  184. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  185. - new upstream release
  186. * Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
  187. - build with WebKit instead of gecko.
  188. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  189. - new upstream release
  190. - added %%pre and %%preun section
  191. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  192. - new upstream release
  193. - rebuilt with firefox-2.0.0.6-0vl3
  194. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
  195. - add BuildRequires: gnome-python
  196. * Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  197. - new upstream release
  198. - rebuilt with new toolchain and firefox-2.0.0.4-0vl6
  199. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  200. - new upstream release
  201. * Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
  202. - source update
  203. - add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
  204. - add BuildRequires: pygtk2-devel
  205. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
  206. - new upstream release
  207. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  208. - rebuild with firefox-1.5.0.2-0vl4
  209. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  210. - new upstream release
  211. - build with firefox-1.5.0.2
  212. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  213. - new upstream release
  214. * Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  215. - new upstream release
  216. - build with firefox-1.5.0.1
  217. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  218. - new upstream release
  219. - build with mozilla-1.7.12
  220. * Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
  221. - rebuild with mozilla-1.7.8
  222. * Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
  223. - new upstream release
  224. * Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
  225. - new upstream release
  226. - build with mozilla-1.7.7
  227. * Fri Apr 1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
  228. - rebuild with mozilla-1.7.6
  229. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  230. - new upstream release
  231. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
  232. - new upstream release
  233. - build with mozilla-1.7.5
  234. * Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  235. - new upstream release
  236. * Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
  237. - new upstream release
  238. * Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
  239. - rebuild with mozilla-1.7.3
  240. * Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  241. - new upstream release
  242. - build with mozilla-1.7.2
  243. - add Patch10 to build with gnome-2.4
  244. * Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
  245. - new upstream version
  246. -- dropped patch10
  247. - changed URL
  248. * Fri Jan 9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
  249. - add alpha into ExclusiveArch
  250. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
  251. - rebuild with mozilla-1.5.1
  252. * Sat Dec 6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
  253. - new upstream release
  254. * Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
  255. - new upstream release
  256. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
  257. - fixed missing locale files
  258. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  259. - new upstream release
  260. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  261. - new upstream release
  262. * Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
  263. - new upstream release
  264. * Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
  265. - new upstream release
  266. - build with mozilla 1.4
  267. * Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
  268. - new upstream release
  269. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
  270. - build for Vine Linux
  271. * Mon Jun 2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
  272. - Rebuild to fix broken mozilla dep, patch for mozilla 1.4
  273. * Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
  274. - 0.6.1
  275. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
  276. - add patch to fix gint/gpointer conversion bugs for 64bit arches
  277. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
  278. - only build on arches mozilla is built on
  279. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
  280. - rebuild against new mozilla, make mozilla requires dynamic
  281. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
  282. - update to 0.6.0
  283. - fix tyop in %%postun
  284. * Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
  285. - make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
  286. * Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
  287. - add some buildrequires, prereq GConf2
  288. - disable building nautilus view
  289. * Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
  290. - Initial build.