gnome-shell-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. %define pkg_version 3.6.0
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. # settings for Vine
  9. Patch101: gnome-shell-vine-settings.patch
  10. License: GPLv2+
  11. Group: User Interface/Desktops
  12. URL: http://live.gnome.org/GnomeShell
  13. Requires(post,postun): scrollkeeper >= 0.1.4
  14. Requires: mutter
  15. Requires: caribou
  16. Requires: ca-certificates
  17. Requires: at-spi2-atk
  18. BuildRequires: gnome-common
  19. BuildRequires: libtool
  20. BuildRequires: automake
  21. BuildRequires: autoconf
  22. BuildRequires: pkgconfig
  23. BuildRequires: gtk2-devel
  24. BuildRequires: clutter-devel
  25. BuildRequires: mutter-devel
  26. BuildRequires: gjs-devel
  27. BuildRequires: gnome-desktop3-devel
  28. BuildRequires: gnome-menus-devel
  29. BuildRequires: libSM-devel
  30. BuildRequires: libffi-devel
  31. BuildRequires: startup-notification-devel
  32. BuildRequires: gnome-doc-utils
  33. BuildRequires: desktop-file-utils
  34. BuildRequires: libcroco-devel
  35. BuildRequires: librsvg2-devel
  36. BuildRequires: gobject-introspection-devel
  37. BuildRequires: gcr-devel
  38. BuildRequires: gstreamer-devel
  39. BuildRequires: dbus-glib-devel
  40. BuildRequires: telepathy-logger-devel
  41. BuildRequires: polkit-devel
  42. BuildRequires: pulseaudio-libs-devel
  43. BuildRequires: evolution-data-server-devel
  44. BuildRequires: folks-devel
  45. BuildRequires: NetworkManager-glib-devel
  46. BuildRequires: libgudev1-devel
  47. BuildRequires: libcanberra-gtk3-devel
  48. BuildRequires: ca-certificates
  49. BuildRequires: intltool
  50. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  51. Vendor: Project Vine
  52. Distribution: Vine Linux
  53. Packager: Takemikaduchi
  54. %description
  55. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  56. It provides core interface functions like switching to windows and launching
  57. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  58. hardware and introduces innovative user interface concepts to provide a delightful
  59. and easy to use experience.
  60. %prep
  61. %setup -q
  62. %patch101 -p1 -b .vine
  63. %build
  64. libtoolize --copy --force
  65. autoreconf
  66. %configure \
  67. --disable-static
  68. %{__make} %{?_smp_mflags}
  69. %install
  70. %{__rm} -rf ${RPM_BUILD_ROOT}
  71. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  72. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  73. %find_lang %{name}
  74. %clean
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. %post
  77. /sbin/ldconfig
  78. touch --no-create %{_datadir}/icons/hicolor
  79. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  80. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  81. fi
  82. %postun
  83. /sbin/ldconfig
  84. touch --no-create %{_datadir}/icons/hicolor
  85. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  86. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  87. fi
  88. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  89. %posttrans
  90. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  91. %files -f %{name}.lang
  92. %defattr(-,root,root)
  93. %doc COPYING NEWS README
  94. %{_bindir}/gnome-shell
  95. %{_bindir}/gnome-shell-extension-tool
  96. %{_bindir}/gnome-shell-extension-prefs
  97. %{_bindir}/gnome-shell-perf-tool
  98. %{_libdir}/gnome-shell/*
  99. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  100. %{_libexecdir}/gnome-shell-calendar-server
  101. %{_libexecdir}/gnome-shell-hotplug-sniffer
  102. %{_libexecdir}/gnome-shell-perf-helper
  103. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  104. %{_datadir}/applications/gnome-shell.desktop
  105. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  106. %{_datadir}/applications/evolution-calendar.desktop
  107. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  108. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  109. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  110. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  111. %{_datadir}/gnome-shell/*
  112. %{_datadir}/gtk-doc/html/shell
  113. %{_datadir}/gtk-doc/html/st
  114. %{_datadir}/man/man1/*.1.gz
  115. %changelog
  116. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  117. - new upstream release
  118. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  119. - update Patch101 (gnome-shell-vine-settings.patch)
  120. - change BuildRequires: ca-certificates instead of openssl
  121. - add BuildRequires: libcanberra-gtl3-devel
  122. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  123. - new upstream release
  124. - remove Patch103 (gnome-shell-ja.po-date.patch)
  125. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  126. - new upstream release
  127. - update Patch101,103
  128. - remove Patch0,102
  129. - add BuildRequires: gcr-devel
  130. - remove BuildRequires: GConf2-devel
  131. - add Requires: at-spi2-atk
  132. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  133. - new upstream release
  134. - remove Patch1
  135. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  136. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  137. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  138. - rename Patch103 (gnome-shell-ja.po-date.patch)
  139. - drop Patch102
  140. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  141. - new upstream release
  142. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  143. - new upstream release
  144. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  145. - new upstream release
  146. - update Patch101
  147. - update Patch102
  148. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  149. - add BuildRequires: libgudev1-devel, openssl
  150. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  151. - new upstream release
  152. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  153. - add Requires: caribou
  154. - remove Patch0
  155. - update Patch101
  156. - update Patch102
  157. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  158. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  159. - rebuild with gnome-menus-3.1.5
  160. - add Patch0 (gnome-shell-git20110821.patch)
  161. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  162. - new upstream release
  163. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  164. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  165. - remove BuildRequires: xulrunner-devel
  166. - add Patch101 (gnome-shell-vine-settings.patch)
  167. - add Patch102 (gnome-shell-vine-customize.patch)
  168. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  169. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  170. - add Requires: mutter
  171. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  172. - new upstream release
  173. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  174. - initial build for Vine Linux