gl2ps-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. %define pkg_name gl2ps
  2. %define pkg_version 1.4.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: An OpenGL to PostScript printing library
  5. Summary(ja): OpenGL から PostScript を出力するライブラリ
  6. Summary(pl): Biblioteka drukowania z OpenGL-a do PostScriptu
  7. Name: %{pkg_name}
  8. Version: %{pkg_version}
  9. Release: %{pkg_release}
  10. License: LGPLv2+ or GL2PS
  11. Group: System Environment/Libraries
  12. URL: http://www.geuz.org/gl2ps/
  13. Source0: http://www.geuz.org/gl2ps/src/%{name}-%{version}.tgz
  14. # # Vine Patch
  15. # Patch700: gl2ps-1.3.8-nostatic.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: cmake >= 2.4
  18. BuildRequires: mesa-libGL-devel
  19. BuildRequires: libpng-devel
  20. BuildRequires: zlib-devel
  21. %description
  22. GL2PS is a C library providing high quality vector output for any
  23. OpenGL application. The main difference between GL2PS and other
  24. similar libraries is the use of sorting algorithms capable of handling
  25. intersecting and stretched polygons, as well as non manifold objects.
  26. GL2PS provides advanced smooth shading and text rendering, culling of
  27. invisible primitives, mixed vector/bitmap output, and much more...
  28. GL2PS can currently create PostScript (PS), Encapsulated PostScript
  29. (EPS) and Portable Document Format (PDF) files, as well as LaTeX files
  30. for the text fragments. Adding new vector output formats should be
  31. relatively easy (and amongst the formats we would be interested in
  32. adding, SVG is first in line). Meanwhile, you can use the excellent
  33. pstoedit program to transform the PostScript files generated by GL2PS
  34. into many other vector formats such as xfig, cgm, wmf, etc.
  35. %description -l ja
  36. GL2PSはOpenGLアプリケーションの高品質のベクトル出力を提供するCライブラリです。
  37. GL2PSは高度なスムーズなシェーディングとテキストのレンダリング、
  38. 混在ベクター/ビットマップ出力、目に見えないプリミティブのカリングを提供して
  39. います。
  40. 現在、PostScript (PS)、カプセル化PostScript (EPS)、ポータブルドキュメント
  41. フォーマット (PDF)、スケーラブルベクターグラフィックス (SVG) ファイルと
  42. LaTeXファイルを作成することができます。
  43. %description -l pl
  44. GL2PS to biblioteka C zapewniająca wysokiej jakości wyjście wektorowe
  45. dla dowolnej aplikacji OpenGL. Główna różnica między GL2PS a innymi
  46. podobnymi bibliotekami polega na użyciu algorytmów sortujących
  47. potrafiących obsłużyć przecinające się i rozciągnięte wielokąty, a
  48. także obiekty nie będące rozmaitościami. GL2PS zapewnia zaawansowane
  49. gładkie cieniowanie i renderowanie tekstu, usuwanie niewidocznych
  50. prymitywów, mieszane wyjście wektorowo-bitmapowe i wiele więcej.
  51. GL2PS aktualnie potrafi tworzyć pliki PostScript (PS), Encapsulated
  52. PostScript (EPS) oraz Portable Document Format (PDF), a także pliki
  53. LaTeXa dla fragmentów tekstowych. Dodanie nowych wyjściowych formatów
  54. wektorowych powinno być względnie łatwe (a spośród formatów, których
  55. dodanie zainteresowani byliby autorzy, pierwszym jest SVG). Tymczasem
  56. można używać świetnego programu pstoedit do przekształcania plików
  57. PostScript generowanych przez GL2PS na wiele innych formatów
  58. wektorowych, takich jak xfig, cgm, wmf itp.
  59. %package devel
  60. Summary: Header files for GL2PS library
  61. Summary(ja): GL2PS ライブラリのヘッダファイル
  62. Summary(pl): Pliki nagłówkowe biblioteki GL2PS
  63. Group: Development/Libraries
  64. Requires: %{name} = %{version}-%{release}
  65. Requires: mesa-libGL-devel
  66. %description devel
  67. Header files for GL2PS library.
  68. %description devel -l ja
  69. GL2PSのヘッダーファイル
  70. %description devel -l pl
  71. Pliki nagłówkowe biblioteki GL2PS.
  72. %prep
  73. %setup -q -n %{name}-%{version}-source
  74. # %patch700 -p1 -b .nostatic
  75. %build
  76. %cmake .
  77. %{__make} %{?_smp_mflags}
  78. %install
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %{make_install}
  81. %{__rm} ${RPM_BUILD_ROOT}%{_libdir}/libgl2ps.a
  82. %{__rm} -rf ${RPM_BUILD_ROOT}%{_docdir}/gl2ps
  83. %clean
  84. %{__rm} -rf ${RPM_BUILD_ROOT}
  85. %post -p %{_syssbindir}/ldconfig
  86. %postun -p %{_syssbindir}/ldconfig
  87. %files
  88. %defattr(644,root,root,755)
  89. %doc COPYING.GL2PS COPYING.LGPL README.txt gl2psTest*.c
  90. %attr(755,root,root) %{_libdir}/libgl2ps.so.*
  91. %files devel
  92. %defattr(644,root,root,755)
  93. %doc gl2ps.pdf gl2psTest*.c
  94. %{_libdir}/libgl2ps.so
  95. %{_includedir}/gl2ps.h
  96. %changelog
  97. * Sat Jul 07 2018 Toshiaki Ara <ara_t@384.jp> 1.4.0-1
  98. - update to 1.4.0
  99. - delete BuildRequires: texlive
  100. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-3
  101. - merge with previous SPEC file
  102. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-2
  103. - correct SPEC file
  104. * Fri Mar 18 2016 Toshiaki Ara <ara_t@384.jp> 1.3.9-1
  105. - update to 1.3.9
  106. * Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.8-6
  107. - Initial build for Vine Linux
  108. - added Patch700
  109. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-5
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  111. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-4
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  113. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-3
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  115. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-2
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  117. * Tue Nov 27 2012 Orion Poplawski <orion@cora.nwra.com> 1.3.8-1
  118. - Updated to 1.3.8
  119. - Dropped soversion patch applied upstream
  120. - Don't need to move library on 64bit anymore
  121. * Sat Sep 01 2012 Dominik Mierzejewski <rpm@greysector.net> 1.3.6-1
  122. - updated to 1.3.6
  123. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-5
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  125. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-4
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  127. * Tue Dec 06 2011 Adam Jackson <ajax@redhat.com> - 1.3.5-3
  128. - Rebuild for new libpng
  129. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.5-2
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  131. * Sat Dec 26 2009 Dominik Mierzejewski <rpm@greysector.net> 1.3.5-1
  132. - updated to 1.3.5
  133. - dropped upstreamed patches
  134. - fixed install in libdir
  135. - fixed missing SO version
  136. * Sun Aug 23 2009 Dominik Mierzejewski <rpm@greysector.net> 1.3.3-1
  137. - updated to 1.3.3
  138. - removed calls to exit(3)
  139. - added a simple build system (Makefile)
  140. - dropped libtool dependency
  141. - 1.3.3 added a new symbol, so made it versioned
  142. - added examples to -devel docs
  143. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-3
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  145. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
  146. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  147. * Fri Jun 13 2008 Dominik Mierzejewski <rpm@greysector.net> 1.3.2-1
  148. - adapted PLD spec r1.2
  149. - dropped static package