perl-Class-Singleton-vl.spec 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. Name: perl-Class-Singleton
  2. Version: 1.4
  3. Release: 7%{?_dist_release}
  4. Summary: Implementation of a "Singleton" class
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Class-Singleton/
  8. Source0: http://www.cpan.org/authors/id/A/AB/ABW/Class-Singleton-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. BuildRequires: perl(ExtUtils::MakeMaker)
  12. BuildRequires: perl(Test::More)
  13. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Packager: yasumichi, inagaki
  17. %description
  18. This is the Class::Singleton module. A Singleton describes an object class
  19. that can have only one instance in any system. An example of a Singleton
  20. might be a print spooler or system registry. This module implements a
  21. Singleton class from which other classes can be derived. By itself, the
  22. Class::Singleton module does very little other than manage the
  23. instantiation of a single object. In deriving a class from
  24. Class::Singleton, your module will inherit the Singleton instantiation
  25. method and can implement whatever specific functionality is required.
  26. %prep
  27. %setup -q -n Class-Singleton-%{version}
  28. %build
  29. %{__perl} Makefile.PL INSTALLDIRS=vendor
  30. make %{?_smp_mflags}
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  34. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
  35. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
  36. %{_fixperms} $RPM_BUILD_ROOT/*
  37. %check
  38. make test
  39. %clean
  40. rm -rf $RPM_BUILD_ROOT
  41. %files
  42. %defattr(-,root,root,-)
  43. %doc Changes README
  44. %{perl_vendorlib}/*
  45. %{_mandir}/man3/*
  46. %changelog
  47. * Wed Jan 25 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4-7
  48. - rebuild with perl-5.12.3
  49. * Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-6
  50. - initial build for Vine Linux
  51. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-5
  52. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  53. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-4
  54. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  55. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.4-3
  56. - Rebuild for perl 5.10 (again)
  57. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4-2
  58. - rebuild for new perl
  59. * Mon Oct 15 2007 Steven Pritchard <steve@kspei.com> 1.4-1
  60. - Update to 1.4.
  61. - Update License tag.
  62. - Drop our copy of the license text.
  63. - Improve Summary.
  64. - Make description match cpanspec output.
  65. - BR Test::More.
  66. * Tue Apr 17 2007 Steven Pritchard <steve@kspei.com> 1.03-4
  67. - Use fixperms macro instead of our own chmod incantation.
  68. - BR ExtUtils::MakeMaker.
  69. * Sat Sep 16 2006 Steven Pritchard <steve@kspei.com> 1.03-3
  70. - Canonicalize Source0 URL.
  71. - Fix find option order.
  72. * Thu Sep 08 2005 Steven Pritchard <steve@kspei.com> 1.03-2
  73. - Fix permissions on Singleton.pm.
  74. * Wed Aug 31 2005 Steven Pritchard <steve@kspei.com> 1.03-1
  75. - Specfile autogenerated.