git-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. # Pass --without docs to rpmbuild if you don't want the documentation
  4. Name: git
  5. Version: 1.7.10.2
  6. Release: 1%{?_dist_release}
  7. Summary: Core git tools
  8. Summary(ja): Core git ツール
  9. License: GPLv2
  10. Group: Development/Tools
  11. URL: http://git-scm.com/
  12. Source: %{name}-%{version}.tar.gz
  13. Source1: vine-default-git.el
  14. Source2: git.xinetd
  15. Source3: git.conf.httpd
  16. Source10: %{name}-install.sh
  17. Source11: %{name}-remove.sh
  18. Source12: git-init.el
  19. Patch0: git-1.5-gitweb-home-link.patch
  20. # Security
  21. # none
  22. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel,
  23. BuildRequires: expat-devel, gettext, asciidoc
  24. BuildRequires: xmlto
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  26. Requires: perl-Git = %{version}-%{release}
  27. Requires: zlib
  28. Provides: git-core = %{version}-%{release}
  29. Obsoletes: git-core <= 1.5.4.3
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: iwaim
  33. %description
  34. Git is a fast, scalable, distributed revision control system with an
  35. unusually rich command set that provides both high-level operations
  36. and full access to internals.
  37. The git rpm installs the core tools with minimal dependencies. To
  38. install all git packages, including tools for integrating with other
  39. SCMs, install the git-all meta-package.
  40. %package all
  41. Summary: Meta-package to pull in all git tools
  42. Summary(ja): すべての git ツール
  43. Group: Development/Tools
  44. Requires: git = %{version}-%{release}
  45. Requires: git-svn = %{version}-%{release}
  46. Requires: git-cvs = %{version}-%{release}
  47. %if "%{?_dist_release}" != "vl4"
  48. Requires: git-arch = %{version}-%{release}
  49. %endif
  50. Requires: git-email = %{version}-%{release}
  51. Requires: gitk = %{version}-%{release}
  52. Requires: git-gui = %{version}-%{release}
  53. Requires: perl-Git = %{version}-%{release}
  54. Requires: emacs-git = %{version}-%{release}
  55. Obsoletes: git <= 1.5.4.3
  56. %description all
  57. Git is a fast, scalable, distributed revision control system with an
  58. unusually rich command set that provides both high-level operations
  59. and full access to internals.
  60. This is a dummy package which brings in all subpackages.
  61. %package daemon
  62. Summary: Git protocol daemon
  63. Summary(ja): Git プロトコルデーモン
  64. Group: Development/Tools
  65. Requires: git = %{version}-%{release}
  66. %description daemon
  67. The git daemon for supporting git:// access to git repositories
  68. %package -n gitweb
  69. Summary: Simple web interface to git repositories
  70. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  71. Group: Development/Tools
  72. Requires: git = %{version}-%{release}
  73. %description -n gitweb
  74. Simple web interface to track changes in git repositories
  75. %package svn
  76. Summary: Git tools for importing Subversion repositories
  77. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  78. Group: Development/Tools
  79. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  80. Requires: perl(SVN::Core)
  81. %description svn
  82. Git tools for importing Subversion repositories.
  83. %package cvs
  84. Summary: Git tools for importing CVS repositories
  85. Summary(ja): CVS リポジトリを git へインポートするためのツール
  86. Group: Development/Tools
  87. Requires: git = %{version}-%{release}, cvs, cvsps
  88. %description cvs
  89. Git tools for importing CVS repositories.
  90. %if "%{?_dist_release}" != "vl4"
  91. %package arch
  92. Summary: Git tools for importing Arch repositories
  93. Summary(ja): Arch リポジトリを git へインポートするためのツール
  94. Group: Development/Tools
  95. Requires: git = %{version}-%{release}, tla
  96. %description arch
  97. Git tools for importing Arch repositories.
  98. %endif
  99. %package email
  100. Summary: Git tools for sending email
  101. Summary(ja): Eメールを送るための git ツール
  102. Group: Development/Tools
  103. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  104. %description email
  105. Git tools for sending email.
  106. %package gui
  107. Summary: Git GUI tool
  108. Summary(ja): Git の GUI ツール
  109. Group: Development/Tools
  110. Requires: git = %{version}-%{release}, tk
  111. %description gui
  112. Git GUI tool.
  113. %package -n gitk
  114. Summary: Git revision tree visualiser
  115. Summary(ja): Git リビジョンツリー可視化ツール
  116. Group: Development/Tools
  117. Requires: git = %{version}-%{release}, tk
  118. %description -n gitk
  119. Git revision tree visualiser.
  120. %package -n perl-Git
  121. Summary: Perl interface to Git
  122. Summary(ja): Git の perl インタフェース
  123. Group: Development/Libraries
  124. Requires: git = %{version}-%{release}, perl(Error)
  125. %if "%{?_dist_release}" == "vl4"
  126. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  127. %else
  128. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  129. %endif
  130. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  131. %description -n perl-Git
  132. Perl interface to Git.
  133. %package -n emacs-git
  134. Summary: Git version control system support for Emacs
  135. Summary(ja): Emacs の Git サポート
  136. Group: Applications/Editors
  137. Requires: git = %{version}-%{release}, emacsen-common
  138. %description -n emacs-git
  139. %{summary}.
  140. %package devel
  141. Summary: Header files for git-core
  142. Summary(ja): git-core 用ヘッダファイル
  143. Group: Development/Libraries
  144. %description devel
  145. Header files for git-core.
  146. %prep
  147. %setup -q
  148. %patch0 -p1
  149. %build
  150. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
  151. ETC_GITCONFIG=/etc/gitconfig \
  152. gitwebdir=/var/www/git \
  153. prefix=%{_prefix} all %{!?_without_docs: doc}
  154. %install
  155. rm -rf $RPM_BUILD_ROOT
  156. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  157. prefix=%{_prefix} mandir=%{_mandir} \
  158. ETC_GITCONFIG=/etc/gitconfig \
  159. NO_PYTHON=1 \
  160. gitwebdir=/var/www/git \
  161. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  162. # perl-Git
  163. # Error.pm provide by perl-Error package
  164. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  165. # emacs-git
  166. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  167. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  168. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  169. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  170. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  171. # install el files
  172. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  173. # install vine-default file
  174. install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  175. # install script( bytecompile el and install elc , remove )
  176. %_installemacsenscript git %{SOURCE10}
  177. %_removeemacsenscript git %{SOURCE11}
  178. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  179. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  180. ## for gitweb sub package
  181. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  182. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  183. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  184. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  185. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  186. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  187. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  188. %if %{!?_without_docs:1}0
  189. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  190. %else
  191. rm -rf $RPM_BUILD_ROOT%{_mandir}
  192. %endif
  193. mkdir -p $RPM_BUILD_ROOT/srv/git
  194. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  195. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  196. # header files and lib
  197. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  198. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  199. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  200. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  201. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  202. %clean
  203. rm -rf $RPM_BUILD_ROOT
  204. %post -n emacs-git
  205. # bytecompile and install
  206. if [ "$1" = 2 ]; then
  207. %_emacsenPackageRemove git
  208. fi
  209. %_addemacsenlist git
  210. %_emacsenPackageInstall git
  211. %preun -n emacs-git
  212. if [ "$1" = 0 ]; then
  213. %_emacsenPackageRemove git
  214. %_removeemacsenlist git
  215. fi
  216. %files -f bin-man-doc-files
  217. %defattr(-,root,root)
  218. %{_bindir}/git
  219. %{_bindir}/git-receive-pack
  220. %{_bindir}/git-upload-archive
  221. %{_bindir}/git-upload-pack
  222. %{_bindir}/git-shell
  223. %{_datadir}/git-core/
  224. %doc README COPYING Documentation/*.txt contrib/hooks
  225. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  226. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  227. %{_sysconfdir}/bash_completion.d
  228. %files svn
  229. %defattr(-,root,root)
  230. %{_libexecdir}/git-core/*svn*
  231. %doc Documentation/*svn*.txt
  232. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  233. %{!?_without_docs: %doc Documentation/*svn*.html }
  234. %files cvs
  235. %defattr(-,root,root)
  236. %doc Documentation/*git-cvs*.txt
  237. %{_bindir}/git-cvsserver
  238. %{_libexecdir}/git-core/*cvs*
  239. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  240. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  241. %if "%{?_dist_release}" != "vl4"
  242. %files arch
  243. %defattr(-,root,root)
  244. %doc Documentation/git-archimport.txt
  245. %{_libexecdir}/git-core/git-archimport
  246. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  247. %{!?_without_docs: %doc Documentation/git-archimport.html }
  248. %endif
  249. %files email
  250. %defattr(-,root,root)
  251. %doc Documentation/*email*.txt
  252. %{_libexecdir}/git-core/*email*
  253. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  254. %{!?_without_docs: %doc Documentation/*email*.html }
  255. %files gui
  256. %defattr(-,root,root)
  257. %{_libexecdir}/git-core/git-gui*
  258. %{_libexecdir}/git-core/git-citool
  259. %{_datadir}/git-gui/
  260. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  261. %{!?_without_docs: %doc Documentation/git-gui.html}
  262. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  263. %{!?_without_docs: %doc Documentation/git-citool.html}
  264. %files -n gitk
  265. %defattr(-,root,root)
  266. %doc Documentation/*gitk*.txt
  267. %{_bindir}/gitk
  268. %{_datadir}/gitk
  269. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  270. %{!?_without_docs: %doc Documentation/*gitk*.html }
  271. %files -n perl-Git -f perl-files
  272. %defattr(-,root,root)
  273. %files -n emacs-git
  274. %defattr(-,root,root)
  275. %{_datadir}/emacs/site-lisp/git
  276. #%{_libdir}/emacsen-common/packages/install/git
  277. #%{_libdir}/emacsen-common/packages/remove/git
  278. %{emacsen_pkgdir}/install/git
  279. %{emacsen_pkgdir}/remove/git
  280. %files daemon
  281. %defattr(-,root,root)
  282. %{_libexecdir}/git-core/git-daemon
  283. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  284. /srv/git
  285. %files -n gitweb
  286. %defattr(-,root,root)
  287. %doc gitweb/README
  288. /var/www/git/
  289. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  290. %files devel
  291. %defattr(644,root,root,755)
  292. %{_includedir}/git
  293. %{_libdir}/libgit.a
  294. %{_libdir}/libgit_xdiff.a
  295. %files all
  296. # No files for you!
  297. %changelog
  298. * Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
  299. - new upstream release
  300. * Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
  301. - new upstream release
  302. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
  303. - new upstream release
  304. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
  305. - build with perl 5.12.3
  306. * Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
  307. - new upstream release
  308. - build with openssl 1.0.0c for VineSeed
  309. * Sat Jan 1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
  310. - new upstream release: include security fix: CVE-2010-3906
  311. * Fri Oct 1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
  312. - new upstream release
  313. - drop CVE-2010-2542 patch (Patch100): upstream fixed
  314. - apply vine-default
  315. - rename Source1: git-init.el -> vine-default-git.el
  316. - add new git-init.el file (Source12)
  317. - update git-install.sh
  318. - update %%build and %%install section for gitweb subpackage
  319. - add README in gitweb subpackage
  320. * Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
  321. - add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
  322. * Wed Jun 9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
  323. - new upstream release
  324. - fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
  325. - disable building of unused python remote helper libs
  326. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  327. - new upstream release with security fix
  328. - drop patch10 (included in new release)
  329. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  330. - new upstream release
  331. - add patch10 git daemon extra arg parsing fix
  332. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  333. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  334. - update git-install.sh (Source10) using contributed patch
  335. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  336. - new upstream release
  337. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  338. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  339. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  340. - fix summary and description in daemon sub package
  341. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  342. - drop Error.pm: provide by perl-Error package
  343. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  344. - new upstream relase
  345. - update URL tag
  346. - add Requires: perl(SVN::Core) for svn subpackage
  347. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  348. - add git-shell in git package
  349. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  350. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  351. - added BuildRequires: xmlto
  352. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  353. - new upstream release
  354. - add devel subpackage (see [wishes:0165])
  355. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  356. - new upstream release
  357. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  358. - new upstream release
  359. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  360. - new upstream release
  361. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  362. - use %%emacsen_pkgdir macro
  363. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  364. - new upstream release
  365. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  366. - initial build for Vine Linux
  367. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  368. - git-1.5.6.4
  369. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  370. - git-1.5.6
  371. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  372. - use tar.bz2 instead of tar.gz
  373. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  374. - git-1.5.5.3
  375. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  376. - git-1.5.5.2
  377. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  378. - git-1.5.5.1
  379. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  380. - git-1.5.5
  381. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  382. - Remove the last two requires on git-core.
  383. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  384. - Remove a patch that's already upstream.
  385. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  386. - git-1.5.4.5
  387. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  388. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  389. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  390. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  391. - Install the bash completion script from contrib (bug 433255).
  392. - Include the html docs in the 'core' package again (bug 434271).
  393. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  394. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  395. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  396. - git-1.5.4.4
  397. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  398. - rebuild for new perl (again)
  399. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  400. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  401. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  402. - git-1.5.4.3
  403. - Include Kristian Høgsberg's changes to rename git-core to
  404. git and git to git-all.
  405. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  406. - git-1.5.4.2
  407. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  408. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  409. gitweb rss feeds point be commitdiffs instead of commit
  410. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  411. - git-1.5.4.1
  412. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  413. - rebuild for new perl
  414. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  415. - Add BuidRequires on gettext.
  416. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  417. - git-1.5.4
  418. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  419. - git-1.5.3.8
  420. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  421. - Have git metapackage require explicit versions (bug 247214)
  422. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  423. - git-1.5.3.7
  424. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  425. - git-1.5.3.6
  426. - git-core requires perl(Error) (bug 367861)
  427. - git-svn requires perl(Term:ReadKey) (bug 261361)
  428. - git-email requires perl-Git (bug 333061)
  429. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  430. - git-Perl requires Error package
  431. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  432. - git-1.5.3.4
  433. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  434. - git-1.5.3.3
  435. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  436. - git-1.5.3.2
  437. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  438. - Include git-gui and git-citool docs
  439. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  440. - git-1.5.3.1-1
  441. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  442. - git-1.5.2.5-1
  443. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  444. - git-1.5.2.4-1
  445. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  446. - Add git-daemon and gitweb packages
  447. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  448. - Add emacs-git package (#235431)
  449. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  450. - git-1.5.2.2
  451. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  452. - git-1.5.2.1
  453. * Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  454. - Added lib files for git-gui
  455. - Added Documentation/technical (As needed by Git Users Manual)
  456. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  457. - Added howto files
  458. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  459. - git-1.5.0.6
  460. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  461. - git-1.5.0.5
  462. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  463. - git-1.5.0.3
  464. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  465. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  466. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  467. - git-1.5.0.2
  468. * Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
  469. - Update core package description (Git isn't as stupid as it used to be)
  470. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  471. - Add git-gui and git-citool.
  472. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  473. - no need to install manpages executable (bz 216790)
  474. - use bytes for git-cvsserver
  475. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  476. - git-1.4.4.2
  477. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  478. - rebuild against the new curl
  479. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  480. - git-1.4.2.4
  481. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  482. - git-1.4.2.3
  483. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  484. - git-1.4.2.1
  485. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  486. - git-1.4.2
  487. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  488. - git-1.4.1
  489. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  490. - git-1.4.0
  491. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  492. - git-1.3.3
  493. - enable git-email building, prereqs have been relaxed
  494. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  495. - git-1.3.2
  496. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  497. - git-1.3.1
  498. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  499. - git-1.3.0
  500. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  501. - git-1.2.6
  502. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  503. - git-1.2.5
  504. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  505. - git-1.2.4
  506. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  507. - git-1.2.3
  508. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  509. - git-1.2.2
  510. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  511. - git-1.2.1
  512. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  513. - git-1.2.0
  514. * Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  515. - git-1.1.6
  516. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  517. - git-1.1.4
  518. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  519. - git-1.1.2
  520. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  521. - git-1.1.1
  522. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  523. - Update to latest git-1.1.0 (drop git-email for now)
  524. - Now creates multiple packages:
  525. - git-core, git-svn, git-cvs, git-arch, gitk
  526. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  527. - Change subpackage names to git-<name> instead of git-core-<name>
  528. - Create empty root package which brings in all subpackages
  529. - Rename git-tk -> gitk
  530. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  531. - zlib dependency fix
  532. - Minor cleanups from split
  533. - Move arch import to separate package as well
  534. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  535. - Move programs with non-standard dependencies (svn, cvs, email)
  536. into separate packages
  537. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  538. - parallelize build
  539. - COPTS -> CFLAGS
  540. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  541. - update to 0.99.6
  542. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  543. - Linus noticed that less is required, added to the dependencies
  544. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  545. - Updated dependencies
  546. - Don't assume manpages are gzipped
  547. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  548. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  549. - use RPM_OPT_FLAGS in spec file, drop patch0
  550. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  551. - use dist tag to differentiate between branches
  552. - use rpm optflags by default (patch0)
  553. - own %{_datadir}/git-core/
  554. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  555. - update spec file to fix Buildroot, Requires, and drop Vendor
  556. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  557. - Redid the description
  558. - Cut overlong make line, loosened changelog a bit
  559. - I think Junio (or perhaps OSDL?) should be vendor...
  560. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  561. - Add the man pages, and the --without docs build option
  562. * Wed Jul 7 2005 Chris Wright <chris@osdl.org>
  563. - initial git spec file