self-build-libmp4v2-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141
  1. %define projname mp4v2
  2. %define pkgname libmp4v2
  3. %define name self-build-%{pkgname}
  4. %define version 1.9.1
  5. %define release 4%{?_dist_release}
  6. #% define sourceurl0 http://resare.com/libmp4v2/dist/%{pkgname}-%{version}.tar.bz2
  7. #% define sourceurl1 http://resare.com/libmp4v2/mklibmp4v2/mklibmp4v2-r51.tar.bz2
  8. %define sourceurl0 http://mp4v2.googlecode.com/files/%{projname}-%{version}.tar.bz2
  9. Summary: Package to automatically build %{pkgname} rpm package (with internal libmp4v2)
  10. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  11. Name: %{name}
  12. Version: %{version}
  13. Release: %{release}
  14. Source0: %{pkgname}-vl.spec
  15. License: MPLv1.1
  16. Group: Restricted Software
  17. Requires(post): self-build-setup >= 0.9.9
  18. # (build)requies of target package.
  19. BuildArch: noarch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Packager: munepi
  22. %description
  23. The libmp4v2 library provides an abstraction layer for working with files
  24. using the mp4 container format. This library is developed by mpeg4ip project
  25. and is an exact copy of the library distributed in the mpeg4ip package.
  26. If you install this package, it automatically downloads
  27. source code, compile it with internal libmp4v2, and create
  28. rpm packages of %{pkgname}-%{version} and libmp4v2-%{version}.
  29. And the created rpm packages are automatically installed
  30. if installation is executed by apt-get command or synaptic
  31. package manager.
  32. [Note]
  33. This package requires many other packages to compile
  34. targetsoftware. So it consume more disk space than usual.
  35. Also installation takes logner time because of compilation.
  36. (This will take a few minutes to quarter or half of an hour,
  37. depends on building environment)
  38. [About self-build package]
  39. For some kind of software, distributing of binary package
  40. may viorate the patent or law. Therefore we chose self-build
  41. packge, create binary package on your machine, for such kind
  42. of softwares instead of distributing binary package.
  43. Please obey the national law when you use the created binary
  44. packages. And if you want to use the softwares using patented
  45. thechnology, it may be required to get a permission, make an
  46. agreement or purchas a license. Please consider it with your
  47. purpose or way of use and take appropriate action.
  48. %description -l ja
  49. libmp4v2 ライブラリは mp4 コンテナフォーマットを用いたファイ
  50. ルで動作するものに対して抽象レイヤーを提供します.このライブ
  51. ラリは mpeg4ip プロジェクトにより開発されており,mpeg4ip パッ
  52. ケージに分散されているライブラリの完全なコピーです.
  53. このパッケージをインストールすると、自動的にソースコードを
  54. ダウンロードして、%{pkgname}-%{version} の rpm パッケージを作成します。
  55. また apt-get コマンドや synaptic パッケージマネージャから実行
  56. した場合は、作成された rpm パッケージのインストールも自動的に
  57. 行います。
  58. [注意]
  59. コンパイルに必要な多くの関連パッケージを要求するので通常より
  60. ディスクの領域を多く消費します。
  61. またインストール時にコンパイルを行うため、通常より時間がかか
  62. る場合があります。(環境にもよりますが数分から数十分程度)
  63. [self-build パッケージについて]
  64. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  65. 違反する可能性があるものがあります。その為、このような問題が
  66. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  67. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  68. ジという方法を採っています。
  69. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  70. アのライセンス、および利用する国の各種法令に従ってください。
  71. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  72. センスの購入などが必要となる場合がありますので、利用する目的
  73. や形態に応じて各自で判断し適切な対応を取ってください。
  74. %prep
  75. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  76. %install
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  79. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  80. %clean
  81. %{__rm} -rf ${RPM_BUILD_ROOT}
  82. %posttrans
  83. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 75000
  84. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  85. %{pkgname}-devel-%{version}-%{release}
  86. %files
  87. %defattr(-,root,root)
  88. %{_datadir}/%{name}
  89. %changelog
  90. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.1-4
  91. - - renamed %%{Source0} to libmp4v2-vl.spec
  92. * Thu Mar 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.1-3
  93. - fixed the permission of /usr/include/mp4v2 to access it by group, others
  94. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.1-2
  95. - added --disable-gch in configure options
  96. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.1-1
  97. - new upstream release
  98. - changed URL: to http://code.google.com/p/mp4v2/
  99. MP4v2 was originally bundled with mpeg4ip library,
  100. but has been moved into its own maintained library
  101. due to a combination of the cessation of support of mpeg4ip
  102. and the usefulness of this library on its own.
  103. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.5.0.1-2
  104. - added BuildArch: noarch
  105. - avoided to execute self-build-rpm.sh on RPM transaction
  106. - moved %%post actions to %%posttrans
  107. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.5.0.1-1
  108. - initial build
  109. ### end of file