curl-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %if %{?_dist_release} != "vl6"
  3. %global with_http2 1
  4. %endif
  5. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  6. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  7. Name: curl
  8. Version: 7.59.0
  9. Release: 1%{?_dist_release}
  10. License: MIT
  11. Group: Applications/Internet
  12. URL: http://curl.haxx.se/
  13. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
  14. # ftp: fix typo in recursive callback detection for seeking
  15. Patch1: 0001-curl-7.58.0-ftp-typo-in-recursive-callback-detection.patch
  16. # patch making libcurl multilib ready
  17. Patch101: 0101-curl-7.58.0-multilib.patch
  18. # prevent configure script from discarding -g in CFLAGS (#496778)
  19. Patch102: 0102-curl-7.36.0-debug.patch
  20. # migrate tests/http_pipe.py to Python 3
  21. Patch103: 0103-curl-7.59.0-python3.patch
  22. # use localhost6 instead of ip6-localhost in the curl test-suite
  23. Patch104: 0104-curl-7.19.7-localhost6.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: openssl-devel
  26. BuildRequires: gnutls-devel
  27. BuildRequires: libidn-devel zlib-devel
  28. BuildRequires: openldap-devel
  29. BuildRequires: openssh-server
  30. BuildRequires: openssh-clients
  31. BuildRequires: pkgconfig
  32. %if "%{?_dist_release}" != "vl6"
  33. BuildRequires: libssh2-devel
  34. %endif
  35. %if 0%{?with_http2}
  36. BuildRequires: libnghttp2-devel
  37. %endif
  38. Requires: ca-certificates
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. Packager: daisuke
  42. %description
  43. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  44. Dict servers, using any of the supported protocols. cURL is designed
  45. to work without user interaction or any kind of interactivity. cURL
  46. offers many useful capabilities, like proxy support, user
  47. authentication, FTP upload, HTTP post, and file transfer resume.
  48. %package devel
  49. Summary: Files needed for building applications with libcurl.
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. Requires: openssl-devel libidn-devel zlib-devel
  53. %description devel
  54. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  55. Dict servers, using any of the supported protocols. The curl-devel
  56. package includes files needed for developing applications which can
  57. use cURL's capabilities internally.
  58. #'
  59. ## to build compat32 for x86_64 architecture support
  60. %package -n compat32-%{name}
  61. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  62. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  63. Group: System Environment/Libraries
  64. %description -n compat32-%{name}
  65. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  66. Dict servers, using any of the supported protocols. cURL is designed
  67. to work without user interaction or any kind of interactivity. cURL
  68. offers many useful capabilities, like proxy support, user
  69. authentication, FTP upload, HTTP post, and file transfer resume.
  70. %package -n compat32-%{name}-devel
  71. Summary: Files needed for building applications with libcurl.
  72. Group: Development/Libraries
  73. %description -n compat32-%{name}-devel
  74. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  75. Dict servers, using any of the supported protocols. The curl-devel
  76. package includes files needed for developing applications which can
  77. use cURL's capabilities internally.
  78. #'
  79. %prep
  80. %setup -q
  81. # upstream patches
  82. %patch1 -p1
  83. # Fedora patches
  84. %patch101 -p1
  85. %patch102 -p1
  86. %patch103 -p1
  87. %patch104 -p1
  88. # make tests/*.py use Python 3
  89. sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
  90. # disable test 1112 (#565305) and test 1801
  91. # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
  92. printf "1112\n1801\n" >> tests/data/DISABLED
  93. %build
  94. %configure \
  95. --with-ssl=%{_prefix} \
  96. --with-libidn \
  97. --enable-ipv6 \
  98. --enable-threaded-resolver \
  99. --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  100. %if "%{?_dist_release}" != "vl6"
  101. --with-libssh2 \
  102. %endif
  103. %if 0%{?with_http2}
  104. --with-nghttp2 \
  105. %endif
  106. --enable-ldaps \
  107. --disable-static \
  108. --enable-hidden-symbols
  109. make %{?_smp_mflags}
  110. %install
  111. rm -rf $RPM_BUILD_ROOT
  112. make DESTDIR=$RPM_BUILD_ROOT install
  113. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  114. %clean
  115. rm -rf $RPM_BUILD_ROOT
  116. %post -p /sbin/ldconfig
  117. %postun -p /sbin/ldconfig
  118. %files
  119. %defattr(-,root,root)
  120. %{!?_licensedir:%global license %%doc}
  121. %license COPYING
  122. %doc CHANGES README
  123. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  124. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  125. %doc docs/TheArtOfHttpScripting docs/TODO
  126. %{_bindir}/curl
  127. #{_datadir}/curl/*
  128. %{_libdir}/*.so.*
  129. %{_mandir}/man1/*.1*
  130. %files devel
  131. %defattr(-,root,root)
  132. %{_bindir}/curl-config
  133. %{_includedir}/curl
  134. %{_libdir}/*.so
  135. %{_libdir}/pkgconfig/*.pc
  136. %{_mandir}/man1/curl-config.1*
  137. %{_mandir}/man3/*
  138. %{_datadir}/aclocal/libcurl.m4
  139. ## to build compat32 for x86_64 architecture support
  140. %if %{build_compat32}
  141. %files -n compat32-%{name}
  142. %defattr(-,root,root)
  143. %{_libdir}/*.so.*
  144. %files -n compat32-%{name}-devel
  145. %defattr(-,root,root)
  146. %{_libdir}/*.so
  147. %{_libdir}/pkgconfig/*.pc
  148. %endif
  149. %changelog
  150. * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
  151. - new upstream release.
  152. - imported Patch1 and 103 from rawhide.
  153. * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
  154. - new upstream release with security fix
  155. - update patch101
  156. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
  157. - new upstream release.
  158. - updated Patch101-104.
  159. - dropped Patch107.
  160. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  161. - new upstream release.
  162. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  163. - new upstream release.
  164. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  165. - new upstream release.
  166. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  167. - new upstream release.
  168. - disabled HTTP/2 on Vine6.
  169. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  170. - added HTTP/2 support.
  171. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  172. - new upstream release with security fix.
  173. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  174. - new upstream release.
  175. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  176. - new upstream release
  177. - built with openssl 1.0.2g
  178. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  179. - new upstream release with security fix .
  180. - removed Patch108 (fixed in upstream).
  181. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  182. - new upstream release with security fix
  183. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  184. - new upstream release
  185. - add libcurl.m4 to -devel package
  186. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  187. - new upstream release
  188. - import upstream/fedora patches
  189. - disable libssh2 on Vine Linux 6
  190. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  191. - new upstream reelase
  192. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  193. - update to 7.28.0
  194. - add configure options
  195. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  196. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  197. - use ca-certificates package
  198. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  199. - R: ca-certificates
  200. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  201. - new upstream release
  202. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  203. - add patch100 for fix CVE-2011-2192 (gssapi)
  204. - add Vendor/Distri tags
  205. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  206. - rebuild with openssl-1.0.0c
  207. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  208. - rebuilt with rpm-4.8.1 for pkg-config
  209. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  210. - new upstream release
  211. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  212. - new upstream release with security fix
  213. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  214. - added compat32 subpackages
  215. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  216. - new upstream release
  217. - use "_smp_mflags" flag
  218. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  219. - rebuild with openldap-2.4.11
  220. - add BR: openldap-devel
  221. - remove static library
  222. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  223. - new upstream release with security fix (CVE-2009-0037)
  224. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  225. - new upstream release
  226. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  227. - new upstream release
  228. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  229. - new upstream release
  230. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  231. - new upstream release
  232. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  233. - new upstream release
  234. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  235. - rebuilt with openssl-0.9.8e
  236. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  237. - new upstream release
  238. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  239. - new upstream release
  240. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  241. - new upstream release
  242. - add pkgconfig file to devel package
  243. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  244. - new upstream release
  245. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  246. - new upstream release
  247. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  248. - new upstream release
  249. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  250. - added libidn, zlib in Requires
  251. - added libidn-devel, zlib-devel in BuildPrereq
  252. - added zlib-devel in curl-devel's Requires
  253. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  254. - added openssl-devel, libidn-devel in curl-devel's Requires
  255. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  256. - new upstream release
  257. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  258. - new upstream release
  259. - rebuild with openssl-0.9.7d
  260. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  261. - upstream release
  262. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  263. - add %%{_datadir}/curl/* to %%files section
  264. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  265. - source upgrade
  266. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  267. - source upgrade
  268. - add PreReq: ldconfig
  269. - add %%{_libdir}/*.la to %%files devel section
  270. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  271. - build for VineSeed
  272. - add Requires: openssl
  273. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  274. - automated rebuild
  275. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  276. - 7.9.2
  277. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  278. - include curl-config in curl-devel
  279. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  280. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  281. - added openssl-devel build req
  282. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  283. - built for the distro
  284. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  285. - upgrade to curl-7.7.2.
  286. - enable IPv6.
  287. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  288. - rebuilt against openssl-0.9.6-1
  289. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  290. - fixed mising ldconfigs
  291. - updated to 7.5.2, bug fixes
  292. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  293. - updated to 7.5.1
  294. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  295. - update to 7.4.1 to fix bug #20337, problems with curl -c
  296. - not using patch anymore, it's included in the new source. Keeping
  297. for reference
  298. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  299. - fix bogus req in -devel package
  300. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  301. - devel package needed defattr so that root owns the files
  302. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  303. - update to 7.3
  304. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  305. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  306. - enable SSL support
  307. - fix packager tag
  308. - move buildroot to %%{_tmppath}
  309. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  310. - fixed vendor tag for bug #15028
  311. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  312. - rebuilt
  313. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  314. - workaround alpha build problems with optimizations
  315. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  316. - rebuilt
  317. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  318. - put man pages in correct place
  319. - use %%makeinstall
  320. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  321. - updated to 6.5.2
  322. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  323. - updated sources to 6.2
  324. - gzip man page
  325. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  326. - changed group
  327. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  328. - changelog started
  329. - general cleanups, changed prefix to /usr, added manpage to files section
  330. - including in Powertools