at-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449
  1. %bcond_without pam
  2. Summary: Job spooling tools.
  3. Summary(ja): ジョブスプーリングツール
  4. Name: at
  5. Version: 3.1.14
  6. Release: 1%{?_dist_release}
  7. License: GPLv2+ and ISC
  8. Group: System Environment/Daemons
  9. URL: http://ftp.debian.org/debian/pool/main/a/at
  10. Source: http://ftp.debian.org/debian/pool/main/a/at/at_%{version}.orig.tar.gz
  11. Source1: pam_atd
  12. Source2: atd.init
  13. Source3: atd.sysconf
  14. Patch1: at-3.1.14-makefile.patch
  15. Patch2: at-3.1.12-opt_V.patch
  16. Patch3: at-3.1.12-shell.patch
  17. Patch4: at-3.1.13-nitpicks.patch
  18. Patch5: at-3.1.13-pam.patch
  19. Patch6: at-3.1.13-selinux.patch
  20. Patch7: at-3.1.12-nowrap.patch
  21. Patch8: at-3.1.12-fix_no_export.patch
  22. Patch9: at-3.1.13-mailwithhostname.patch
  23. Patch10: at-3.1.13-usePOSIXtimers.patch
  24. #Patch11: at-3.1.13-help.patch
  25. # http://mantis.vinelinux.org/view.php?id=2483
  26. Patch20: at-3.1.13-usePOSIXtimers-fix.patch
  27. BuildRequires: fileutils
  28. BuildRequires: chkconfig
  29. BuildRequires: flex
  30. BuildRequires: bison
  31. BuildRequires: autoconf
  32. %if %{with pam}
  33. BuildRequires: pam-devel
  34. %endif
  35. Conflicts: crontabs <= 1.5
  36. # No, I'm not kidding
  37. BuildRequires: smtpdaemon
  38. Buildroot: %{_tmppath}/%{name}-%{version}-root
  39. %description
  40. At and batch read commands from standard input or from a specified
  41. file. At allows you to specify that a command will be run at a
  42. particular time. Batch will execute commands when the system load
  43. levels drop to a particular level. Both commands use /bin/sh.
  44. You should install the at package if you need a utility for
  45. time-oriented job control. Note: If it is a recurring job that will
  46. need to be repeated at the same time every day/week, etc. you should
  47. use crontab instead.
  48. %description -l ja
  49. at と batch は標準入力や指定されたファイルからコマンドを読み取ります。
  50. at を使用して特定の時間にコマンドを実行するように指定することが可能です。
  51. batch はシステムの負荷レベルが特定のレベルを下回るとコマンドを実行します。
  52. 両コマンドとも /bin/sh を使います。
  53. あなたが時間志向のジョブ管理のためのユーティリティを必要とするならば、at
  54. パッケージをインストールしてください。
  55. メモ: もし毎日/週などの同じ時間にくり返される必要があるジョブであれば、
  56. 代わりに crontab を使うべきでしょう。
  57. %prep
  58. %setup -q
  59. cp %{SOURCE1} .
  60. %patch1 -p1 -b .make
  61. %patch2 -p1 -b .opt_V
  62. %patch3 -p1 -b .shell
  63. %patch4 -p1 -b .nit
  64. %patch5 -p1 -b .pam
  65. %patch6 -p1 -b .selinux
  66. %patch7 -p1 -b .nowrap
  67. %patch8 -p1 -b .export
  68. %patch9 -p1 -b .mail
  69. %patch10 -p1 -b .posix
  70. #%patch11 -p1 -b .help
  71. %patch20 -p1 -b .posix-fix
  72. %build
  73. # patch10 touches configure.in
  74. autoconf
  75. # for patch11
  76. rm -f lex.yy.* y.tab.*
  77. %configure --with-atspool=%{_localstatedir}/spool/at/spool \
  78. --with-jobdir=%{_localstatedir}/spool/at \
  79. --with-daemon_username=root \
  80. --with-daemon_groupname=root \
  81. %if %{with pam}
  82. --with-pam
  83. %endif
  84. make
  85. %check
  86. # don't run "make test" by default
  87. %{?_without_check: %define _without_check 1}
  88. %{!?_without_check: %define _without_check 1}
  89. %if ! %{_without_check}
  90. LANG=C make test > /dev/null
  91. %endif
  92. %install
  93. rm -rf %{buildroot}
  94. make install \
  95. DAEMON_USERNAME=`id -nu`\
  96. DAEMON_GROUPNAME=`id -ng` \
  97. DESTDIR=%{buildroot}\
  98. sbindir=%{buildroot}%{_prefix}/sbin\
  99. bindir=%{buildroot}%{_bindir}\
  100. prefix=%{buildroot}%{_prefix}\
  101. exec_prefix=%{buildroot}%{_prefix}\
  102. docdir=%{buildroot}/usr/doc\
  103. mandir=%{buildroot}%{_mandir}\
  104. etcdir=%{buildroot}%{_sysconfdir} \
  105. ATJOB_DIR=%{buildroot}%{_localstatedir}/spool/at \
  106. ATSPOOL_DIR=%{buildroot}%{_localstatedir}/spool/at/spool \
  107. INSTALL_ROOT_USER=`id -nu` \
  108. INSTALL_ROOT_GROUP=`id -nu`;
  109. echo > %{buildroot}%{_sysconfdir}/at.deny
  110. mkdir docs
  111. cp $RPM_BUILD_ROOT/%{_prefix}/doc/at/* docs/
  112. mkdir -p %{buildroot}%{_sysconfdir}/pam.d
  113. install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/atd
  114. mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
  115. install -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/rc.d/init.d/atd
  116. mkdir -p %{buildroot}/etc/sysconfig
  117. install -m 755 %{SOURCE3} %{buildroot}/etc/sysconfig/atd
  118. # remove unpackaged files from the buildroot
  119. rm -r %{buildroot}%{_prefix}/doc
  120. %clean
  121. rm -rf %{buildroot}
  122. %post
  123. touch %{_localstatedir}/spool/at/.SEQ
  124. chmod 600 %{_localstatedir}/spool/at/.SEQ
  125. chown daemon.daemon %{_localstatedir}/spool/at/.SEQ
  126. # must be in chkconfig on
  127. /sbin/chkconfig --add atd
  128. %preun
  129. if [ "$1" = 0 ] ; then
  130. /sbin/service atd stop
  131. /sbin/chkconfig --del atd
  132. fi
  133. %postun
  134. if [ "$1" -ge "1" ]; then
  135. /sbin/service atd condrestart
  136. fi
  137. %files
  138. %defattr(-,root,root)
  139. %doc docs/*
  140. %config %{_sysconfdir}/at.deny
  141. %attr(0700,root,root) %{_sysconfdir}/rc.d/init.d/atd
  142. %attr(0700,root,root) %{_sysconfdir}/sysconfig/atd
  143. %attr(0700,daemon,daemon) %dir %{_localstatedir}/spool/at
  144. %attr(0600,daemon,daemon) %verify(not md5 size mtime) %ghost %{_localstatedir}/spool/at/.SEQ
  145. %attr(0700,daemon,daemon) %dir %{_localstatedir}/spool/at/spool
  146. %attr(0640,root,daemon) %config(noreplace) /etc/pam.d/atd
  147. %{_sbindir}/atrun
  148. %attr(0755,root,root) %{_sbindir}/atd
  149. %{_mandir}/man*/*
  150. %{_bindir}/batch
  151. %{_bindir}/atrm
  152. %{_bindir}/atq
  153. %attr(4755,root,root) %{_bindir}/at
  154. %changelog
  155. * Sun Jun 15 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.14-1
  156. - new upstream release.
  157. - updated Patch1.
  158. - removed Patch11 (no longer needed).
  159. * Sat Nov 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-4
  160. - re-add Patch10 and Patch12 to use posix timer
  161. - http://mantis.vinelinux.org/view.php?id=2483
  162. * Sat Nov 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-3
  163. - remove Patch10
  164. - atd doesn't execute queued job until the next jobs is queued.
  165. * Thu Nov 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-2
  166. - fix pam_atd to use system-auth instead of password-auth
  167. * Tue Nov 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.13-1
  168. - update to 3.1.13
  169. - update patches to sync with fedora 3.1.13-10.
  170. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.10.1-17
  171. - rebuild with rpm-4.8.1
  172. * Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.10.1-16
  173. - spec in utf-8
  174. * Tue May 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10.1-15
  175. - new upstream release
  176. - apply new versioning policy
  177. * Thu Jul 12 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.1.10-14vl1
  178. - update based on fedora development 3.1.10-14.
  179. - build with new toolchains.
  180. * Tue Jul 9 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-14
  181. - feature: add configuration file
  182. - fix -V option
  183. - fix init script
  184. * Tue Jul 3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-13
  185. - Resolves: rhbz#243064
  186. * Tue Jul 3 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-12
  187. - crashing atd
  188. - work only for root, still broken some functions
  189. - Resolves: rhbz#243064
  190. * Tue Mar 27 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-11
  191. - mistake in pam_atd
  192. - rhbz#234120
  193. * Tue Mar 05 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-10
  194. - rhbz#224597
  195. * Mon Mar 03 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-9
  196. - review
  197. * Wed Feb 20 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-8
  198. - review
  199. - rhbz#225288
  200. * Tue Jan 30 2007 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-7
  201. - no debug file - useless
  202. - new pam configuration
  203. - rhbz#224597
  204. * Tue Oct 27 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-6
  205. - fix daylight-saving again
  206. - fix #214759 - problem with seteuid
  207. * Wed Oct 25 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-5
  208. - daylight-saving
  209. * Tue Oct 24 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.10-3
  210. - new version from upstream 3.1.10
  211. * Thu Aug 23 2006 Marcela Maslanova <mmaslano@redhat.com> - 3.1.8-82.fc6
  212. - #176486 don't fork option added (patch from Enrico Scholz)
  213. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.2
  214. - rebuild
  215. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.1.8-81.1
  216. - bump again for double-long bug on ppc(64)
  217. * Tue Feb 07 2006 Jason Vas Dias <jvdias@redhat.com> - 3.1.8-81
  218. - rebuild for new gcc, glibc, glibc-kernheaders
  219. - workaround new refusal of /usr/bin/install to chown
  220. * Fri Dec 18 2005 Jason Vas Dias<jvdias@redhat.com> - 3.1.8-80.2
  221. - rebuild for new flex
  222. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  223. - rebuilt for new gcj
  224. * Fri Oct 14 2005 Dan Walsh <dwalsh@redhat.com> - 3.1.8-80
  225. - Add seuserbyname support
  226. * Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 3.1.8-79
  227. - use include instead of pam_stack in pam config
  228. * Fri Jun 03 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-78
  229. - fix bug 159220: add pam_loginuid to pam session stack in /etc/pam.d/atd
  230. - fix bug 102341: add '-r' synonym for '-d' / atrm for POSIX / SuS conformance
  231. * Fri Apr 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-77
  232. - always call pam_setcred(pamh, PAM_DELETE_CRED) before session
  233. - close
  234. * Tue Apr 05 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-70
  235. - always call pam_close_session on PAM_FAIL or pam_end
  236. * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-68
  237. - Put PAM authentication check in 'check_permissions()', so
  238. - user can know when using at(1) if PAM permission is denied.
  239. * Tue Mar 08 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-67
  240. - better fix for bug 150131: change DAEMON_USERNAME and
  241. - DAEMON_GROUPNAME to 'root' .
  242. * Mon Mar 07 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-66
  243. - fix bug 150131: atd should not relinquish root privilege if
  244. - doing su(1) equivalent with PAM .
  245. * Tue Jan 25 2005 Jason Vas Dias <jvdias@redhat.com> 3.1.8-64
  246. - bugs 5160/146132: add PAM authentication control to atd
  247. * Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.8-60vl1
  248. - based on Fedora development 3.1.8-60
  249. * Tue Oct 05 2004 Jason Vas Dias <jvdias@redhat.com> 3.1.8-60
  250. - fix bug 131510: no_export env. var. blacklisting should not
  251. - remove 'SHELL' when only 'SHELLOPTS' is blacklisted.
  252. - at(1) man-page should not say 'commands are run with /bin/sh'
  253. - and should explain usage of SHELL environement variable and
  254. - details of blacklisted variables.
  255. * Tue Sep 28 2004 Rik van Riel <riel@redhat.com> 3.1.8-58
  256. - fix typo in man page, bug 112303
  257. - (regenerated at-3.1.8-man-timespec-path.patch with fix)
  258. * Tue Aug 03 2004 Jason Vas Dias <jvdias@redhat.com>
  259. - fixed bug 125634 - made usage() agree with manpage
  260. * Thu Jul 29 2004 Jason Vas Dias <jvdias@redhat.com>
  261. - Added POSIX.2 -t option for RFE 127485
  262. * Fri Jun 20 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-46
  263. - add at-3.1.8-atrun.8-typo-97697.patch to fix typo in atrun.8 (#97697)
  264. - update at.1 description of shell behaviour (#91233)
  265. * Tue Jun 17 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-45
  266. - make the job shell default to SHELL instead of "/bin/sh" (#91233)
  267. * Tue Jun 3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-43
  268. - Replace redundant at-3.1.7-paths.patch by at-3.1.8-man-timespec-path.patch
  269. to fix timespec path
  270. * Tue Jun 3 2003 Jens Petersen <petersen@redhat.com> - 3.1.8-41
  271. - update source to at_3.1.8-11 from debian upstream
  272. - update source url
  273. - at-debian.patch no longer needed
  274. - at-3.1.7-paths.patch: the patch to "at.1.in" no longer needed
  275. - replace at-3.1.8-lexer.patch with at-3.1.8-11-lexer-parser.diff
  276. - at-3.1.8-dst.patch no longer needed
  277. - at-3.1.8-lsbdoc.patch no longer needed
  278. - at-3.1.8-o_excl.patch no longer needed
  279. - bump release number
  280. - added Japanese summary and description from vinedocs.sf.jp :)
  281. - rebuild with new toolchains
  282. * Wed Jan 23 2002 Toru Sagami <sagami@vinelinux.org> 3.1.8-23vl1
  283. - follow 3.1.8-23 (RHSA-2002:015-13)
  284. - apply docpath patch instead of patch16 (due to brute-force patch2 unrevised)
  285. - Replace sendmail with /usr/sbin/sendmail (postfix) for BuildPreReq
  286. * Sat Jun 09 2001 <sagami@vinelinux.org>
  287. - 3.1.8-12vl3: rebuilt for %%{_mandir}
  288. * Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.8-12vl2
  289. - remove /etc/init.d from PreReq
  290. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.1.8-12vl1
  291. - build on Vine Linux with gcc-2.95.3
  292. * Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
  293. - Well, we will likely never really close the UTC issues,
  294. - because of 1) fractional timezones, and 2) daylight savigns time.
  295. - but there is a slight tweak to the handling of dst in the UTC patch.
  296. * Wed Aug 23 2000 Crutcher Dunnavant <crutcher@redhat.com>
  297. - fixed bug #15685
  298. - which had at miscaluclating UTC times.
  299. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  300. - move initscript back
  301. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  302. - automatic rebuild
  303. * Thu Jul 6 2000 Bill Nottingham <notting@redhat.com>
  304. - prereq /etc/init.d
  305. * Sat Jul 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  306. - fix syntax error in init script
  307. * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
  308. - don't prereq, only require initscripts
  309. * Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
  310. - move init script
  311. - add condrestart directive
  312. - fix post/preun/postun scripts
  313. - prereq initscripts >= 5.20
  314. * Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
  315. - fix verify of /var/spool/at/.SEQ (#12262)
  316. * Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
  317. - fix status checking and syntax error in init script
  318. * Fri Jun 9 2000 Bill Nottingham <notting@redhat.com>
  319. - fix for long usernames (#11321)
  320. - add some bugfixes from debian
  321. * Mon May 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  322. - 3.1.8
  323. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  324. - fix a couple of more typos, null-terminate some strings
  325. * Thu Feb 10 2000 Bill Nottingham <notting@redhat.com>
  326. - fix many-years-old typo in atd.c
  327. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  328. - handle compressed man pages
  329. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  330. - initscript munging, build as non-root user
  331. * Sun Jun 13 1999 Jeff Johnson <jbj@redhat.com>
  332. - correct perms for /var/spool/at after defattr.
  333. * Mon May 24 1999 Jeff Johnson <jbj@redhat.com>
  334. - reset SIGCHLD before exec (#3016).
  335. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  336. - auto rebuild in the new build environment (release 8)
  337. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  338. - fix handling the 12:00 time
  339. * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
  340. - configure fix for arm
  341. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  342. - build for glibc 2.1
  343. * Tue May 05 1998 Prospector System <bugs@redhat.com>
  344. - translations modified for de, fr, tr
  345. * Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
  346. - enhanced initscript
  347. * Sun Nov 09 1997 Michael K. Johnson <johnsonm@redhat.com>
  348. - learned to spell
  349. * Wed Oct 22 1997 Michael K. Johnson <johnsonm@redhat.com>
  350. - updated to at version 3.1.7
  351. - updated lock and sequence file handling with %ghost
  352. - Use chkconfig and atd, now conflicts with old crontabs packages
  353. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  354. - built against glibc