libsoup-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: Soup, an HTTP library implementation
  4. Summary(ja): Soup - HTTP ライブラリ実装
  5. Name: libsoup
  6. Version: 2.61.1
  7. Release: 1%{?_dist_release}
  8. License: LGPL
  9. Group: System Environment/Libraries
  10. Source0: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.54/%{name}-%{version}.tar.xz
  11. URL: ftp://ftp.gnome.org/pub/gnome/sources/libsoup/
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: glib2-devel >= 2.26.0
  14. BuildRequires: gnutls-devel, libxml2-devel, pkgconfig
  15. BuildRequires: libproxy-devel >= 0.2.3
  16. BuildRequires: libgnome-keyring-devel
  17. BuildRequires: sqlite3-devel
  18. BuildRequires: gobject-introspection-devel
  19. BuildRequires: vala-devel
  20. BuildRequires: vala-tools
  21. BuildRequires: python3
  22. BuildRequires: mod_ssl-apache2
  23. BuildRequires: curl
  24. BuildRequires: glib-networking
  25. Requires: glib-networking
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %description
  29. Libsoup is an HTTP library implementation in C. It was originally part
  30. of a SOAP (Simple Object Access Protocol) implementation called Soup, but
  31. the SOAP and non-SOAP parts have now been split into separate packages.
  32. libsoup uses the Glib main loop and is designed to work well with GTK
  33. applications. This enables GNOME applications to access HTTP servers
  34. on the network in a completely asynchronous fashion, very similar to
  35. the Gtk+ programming model (a synchronous operation mode is also
  36. supported for those who want it).
  37. %package devel
  38. Summary: Header files for the Soup library
  39. Summary(ja): Soup ライブラリのヘッダファイル
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: glib2-devel >= 2.26.0
  43. Requires: gnutls-devel, libxml2-devel, libgpg-error-devel
  44. %description devel
  45. Libsoup is an HTTP library implementation in C. This package allows
  46. you to develop applications that use the libsoup library.
  47. %package vala
  48. Summary: Vala bindings for %{name}
  49. Summary(ja): %{name} の Vala バインディング
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. Requires: vala
  53. %description vala
  54. Vala bindings for %{name}.
  55. # compat32
  56. %package -n compat32-%{name}
  57. Summary: Soup, an HTTP library implementation
  58. Summary(ja): Soup - HTTP ライブラリ実装
  59. Group: System Environment/Libraries
  60. %description -n compat32-%{name}
  61. Libsoup is an HTTP library implementation in C. It was originally part
  62. of a SOAP (Simple Object Access Protocol) implementation called Soup, but
  63. the SOAP and non-SOAP parts have now been split into separate packages.
  64. libsoup uses the Glib main loop and is designed to work well with GTK
  65. applications. This enables GNOME applications to access HTTP servers
  66. on the network in a completely asynchronous fashion, very similar to
  67. the Gtk+ programming model (a synchronous operation mode is also
  68. supported for those who want it).
  69. %prep
  70. %setup -q
  71. %build
  72. %configure \
  73. --disable-static \
  74. --enable-introspection=yes
  75. make %{?_smp_mflags}
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. make install DESTDIR=$RPM_BUILD_ROOT
  79. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  80. %find_lang %{name}
  81. %post -p /sbin/ldconfig
  82. %postun -p /sbin/ldconfig
  83. %post -n compat32-%{name} -p /sbin/ldconfig
  84. %postun -n compat32-%{name} -p /sbin/ldconfig
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %files -f %{name}.lang
  88. %defattr(-, root, root)
  89. %doc README COPYING NEWS AUTHORS
  90. %{_libdir}/lib*.so.*
  91. %{_libdir}/girepository-1.0
  92. %files devel
  93. %defattr(-, root, root)
  94. %{_includedir}/libsoup-2.4
  95. %{_includedir}/libsoup-gnome-2.4
  96. %{_libdir}/*.so
  97. %{_libdir}/pkgconfig/*.pc
  98. %{_datadir}/gtk-doc/html/libsoup-2.4
  99. %{_datadir}/gir-1.0
  100. %files vala
  101. %defattr(-, root, root)
  102. %{_datadir}/vala/vapi/libsoup-2.4.vapi
  103. %{_datadir}/vala/vapi/libsoup-2.4.deps
  104. %if %{build_compat32}
  105. %files -n compat32-%{name}
  106. %defattr(-, root, root)
  107. %{_libdir}/lib*.so.*
  108. %endif
  109. %changelog
  110. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.61.1-1
  111. - new upstream release.
  112. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.54.1-1
  113. - new upstream release
  114. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-2
  115. - create compat32-libsoup subpackage
  116. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.2-1
  117. - new upstream release
  118. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.52.1-1
  119. - new upstream release
  120. - add BuildRequires: vala-devel, vala-tools
  121. - create %%{name}-vala subpackage
  122. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.50.0-1
  123. - new upstream release
  124. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
  125. - new upstream release
  126. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.0-1
  127. - new upstream release
  128. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.0-1
  129. - new upstream release
  130. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.2-1
  131. - new upstream release
  132. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
  133. - new upstream release
  134. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
  135. - new upstream release
  136. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
  137. - new upstream release
  138. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.3-1
  139. - new upstream release
  140. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.2-1
  141. - new upstream release
  142. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
  143. - new upstream release
  144. * Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
  145. - new upstream release
  146. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
  147. - new upstream release
  148. * Thu Oct 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  149. - new upstream release
  150. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.0-1
  151. - new upstream release
  152. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.92-1
  153. - new upstream release
  154. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.90-1
  155. - new upstream release
  156. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.5-1
  157. - new upstream release
  158. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.35.4-1
  159. - new upstream release
  160. - add BuildRequires: glib-networking
  161. - add Requires: glib-networking
  162. - change BuildRequires: mod_ssl-apache2 instead of apache2
  163. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  164. - new upstream release
  165. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  166. - new upstream release
  167. - add BuildRequires: apache2, curl
  168. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  169. - new upstream release
  170. - add configure option (--enable-introspection=yes)
  171. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.2-2
  172. - build with rpm-4.8.1-1 for pkg-config file
  173. * Mon Jun 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  174. - new upstream release
  175. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  176. - new upstream release
  177. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  178. - new upstream release
  179. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  180. * Sat Jan 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  181. - new upstream release
  182. - added BR: gnome-keyring-devel, GConf2-devel, sqlite3-devel
  183. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  184. - new upstream release
  185. * Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  186. - new upstream release
  187. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  188. - new upstream release
  189. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  190. - new upstream release
  191. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  192. - new upstream release
  193. - add BR: libproxy-devel >= 0.2.3
  194. * Sat Mar 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.3-1
  195. - new upstream release
  196. * Sat Jan 17 2009 Toshiharu kudoh <toshi.kd2@gmail.com> 2.24.2.1-2
  197. - rebuild with gnutls-2.6.3
  198. * Fri Jan 2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2.1-1
  199. - new upstream release
  200. * Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
  201. - new upstream release
  202. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  203. - new upstream release
  204. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  205. - new upstream release
  206. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.91-1
  207. - new upstream release
  208. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1vl5
  209. - new upstream release
  210. * Thu Mar 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.0-1vl5
  211. - new upstream release
  212. * Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.104-0vl1
  213. - new upstream release
  214. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.100-0vl1
  215. - new upstream release
  216. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.99-0vl1
  217. - new upstream release
  218. (includes security fix CVE-2006-5876 <BTS:462>)
  219. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.2.96-0vl2
  220. - rebuild with gnutls-1.4.1
  221. * Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.96-0vl1
  222. - new upstream release
  223. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.93-0vl1
  224. - new upstream release
  225. * Wed Nov 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-0vl1
  226. - new upstream release
  227. * Fri Sep 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6.1-0vl1
  228. - new upstream release
  229. - added BuildRequires: gnutls-devel instead of openssl-devel
  230. * Tue Apr 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  231. - new upstream release
  232. * Sat Mar 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.28-0vl1
  233. - new upstream release
  234. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.26-0vl1
  235. - new upstream release
  236. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.23-0vl1
  237. - new upstream release
  238. * Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.22-0vl1
  239. - new upstream release
  240. * Sun May 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.20-1vl1
  241. - build for Vine Linux
  242. * Tue May 6 2003 Jeremy Katz <katzj@redhat.com> 1.99.20-1
  243. - 1.99.20
  244. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-3
  245. - include ssl proxy so that ssl urls work properly (#90165, #90166)
  246. * Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-2
  247. - forward port patch to use a union initializer to fix build on x86_64
  248. * Wed Apr 16 2003 Jeremy Katz <katzj@redhat.com> 1.99.17-1
  249. - rename package to libsoup
  250. - update to 1.99.17
  251. - don't obsolete soup for now, it's parallel installable
  252. * Sun Apr 6 2003 Jeremy Katz <katzj@redhat.com> 0.7.11-1
  253. - update to 0.7.11
  254. * Wed Apr 2 2003 Matt Wilson <msw@redhat.com> 0.7.10-5
  255. - added soup-0.7.10-64bit.patch to fix 64 bit platforms (#86347)
  256. * Sat Feb 01 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  257. - only runtime libs in normal rpm
  258. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  259. - rebuilt
  260. * Tue Jan 21 2003 Jeremy Katz <katzj@redhat.com>
  261. - update url (#82347)
  262. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.7.10-2
  263. - use pkgconfig's openssl configuration information, if it exists
  264. * Fri Dec 13 2002 Jeremy Katz <katzj@redhat.com> 0.7.10-1
  265. - update to 0.7.10
  266. * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-4
  267. - fix fpic patch
  268. - soup-devel should require soup
  269. * Thu Dec 12 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-3
  270. - better lib64 patch
  271. - fix building of libwsdl-build to use libtool so that it gets built
  272. with -fPIC as needed
  273. * Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-2
  274. - change popt handling in configure slightly so that it will work on
  275. multilib arches
  276. * Tue Dec 10 2002 Jeremy Katz <katzj@redhat.com> 0.7.9-1
  277. - update to 0.7.9, pulling the tarball out of Ximian packages
  278. * Wed Oct 23 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-3
  279. - fix to not try to include non-existent doc files and remove all
  280. unwanted files from the build
  281. - include api docs
  282. - don't build the apache module
  283. * Wed Sep 25 2002 Jeremy Katz <katzj@redhat.com> 0.7.4-2
  284. - various specfile tweaks to include in Red Hat Linux
  285. - include all the files
  286. * Tue Jan 23 2001 Alex Graveley <alex@ximian.com>
  287. - Inital RPM config.