xerces-c-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159
  1. Summary: Validating XML Parser
  2. Name: xerces-c
  3. Version: 2.8.0
  4. Release: 2%{?_dist_release}
  5. License: ASL 2.0
  6. Group: System Environment/Libraries
  7. URL: http://xml.apache.org/xerces-c/
  8. Source: http://www.apache.org/dist/xerces/c/sources/xerces-c-src_2_8_0.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. %description
  11. Xerces-C is a validating XML parser written in a portable subset of
  12. C++. Xerces-C makes it easy to give your application the ability to
  13. read and write XML data. A shared library is provided for parsing,
  14. generating, manipulating, and validating XML documents. Xerces-C is
  15. faithful to the XML 1.0 recommendation and associated standards ( DOM
  16. 1.0, DOM 2.0. SAX 1.0, SAX 2.0, Namespaces).
  17. %package devel
  18. Summary: Header files, libraries and development documentation for %{name}
  19. Group: Development/Libraries
  20. Requires: %{name} = %{version}-%{release}
  21. %description devel
  22. This package contains the header files, static libraries and development
  23. documentation for %{name}. If you like to develop programs using %{name},
  24. you will need to install %{name}-devel.
  25. %package doc
  26. Group: Documentation
  27. Summary: Documentation for Xerces-C++ validating XML parser
  28. %description doc
  29. Documentation for Xerces-C++.
  30. Xerces-C++ is a validating XML parser written in a portable subset of C++.
  31. Xerces-C++ makes it easy to give your application the ability to read and
  32. write XML data. A shared library is provided for parsing, generating,
  33. manipulating, and validating XML documents.
  34. %prep
  35. %setup -q -n xerces-c-src_2_8_0
  36. rm -rf doc/html/resources/.svn
  37. find ./doc -type f -perm 755 -exec chmod 644 {} \;
  38. find ./samples -type f -perm 755 -exec chmod 644 {} \;
  39. %{__perl} -pi.orig -e 's|(PREFIX.)/lib\b|$1/%{_lib}|g' src/xercesc/configure */Makefile.in
  40. rm doc/html/apiDocs/XMLRegisterCleanup_8hpp__incl.map
  41. rm doc/html/apiDocs/XSConstants_8hpp__incl.map
  42. # make rpmlint happy
  43. sed -i 's/\r//' doc/charter.xml
  44. iconv -f iso8859-1 -t utf-8 credits.txt > credits.utf8 && mv -f credits.{utf8,txt}
  45. iconv -f iso8859-1 -t utf-8 doc/feedback.xml > doc/feedback.utf8 && mv -f doc/feedback.{utf8,xml}
  46. iconv -f iso8859-1 -t utf-8 doc/migration.xml > doc/migration.utf8 && mv -f doc/migration.{utf8,xml}
  47. iconv -f iso8859-1 -t utf-8 doc/releases_archive.xml > doc/releases_archive.utf8 && mv -f doc/releases_archive.{utf8,xml}
  48. %build
  49. export XERCESCROOT="$PWD"
  50. # Let Makefiles be verbose
  51. find -name 'Makefile.*' | while read f; do
  52. sed -i -e 's/$Q//g' \
  53. -e 's/{MAKE} -s/(MAKE)/g' \
  54. -e '/echo \" (/d' \
  55. $f
  56. done
  57. # Remove conflicting flags from runConfigure
  58. find -name runConfigure | while read f; do
  59. sed -i -e 's/-w -O -DNDEBUG/-DNDEBUG/g' $f
  60. done
  61. cd $XERCESCROOT/src/xercesc
  62. %ifarch alpha ppc64 s390x sparc64 x86_64
  63. CXXFLAGS="${RPM_OPT_FLAGS}" CFLAGS="${RPM_OPT_FLAGS}" ./runConfigure -plinux -cgcc -xg++ -minmem -nsocket -tnative -rpthreads -b64 -P %{_prefix} -C --libdir="%{_libdir}"
  64. %else
  65. CXXFLAGS="${RPM_OPT_FLAGS}" CFLAGS="${RPM_OPT_FLAGS}" ./runConfigure -plinux -cgcc -xg++ -minmem -nsocket -tnative -rpthreads -b32 -P %{_prefix} -C --libdir="%{_libdir}"
  66. %endif
  67. # not smp safe
  68. %{__make}
  69. #cd $XERCESCROOT/samples
  70. #CXXFLAGS="${RPM_OPT_FLAGS}" CFLAGS="${RPM_OPT_FLAGS}" ./runConfigure -plinux -cgcc -xg++
  71. #%{__make}
  72. %install
  73. %{__rm} -rf $RPM_BUILD_ROOT
  74. export XERCESCROOT="$PWD"
  75. %{__make} install -C src/xercesc DESTDIR="$RPM_BUILD_ROOT"
  76. #mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
  77. #rm -rf $XERCESCROOT/samples/Projects
  78. #cp -a $XERCESCROOT/samples $RPM_BUILD_ROOT%{_datadir}/%{name}
  79. %post -p /sbin/ldconfig
  80. %postun -p /sbin/ldconfig
  81. %clean
  82. %{__rm} -rf $RPM_BUILD_ROOT
  83. %files
  84. %defattr(-,root,root,-)
  85. %doc LICENSE.txt
  86. %{_libdir}/libxerces*.so.*
  87. %files devel
  88. %defattr(-,root,root,-)
  89. %{_libdir}/libxerces*.so
  90. %{_includedir}/xercesc/
  91. %files doc
  92. %defattr(-,root,root,-)
  93. %doc Readme.html LICENSE NOTICE STATUS credits.txt doc samples
  94. #%files samples
  95. #%defattr(-,root,root,-)
  96. #%{_datadir}/%{name}/samples
  97. %changelog
  98. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.0-2
  99. - rebuilt with new toolchain
  100. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
  101. - initial build for Vine Linux
  102. * Mon Jun 30 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-2
  103. - Spec cleanups ( https://bugzilla.redhat.com/show_bug.cgi?id=435132 )
  104. * Sun Feb 10 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-1
  105. - Ver. 2.8.0
  106. * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-6
  107. - typo fix
  108. * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-5
  109. - fixed some rpmlint warnings
  110. * Fri Nov 24 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-4
  111. - Added samples to docs-package
  112. * Sat Nov 18 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-3
  113. - improvements suggested by Aurelien Bompard
  114. * Sat Oct 14 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-2
  115. - Disabled package 'samples'
  116. * Fri Oct 13 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-1
  117. - initial build for FE
  118. * Fri Jan 06 2006 Dag Wieers <dag@wieers.com> - 2.7.0-1 - 3891/dag
  119. - Cleaned SPEC file.
  120. * Tue Jan 03 2006 Dries Verachtert <dries@ulyssis.org> - 2.7.0-1
  121. - Updated to release 2.7.0.
  122. * Thu Sep 22 2005 C.Lee Taylor <leet@leenx.co.za> 2.6.1-1
  123. - Update to 2.6.1
  124. - Build for FC4 32/64bit
  125. * Sat Aug 20 2005 Che
  126. - initial rpm release