rpmdevtools-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590
  1. %bcond_with python3
  2. %global spectool_version 1.0.10
  3. %global _emacs_sitestartdir /usr/share/emacs/site-lisp
  4. Name: rpmdevtools
  5. Version: 8.10
  6. Release: 11%{?_dist_release}
  7. Summary: RPM Development Tools
  8. # rpmdev-setuptree is GPLv2, everything else GPLv2+
  9. License: GPLv2+ and GPLv2
  10. URL: https://pagure.io/rpmdevtools
  11. Source0: https://releases.pagure.org/rpmdevtools/%{name}-%{version}.tar.xz
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. # Backports from upstream
  15. Patch0001: 0001-bumpspec-checksig-Avoid-python-3.6-regex-related-dep.patch
  16. Patch0002: 0001-Limit-newVersion-s-re.sub-to-a-single-replacement.patch
  17. # Vine patch(es)
  18. Patch1000: rpmdevtools-vine.patch
  19. BuildArch: noarch
  20. # help2man, pod2man, *python for creating man pages
  21. BuildRequires: help2man
  22. BuildRequires: %{_bindir}/pod2man
  23. BuildRequires: perl
  24. %if %{with python3}
  25. BuildRequires: python3
  26. BuildRequires: rpm-python3
  27. %else
  28. BuildRequires: python >= 2.7
  29. BuildRequires: rpm-python
  30. %endif
  31. # emacs-common >= 1:22.3-3 for macros.emacs
  32. BuildRequires: emacsen-common
  33. BuildRequires: bash-completion
  34. Provides: spectool = %{spectool_version}
  35. Requires: curl
  36. Requires: diffutils
  37. Requires: fakeroot
  38. Requires: file
  39. Requires: findutils
  40. Requires: gawk
  41. Requires: grep
  42. Requires: rpm-build >= 4.4.2.3
  43. %if %{with python3}
  44. Requires: rpm-python3
  45. %else
  46. Requires: python >= 2.4
  47. Requires: rpm-python
  48. %endif
  49. Requires: sed
  50. %description
  51. This package contains scripts and (X)Emacs support files to aid in
  52. development of RPM packages.
  53. rpmdev-setuptree Create RPM build tree within user's home directory
  54. rpmdev-diff Diff contents of two archives
  55. rpmdev-newspec Creates new .spec from template
  56. rpmdev-rmdevelrpms Find (and optionally remove) "development" RPMs
  57. rpmdev-checksig Check package signatures using alternate RPM keyring
  58. rpminfo Print information about executables and libraries
  59. rpmdev-md5/sha* Display checksums of all files in an archive file
  60. rpmdev-vercmp RPM version comparison checker
  61. spectool Expand and download sources and patches in specfiles
  62. rpmdev-wipetree Erase all files within dirs created by rpmdev-setuptree
  63. rpmdev-extract Extract various archives, "tar xvf" style
  64. rpmdev-bumpspec Bump revision in specfile
  65. ...and many more.
  66. %prep
  67. %autosetup -p1
  68. %if %{with python3}
  69. grep -lF "%{_bindir}/python " * \
  70. | xargs sed -i -e "s|%{_bindir}/python |%{_bindir}/python3 |"
  71. %endif
  72. %build
  73. %configure --libdir=%{_prefix}/lib
  74. %make_build
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. %make_install
  78. echo %%{_datadir}/bash-completion > %{name}.files
  79. [ -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d ] && \
  80. echo %%{_sysconfdir}/bash_completion.d > %{name}.files
  81. %if 0%{?fedora}
  82. for dir in %{_emacs_sitestartdir} %{_xemacs_sitestartdir} ; do
  83. %else
  84. for dir in %{_emacs_sitestartdir} ; do
  85. %endif
  86. install -dm 755 $RPM_BUILD_ROOT$dir
  87. ln -s %{_datadir}/rpmdevtools/rpmdev-init.el $RPM_BUILD_ROOT$dir
  88. touch $RPM_BUILD_ROOT$dir/rpmdev-init.elc
  89. done
  90. %files -f %{name}.files
  91. %license COPYING
  92. %doc NEWS
  93. %config(noreplace) %{_sysconfdir}/rpmdevtools/
  94. %{_datadir}/rpmdevtools/
  95. %{_bindir}/*
  96. %{_emacs_sitestartdir}/rpmdev-init.el
  97. %ghost %{_emacs_sitestartdir}/rpmdev-init.elc
  98. %if 0%{?fedora}
  99. %{_xemacs_sitestartdir}/rpmdev-init.el
  100. %ghost %{_xemacs_sitestartdir}/rpmdev-init.elc
  101. %endif
  102. %{_mandir}/man[18]/*.[18]*
  103. %changelog
  104. * Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.10-11
  105. - rpmdev-bumpspec: made to set %%_dist_release to %%nil.
  106. * Mon Aug 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 8.10-10
  107. - initial build for Vine Linux.
  108. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-9
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  110. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-8
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  112. * Wed Nov 28 2018 Neal Gompa <ngompa13@gmail.com> - 8.10-7
  113. - Fix regex substitution issues with Python 3.7 (rhbz#1651954)
  114. * Sun Sep 16 2018 Neal Gompa <ngompa13@gmail.com> - 8.10-6
  115. - Fix regex related deprecation warnings (rhbz#1598089)
  116. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-5
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  118. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-4
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  120. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-3
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  122. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.10-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  124. * Sat Jan 14 2017 Ville Skyttä <ville.skytta@iki.fi> - 8.10-1
  125. - Update to 8.10
  126. * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 8.9-2
  127. - Rebuild for Python 3.6
  128. * Sat Jun 25 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.9-1
  129. - Update to 8.9
  130. * Sat Jun 25 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.8-1
  131. - Update to 8.8
  132. * Fri Jun 24 2016 Petr Písař <ppisar@redhat.com>
  133. - Add new mandatory perl build deps
  134. * Thu Jun 23 2016 Ville Skyttä <ville.skytta@iki.fi> - 8.7-1
  135. - Update to 8.7
  136. - Specfile cleanups
  137. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 8.6-3
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  139. * Fri Jun 5 2015 Ville Skyttä <ville.skytta@iki.fi> - 8.6-2
  140. - Use python3 on > F-22
  141. * Sun May 10 2015 Ville Skyttä <ville.skytta@iki.fi> - 8.6-1
  142. - Update to 8.6
  143. * Mon Oct 20 2014 Ville Skyttä <ville.skytta@iki.fi> - 8.5-1
  144. - Update to 8.5
  145. - Mark COPYING as %%license where applicable
  146. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.4-3
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  148. * Thu Oct 17 2013 Ville Skyttä <ville.skytta@iki.fi> - 8.4-2
  149. - Do not require devscripts in any scenario.
  150. * Mon Oct 7 2013 Ville Skyttä <ville.skytta@iki.fi> - 8.4-1
  151. - Update to 8.4.
  152. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.3-5
  153. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  154. * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 8.3-4
  155. - Perl 5.18 rebuild
  156. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.3-3
  157. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  158. * Tue Oct 16 2012 Thomas Woerner <twoerner@redhat.com> - 8.3-2
  159. - xemacs is not available on RHEL (RHBZ#866841)
  160. * Sun Sep 2 2012 Ville Skyttä <ville.skytta@iki.fi> - 8.3-1
  161. - Update to 8.3.
  162. - Drop specfile constructs no longer needed with Fedora's rpm.
  163. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2-3
  164. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  165. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.2-2
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  167. * Sat Nov 12 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.2-1
  168. - Update to 8.2.
  169. * Tue Apr 26 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.1-1
  170. - Update to 8.1.
  171. * Tue Mar 1 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.0-3
  172. - Require xemacs-filesystem on F-15+ (#672093).
  173. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 8.0-2
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  175. * Sun Feb 6 2011 Ville Skyttä <ville.skytta@iki.fi> - 8.0-1
  176. - Update to 8.0, fixes #519061 and #657594.
  177. * Mon Sep 27 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.10-1
  178. - Update to 7.10, fixes #595135 and #619867.
  179. - Patch spectool to work with specfiles containing Icon or BuildArchitectures
  180. (#637000).
  181. * Thu May 20 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.9-1
  182. - Update to 7.9, fixes #588313 and #589705.
  183. * Fri Apr 16 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.8-2
  184. - Require %%{_bindir}/man instead of man (#582932).
  185. * Tue Feb 16 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.8-1
  186. - Update to 7.8, fixes #562316.
  187. * Tue Feb 2 2010 Ville Skyttä <ville.skytta@iki.fi> - 7.7-1
  188. - Update to 7.7, fixes #558263.
  189. * Mon Dec 7 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.6-1
  190. - Update to 7.6, fixes #528907.
  191. * Thu Sep 17 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.5-1
  192. - Update to 7.5, fixes #502403.
  193. * Fri Aug 21 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.4-1
  194. - Update to 7.4, fixes #215927 and #466353.
  195. - Patch spectool to make -s and -p to work as documented (Todd Zullinger).
  196. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.3-2
  197. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  198. * Mon May 25 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.3-1
  199. - Release 7.3.
  200. * Sat May 23 2009 Ville Skyttä <ville.skytta@iki.fi>
  201. - Add rpmdev-packager - script for getting rpm packager info.
  202. - Use rpmdev-packager in rpmdev-bumpspec and rpmdev-init.el.
  203. - Fix rpmdev-extract MIME type comparisons with file(1) output containing
  204. parameters.
  205. * Wed May 20 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.2-1
  206. - Release 7.2.
  207. * Sun May 3 2009 Ville Skyttä <ville.skytta@iki.fi>
  208. - Add dummy spec template for ad-hoc testing.
  209. * Sat May 2 2009 Ville Skyttä <ville.skytta@iki.fi>
  210. - Improve newspec/newinit when only "-o foo" argument is given (#498588,
  211. thanks to Edwin ten Brink).
  212. - Try to get packager mail address for *Emacs rpm-spec-mode from ~/.fedora.cert
  213. if rpm-spec-user-mail-address is not set.
  214. - Add xz support to rpmdev-extract.
  215. * Sat Apr 18 2009 Ville Skyttä <ville.skytta@iki.fi>
  216. - Make bumpspec's use of "head" POSIX compliant.
  217. * Thu Apr 16 2009 Ville Skyttä <ville.skytta@iki.fi>
  218. - Add rpmdev-newinit for easier access to the init script template, move the
  219. template to %%{_sysconfdir}/rpmdevtools, improve reload action example.
  220. * Tue Apr 7 2009 Ville Skyttä <ville.skytta@iki.fi>
  221. - Speed up rpmls bash completion.
  222. * Sat Apr 4 2009 Ville Skyttä <ville.skytta@iki.fi> - 7.1-1
  223. - 7.1.
  224. - Make rpmdev-md5 and friends work on non-srpm package files too.
  225. * Sun Mar 15 2009 Ville Skyttä <ville.skytta@iki.fi>
  226. - Add bash completion.
  227. * Mon Mar 9 2009 Ville Skyttä <ville.skytta@iki.fi>
  228. - Add query format option to rmdevelrpms, sort output by NEVRA.
  229. * Sun Feb 22 2009 Ville Skyttä <ville.skytta@iki.fi>
  230. - Use %%global instead of %%define in spec templates.
  231. - Handle %%global in addition to %%define in rpmdev-bumpspec.
  232. * Mon Jan 26 2009 Ville Skyttä <ville.skytta@iki.fi>
  233. - Add result dependent exit statuses to rpmdev-vercmp.
  234. * Fri Dec 26 2008 Ville Skyttä <ville.skytta@iki.fi>
  235. - Add minimum version to rpm-python dependency (for rpmdev-bumpspec).
  236. * Fri Dec 26 2008 Ville Skyttä <ville.skytta@iki.fi> - 7.0-1
  237. - 7.0.
  238. - Drop fonts spec template, adapt to new ones from Fedora fonts SIG (#477055).
  239. - Add man page for rpmdev-newspec.
  240. * Tue Dec 16 2008 Ville Skyttä <ville.skytta@iki.fi>
  241. - Add imake and intltool to internal list of devel packages in rmdevelrpms.
  242. * Sat Dec 13 2008 Ville Skyttä <ville.skytta@iki.fi>
  243. - Add rpmdev-sha*/*sum companions to rpmdev-md5 (ticket #7).
  244. * Wed Nov 26 2008 Ville Skyttä <ville.skytta@iki.fi>
  245. - Add vamp-plugin-sdk to internal list of non-devel packages in rmdevelrpms
  246. (#472641, Michael Schwendt).
  247. * Thu Nov 20 2008 Ville Skyttä <ville.skytta@iki.fi>
  248. - Drop "minimal buildroot" dependencies.
  249. - Drop fedora-rpmdevtools Obsoletes.
  250. * Mon Oct 13 2008 Ville Skyttä <ville.skytta@iki.fi>
  251. - Show available types in rpmdev-newspec --help (ticket #6, Todd Zullinger).
  252. * Fri Sep 26 2008 Ville Skyttä <ville.skytta@iki.fi>
  253. - Add -r/--rightmost option to rpmdev-bumpspec (ticket #1, Thorsten Leemhuis).
  254. - Add %%packager from rpm config to the set of defaults for rpmdev-bumpspec's
  255. user string.
  256. * Thu Sep 25 2008 Ville Skyttä <ville.skytta@iki.fi>
  257. - Bring rpmdev-bumpspec copyright holder closer to truth (Michael Schwendt).
  258. * Mon Sep 22 2008 Ville Skyttä <ville.skytta@iki.fi>
  259. - Switch to lzma compressed tarball.
  260. * Sun Sep 7 2008 Ville Skyttä <ville.skytta@iki.fi>
  261. - Improve arch specific %%files in perl spec template (#461177, Chris Weyl).
  262. * Sun Aug 3 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.7-1
  263. - 6.7.
  264. - Make rpmdev-diff, rpmdev-md5 and rpminfo honor TMPDIR.
  265. * Sat Apr 26 2008 Ville Skyttä <ville.skytta@iki.fi>
  266. - Make rpmls work with URLs.
  267. * Sun Apr 20 2008 Ville Skyttä <ville.skytta@iki.fi>
  268. - Include rpm arch in dir names created by rpmdev-extract (#443266).
  269. * Fri Apr 18 2008 Ville Skyttä <ville.skytta@iki.fi>
  270. - Remove duplicate "reload" from case block in init script template.
  271. - Fix exit status of "reload" in case service is not running in init
  272. script template (#442993).
  273. * Thu Mar 27 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.6-1
  274. - Fix man page generation.
  275. * Wed Mar 26 2008 Ville Skyttä <ville.skytta@iki.fi> - 6.5-1
  276. - 6.5.
  277. * Sun Mar 23 2008 Ville Skyttä <ville.skytta@iki.fi>
  278. - Generate man pages at build time.
  279. * Sat Mar 22 2008 Ville Skyttä <ville.skytta@iki.fi>
  280. - Remove libgcj-devel and zlib-devel from rmdevelrpms' internal exclusion
  281. list, they're not essential on non-devel systems any more.
  282. * Mon Mar 17 2008 Ville Skyttä <ville.skytta@iki.fi>
  283. - Include ocaml spec template.
  284. * Tue Mar 11 2008 Ville Skyttä <ville.skytta@iki.fi>
  285. - Include Michael Schwendt's bumpspecfile.py (as rpmdev-bumpspec).
  286. * Tue Feb 12 2008 Ville Skyttä <ville.skytta@iki.fi>
  287. - Sync with qa-robot upstream.
  288. - Update spectool to 1.0.10.
  289. * Sun Feb 3 2008 Ville Skyttä <ville.skytta@iki.fi>
  290. - Add support for 7-zip, lzma and lzo in rpmdev-extract.
  291. * Fri Feb 1 2008 Ville Skyttä <ville.skytta@iki.fi>
  292. - Add ';;' to the init script template's reload action.
  293. * Sat Dec 8 2007 Ville Skyttä <ville.skytta@iki.fi>
  294. - Add fonts spec template from the Fedora Fonts SIG (#407781).
  295. - Add option to use macro style instead of shell style variables to newspec.
  296. - Prefer ~/.config/rpmdevtools/rmdevelrpms.conf over ~/.rmdevelrpmsrc in
  297. rmdevelrpms.
  298. * Fri Oct 12 2007 Lubomir Kundrak <lkundrak@redhat.com> - 6.4-1
  299. - Import the previous fix into CVS to resync, bump version
  300. * Fri Oct 12 2007 Lubomir Kundrak <lkundrak@redhat.com> - 6.3-1
  301. - Fix paths in qa-robot tools
  302. * Sat Sep 8 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.2-1
  303. - Sync deps with Fedora's new "assumed present in buildroots" packages list.
  304. * Thu Sep 6 2007 Ville Skyttä <ville.skytta@iki.fi>
  305. - Init script template cleanups.
  306. * Tue Aug 28 2007 Ville Skyttä <ville.skytta@iki.fi>
  307. - Update rpminfo to version 2004-07-07-02.
  308. * Fri Aug 10 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.1-1
  309. - Sync COPYING with http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
  310. * Mon Aug 6 2007 Ville Skyttä <ville.skytta@iki.fi>
  311. - Work around #250990 in rpmls and rpmdev-extract.
  312. - Clarify copyright info of rpmdev-* and rpmls.
  313. * Sat Jul 7 2007 Ville Skyttä <ville.skytta@iki.fi>
  314. - Fix Epoch handling in the 2-arg form of rpmdev-vercmp with yum < 3.1.2.
  315. - The long form of the list option in rmdevelrpms is --list-only, not --list.
  316. * Thu Jul 5 2007 Ville Skyttä <ville.skytta@iki.fi> - 6.0-1
  317. - Remove check-{buildroot,rpaths*}, now included in rpm-build >= 4.4.2.1.
  318. - Drop explicit dependency on patch, pulled in by recent rpm-build.
  319. - Add cmake and scons to default devel package list in rpmdev-rmdevelrpms.
  320. - Add LSB comment block to init script template.
  321. * Wed Jun 27 2007 Ville Skyttä <ville.skytta@iki.fi>
  322. - Add 2-argument form for comparing EVR strings to rpmdev-vercmp
  323. (available only if rpmUtils.miscutils is available).
  324. * Sat Jun 16 2007 Ville Skyttä <ville.skytta@iki.fi>
  325. - Include rpmsodiff and dependencies (rpmargs, rpmelfsym, rpmfile, rpmpeek,
  326. rpmsoname) from ALT Linux's qa-robot package.
  327. - Include rpmls (#213778).
  328. * Fri Jun 15 2007 Ville Skyttä <ville.skytta@iki.fi>
  329. - Update spectool to 1.0.9 (#243731).
  330. * Wed Apr 11 2007 Ville Skyttä <ville.skytta@iki.fi>
  331. - Add --list-only option to rmdevelrpms (Thorsten Leemhuis).
  332. * Tue Mar 13 2007 Ville Skyttä <ville.skytta@iki.fi>
  333. - BR perl(ExtUtils::MakeMaker) by default in perl spec template.
  334. - Drop deprecated backwards compatibility with fedora-rpmdevtools.
  335. - Update URL.
  336. * Wed Nov 8 2006 Ville Skyttä <ville.skytta@iki.fi>
  337. - Arch-qualify output of matched packages in rmdevelrpms and allow
  338. arch-qualified packages in the config file.
  339. * Wed Oct 25 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.3-1
  340. - Update spectool to 1.0.8, fixes #212108.
  341. * Mon Oct 2 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.2-1
  342. - Skip *.jar.so.debug in check-buildroot (#208903).
  343. - Treat yasm and *-static as devel packages in rmdevelrpms.
  344. * Sat Sep 9 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.1-1
  345. - Re-add PHP PEAR spec template, more improvements to it (#198706,
  346. Christopher Stone, Remi Collet).
  347. * Tue Aug 22 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.0-2
  348. - Migrate rmdevelrpms config when upgrading from fedora-rpmdevtools.
  349. * Sun Aug 20 2006 Ville Skyttä <ville.skytta@iki.fi> - 5.0-1
  350. - Re-rename almost everything to rpmdev-*, with backwards compat symlinks.
  351. - Don't encourage %%ghost'ing *.pyo in Python spec template, add some comments.
  352. - Drop PHP PEAR spec template, it's not ready yet.
  353. * Wed Aug 2 2006 Ville Skyttä <ville.skytta@iki.fi>
  354. - Treat *-sdk as devel packages in rmdevelrpms (#199909).
  355. - Don't assume compface is a devel package in rmdevelrpms.
  356. * Thu Jul 20 2006 Ville Skyttä <ville.skytta@iki.fi>
  357. - Mark things that are not needed for noarch module packages in the Perl
  358. spec template.
  359. * Wed Jul 19 2006 Ville Skyttä <ville.skytta@iki.fi>
  360. - Move option arguments to "find" before non-option ones in Perl spec template.
  361. - Drop python-abi dependency from Python spec template (#189947).
  362. * Tue Jul 18 2006 Ville Skyttä <ville.skytta@iki.fi>
  363. - Add PHP PEAR spec template (#198706, Christopher Stone).
  364. * Mon Jul 17 2006 Ville Skyttä <ville.skytta@iki.fi>
  365. - Drop fedora- prefix everywhere, add backcompat symlinks for execubtables.
  366. - Move %%{_sysconfdir}/fedora to %%{_sysconfdir}/rpmdevtools and
  367. %%{_datadir}/fedora to %%{_datadir}/rpmdevtools.
  368. - Move spec templates to %%{_sysconfdir}/rpmdevtools, mark as config.
  369. - Bump version to 5.0.
  370. * Sun Jul 16 2006 Ville Skyttä <ville.skytta@iki.fi>
  371. - Drop fedora-kmodhelper.
  372. - Drop fedora-installdevkeys and GPG keys, modify rpmchecksig to use
  373. the system rpmdb.
  374. * Sat Jul 15 2006 Ville Skyttä <ville.skytta@iki.fi>
  375. - Sort rmdevelrpms' output.
  376. * Fri Jul 7 2006 Ville Skyttä <ville.skytta@iki.fi>
  377. - Improve ruby spec template (#180066, David Lutterkort).
  378. * Mon Jun 5 2006 Ville Skyttä <ville.skytta@iki.fi>
  379. - Add manual pages for rmdevelrpms, diffarchive and extract.
  380. - Trim pre-2005 changelog entries.
  381. - Autotoolize source tree.
  382. * Tue May 16 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.6-1
  383. - Add spec template for library packages (#185606, Ignacio Vazquez-Abrams).
  384. * Sun Feb 26 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.5-1
  385. - Improve diffarchive and extract error messages.
  386. * Fri Feb 24 2006 Ville Skyttä <ville.skytta@iki.fi>
  387. - Update spectool to 1.0.7 (#162253).
  388. * Thu Feb 9 2006 Ville Skyttä <ville.skytta@iki.fi>
  389. - Add file(1) based archive type detection to fedora-extract.
  390. * Wed Feb 8 2006 Ville Skyttä <ville.skytta@iki.fi>
  391. - Add "diff file lists only" option to diffarchive.
  392. * Sun Feb 5 2006 Ville Skyttä <ville.skytta@iki.fi>
  393. - Add Ruby spec template (#180066, Oliver Andrich) and make newrpmspec
  394. use it for ruby-*.
  395. * Sat Feb 4 2006 Ville Skyttä <ville.skytta@iki.fi> - 1.4-2
  396. - Fix rpath checker tests with bash 3.1 (#178636, Enrico Scholz).
  397. * Fri Dec 30 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.4-1
  398. - Update spectool to 1.0.6 (#176521).
  399. * Wed Dec 28 2005 Ville Skyttä <ville.skytta@iki.fi>
  400. - Update spectool to 1.0.5 (#162253), require wget for it.
  401. - Add disttags to spec templates.
  402. * Thu Oct 27 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.3-1
  403. - check-rpaths-worker: detect when RPATH references the parent directory
  404. of an absolute path (#169298, Enrico Scholz).
  405. - Add regression test for check-rpaths* (#169298, Enrico Scholz).
  406. - Honor user's indent-tabs-mode setting in fedora-init.el (#170902).
  407. * Fri Oct 7 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.2-1
  408. - check-buildroot: grep for buildroot as a fixed string, not a regexp.
  409. - Update FSF's address in copyright notices.
  410. - check-rpaths-worker: allow multiple $ORIGIN paths in an RPATH and allow
  411. RPATHs which are relative to $ORIGIN (#169298, Enrico Scholz).
  412. - check-rpaths-worker: give out an hint about usage and the detected issues
  413. at the first detected error (Enrico Scholz).
  414. - Remove some redundancy from the Perl spec template.
  415. - Teach fedora-newrpmspec to detect and use different specfile variants.
  416. - Use fedora-newrpmspec in fedora-init.el.
  417. * Fri Jul 8 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.1-1
  418. - Drop more pre-FC2 compat stuff from Perl spec template.
  419. - Treat gcc-gfortran as a devel package in rmdevelrpms.
  420. - Drop fedora.us GPG key.
  421. * Thu Mar 24 2005 Ville Skyttä <ville.skytta@iki.fi> - 1.0-1
  422. - Make fedora-diffarchive work better with archives containing dirs without
  423. read/execute permissions.
  424. - Sync "Epoch: 0" drops with Fedora Extras CVS.
  425. - Include Nils Philippsen's spectool.
  426. - Own (%%ghost'd) more dirs from the site-lisp dir hierarchies.
  427. - Drop trigger support pre-FC2 Emacs and XEmacs packages.
  428. - Drop rpm-spec-mode.el patch, no longer needed for FC2 Emacs and later.
  429. - Update URLs.
  430. - Drop developer GPG keys from the package, add Fedora Extras key.
  431. - Drop fedora-pkgannfmt, it's no longer relevant.
  432. - Remove pre-FC2 compatibility stuff from Perl spec template.
  433. - Don't try to remove gcc-java and related packages by default in rmdevelrpms.
  434. - Remove "full featured" spec template, convert newrpmspec to use -minimal.
  435. * Sun Feb 6 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.3.1-1
  436. - Make buildrpmtree and wipebuildtree less dependent on a specific
  437. configuration (#147014, Ignacio Vazquez-Abrams).
  438. * Tue Jan 18 2005 Ville Skyttä <ville.skytta@iki.fi> - 0:0.3.0-1
  439. - Remove 0.fdr. prefixes and epoch 0's from all spec templates.
  440. - Add try-restart action to init script template.
  441. - Remove deprecated fedora-diffrpm and fedora-unrpm.
  442. - Install check-* to %%{_prefix}/lib/rpm instead of %%{_libdir}/rpm (bug 2351).
  443. - Check both %%{_prefix}/lib and %%{_prefix}/lib64 in the xemacs trigger.
  444. - Update rpminfo to 2004-07-07-01 and include it in the tarball.