nginx-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %bcond_without geoip
  5. %if "%{_dist_release}" > "vl6"
  6. %define nginx_user www-data
  7. %else
  8. %define nginx_user nginx
  9. %endif
  10. %define nginx_group %{nginx_user}
  11. %define nginx_home %{_localstatedir}/lib/nginx
  12. %define nginx_home_tmp %{nginx_home}/tmp
  13. %define nginx_home_cache %{nginx_home}/cache
  14. %define nginx_logdir %{_localstatedir}/log/nginx
  15. %define nginx_confdir %{_sysconfdir}/nginx
  16. %define nginx_datadir %{_datadir}/nginx
  17. %define nginx_webroot %{nginx_datadir}/html
  18. Summary: Robust, small and high performance http and reverse proxy server
  19. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  20. Name: nginx
  21. Version: 1.2.4
  22. Release: 2%{?_dist_release}
  23. Group: System Environment/Daemons
  24. # BSD License (two clause)
  25. # http://www.freebsd.org/copyright/freebsd-license.html
  26. License: BSD
  27. URL: http://nginx.net/
  28. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  29. Source1: %{name}.init
  30. Source2: %{name}.logrotate
  31. Source3: nginx-virtual.conf.template
  32. Source4: nginx-ssl.conf
  33. Source5: %{name}.sysconfig
  34. Source10: nginx-vine.conf
  35. Source11: nginx-default-vine
  36. Source20: proxy_cache.conf
  37. Source100: nginx-index.html
  38. Source101: poweredby-vine.png
  39. Source102: nginx-logo.png
  40. Source103: nginx-50x.html
  41. Source104: nginx-404.html
  42. %define ngx_fancyindex_version 0.3
  43. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  44. %define nginx_accept_language_module_version 02262ce
  45. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  46. %define passenger_version 3.0.12
  47. Source1020: passenger-%{passenger_version}.tar.gz
  48. %define upstream_fair_version 2131c73
  49. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  50. %define mod_wsgi_version 6975f0ec7eeb
  51. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  52. # removes -Werror in upstream build scripts. -Werror conflicts with
  53. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  54. Patch0: nginx-auto-cc-gcc.patch
  55. # configuration patch to match all the Vine Linux paths for logs, pid files
  56. # etc.
  57. Patch1: nginx-conf.patch
  58. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  59. BuildRequires: pcre-devel
  60. BuildRequires: zlib-devel
  61. BuildRequires: openssl-devel
  62. BuildRequires: gd-devel
  63. BuildRequires: perl
  64. BuildRequires: perl(ExtUtils::Embed)
  65. BuildRequires: libxml2-devel
  66. BuildRequires: libxslt-devel
  67. BuildRequires: curl-devel
  68. %if %{with geoip}
  69. BuildRequires: GeoIP-devel
  70. %endif
  71. %if "%{?_dist_release}" == "vl4"
  72. Requires: perl >= 5.8.6
  73. %else
  74. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  75. %endif
  76. # for /usr/sbin/useradd
  77. Requires(pre): shadow-utils
  78. Requires(post): chkconfig
  79. # for /sbin/service
  80. Requires(preun): chkconfig, initscripts
  81. Requires(postun): initscripts
  82. %if "%{_dist_release}" > "vl6"
  83. Requires(pre): www-common
  84. %endif
  85. Provides: webserver
  86. Vendor: Project Vine
  87. Distribution: Vine Linux
  88. Packager: daisuke
  89. %description
  90. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  91. proxy server written by Igor Sysoev.
  92. %description -l ja
  93. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  94. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  95. - HTTP(S) サーバ
  96. - HTTP(S) リバースプロキシサーバ
  97. - IMAP/POP3 プロキシサーバ
  98. %package passenger
  99. Summary: Nginx with mod_passenger support
  100. Summary(ja): Passenger サポート入りの Nginx
  101. Group: System Environment/Daemons
  102. BuildRequires: ruby, rubygems, rubygem-rake
  103. Requires: nginx
  104. %description passenger
  105. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  106. This package contains nginx server with passenger support.
  107. %description -l ja passenger
  108. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  109. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  110. - HTTP(S) サーバ
  111. - HTTP(S) リバースプロキシサーバ
  112. - IMAP/POP3 プロキシサーバ
  113. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  114. %prep
  115. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  116. %patch0 -p0
  117. %patch1 -p1
  118. %build
  119. # nginx does not utilize a standard configure script. It has its own
  120. # and the standard configure options cause the nginx configure script
  121. # to error out. This is is also the reason for the DESTDIR environment
  122. # variable. The configure script(s) have been patched (Patch1 and
  123. # Patch2) in order to support installing into a build environment.
  124. export DESTDIR=%{buildroot}
  125. ## build with passenger
  126. ./configure \
  127. --user=%{nginx_user} \
  128. --group=%{nginx_group} \
  129. --prefix=%{nginx_datadir} \
  130. --sbin-path=%{_sbindir}/%{name} \
  131. --conf-path=%{nginx_confdir}/%{name}.conf \
  132. --error-log-path=%{nginx_logdir}/error.log \
  133. --http-log-path=%{nginx_logdir}/access.log \
  134. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  135. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  136. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  137. --pid-path=%{_localstatedir}/run/%{name}.pid \
  138. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  139. --with-file-aio \
  140. --with-ipv6 \
  141. --with-http_ssl_module \
  142. --with-http_realip_module \
  143. --with-http_addition_module \
  144. --with-http_xslt_module \
  145. --with-http_image_filter_module \
  146. --with-http_sub_module \
  147. --with-http_dav_module \
  148. --with-http_flv_module \
  149. --with-http_gzip_static_module \
  150. --with-http_random_index_module \
  151. --with-http_secure_link_module \
  152. --with-http_stub_status_module \
  153. --with-http_perl_module \
  154. %if %{with geoip}
  155. --with-http_geoip_module \
  156. %endif
  157. --with-mail \
  158. --with-mail_ssl_module \
  159. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  160. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  161. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  162. %if %{with wsgi}
  163. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  164. %endif
  165. --add-module=passenger-%{passenger_version}/ext/nginx \
  166. %ifarch i686
  167. --with-cpu-opt=pentiumpro \
  168. --with-zlib-asm=pentiumpro \
  169. --with-md5-asm \
  170. --with-sha1-asm \
  171. %endif
  172. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  173. make %{?_smp_mflags}
  174. mv objs/nginx objs/nginx.passenger
  175. ## build without passenger
  176. ./configure \
  177. --user=%{nginx_user} \
  178. --group=%{nginx_group} \
  179. --prefix=%{nginx_datadir} \
  180. --sbin-path=%{_sbindir}/%{name} \
  181. --conf-path=%{nginx_confdir}/%{name}.conf \
  182. --error-log-path=%{nginx_logdir}/error.log \
  183. --http-log-path=%{nginx_logdir}/access.log \
  184. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  185. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  186. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  187. --pid-path=%{_localstatedir}/run/%{name}.pid \
  188. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  189. --with-file-aio \
  190. --with-ipv6 \
  191. --with-http_ssl_module \
  192. --with-http_realip_module \
  193. --with-http_addition_module \
  194. --with-http_xslt_module \
  195. --with-http_image_filter_module \
  196. --with-http_sub_module \
  197. --with-http_dav_module \
  198. --with-http_flv_module \
  199. --with-http_gzip_static_module \
  200. --with-http_random_index_module \
  201. --with-http_secure_link_module \
  202. --with-http_stub_status_module \
  203. --with-http_perl_module \
  204. %if %{with geoip}
  205. --with-http_geoip_module \
  206. %endif
  207. --with-mail \
  208. --with-mail_ssl_module \
  209. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  210. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  211. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  212. %if %{with wsgi}
  213. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  214. %endif
  215. %ifarch i686
  216. --with-cpu-opt=pentiumpro \
  217. --with-zlib-asm=pentiumpro \
  218. --with-md5-asm \
  219. --with-sha1-asm \
  220. %endif
  221. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  222. make %{?_smp_mflags}
  223. %install
  224. rm -rf %{buildroot}
  225. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  226. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  227. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  228. find %{buildroot} -type f -empty -exec rm -f {} \;
  229. find %{buildroot} -type f -exec chmod 0644 {} \;
  230. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  231. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  232. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  233. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  234. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  235. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  236. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  237. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  238. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  239. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  240. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  241. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  242. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  243. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  244. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  245. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  246. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  247. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  248. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  249. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  250. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  251. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  252. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  253. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  254. %if %{with wsgi}
  255. %{__install} -p -m 0644 \
  256. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  257. %{buildroot}%{nginx_confdir}
  258. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  259. %endif
  260. # upstream fair module document
  261. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  262. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  263. # convert to UTF-8 all files that give warnings.
  264. for textfile in CHANGES
  265. do
  266. mv $textfile $textfile.old
  267. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  268. rm -f $textfile.old
  269. done
  270. %clean
  271. rm -rf %{buildroot}
  272. %post
  273. if [ $1 == 1 ]; then
  274. /sbin/chkconfig --add %{name}
  275. fi
  276. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  277. %post passenger
  278. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  279. %preun
  280. if [ $1 = 0 ]; then
  281. /sbin/service %{name} stop >/dev/null 2>&1
  282. /sbin/chkconfig --del %{name}
  283. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  284. fi
  285. %preun passenger
  286. if [ $1 = 0 ]; then
  287. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  288. fi
  289. %postun
  290. if [ $1 == 2 ]; then
  291. /sbin/service %{name} upgrade || :
  292. fi
  293. %files
  294. %defattr(-,root,root,-)
  295. %doc LICENSE CHANGES README
  296. %doc README.upstream_fair
  297. %doc %{?with_wsgi:README.mod_wsgi}
  298. %{nginx_datadir}/
  299. %{_sbindir}/%{name}.normal
  300. %{_mandir}/man3/%{name}.3pm.gz
  301. %{_initrddir}/%{name}
  302. %dir %{nginx_confdir}
  303. %dir %{nginx_confdir}/conf.d
  304. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  305. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  306. %config(noreplace) %{nginx_confdir}/sites.d/*
  307. %config(noreplace) %{nginx_confdir}/win-utf
  308. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  309. %config(noreplace) %{nginx_confdir}/mime.types.default
  310. %config(noreplace) %{nginx_confdir}/fastcgi_params
  311. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  312. %config(noreplace) %{nginx_confdir}/koi-win
  313. %config(noreplace) %{nginx_confdir}/koi-utf
  314. %config(noreplace) %{nginx_confdir}/%{name}.conf
  315. %config(noreplace) %{nginx_confdir}/mime.types
  316. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  317. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  318. %config(noreplace) %{nginx_confdir}/scgi_params
  319. %config(noreplace) %{nginx_confdir}/scgi_params.default
  320. %config(noreplace) %{nginx_confdir}/uwsgi_params
  321. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  322. %if %{with wsgi}
  323. %config(noreplace) %{nginx_confdir}/wsgi_vars
  324. %endif
  325. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  326. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  327. %dir %{perl_vendorarch}/auto/%{name}
  328. %{perl_vendorarch}/%{name}.pm
  329. %{perl_vendorarch}/auto/%{name}/%{name}.so
  330. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  331. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  332. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  333. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  334. %files passenger
  335. %defattr(-,root,root,-)
  336. %doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
  337. %doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
  338. %doc passenger-%{passenger_version}/doc/Architectural\ overview.*
  339. %doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
  340. %doc passenger-%{passenger_version}/doc/template
  341. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  342. %doc passenger-%{passenger_version}/doc/images
  343. %{_sbindir}/%{name}.passenger
  344. %changelog
  345. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  346. - added http_geoip_module.
  347. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  348. - update to 1.2.4
  349. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  350. - update to 1.2.2
  351. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  352. - update to 1.2.1
  353. - change nginx user from nginx to www-data
  354. - R(pre): www-common
  355. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  356. - update to 1.2.0
  357. - update passenger to 3.0.12
  358. - drop http_upstream_keepalive
  359. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  360. - new upstream release
  361. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  362. - update to 1.0.12
  363. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  364. - update to 1.0.11
  365. - update passenger to 3.0.11
  366. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  367. - update to 1.0.10
  368. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  369. - update passenger to 3.0.9
  370. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  371. - update to 1.0.6
  372. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  373. - update to 1.0.4
  374. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  375. - add gnosek-nginx-upstream-fair module
  376. - add ngx_http_upstream_keepalive module
  377. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  378. - add nginx-passenger sub pakckage
  379. - use alternatives to choose nginx with or without passenger
  380. - add BR: ruby, rubygems, rubygem-rake
  381. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  382. - update to 1.0.2
  383. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  384. - update to 1.0.1
  385. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  386. - add bcond_with wsgi for mod_wsgi
  387. - add bcond_with passenger
  388. - you need to install rake.gem to build with this option.
  389. - add Provides: webserver
  390. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  391. - new upstream release 1.0.0!
  392. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  393. - rebuild with perl-5.12.3
  394. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  395. - update to 0.8.54
  396. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  397. - update to 0.8.53
  398. - add nginx_accept_language_module
  399. * Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  400. - update to 0.8.50
  401. - update ngx-fancyindex to 0.3
  402. - add BR: libxml2-devel, libxslt-devel
  403. - add scgi_params* and uwsgi_params* to %%files
  404. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  405. - update to 0.8.35 (development version)
  406. - add sites.d/ to store vitualhost settings
  407. - split out default server settings to sites.d/default
  408. - add fancyindex module
  409. * Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  410. - new upstream release
  411. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  412. - update to 0.7.62 (included security fix: VU#180065)
  413. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  414. - fix typo
  415. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  416. - add translated descriptions
  417. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  418. - update 404.html/50x.html to use powered by vine logo.
  419. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  420. - initial build for Vine Linux
  421. - update to 0.7.61
  422. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  423. - init script updates from Gena Makhomed
  424. - remove nginx-upstream-fair
  425. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  426. - update to 0.6.36
  427. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  428. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  429. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  430. - rebuild
  431. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  432. - update to 0.6.35
  433. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  434. - rebuild with new openssl
  435. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  436. - update to 0.6.34
  437. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  438. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  439. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  440. - update to 0.6.33
  441. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  442. - update to 0.6.32
  443. - nginx now supports DESTDIR so removed the patches that enabled it
  444. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  445. - init script fixes
  446. - resolve 'listen 80 default' [#447873]
  447. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  448. - update to 0.6.31
  449. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  450. - upate to new upstream stable branch 0.6
  451. - added 3rd party module nginx-upstream-fair
  452. - added default webpages
  453. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  454. - update init script to match recommended guidelines
  455. - add /etc/nginx/conf.d support [#443280]
  456. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  457. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  458. - add Requires for versioned perl (libperl.so)
  459. - drop silly file Requires
  460. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  461. - Autorebuild for GCC 4.3
  462. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  463. - update to 0.5.35
  464. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  465. - update to 0.5.34
  466. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  467. - Rebuild for deps
  468. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  469. - update to 0.5.33
  470. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  471. - updated to 0.5.32
  472. - fixed rpmlint UTF-8 complaints.
  473. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  474. - added --with-http_stub_status_module build option.
  475. - added --with-http_sub_module build option.
  476. - added use of pcre-config --cflags
  477. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  478. - Update to 0.5.31
  479. - specify license is BSD
  480. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  481. - Add BuildRequires: perl-devel - fixing rawhide build
  482. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  483. - Update to 0.5.30
  484. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  485. - Update to 0.5.29
  486. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  487. - Update to 0.5.28
  488. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  489. - Update to 0.5.27
  490. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  491. - Update to 0.5.26
  492. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  493. - Update to 0.5.19
  494. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  495. - Update to 0.5.17
  496. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  497. - Update to 0.5.16
  498. - add ownership of /usr/share/nginx/html (#233950)
  499. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  500. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  501. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  502. - fixed package review bugs (#233522) given by kevin@tummy.com
  503. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  504. - create patches to assist with building for Fedora
  505. - initial packaging for Fedora