unbound-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %global with_munin 0
  4. %{?!enable_gost: %global enable_gost 1}
  5. # not ready yet
  6. %{?!with_python: %global with_python 0}
  7. %define _sharedstatedir /var/lib
  8. Summary: Validating, recursive, and caching DNS(SEC) resolver
  9. Name: unbound
  10. Version: 1.16.0
  11. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  12. Group: servers
  13. Distribution: Vine Linux
  14. Vendor: Project Vine
  15. Packager: iwaim, daisuke
  16. License: BSD
  17. Url: http://www.unbound.net/
  18. Source: https://nlnetlabs.nl/downloads/unbound/%{name}-%{version}.tar.gz
  19. Source1: unbound.init
  20. Source3: unbound.munin
  21. Source4: dlv.isc.org.key
  22. Source5: root.key
  23. Source6: root.anchor
  24. Source7: icannbundle.pem
  25. Source8: unbound.cron
  26. Source9: example.com.key
  27. Source10: example.com.conf
  28. Source11: block-example.com.conf
  29. Source100: unbound.service
  30. Source101: unbound-keygen.service
  31. Source102: unbound-anchor.service
  32. Source103: unbound-anchor.timer
  33. Source104: tmpfiles-unbound.conf
  34. Source105: unbound.sysconfig
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  36. BuildRequires: flex
  37. BuildRequires: libevent-devel
  38. BuildRequires: expat-devel
  39. %if %{with_python}
  40. BuildRequires: python3-devel python3-rpm-macros swig
  41. %endif
  42. %if %{enable_gost}
  43. BuildRequires: openssl-devel >= 1.0.0
  44. %else
  45. BuildRequires: openssl-devel
  46. %endif
  47. BuildRequires: libnghttp2-devel
  48. # Required for SVN versions
  49. #BuildRequires: bison
  50. %if %{with systemd}
  51. %global piddir /run/%{name}
  52. BuildRequires: systemd
  53. %{?systemd_requires}
  54. %else
  55. %global piddir %{_localstatedir}/run/%{name}
  56. Requires(post): chkconfig
  57. Requires(preun): chkconfig
  58. Requires(preun): initscripts
  59. Requires(postun): initscripts
  60. %endif
  61. Requires(pre): shadow-utils
  62. %description
  63. Unbound is a validating, recursive, and caching DNS(SEC) resolver.
  64. The C implementation of Unbound is developed and maintained by NLnet
  65. Labs. It is based on ideas and algorithms taken from a java prototype
  66. developed by Verisign labs, Nominet, Kirei and ep.net.
  67. Unbound is designed as a set of modular components, so that also
  68. DNSSEC (secure DNS) validation and stub-resolvers (that do not run
  69. as a server, but are linked into an application) are easily possible.
  70. %if %{with_munin}
  71. %package munin
  72. Summary: Plugin for the munin / munin-node monitoring package
  73. Summary(ja): munin/munin-node モニタリングパッケージ用のプラグイン
  74. Group: servers
  75. Requires: munin-node
  76. Requires: %{name} = %{version}-%{release}, bc
  77. %description munin
  78. Plugin for the munin / munin-node monitoring package
  79. %endif
  80. %package devel
  81. Summary: Development package that includes the unbound header files
  82. Group: programming
  83. Requires: %{name}-libs = %{version}-%{release}, openssl-devel
  84. %description devel
  85. The devel package contains the unbound library and the include files
  86. %package libs
  87. Summary: Libraries used by the unbound server and client applications
  88. Group: system
  89. Requires(post): /sbin/ldconfig
  90. Requires(postun): /sbin/ldconfig
  91. Requires: openssl >= 0.9.8g-12
  92. %description libs
  93. Contains libraries used by the unbound server and client applications
  94. %if %{with_python}
  95. %package python
  96. Summary: Python modules and extensions for unbound
  97. Group: programming
  98. Requires: %{name}-libs = %{version}-%{release}
  99. %description python
  100. Python modules and extensions for unbound
  101. %endif
  102. %package -n compat32-%{name}-libs
  103. Summary: Libraries used by the unbound server and client applications
  104. Group: system,legacy
  105. Requires: %{name}-libs = %{version}-%{release}
  106. Requires(post): /sbin/ldconfig
  107. Requires(postun): /sbin/ldconfig
  108. Requires: openssl >= 0.9.8g-12
  109. %description -n compat32-%{name}-libs
  110. Contains libraries used by the unbound server and client applications
  111. %debug_package
  112. %prep
  113. %setup -q
  114. %build
  115. %configure --with-libevent --with-pthreads --with-ssl \
  116. --disable-rpath --enable-debug --disable-static \
  117. --enable-relro-now --enable-pie \
  118. --enable-subnet --enable-ipsecmod \
  119. --with-conf-file=%{_sysconfdir}/%{name}/unbound.conf \
  120. --with-pidfile=%{piddir}/%{name}.pid \
  121. %if %{with_python}
  122. --with-pythonmodule --with-pyunbound \
  123. %endif
  124. %if !%{enable_gost}
  125. --disable-gost \
  126. %endif
  127. --enable-sha2 \
  128. --disable-sha1 \
  129. --with-libnghttp2 \
  130. --with-rootkey-file=%{_sharedstatedir}/unbound/root.key
  131. %{__make} %{?_smp_mflags}
  132. %install
  133. rm -rf %{buildroot}
  134. %{__make} DESTDIR=%{buildroot} install
  135. install -d 0755 %{buildroot}%{_initrddir}
  136. %if %{with systemd}
  137. install -d -m 0755 %{buildroot}%{_unitdir} %{buildroot}%{_sysconfdir}/sysconfig
  138. install -p -m 0644 %{SOURCE100} %{buildroot}%{_unitdir}/unbound.service
  139. install -p -m 0644 %{SOURCE101} %{buildroot}%{_unitdir}/unbound-keygen.service
  140. install -p -m 0644 %{SOURCE103} %{buildroot}%{_unitdir}/unbound-anchor.timer
  141. install -p -m 0644 %{SOURCE102} %{buildroot}%{_unitdir}/unbound-anchor.service
  142. install -p -m 0644 %{SOURCE105} %{buildroot}%{_sysconfdir}/sysconfig/unbound
  143. # Install tmpfiles.d config
  144. install -d -m 0755 %{buildroot}%{_tmpfilesdir} %{buildroot}%{_sharedstatedir}/unbound
  145. install -m 0644 %{SOURCE104} %{buildroot}%{_tmpfilesdir}/unbound.conf
  146. %else
  147. install -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/unbound
  148. install -d 0755 %{buildroot}%{_sysconfdir}/cron.d
  149. install -p -m 0644 %{SOURCE8} %{buildroot}%{_sysconfdir}/cron.d/unbound-anchor
  150. %endif
  151. install -m 0644 %{SOURCE7} %{buildroot}%{_sysconfdir}/unbound
  152. echo "include: %{_sysconfdir}/unbound/conf.d/*.conf" >> %{buildroot}%{_sysconfdir}/unbound/unbound.conf
  153. %if %{with_munin}
  154. # Install munin plugin and its softlinks
  155. install -d 0755 %{buildroot}%{_sysconfdir}/munin/plugin-conf.d
  156. install -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/munin/plugin-conf.d/unbound
  157. install -d 0755 %{buildroot}%{_datadir}/munin/plugins/
  158. install -m 0755 contrib/unbound_munin_ %{buildroot}%{_datadir}/munin/plugins/unbound
  159. for plugin in unbound_munin_hits unbound_munin_queue \
  160. unbound_munin_memory unbound_munin_by_type \
  161. unbound_munin_by_class unbound_munin_by_opcode \
  162. unbound_munin_by_rcode unbound_munin_by_flags \
  163. unbound_munin_histogram; do
  164. ln -s unbound %{buildroot}%{_datadir}/munin/plugins/$plugin
  165. done
  166. %endif
  167. # install root and DLV key
  168. install -m 0644 %{SOURCE4} %{SOURCE5} %{buildroot}%{_sysconfdir}/unbound/
  169. install -d -m 0755 %{buildroot}%{_sharedstatedir}/unbound
  170. install -m 0644 %{SOURCE6} %{buildroot}%{_sharedstatedir}/unbound/root.key
  171. # remove static library from install (fedora packaging guidelines)
  172. rm -rf %{buildroot}%{_libdir}/*.la
  173. %if %{with_python}
  174. rm -rf %{buildroot}%{python_sitelib}/*/*.la
  175. %endif
  176. mkdir -p %{buildroot}%{_localstatedir}/run/unbound
  177. # Install directories for easier config file drop in
  178. install -d -m 0755 %{buildroot}%{_sysconfdir}/unbound/{keys.d,local.d,conf.d}
  179. install -p %{SOURCE9} %{buildroot}%{_sysconfdir}/unbound/keys.d/
  180. install -p %{SOURCE10} %{buildroot}%{_sysconfdir}/unbound/conf.d/
  181. install -p %{SOURCE11} %{buildroot}%{_sysconfdir}/unbound/local.d/
  182. %clean
  183. rm -rf ${RPM_BUILD_ROOT}
  184. %files
  185. %defattr(-,root,root,-)
  186. %license doc/LICENSE
  187. %doc doc/README doc/CREDITS doc/FEATURES
  188. %if %{with systemd}
  189. %attr(0644,root,root) %{_tmpfilesdir}/unbound.conf
  190. %{_unitdir}/%{name}.service
  191. %{_unitdir}/%{name}-keygen.service
  192. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  193. %else
  194. %attr(0755,root,root) %{_initrddir}/%{name}
  195. %endif
  196. %attr(0755,root,root) %dir %{_sysconfdir}/%{name}
  197. %attr(0755,unbound,unbound) %dir %{_localstatedir}/run/%{name}
  198. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/unbound.conf
  199. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/keys.d
  200. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/keys.d/*.key
  201. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/conf.d
  202. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/conf.d/*.conf
  203. %dir %attr(0755,root,unbound) %{_sysconfdir}/%{name}/local.d
  204. %attr(0664,root,unbound) %config(noreplace) %{_sysconfdir}/%{name}/local.d/*.conf
  205. %{_sbindir}/*
  206. %exclude %{_sbindir}/unbound-anchor
  207. %{_mandir}/*/*
  208. %if %{with_python}
  209. %files python
  210. %{python3_sitelib}/*
  211. %endif
  212. %if %{with_munin}
  213. %files munin
  214. %defattr(-,root,root,-)
  215. %config(noreplace) %{_sysconfdir}/munin/plugin-conf.d/unbound
  216. %{_datadir}/munin/plugins/unbound*
  217. %endif
  218. %files devel
  219. %defattr(-,root,root,-)
  220. %{_libdir}/libunbound.so
  221. %{_includedir}/unbound.h
  222. %{_libdir}/pkgconfig/libunbound.pc
  223. %doc README
  224. %files libs
  225. %defattr(-,root,root,-)
  226. %license doc/LICENSE
  227. %doc doc/README
  228. %{_sbindir}/unbound-anchor
  229. %{_libdir}/libunbound.so.*
  230. %{_sysconfdir}/%{name}/icannbundle.pem
  231. %dir %attr(0755,unbound,unbound) %{_sharedstatedir}/%{name}
  232. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/dlv.isc.org.key
  233. %attr(0644,unbound,unbound) %config(noreplace) %{_sharedstatedir}/%{name}/root.key
  234. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/root.key
  235. %if %{with systemd}
  236. %{_unitdir}/unbound-anchor.timer
  237. %{_unitdir}/unbound-anchor.service
  238. %else
  239. %attr(0644,root,root) %{_sysconfdir}/cron.d/unbound-anchor
  240. %endif
  241. %if %{build_compat32}
  242. %files -n compat32-%{name}-libs
  243. %defattr(-,root,root,-)
  244. %{_libdir}/libunbound.so.*
  245. %endif
  246. %pre libs
  247. getent group unbound >/dev/null || groupadd -r unbound
  248. getent passwd unbound >/dev/null || \
  249. useradd -r -g unbound -d %{_sysconfdir}/unbound -s /sbin/nologin \
  250. -c "Unbound DNS resolver" unbound
  251. exit 0
  252. %post libs
  253. /sbin/runuser --command="%{_sbindir}/unbound-anchor -a %{_sharedstatedir}/unbound/root.key -c %{_sysconfdir}/unbound/icannbundle.pem" --shell /bin/sh unbound ||:
  254. %if %{with systemd}
  255. %systemd_post unbound-anchor.timer
  256. # start the timer only if installing the package to prevent starting it, if it was stopped on purpose
  257. if [ "$1" -eq 1 ]; then
  258. # the Unit is in presets, but would be started after reboot
  259. /bin/systemctl start unbound-anchor.timer >/dev/null 2>&1 || :
  260. fi
  261. %endif
  262. %if %{with systemd}
  263. %preun libs
  264. %systemd_preun unbound-anchor.timer
  265. %endif
  266. %postun libs
  267. %if %{with systemd}
  268. %systemd_postun_with_restart unbound-anchor.timer
  269. %endif
  270. %post
  271. %if %{with systemd}
  272. %systemd_post unbound.service
  273. %systemd_post unbound-keygen.service
  274. %else
  275. /sbin/chkconfig --add %{name}
  276. %endif
  277. # dnssec-conf used to contain our DLV key, but now we include it via unbound
  278. # If unbound had previously been configured with dnssec-configure, we need
  279. # to migrate the location of the DLV key file (to keep DLV enabled, and because
  280. # unbound won't start with a bad location for a DLV key file.
  281. sed -i "s:/etc/pki/dnssec-keys[/]*dlv:/etc/unbound:" %{_sysconfdir}/unbound/unbound.conf
  282. %preun
  283. %if %{with systemd}
  284. %systemd_preun unbound.service
  285. %systemd_preun unbound-keygen.service
  286. %else
  287. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  288. /sbin/service %{name} stop >/dev/null 2>&1
  289. /sbin/chkconfig --del %{name}
  290. fi
  291. %endif
  292. %postun
  293. %if %{with systemd}
  294. %systemd_postun_with_restart unbound.service
  295. %systemd_postun unbound-keygen.service
  296. %else
  297. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  298. /sbin/service %{name} condrestart >/dev/null 2>&1 || :
  299. fi
  300. %endif
  301. %changelog
  302. * Thu Jun 02 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  303. - updated to 1.16.0.
  304. * Thu Feb 10 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.0-1
  305. - updated to 1.15.0.
  306. * Thu Dec 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.0-1
  307. - updated to 1.14.0.
  308. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.2-2
  309. - rebuilt with openssl-3.0.0.
  310. * Thu Aug 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.2-1
  311. - updated to 1.13.2.
  312. - dropped ldconfig scriptlets.
  313. * Wed Feb 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.1-1
  314. - updated to 1.13.1.
  315. * Thu Dec 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.0-1
  316. - updated to 1.13.0.
  317. * Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
  318. - updated to 1.12.0.
  319. * Mon Jul 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.0-1
  320. - updated to 1.11.1.
  321. * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
  322. - updated to 1.10.1.
  323. * Tue Apr 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-2
  324. - rebuilt with libevent-2.1.11.
  325. * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
  326. - updated to 1.10.0.
  327. - added systemd support (disabled as default).
  328. - disabled munin.
  329. * Mon Dec 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.6-1
  330. - updated to 1.9.6.
  331. * Fri Oct 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.4-1
  332. - updated to 1.9.4.
  333. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.3-1
  334. - updated to 1.9.3.
  335. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-1
  336. - updated to 1.9.2.
  337. * Fri Nov 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-2
  338. - added a subpackage 'compat32-unbound-libs'.
  339. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
  340. - updated to 1.8.1.
  341. - rebuilt with openssl-1.1.1 and libevent-2.1.8.
  342. - updated root.key and root.anchor.
  343. * Thu Oct 4 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.0-1
  344. - update to 1.8.0
  345. - drop mesh patch (Patch0): upstream fixed
  346. * Thu May 24 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-3
  347. - Fix mesh state assertion failure due to callback removal. (Patch0)
  348. * Sun May 6 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-2
  349. - enable ECDSA support
  350. - enable GOST support
  351. * Sat May 5 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.1-1
  352. - update to 1.7.1
  353. - add pkgconfig file in devel sub package
  354. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.7-1
  355. - updated to 1.6.7.
  356. * Mon Jul 31 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.4-1
  357. - update to 1.6.4
  358. * Sat Jun 24 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.3-1
  359. - update to 1.6.3
  360. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.2-1
  361. - update to 1.6.2
  362. - disables SHA1 support
  363. * Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.1-1
  364. - update to 1.6.1
  365. * Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-2
  366. - fix Requires and BuildRequres
  367. - drop ldns
  368. * Thu Dec 29 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.0-1
  369. - update to 1.6.0
  370. * Thu Jun 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.9-1
  371. - new upstream release.
  372. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.8-1
  373. - new upstream release.
  374. * Thu Dec 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
  375. - new upstream release.
  376. * Tue Nov 3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-1
  377. - new upstream release.
  378. * Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.5.3-1
  379. - update to 1.5.3
  380. * Tue Dec 09 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.1-1
  381. - update to 1.5.1
  382. * Tue Jun 17 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-3
  383. - move create user script to libs subpackage
  384. * Wed Jun 11 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.22-2
  385. - add {B,C}.ROOT-SERVERS.NET. IPv6 address
  386. * Wed Apr 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.22-1
  387. - update to 1.4.22
  388. - move root.key to /var/lib/unbound
  389. - add icannbundle.pem from http://data.iana.org/root-anchors/icannbundle.pem
  390. - add unbound.cron
  391. - move keys and unbound-anchor to libs subpackage
  392. * Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.21-1
  393. - new upstream release
  394. * Tue Mar 26 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.20-1
  395. - new upstream release
  396. * Thu Dec 13 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.19-1
  397. - new upstream release
  398. - drop glob patch (Patch1): upstream merged
  399. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.4.18-1
  400. - new upstream release
  401. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.17-1
  402. - update to 1.4.17
  403. - add root.key for DNSSEC
  404. - enable munin subpackage by default
  405. - buildrequire ldns-devel >= 1.6.13
  406. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-2
  407. - rebuild with python-2.7.2
  408. * Wed Dec 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.14-1
  409. - new upstream release
  410. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.12-1
  411. - new upstream release
  412. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.10-1
  413. - new upstream releas
  414. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.9-1
  415. - new upstream release
  416. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.4.8-1
  417. - new upstream release
  418. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.7-2
  419. - rebuilt with libevent-2.0.10
  420. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.7-1
  421. - new upstream release
  422. - add enable_gost flag: default disable
  423. - add BuildRequires: expat-devel
  424. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.6-1
  425. - new upstream release
  426. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.5-1
  427. - new upstream release
  428. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.4.4-1
  429. - initial build for Vine Linux: based Fedora 1.4.3-1.fc14
  430. - update to 1.4.4
  431. - build without munin
  432. * Thu Mar 11 2010 Paul Wouters <paul@xelerance.com> - 1.4.3-1
  433. - Update to 1.4.3 that fixes 64bit crasher
  434. * Tue Mar 09 2010 Paul Wouters <paul@xelerance.com> - 1.4.2-1
  435. - Updated to 1.4.2
  436. - Updated unbound.conf with new options
  437. - Enabled pre-fetching DNSKEY records (DNSSEC speedup)
  438. - Enabled re-fetching popular records before they expire
  439. - Enabled logging of DNSSEC validation errors
  440. * Mon Mar 01 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-5
  441. - Overriding -D_GNU_SOURCE is no longer needed. This fixes DSO issues
  442. with pthreads
  443. * Wed Feb 24 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-3
  444. - Change make/configure lines to attempt to fix -lphtread linking issue
  445. * Thu Feb 18 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-2
  446. - Removed dependancy for dnssec-conf
  447. - Added ISC DLV key (formerly in dnssec-conf)
  448. - Fixup old DLV locations in unbound.conf file via %%post
  449. - Fix parent child disagreement handling and no-ipv6 present [svn r1953]
  450. * Tue Jan 05 2010 Paul Wouters <paul@xelerance.com> - 1.4.1-1
  451. - Updated to 1.4.1
  452. - Changed %%define to %%global
  453. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-2
  454. - Bump version
  455. * Thu Oct 08 2009 Paul Wouters <paul@xelerance.com> - 1.3.4-1
  456. - Upgraded to 1.3.4. Security fix with validating NSEC3 records
  457. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.3.3-2
  458. - rebuilt with new openssl
  459. * Mon Aug 17 2009 Paul Wouters <paul@xelerance.com> - 1.3.3-1
  460. - Updated to 1.3.3
  461. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  462. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  463. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  464. - Added missing glob patch to cvs
  465. - Place python macros within the %%with_python check
  466. * Sat Jun 20 2009 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  467. - Updated to 1.3.0
  468. - Added unbound-python sub package. disabled for now
  469. - Patch from svn to fix DLV lookups
  470. - Patches from svn to detect wrong truncated response from BIND 9.6.1 with
  471. minimal-responses)
  472. - Added Default-Start and Default-Stop to unbound.init
  473. - Re-enabled --enable-sha2
  474. - Re-enabled glob.patch
  475. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-7
  476. - unbound-iterator.patch was not commited
  477. * Wed May 20 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-6
  478. - Fix for https://bugzilla.redhat.com/show_bug.cgi?id=499793
  479. * Tue Mar 17 2009 Paul Wouters <paul@xelerance.com> - 1.2.1-5
  480. - Use --nocheck to avoid giving an error on missing unbound-remote certs/keys
  481. * Tue Mar 10 2009 Adam Tkac <atkac redhat com> - 1.2.1-4
  482. - enable DNSSEC only if it is enabled in sysconfig/dnssec
  483. * Mon Mar 09 2009 Adam Tkac <atkac redhat com> - 1.2.1-3
  484. - add DNSSEC support to initscript and enabled it per default
  485. - add requires dnssec-conf
  486. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
  487. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  488. * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com - 1.2.1-1
  489. - updated to 1.2.1
  490. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 1.2.0-2
  491. - rebuild with new openssl
  492. * Wed Jan 14 2009 Paul Wouters <paul@xelerance.com - 1.2.0-1
  493. - Updated to 1.2.0
  494. - Added dependancy on minimum SSL for CVE-2008-5077
  495. - Added dependancy on bc for unbound-munin
  496. - Added minimum requirement of libevent 1.4.5. Crashes with older versions
  497. (note: libevent is stale in EL-4 and not in EL-5, needs fixing there)
  498. - Removed dependancy on selinux-policy (will get used when available)
  499. - Enable options as per draft-wijngaards-dnsext-resolver-side-mitigation-00.txt
  500. - Enable unwanted-reply-threshold to mitigate against a Kaminsky attack
  501. - Enable val-clean-additional to drop addition unsigned data from signed
  502. response.
  503. - Removed patches (got merged into upstream)
  504. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-7
  505. - Modified scandir patch to silently fail when wildcard matches nothing
  506. - Patch to allow unbound-checkconf to find empty wildcard matches
  507. * Mon Jan 5 2009 Paul Wouters <paul@xelerance.com> - 1.1.1-6
  508. - Added scandir patch for trusted-keys-file: option, which
  509. is used to load multiple dnssec keys in bind file format
  510. * Mon Dec 8 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-4
  511. - Added Requires: for selinux-policy >= 3.5.13-33 for proper SElinux rules.
  512. * Mon Dec 1 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-3
  513. - We did not own the /etc/unbound directory (#474020)
  514. - Fixed cvs anomalies
  515. * Fri Nov 28 2008 Adam Tkac <atkac redhat com> - 1.1.1-2
  516. - removed all obsolete chroot related stuff
  517. - label control certs after generation correctly
  518. * Thu Nov 20 2008 Paul Wouters <paul@xelerance.com> - 1.1.1-1
  519. - Updated to unbound 1.1.1 which fixes a crasher and
  520. addresses nlnetlabs bug #219
  521. * Wed Nov 19 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-3
  522. - Remove the chroot, obsoleted by SElinux
  523. - Add additional munin plugin links supported by unbound plugin
  524. - Move configuration directory from /var/lib/unbound to /etc/unbound
  525. - Modified unbound.init and unbound.conf to account for chroot changes
  526. - Updated unbound.conf with new available options
  527. - Enabled dns-0x20 protection per default
  528. * Wed Nov 19 2008 Adam Tkac <atkac redhat com> - 1.1.0-2
  529. - unbound-1.1.0-log_open.patch
  530. - make sure log is opened before chroot call
  531. - tracked as http://www.nlnetlabs.nl/bugs/show_bug.cgi?id=219
  532. - removed /dev/log and /var/run/unbound and /etc/resolv.conf from
  533. chroot, not needed
  534. - don't mount files in chroot, it causes problems during updates
  535. - fixed typo in default config file
  536. * Fri Nov 14 2008 Paul Wouters <paul@xelerance.com> - 1.1.0-1
  537. - Updated to version 1.1.0
  538. - Updated unbound.conf's statistics options and remote-control
  539. to work properly for munin
  540. - Added unbound-munin package
  541. - Generate unbound remote-control key/certs on first startup
  542. - Required ldns is now 1.4.0
  543. * Wed Oct 22 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-5
  544. - Only call ldconfig in -libs package
  545. - Move configure into build section
  546. - devel subpackage should only depend on libs subpackage
  547. * Tue Oct 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-4
  548. - Fix CFLAGS getting lost in build
  549. - Don't enable interface-automatic:yes because that
  550. causes unbound to listen on 0.0.0.0 instead of 127.0.0.1
  551. * Sun Oct 19 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-3
  552. - Split off unbound-libs, make build verbose
  553. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-2
  554. - FSB compliance, chroot fixes, initscript fixes
  555. * Thu Sep 11 2008 Paul Wouters <paul@xelerance.com> - 1.0.2-1
  556. - Upgraded to 1.0.2
  557. * Wed Jul 16 2008 Paul Wouters <paul@xelerance.com> - 1.0.1-1
  558. - upgraded to new release
  559. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-2
  560. - Build against ldns-1.3.0
  561. * Wed May 21 2008 Paul Wouters <paul@xelerance.com> - 1.0.0-1
  562. - Split of -devel package, fixed dependancies, make rpmlint happy
  563. * Fri Apr 25 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.12
  564. - Using parts from ports collection entry by Jaap Akkerhuis.
  565. - Using Fedoraproject wiki guidelines.
  566. * Wed Apr 23 2008 Wouter Wijngaards <wouter@nlnetlabs.nl> - 0.11
  567. - Initial version.