rrdtool-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284
  1. # Basic Information
  2. Name: rrdtool
  3. Summary: RRDtool - Round Robin Database tool
  4. Summary(ja): RRDtool - ラウンドロビンデータベースツール
  5. Version: 1.7.2
  6. Release: 2%{?_dist_release}
  7. Group: admin-tools,graphics
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: yasumichi
  11. License: GPLv2+ with exceptions
  12. URL: http://oss.oetiker.ch/rrdtool/
  13. Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
  14. Patch3: rrdtool-1.6.0-ruby-2-fix.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. # Dependency
  17. BuildRequires: glib2-devel
  18. BuildRequires: glibc-devel
  19. BuildRequires: libdbi-devel
  20. BuildRequires: libxml2-devel
  21. BuildRequires: lua-devel
  22. BuildRequires: pango-devel
  23. BuildRequires: perl(ExtUtils::MakeMaker)
  24. BuildRequires: python-devel
  25. BuildRequires: python-setuptools
  26. BuildRequires: ruby-devel
  27. BuildRequires: tcl-devel
  28. %description
  29. It is pretty easy to gather status information from all sorts of things,
  30. ranging from the temperature in your office to the number of octets which
  31. have passed through the FDDI interface of your router. But it is not so
  32. trivial to store this data in a efficient and systematic manner. This is
  33. where RRDtool kicks in. It lets you log and analyze the data you gather from
  34. all kinds of data-sources (DS). The data analysis part of RRDtool is based
  35. on the ability to quickly generate graphical representations of the data
  36. values collected over a definable time period.
  37. #%%description -l ja
  38. %package devel
  39. Summary: Libraries and include files of RRDtool
  40. Group: system
  41. Requires: %{name} = %{version}-%{release}
  42. %description devel
  43. Libraries and include files of RRDtool
  44. %package doc
  45. Summary: RRDtool documentation
  46. Summary(ja): RRDtool のドキュメント
  47. Group: documentation
  48. BuildArch: noarch
  49. %description doc
  50. RRD is the Acronym for Round Robin Database. RRD is a system to store and
  51. display time-series data (i.e. network bandwidth, machine-room temperature,
  52. server load average). This package contains documentation on using RRD.
  53. %package tcl
  54. Summary: RRDTool modules for tcl
  55. Group: programming
  56. Requires: %{name} = %{version}-%{release}
  57. %description tcl
  58. RRDTool bindings for Tcl.
  59. %package -n perl-rrdtool
  60. Summary: Perl RRDtool bindings
  61. Summary(ja): RRDTool の perl バインディング
  62. Group: programming
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  65. %description -n perl-rrdtool
  66. The Perl RRDTool bindings.
  67. %package -n python-rrdtool
  68. Summary: Python RRDTool bindings
  69. Summary(ja): RRDTool の Python バインディング
  70. Group: programming
  71. Requires: %{name} = %{version}-%{release}
  72. %description -n python-rrdtool
  73. RDTool bindings for python.
  74. %package -n python3-rrdtool
  75. Summary: Python3 RRDTool bindings
  76. Summary(ja): RRDTool の Python3 バインディング
  77. Group: programming
  78. BuildRequires: python3-devel
  79. BuildRequires: python3-rpm-macros
  80. BuildRequires: python3-setuptools
  81. Requires: %{name} = %{version}-%{release}
  82. %description -n python3-rrdtool
  83. RDTool bindings for python3.
  84. %package -n ruby-rrdtool
  85. Summary: Ruby RRDTool bindings
  86. Summary(ja): RRDTool の ruby バインディング
  87. Group: programming
  88. Requires: %{name} = %{version}-%{release}
  89. %description -n ruby-rrdtool
  90. RRDtool bindings for Ruby.
  91. %prep
  92. %setup -q
  93. %patch3 -p1 -b .ruby-2-fix
  94. autoreconf -vif
  95. %build
  96. %configure \
  97. --disable-rpath \
  98. --disable-static \
  99. --enable-perl-site-install \
  100. --with-perl-options="INSTALLDIRS=vendor" \
  101. --enable-ruby \
  102. --enable-ruby-site-install \
  103. --with-pic
  104. # Fix another rpath issue
  105. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
  106. bindings/perl-shared/Makefile.PL
  107. # Remove Rpath from Ruby
  108. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
  109. bindings/ruby/extconf.rb
  110. sed -i 's|/ruby/extconf.rb|/ruby/extconf.rb --vendor |' bindings/Makefile
  111. perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
  112. %{__make} %{?_smp_mflags}
  113. %{__make} %{?_smp_mflags} -C bindings python PYTHON=%{__python3}
  114. %install
  115. %{__rm} -rf ${RPM_BUILD_ROOT}
  116. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  117. pushd bindings/python
  118. %{py3_install}
  119. popd
  120. # Install ruby module by force
  121. mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
  122. make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
  123. # We only want .txt and .html files for the main documentation
  124. rm -rf docs_to_be_included
  125. mkdir -p docs_to_be_included/html docs_to_be_included/txt
  126. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
  127. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
  128. # Put perl docs in perl package
  129. rm -rf docs_perl
  130. mkdir -p docs_perl/html
  131. mv docs_to_be_included/html/RRD*.html docs_perl/html/
  132. # Clean up
  133. %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
  134. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/lua/*/rrd.la
  135. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
  136. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  137. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
  138. %find_lang %{name}
  139. %clean
  140. %{__rm} -rf ${RPM_BUILD_ROOT}
  141. %post -p /sbin/ldconfig
  142. %postun -p /sbin/ldconfig
  143. %files -f %{name}.lang
  144. %defattr(-,root,root)
  145. #doc COPYING NEWS README TODO
  146. %{_bindir}/rrd*
  147. %{_libdir}/lua/*/rrd.so.*
  148. %{_libdir}/librrd*.so.*
  149. %{_mandir}/man1/*.1*
  150. %{_datadir}/rrdtool/examples/cgi-demo.cgi
  151. %files devel
  152. %defattr(-,root,root)
  153. %{_includedir}/rrd*.h
  154. %{_libdir}/lua/*/rrd.so
  155. %{_libdir}/librrd.so
  156. %{_libdir}/pkgconfig/librrd.pc
  157. %{_mandir}/man3/librrd.3*
  158. %files doc
  159. %defattr(-,root,root,-)
  160. %license COPYRIGHT LICENSE
  161. %doc CONTRIBUTORS TODO NEWS THREADS
  162. %doc docs_to_be_included/html docs_to_be_included/txt
  163. %files tcl
  164. %defattr(-,root,root)
  165. %doc bindings/tcl/README
  166. #%{_datadir}/rrdtool/ifOctets.tcl
  167. #%{_datadir}/rrdtool/pkgIndex.tcl
  168. %{_libdir}/tclrrd*.so
  169. %{_libdir}/rrdtool/*.tcl
  170. %files -n perl-rrdtool
  171. %defattr(-,root,root)
  172. %{perl_vendorlib}/RRDp.pm
  173. %{perl_vendorarch}/RRDs.pm
  174. %{perl_vendorarch}/auto/RRDs/RRDs.so
  175. %{_datadir}/rrdtool/examples/*.pl
  176. %{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
  177. %{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
  178. %{_mandir}/man3/RRD?.3pm*
  179. %files -n python-rrdtool
  180. %defattr(-,root,root)
  181. %license bindings/python/COPYING
  182. %doc bindings/python/AUTHORS bindings/python/README
  183. %{python_sitearch}/rrdtool-*-py*.egg-info
  184. %{python_sitearch}/rrdtool.so
  185. %files -n python3-rrdtool
  186. %defattr(-,root,root)
  187. %license bindings/python/COPYING
  188. %doc bindings/python/AUTHORS bindings/python/README
  189. %{python3_sitearch}/rrdtool-*-py*.egg-info
  190. %{python3_sitearch}/rrdtool.*.so
  191. %{_datadir}/rrdtool/examples/*.py
  192. %files -n ruby-rrdtool
  193. %defattr(-,root,root,-)
  194. %doc bindings/ruby/README
  195. %{ruby_vendorarchdir}/RRD.so
  196. %changelog
  197. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-2
  198. - rebuilt with python-3.8.
  199. * Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
  200. - new upstream release.
  201. - built with ruby-2.6.5.
  202. - added python3 support.
  203. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  204. - new upstream release.
  205. - rebuilt with perl-5.26.
  206. - rebuilt with ruby-2.4.6.
  207. - updated Patch3.
  208. * Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
  209. - rebuild with ruby-2.2.3
  210. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
  211. - rebuild with libdbi-0.9.0
  212. * Mon Jan 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
  213. - new upstream release.
  214. - added Group tag to subpackages
  215. - added ruby subpackages
  216. - split documents into subpackages
  217. - added %%post and %%postun section
  218. * Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
  219. - new upstream release.
  220. * Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
  221. - initial build for Vine Linux