gnome-do-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. %define mainver 0.8.4
  2. %define build_vine5 %( [ "%{?_dist_release}" == "vl5" ] && echo 1 || echo 0)
  3. Name: gnome-do
  4. Version: 0.8.4
  5. Release: 1%{?_dist_release}
  6. Summary: An intelligent launcher tool for Gnome
  7. Summary(ja): Gnome 用の高機能ランチャー
  8. License: GPLv3+
  9. Group: Applications/Accessories
  10. URL: http://do.davebsd.com/
  11. Source0: http://edge.launchpad.net/do/0.8/%{mainver}/+download/gnome-do-%{version}.tar.gz
  12. Source1: gnome-do.desktop
  13. # https://bugs.launchpad.net/do/+bug/634556
  14. #Patch0: gnome-do-0.8.3.1-mono-2.8.patch
  15. #Patch1: gnome-do-0.8.3.1-gdk-build-fix.patch
  16. # https://bugs.launchpad.net/do/+bug/634550
  17. Patch2: gnome-do-0.8.4-cs0200.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  19. # Various Mono dependencies are not available for ppc64; see bug 241850.
  20. ExcludeArch: ppc64
  21. BuildRequires: mono-devel, mono-addins
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: ndesk-dbus
  24. BuildRequires: ndesk-dbus-glib
  25. BuildRequires: gtk-sharp2
  26. BuildRequires: notify-sharp-devel
  27. BuildRequires: gnome-sharp2, gnome-desktop-sharp2 >= 2.26
  28. BuildRequires: gnome-keyring-sharp-devel
  29. BuildRequires: gettext
  30. BuildRequires: perl-XML-Parser
  31. BuildRequires: intltool
  32. BuildRequires: gtk2-devel
  33. BuildRequires: desktop-file-utils
  34. BuildRequires: wnck-sharp
  35. BuildRequires: gconf-sharp2
  36. BuildRequires: rsvg2-sharp
  37. Requires(pre): GConf2
  38. Requires(post): GConf2
  39. Requires(preun): GConf2
  40. Requires: gnome-keyring-sharp, gnome-desktop-sharp2
  41. Requires: pkgconfig
  42. Packager: kazutaka
  43. %description
  44. GNOME Do (Do) is an intelligent launcher tool that makes performing
  45. common tasks on your computer simple and efficient. Do not only
  46. allows you to search for items in your desktop environment
  47. (e.g. applications, contacts, bookmarks, files, music), it also
  48. allows you to specify actions to perform on search results
  49. (e.g. run, open, email, chat, play).
  50. %description -l ja
  51. GNOME Do (Do) は高機能なランチャーツールです。 PC を使った一
  52. 般的なタスクをシンプルかつ効率的に実行できるようにします。Do
  53. はデスクトップ環境の様々なアイテム(例えばアプリケーションや
  54. 連絡先、ブックマーク、ファイル、音楽等)の検索だけでなく、検索
  55. した結果をどう操作するのか(例えば開く、メールに添付、チャット、
  56. 再生する等)を指定することができます。
  57. %package devel
  58. Summary: Development files for GNOME Do
  59. Summary(ja): GNOME Do の開発用ファイル
  60. Group: Development/Libraries
  61. Requires: %{name} = %{version}-%{release}
  62. Requires: pkgconfig
  63. %description devel
  64. Development files for GNOME Do
  65. %description devel -l ja
  66. GNOME Do の開発用ファイルです。
  67. %prep
  68. %setup -q
  69. #%if !%{build_vine5}
  70. #%patch0 -p0 -b .mono28-fix
  71. #%patch1 -p1 -b .gdkbuild-fix
  72. #%endif
  73. %patch2 -p0 -b .cs0200
  74. %build
  75. %configure
  76. make %{?_smp_mflags}
  77. %install
  78. rm -rf ${RPM_BUILD_ROOT}
  79. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  80. make install DESTDIR=${RPM_BUILD_ROOT}
  81. desktop-file-install \
  82. --dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart \
  83. --add-only-show-in=GNOME \
  84. %{SOURCE1}
  85. desktop-file-install \
  86. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  87. --remove-category Application \
  88. %{SOURCE1}
  89. #own this dir:
  90. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  91. %find_lang %{name}
  92. %pre
  93. if [ "$1" -gt 1 ]; then
  94. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  95. gconftool-2 --makefile-uninstall-rule \
  96. %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
  97. fi
  98. %post
  99. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  100. gconftool-2 --makefile-install-rule \
  101. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  102. touch --no-create %{_datadir}/icons/hicolor
  103. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  104. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  105. fi
  106. %preun
  107. if [ "$1" -eq 0 ]; then
  108. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  109. gconftool-2 --makefile-uninstall-rule \
  110. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  111. fi
  112. %postun
  113. touch --no-create %{_datadir}/icons/hicolor
  114. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  115. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  116. fi
  117. %clean
  118. rm -rf ${RPM_BUILD_ROOT}
  119. %files -f %{name}.lang
  120. %defattr(-,root,root,-)
  121. %doc AUTHORS COPYING COPYRIGHT
  122. %{_bindir}/gnome-do/
  123. %{_libdir}/gnome-do/
  124. %{_datadir}/gnome-do/
  125. %config(noreplace) %{_sysconfdir}/xdg/autostart/gnome-do.desktop
  126. %config(noreplace) %{_sysconfdir}/gconf/schemas/*
  127. %{_datadir}/icons/hicolor/*/apps/gnome-do.*
  128. %{_datadir}/applications/*
  129. %files devel
  130. %defattr(-,root,root,-)
  131. %{_libdir}/pkgconfig/*
  132. %changelog
  133. * Thu Jan 13 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.4-1
  134. - new upstream release
  135. - drop Patch0 & 1
  136. - add Patch2: fix compilation error (cs0200)
  137. - add Source1: temporary fix for desktop-file-install failure.
  138. (Comment[kk] contains a bogus linebreak)
  139. * Sat Nov 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.8.3.1-4
  140. - add Patch0 & 1 to fix compilation error (Seed only)
  141. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3.1-3
  142. - rebuild with rpm-4.8.1 for pkg-config file
  143. - add BuildRequires: gconf-sharp2, rsvg2-sharp
  144. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.3.1-2
  145. - rebuilt with mono-addins-0.5
  146. * Sun Jan 10 2010 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.3.1-1
  147. - new upstream release
  148. * Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.2-1
  149. - new upstream release
  150. - drop Patch0 (merged in upstream)
  151. * Fri Jun 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-3
  152. - change Group to Applications/Accessories
  153. * Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1.3-2
  154. - add BuildRequires: wnck-sharp
  155. * Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-1
  156. - initial build for Vine Linux based on fedora development
  157. * Fri Apr 10 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-5
  158. - Fix .desktop issue, install in both autostart and applications
  159. - Rebuild for new gnome-desktop-sharp
  160. - Add missing gnome-desktop-sharp requires
  161. - Fix Ndesk-dbus Requires
  162. * Wed Apr 01 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-3
  163. - Add patch to fix issue where applications wasn't being indexed
  164. * Tue Mar 17 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-2
  165. - New upstream release
  166. * Tue Mar 3 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-4
  167. - Own _datadir/gnome-do
  168. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-3
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  170. * Sat Feb 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.8.0-2
  171. - Rebuild against new mono-addins
  172. * Fri Jan 30 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-1
  173. - New upstream release
  174. * Thu Jan 29 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1.0-3
  175. - Remove Tomboy dependency (bz #481183)
  176. - Updated description, from Do
  177. * Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.1.0-2
  178. - rebuild against new gnome-sharp
  179. * Wed Oct 08 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.1.0-1
  180. - New Upstream Release
  181. * Fri Oct 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.1-1
  182. - New upstream release
  183. * Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.0-1
  184. - New upstream release
  185. * Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.5.0.1-4
  186. - New upstream release
  187. - Add gnome-desktop-sharp dependency
  188. * Wed Jun 04 2008 Caol叩n McNamara <caolanm@redhat.com> - 0.4.2.0-2
  189. - rebuild for dependancies
  190. * Tue Apr 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.4.2.0-1
  191. - New upstream release
  192. * Tue Apr 01 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-2
  193. - #439793 - correct URL
  194. * Sat Mar 29 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-1
  195. - Bump to 0.4.0.1
  196. - Hopefully bring an end to the endless dups of 432201
  197. * Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-2
  198. - Fix 432201
  199. * Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-1
  200. - Bump to 0.3.1
  201. * Wed Feb 06 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-5
  202. - #431589 - Force runtime dependency on ndesk-dbus(-glib)
  203. * Mon Feb 04 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-4
  204. - #431462 - Correctly pull in Tomboy runtime dependency
  205. * Fri Jan 25 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-3
  206. - autostart gnome-do in quiet mode with the user session
  207. - to invoke gnome-do use super+space
  208. * Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-2
  209. - Fix BuildRequires
  210. * Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-1
  211. - bump to 0.3.0.1
  212. - update patches
  213. * Sat Nov 17 2007 David Nielsen <david@lovesunix.net> - 0.0.2-2
  214. - updated libdir patch
  215. - cleaned up desktop-file-install invocation
  216. - correct BuildRequires
  217. * Mon Nov 12 2007 David Nielsen <david@lovesunix.net> - 0.0.2-1
  218. - Initial package