ModemManager-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. #%define snapshot .git20100720
  2. %define snapshot %{nil}
  3. %define ppp_version 2.4.5
  4. Summary: Mobile broadband modem management service
  5. Summary(ja): Mobile broadband modem management service
  6. Name: ModemManager
  7. Version: 0.5.2.0
  8. Release: 1%{?snapshot}%{?_dist_release}
  9. License: GPLv2+
  10. Group: System Environment/Base
  11. URL: http://www.gnome.org/projects/NetworkManager/
  12. #
  13. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  14. # tarball built with:
  15. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  16. # make distcheck
  17. #
  18. Source: %{name}-%{version}%{?snapshot}.tar.xz
  19. Patch1: %{name}-0.3-jp-modems.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  21. Requires: dbus-glib
  22. Requires: glib2
  23. BuildRequires: glib2-devel >= 2.26.1
  24. BuildRequires: dbus-glib-devel >= 0.92
  25. BuildRequires: libgudev-devel >= 143
  26. BuildRequires: ppp = %{ppp_version}
  27. BuildRequires: ppp-devel = %{ppp_version}
  28. BuildRequires: polkit-devel
  29. BuildRequires: automake autoconf intltool libtool
  30. # for xsltproc
  31. BuildRequires: libxslt
  32. %description
  33. The ModemManager service provides a consistent API to operate many different
  34. modems, including mobile broadband (3G) devices.
  35. %prep
  36. %setup -q
  37. %patch1 -p1 -b .jp-modems
  38. %build
  39. autoreconf -i
  40. pppddir=`ls -1d %{_libdir}/pppd/2*`
  41. %configure \
  42. --enable-more-warnings=yes \
  43. --with-udev-base-dir=/lib/udev \
  44. --with-tests=yes \
  45. --with-docs=yes \
  46. --disable-static \
  47. --with-pppd-plugin-dir=$pppddir \
  48. --with-polkit=no
  49. make %{?_smp_mflags}
  50. %check
  51. make check
  52. %install
  53. make install DESTDIR=$RPM_BUILD_ROOT
  54. rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
  55. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
  56. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  57. rm -f $RPM_BUILD_ROOT%{_includedir}/mm/mm-modem.h
  58. %post
  59. /sbin/ldconfig
  60. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  61. %postun
  62. /sbin/ldconfig
  63. if [ $1 -eq 0 ]; then
  64. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  65. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  66. fi
  67. %posttrans
  68. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  69. %files
  70. %defattr(0644, root, root, 0755)
  71. %doc COPYING README
  72. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
  73. %{_datadir}/dbus-1/interfaces/*.xml
  74. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
  75. %attr(0755,root,root) %{_sbindir}/modem-manager
  76. %dir %{_libdir}/%{name}
  77. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  78. /lib/udev/rules.d/*
  79. %{_datadir}/polkit-1/actions/*.policy
  80. %{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
  81. %changelog
  82. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  83. - new upstream release
  84. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  85. - new upstream release
  86. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  87. - delete Patch20
  88. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  89. - update Patch20 (ModemManager-0.4-git20110428.patch)
  90. - delete Patch21,22
  91. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  92. - update to 0.4
  93. - add Patch20 (ModemManager-0.4-git20100720.patch)
  94. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  95. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  96. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  97. - initial build for Vine Linux
  98. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  99. - core: ignore some failures on disconnect (rh #578280)
  100. - core: add support for platform serial devices
  101. - gsm: better Blackberry DUN support
  102. - gsm: periodically poll access technology
  103. - cdma: prevent crash on modem removal (rh #571921)
  104. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  105. - novatel: better signal strength reporting on CDMA cards
  106. - novatel: add access technology and mode preference support on GSM cards
  107. - zte: fix mode preference retrieval
  108. - longcheer: add support for Zoom modems (4595, 4596, etc)
  109. - longcheer: add access technology and mode preference support
  110. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  111. - Silence %%post
  112. - Update scripts
  113. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  114. - gsm: fix parsing Blackberry supported character sets response
  115. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  116. - mbm: fix retrieval of current allowed mode
  117. - gsm: fix initialization issues with some devices (like Blackberries)
  118. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  119. - core: fix detection of some generic devices (rh #579247)
  120. - core: fix detection regression of some Huawei devices in 0.3-5
  121. - cdma: periodically poll registration state and signal quality
  122. - cdma: really fix registration detection on various devices (rh #569067)
  123. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  124. - core: fix PPC/SPARC/etc builds
  125. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  126. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  127. - cdma: handle signal quality requests while connected for more devices
  128. - cdma: handle serving system requests while connected for more devices
  129. - gsm: determine current access technology earlier
  130. - huawei: work around automatic registration issues on some devices
  131. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  132. - core: ensure enabled modems are disabled when MM stops
  133. - core: better capability detection for Blackberry devices (rh #573510)
  134. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  135. - gsm: don't block modem when it requires PIN2
  136. - option: fix access technology updates
  137. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  138. - mbm: add device IDs for C3607w
  139. - mbm: fail earlier during connection failures
  140. - mbm: fix username/password authentication when checked by the network
  141. - hso: implement asynchronous signal quality updates
  142. - option: implement asynchronous signal quality updates
  143. - novatel: correctly handle CDMA signal quality
  144. - core: basic PolicyKit support
  145. - core: fix direct GSM registration information requests
  146. - core: general GSM PIN/PUK unlock fixes
  147. - core: poll GSM registration state internally for quicker status updates
  148. - core: implement GSM 2G/3G preference
  149. - core: implement GSM roaming allowed/disallowed preference
  150. - core: emit signals on access technology changes
  151. - core: better handling of disconnections
  152. - core: fix simple CDMA status requests
  153. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  154. - core: startup speed improvements
  155. - core: GSM PIN checking improvements
  156. - huawei: fix EVDO-only connections on various devices (rh #553199)
  157. - longcheer: add support for more devices
  158. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  159. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  160. - core: fix crashes when devices are unplugged during operation (rh #553953)
  161. - cdma: prefer primary port for status/registration queries
  162. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  163. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  164. - gsm: fix Nokia N80 network scan parsing
  165. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  166. - core: fix apparent hangs by limiting retried serial writes
  167. - gsm: ensure modem state is reset when disabled
  168. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  169. - sierra: fix CDMA registration detection in some cases (rh #547513)
  170. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  171. - sierra: ensure CDMA device is powered up when trying to use it
  172. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  173. - zte: handle unsolicited messages better during probing
  174. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  175. - cdma: fix signal strength reporting on some devices
  176. - cdma: better registration state detection when dialing (ex Sierra 5275)
  177. - option: always use the correct tty for dialing commands
  178. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  179. - core: fix reconnect after manual disconnect (rh #541314)
  180. - core: fix various segfaults during registration
  181. - core: fix probing of various modems on big-endian architectures (ie PPC)
  182. - core: implement modem states to avoid duplicate operations
  183. - hso: fix authentication for Icera-based devices like iCON 505
  184. - zte: use correct port for new devices
  185. - nozomi: fix detection
  186. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  187. - Update to latest git
  188. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  189. - cdma: wait for network registration before trying to connect
  190. - gsm: add cell access technology reporting
  191. - gsm: allow longer-running network scans
  192. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  193. - nokia: don't power down phones on disconnect
  194. - hso: fix disconnection/disable
  195. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  196. - Fixes for Motorola and Ericsson devices
  197. - Fixes for CDMA "serving-system" command parsing
  198. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  199. - Fix a typo in one of the udev rules files
  200. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  201. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  202. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  203. - Fix source repo location
  204. - Fix directory ownership
  205. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  206. - Initial version