WebKit-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358
  1. %define add_to_doc_files() \
  2. mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
  3. cp -p %1 %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
  4. echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
  5. #define svn_revision 43436
  6. # --with coverage: Enables compile-time checking of code coverage. (default: no)
  7. %bcond_with coverage
  8. # --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
  9. #%bcond_with jit
  10. # --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
  11. %bcond_with pango
  12. # --with wml: Build support for WML
  13. %bcond_with wml
  14. Name: WebKit
  15. Version: 1.8.0
  16. Release: 1%{?_dist_release}
  17. Summary: Web content engine library
  18. Summary(ja): ウェブコンテンツエンジンライブラリ
  19. Group: Development/Libraries
  20. License: LGPLv2+ and BSD
  21. URL: http://webkitgtk.org/
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: yasumichi
  25. Source0: http://www.webkitgtk.org/webkit-%{version}.tar.xz
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: bison
  28. BuildRequires: flex
  29. BuildRequires: gperf
  30. BuildRequires: gtk2-devel
  31. BuildRequires: libicu-devel
  32. BuildRequires: libjpeg-turbo-devel
  33. BuildRequires: libtool
  34. BuildRequires: libxslt-devel
  35. BuildRequires: libXt-devel
  36. BuildRequires: pcre-devel
  37. BuildRequires: sqlite3-devel
  38. BuildRequires: geoclue-devel
  39. BuildRequires: gcr-devel
  40. BuildRequires: gstreamer-devel
  41. BuildRequires: gstreamer-plugins-base-devel
  42. BuildRequires: enchant-devel
  43. BuildRequires: gobject-introspection-devel
  44. BuildRequires: gsettings-desktop-schemas
  45. BuildRequires: gtk-doc
  46. %if %{with pango}
  47. BuildRequires: pango-devel
  48. %else
  49. BuildRequires: cairo-devel
  50. BuildRequires: fontconfig-devel
  51. BuildRequires: freetype2-devel
  52. %endif
  53. BuildRequires: libsoup-devel >= 2.28.2
  54. %description
  55. WebKit is an open source web browser engine.
  56. %package gtk
  57. Summary: GTK+ port of WebKit
  58. Summary(ja): WebKit の GTK+ ポート
  59. Group: Development/Libraries
  60. %description gtk
  61. %{name} is an open-source Web content engine library. This package contains
  62. the shared libraries for the WebKit GTK+ port as well as the sample
  63. GtkLauncher tool.
  64. %package gtk-devel
  65. Summary: Development package for %{name}
  66. Summary(ja): %{name} の開発パッケージ
  67. Group: Development/Libraries
  68. Requires: %{name}-gtk = %{version}-%{release}
  69. Requires: pkgconfig
  70. Requires: gtk2-devel
  71. Requires: libsoup-devel >= 2.28.2
  72. %description gtk-devel
  73. The %{name}-gtk-devel package contains libraries, build data, and header
  74. files for developing applications that use %{name}-gtk.
  75. Please note that the WebKit/GTK+ API is not yet stable. This should
  76. only be used as a "preview" rather than a stable platform library.
  77. %package doc
  78. Summary: Documentation for %{name}
  79. Summary(ja): %{name} のドキュメント
  80. Group: Documentation
  81. %description doc
  82. %{name} is an open-source Web content engine library. This package contains
  83. the documentation for %{name}, including various LICENSE, README, and
  84. AUTHORS files.
  85. %prep
  86. %setup -q -n webkit-%{version}
  87. %build
  88. %configure \
  89. --with-gtk=2.0 \
  90. --enable-icon-database \
  91. --enable-jit \
  92. --enable-geolocation \
  93. --enable-introspection=yes \
  94. --enable-webgl \
  95. %{?with_coverage: --enable-coverage } \
  96. %{?with_pango: --with-font-backend=pango } \
  97. %{?with_wml: --enable-wml }
  98. make V=1 %{?_smp_mflags}
  99. # workaround for bug 488112
  100. # Compile libJavaScriptCore.a with -fno-strict-aliasing
  101. ##touch JavaScriptCore/AllInOneFile.cpp
  102. ##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
  103. %install
  104. rm -rf %{buildroot}
  105. make install DESTDIR=%{buildroot}
  106. install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
  107. install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
  108. # Finally, copy over and rename the various files for %%doc inclusion.
  109. %add_to_doc_files Source/WebKit/LICENSE
  110. %add_to_doc_files Source/WebKit/gtk/po/README
  111. %add_to_doc_files Source/WebKit/gtk/NEWS
  112. %add_to_doc_files Source/WebCore/icu/LICENSE
  113. %add_to_doc_files Source/WebCore/LICENSE-APPLE
  114. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2
  115. %add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
  116. %add_to_doc_files Source/JavaScriptCore/COPYING.LIB
  117. %add_to_doc_files Source/JavaScriptCore/THANKS
  118. %add_to_doc_files Source/JavaScriptCore/AUTHORS
  119. %add_to_doc_files Source/JavaScriptCore/icu/README
  120. %add_to_doc_files Source/JavaScriptCore/icu/LICENSE
  121. %find_lang webkit-2.0
  122. %clean
  123. rm -rf %{buildroot}
  124. %post gtk -p /sbin/ldconfig
  125. %posttrans gtk
  126. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  127. %postun gtk
  128. /sbin/ldconfig
  129. if [ $1 -eq 0 ] ; then
  130. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  131. fi
  132. # %files -f webkit.lang gtk
  133. %files gtk -f webkit-2.0.lang
  134. %defattr(-,root,root,-)
  135. %doc
  136. %{_libdir}/*.so.*
  137. %{_libexecdir}/WebKit/
  138. %{_bindir}/jsc-1
  139. %{_libdir}/girepository-1.0/*.typelib
  140. #%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
  141. %{_datadir}/webkitgtk-1.0/*
  142. %files gtk-devel
  143. %defattr(-,root,root,-)
  144. %exclude %{_libdir}/*.la
  145. %{_includedir}/webkitgtk-1.0
  146. %{_libdir}/*.so
  147. %{_libdir}/pkgconfig/*.pc
  148. %{_datadir}/gir-1.0/*.gir
  149. %files doc -f docfiles.list
  150. %defattr(-,root,root,-)
  151. %{_datadir}/gtk-doc/html/webkitgtk
  152. %changelog
  153. * Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.0-1
  154. - new upstream release
  155. - change BuildRequires: gcr-devel instead of gnome-keyring-devel
  156. - add BuildRequires: gsettings-desktop-schemas, gtk-doc
  157. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
  158. - new upstream release
  159. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
  160. - new upstream release
  161. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
  162. - new upstream release
  163. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
  164. - new upstream release
  165. * Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
  166. - new upstream release
  167. - delete Patch0
  168. - add BuildRequires: gtk-doc
  169. * Sat Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
  170. - new upstream release
  171. * Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
  172. - new upstream release
  173. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
  174. - new upstream release
  175. - add BuildRequires: gobject-introspection-devel
  176. - add configure option (--enable-introspection=yes)
  177. - add Patch0 (WebKit-1.2.5-gir.patch)
  178. * Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
  179. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  180. - changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
  181. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
  182. - new upstream release
  183. - add Requires: libsoup-devel (devel package)
  184. - fix configure (remove unrecognized option)
  185. - drop Patch100
  186. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
  187. - rebuilt again on ppc
  188. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  189. - new upstream release
  190. - rebuilt with libicu-4.4
  191. - added Patch100 for compiling with libicu-4.4
  192. - s/sqlite-devel/sqlite3-devel/
  193. - s/freetype-devel/freetype2-devel/
  194. * Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
  195. - updated to 1.1.18
  196. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
  197. - change BR from libsoup to libsoup-devel
  198. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
  199. - new upstream release.
  200. - add Vendor, Distribution and Packager.
  201. * Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
  202. - update to webkit-1.1.10 release version
  203. - added BuildRequires: enchant-devel
  204. * Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
  205. - update to webkit-1.1.6 release version
  206. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
  207. - update to new upstream snapshot (svn r41944)
  208. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
  209. - update to new upstream snapshot (svn r40471)
  210. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
  211. - update to new upstream snapshot (svn r37056)
  212. - disable html5video by default
  213. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
  214. - update to new upstream snapshot (svn r36882)
  215. - build with gnome-2.24
  216. * Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
  217. - build without pango by default.
  218. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
  219. - update to new upstream snapshot (svn r36053)
  220. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
  221. - update to new upstream snapshot (svn r34655)
  222. * Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1.svn34279
  223. - initial build for Vine Linux
  224. * Tue Jun 3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
  225. - rebuild for new icu
  226. * Tue Jun 3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
  227. - Update to new upstream snapshot (SVN 34279) anyway
  228. - Add BR: libXt-devel
  229. * Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
  230. - Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
  231. of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
  232. subdirectories either.)
  233. - Reference: bug 442200 (RFE: WebKit Migration)
  234. - Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
  235. tree).
  236. * Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
  237. - Update to new upstream snapshot (SVN 32531).
  238. - Fix bug 443048 and hopefully fix bug 444445
  239. - Modify the process of building GTK+ port a bit
  240. - on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
  241. * Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
  242. - Update to new upstream snapshot (SVN 31787).
  243. - Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
  244. CVE-2008-1011 (bug 438531: Cross-Site Scripting).
  245. - Switch to using autotools for building the GTK+ port.
  246. * Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
  247. - Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
  248. bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
  249. - Thanks to Mamoru Tasaka for helping find and squash these many bugs.
  250. * Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
  251. - Fix include directory naming. Resolves: bug 435561 (Header file <> header
  252. file location mismatch)
  253. - Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
  254. Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
  255. * Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
  256. - Update to new upstream snapshot (SVN 30667)
  257. - Add some build fixes for GCC 4.3:
  258. + gcc43.patch
  259. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
  260. - Autorebuild for GCC 4.3
  261. * Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
  262. - Update to new upstream snapshot (SVN 29336).
  263. - Drop TCSpinLock pthread workaround (fixed upstream):
  264. - TCSpinLock-use-pthread-stubs.patch
  265. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
  266. - Add proper %%defattr line to qt, qt-devel, and doc subpackages.
  267. - Add patch to forcibly build the TCSpinLock code using the pthread
  268. implementation:
  269. + TCSpinLock-use-pthread-stubs.patch
  270. * Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
  271. - Package renamed from WebKitGtk.
  272. - Update to SVN 28482.
  273. - Build both the GTK and Qt ports, putting each into their own respective
  274. subpackages.
  275. - Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
  276. the build-webkit script from upstream.
  277. - Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
  278. * Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
  279. - Initial packaging for Fedora.