epiphany-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379
  1. # gecko backend was removed 2.27.0
  2. %define with_gecko 0
  3. %define with_webkit 1
  4. %define gecko_version 1.9.1
  5. %define webkit_version 1.7.92
  6. ExclusiveArch: %ix86 ppc x86_64 alpha
  7. Summary: GNOME web browser based on Gecko/WebKit
  8. Summary(ja): Gecko/WebKit レンダリングエンジンベースの GNOME ウェブブラウザ
  9. Name: epiphany
  10. Version: 3.4.0.1
  11. Release: 1%{?_dist_release}
  12. License: GPL
  13. Group: Applications/Internet
  14. URL: http://www.gnome.org/projects/epiphany/
  15. Source0: http://ftp.gnome.org/pub/GNOME/sources/epiphany/3.4/%{name}-%{version}.tar.xz
  16. Patch1: epiphany-2.26.2-gecko191.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Requires: gnome-icon-theme >= 2.30.0
  19. %if %{with_gecko}
  20. Requires: gecko-libs
  21. %endif
  22. Requires(post,postun): scrollkeeper, shared-mime-info
  23. %if %{with_gecko}
  24. BuildRequires: gecko-devel-unstable >= %{gecko_version}
  25. %endif
  26. %if %{with_webkit}
  27. BuildRequires: WebKit3-gtk-devel >= %{webkit_version}
  28. %endif
  29. BuildRequires: glib2-devel >= 2.31.2
  30. BuildRequires: gtk3-devel >= 3.3.14
  31. BuildRequires: libxml2-devel >= 2.6.12
  32. BuildRequires: libxslt-devel >= 1.1.7
  33. BuildRequires: libnotify-devel >= 0.4.0
  34. BuildRequires: libsoup-devel >= 2.37.1
  35. BuildRequires: gnome-desktop-devel >= 2.30.0
  36. BuildRequires: libSM-devel
  37. BuildRequires: libgnome-keyring-devel
  38. BuildRequires: gobject-introspection-devel
  39. BuildRequires: gsettings-desktop-schemas-devel
  40. BuildRequires: sqlite3-devel
  41. BuildRequires: seed-devel
  42. BuildRequires: nss-devel
  43. BuildRequires: avahi-gobject-devel
  44. BuildRequires: iso-codes
  45. BuildRequires: gnome-doc-utils
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. %description
  49. epiphany is a simple GNOME web browser based on the Mozilla rendering
  50. engine
  51. %description -l ja
  52. epiphany は Mozilla レンダリングエンジンベースのシンプルな GNOME
  53. ウェブブラウザです。
  54. %package devel
  55. Summary: Epipany development environment
  56. Summary(ja): Epipany の開発環境
  57. Group: Development/Libraries
  58. Requires: %{name} = %{version}-%{release}
  59. Requires: pkgconfig
  60. %description devel
  61. Header files and libraries for building a extension library for the
  62. epipany.
  63. %prep
  64. %setup -q
  65. #patch1 -p1
  66. %build
  67. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
  68. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  69. %configure \
  70. %if %{with_gecko}
  71. --with-gecko=libxul-embedding \
  72. %endif
  73. %if %{with_webkit}
  74. --with-engine=webkit \
  75. %endif
  76. --enable-zeroconf \
  77. --enable-network-manager \
  78. --disable-scrollkeeper \
  79. --without-ca-file \
  80. --enable-introspection=yes \
  81. --enable-seed
  82. %__make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  86. make install DESTDIR=$RPM_BUILD_ROOT
  87. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  88. %find_lang %{name} --with-gnome
  89. rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/*/plugins/*.la
  91. %postun
  92. if [ $1 -eq 0 ] ; then
  93. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  94. scrollkeeper-update >& /dev/null ||:
  95. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  96. fi
  97. %posttrans
  98. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  99. scrollkeeper-update >& /dev/null ||:
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %files -f %{name}.lang
  104. %defattr(-,root,root,-)
  105. %doc AUTHORS ChangeLog* COPYING* NEWS README
  106. %{_bindir}/epiphany
  107. %{_bindir}/ephy-profile-migrator
  108. %{_libdir}/girepository-1.0/*.typelib
  109. %if %{with_gecko}
  110. %{_libdir}/epiphany
  111. %endif
  112. #{_datadir}/pygtk/*/defs/*
  113. %{_datadir}/GConf/gsettings/*.convert
  114. %{_datadir}/applications/*.desktop
  115. %{_datadir}/epiphany
  116. %{_datadir}/glib-2.0/schemas/*.xml
  117. %{_datadir}/dbus-1/services/*
  118. %{_mandir}/man1/epiphany.1*
  119. %files devel
  120. %defattr(-,root,root,-)
  121. %{_includedir}/%{name}
  122. %{_libdir}/pkgconfig/*.pc
  123. %{_datadir}/aclocal/*
  124. %{_datadir}/gir-1.0/*.gir
  125. %{_datadir}/gtk-doc/html/*
  126. %changelog
  127. * Mon Apr 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0.1-1
  128. - new upstream release
  129. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  130. - new upstream release
  131. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  132. - new upstream release
  133. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  134. - new upstream release
  135. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
  136. - new upstream release
  137. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
  138. - new upstream release
  139. - add BuildRequires: gsettings-desktop-schemas
  140. - create -devel sub package
  141. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.6-1
  142. - new upstream release
  143. - remove BuildRequires: gir-repository-devel
  144. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.2-2
  145. - rebuilt with rpm-4.8.1 for pkg-config
  146. * Sat May 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  147. - new upstream release
  148. - add BuildRequires: gobject-introspection-devel, seed-devel
  149. - add configure option (--enable-introspection=yes, --enable-seed)
  150. * Sat Apr 17 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  151. - new upstream release
  152. - add BuildRequires: gobject-introspection-devel, gir-repository-devel
  153. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  154. - add configure option (--without-ca-file)
  155. - remove unrecognized configure option (--with-engine)
  156. * Sat Jan 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  157. - new upstream release
  158. - added BR: libICE-devel, libSM-devel and gnome-keyring-devel
  159. * Sat Nov 07 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  160. - new upstream release
  161. * Mon Jul 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  162. - run gtk-update-icon-cache in %%post/postun script.
  163. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  164. - new upstream release
  165. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  166. - rebuild with gecko-1.9.1
  167. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  168. - new upstream release
  169. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  170. - new upstream release
  171. - build with xulrunner-1.9.0.7
  172. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  173. - new upstream release
  174. * Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-2
  175. - build with gecko-1.9.0.3 instead of WebKit.
  176. - WebKit port is unstable yet.
  177. - enable zeroconf, NetworkManager support
  178. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0.1-1
  179. - new upstream release
  180. * Thu Jul 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1.1-2vl5
  181. - build with WebKit instead of gecko.
  182. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1.1-1vl5
  183. - new upstream release
  184. - added %%pre and %%preun section
  185. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.3-0vl1
  186. - new upstream release
  187. - rebuilt with firefox-2.0.0.6-0vl3
  188. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
  189. - add BuildRequires: gnome-python
  190. * Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  191. - new upstream release
  192. - rebuilt with new toolchain and firefox-2.0.0.4-0vl6
  193. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  194. - new upstream release
  195. * Tue Nov 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.14.3-0vl1
  196. - source update
  197. - add Patch0 to build with firefox 2.0 <BTS:VineLinux:342>
  198. - add BuildRequires: pygtk2-devel
  199. * Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2.1-0vl1
  200. - new upstream release
  201. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  202. - rebuild with firefox-1.5.0.2-0vl4
  203. * Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  204. - new upstream release
  205. - build with firefox-1.5.0.2
  206. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  207. - new upstream release
  208. * Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
  209. - new upstream release
  210. - build with firefox-1.5.0.1
  211. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  212. - new upstream release
  213. - build with mozilla-1.7.12
  214. * Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl2
  215. - rebuild with mozilla-1.7.8
  216. * Sun Apr 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.3-0vl1
  217. - new upstream release
  218. * Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.2-0vl1
  219. - new upstream release
  220. - build with mozilla-1.7.7
  221. * Fri Apr 1 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl2
  222. - rebuild with mozilla-1.7.6
  223. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  224. - new upstream release
  225. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl1
  226. - new upstream release
  227. - build with mozilla-1.7.5
  228. * Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  229. - new upstream release
  230. * Tue Nov 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-0vl1
  231. - new upstream release
  232. * Mon Sep 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl2
  233. - rebuild with mozilla-1.7.3
  234. * Wed Aug 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  235. - new upstream release
  236. - build with mozilla-1.7.2
  237. - add Patch10 to build with gnome-2.4
  238. * Wed Jan 21 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.7-0vl1
  239. - new upstream version
  240. -- dropped patch10
  241. - changed URL
  242. * Fri Jan 9 2004 Tomoya TAKA <taka@vinelinux.org> 1.0.6-0vl3
  243. - add alpha into ExclusiveArch
  244. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-0vl2
  245. - rebuild with mozilla-1.5.1
  246. * Sat Dec 6 2003 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.0.6-0vl1
  247. - new upstream release
  248. * Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.3-0vl1
  249. - new upstream release
  250. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl2
  251. - fixed missing locale files
  252. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  253. - new upstream release
  254. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  255. - new upstream release
  256. * Sun Jul 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl1
  257. - new upstream release
  258. * Sun Jul 06 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-0vl1
  259. - new upstream release
  260. - build with mozilla 1.4
  261. * Sat Jun 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.0-0vl1
  262. - new upstream release
  263. * Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1-0vl1
  264. - build for Vine Linux
  265. * Mon Jun 2 2003 Elliot Lee <sopwith@redhat.com> 0.6.1-2
  266. - Rebuild to fix broken mozilla dep, patch for mozilla 1.4
  267. * Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 0.6.1-1
  268. - 0.6.1
  269. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-4
  270. - add patch to fix gint/gpointer conversion bugs for 64bit arches
  271. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-3
  272. - only build on arches mozilla is built on
  273. * Fri May 9 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-2
  274. - rebuild against new mozilla, make mozilla requires dynamic
  275. * Sun May 4 2003 Jeremy Katz <katzj@redhat.com> 0.6.0-1
  276. - update to 0.6.0
  277. - fix tyop in %%postun
  278. * Wed Apr 16 2003 Bill Nottingham <notting@redhat.com> 0.5.0-3
  279. - make it build with mozilla-1.4 (shouldn't affect moz-1.2/moz-1.3 builds)
  280. * Mon Apr 14 2003 Jeremy Katz <katzj@redhat.com> 0.5.0-2
  281. - add some buildrequires, prereq GConf2
  282. - disable building nautilus view
  283. * Sun Apr 13 2003 Jeremy Katz <katzj@redhat.com>
  284. - Initial build.