glade3-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214
  1. %define helpdir glade3
  2. Version: 3.12.0
  3. Release: 1%{?_dist_release}
  4. Summary: A user interface builder for the GTK+ toolkit and GNOME
  5. Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
  6. Name: glade3
  7. License: GPL
  8. Group: Applications/Development
  9. URL: http://glade.gnome.org/
  10. Source0: http://ftp.gnome.org/pub/GNOME/sources/glade/3.10/glade-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gtk3-devel >= 3.0.2
  13. BuildRequires: libxml2-devel >= 2.4.0
  14. #BuildRequires: libbonoboui-devel
  15. #BuildRequires: libgnomeui-devel
  16. BuildRequires: libSM-devel
  17. BuildRequires: gnome-doc-utils
  18. Requires: gtk3 >= 3.0.2
  19. Requires: libxml2 >= 2.4.0
  20. #Requires: libbonoboui
  21. #Requires: libgnomeui
  22. Requires: devhelp
  23. Requires(pre): scrollkeeper
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. Glade is a RAD tool to enable quick & easy development of user interfaces
  28. for the Gtk+ toolkit and the GNOME desktop environment.
  29. The user interfaces designed in Glade are stored in XML format,
  30. enabling easy integration with external tools.
  31. In particular libglade can load the XML files and create the interfaces
  32. at runtime. The DTD for the XML files is included with libglade, and is
  33. also at http://glade.gnome.org/glade-2.0.dtd.
  34. Other tools are available which can turn the XML files into source code
  35. in languages such as C++, Perl and Python.
  36. %description -l ja
  37. Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
  38. 発する事が可能なRADツールです。
  39. Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
  40. フォーマットで保存されます。
  41. 特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
  42. ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
  43. http://glade.gnome.org/glade-2.0.dtdにもあります。
  44. このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
  45. ルも利用可能です。
  46. %package devel
  47. Summary: the Glade UI Builder core library
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: gtk2-devel >= 2.12.0
  51. Requires: libxml2-devel >= 2.4.0
  52. Requires: libbonoboui-devel
  53. Requires: libgnomeui-devel
  54. %description devel
  55. the Glade UI Builder core library to integrate Glade into your application
  56. and integrate your custom (GTK+ based) widget toolkit into the Glade
  57. UI Builder.
  58. %prep
  59. %setup -q -n glade-%{version}
  60. pushd src
  61. ## change gnome help directory
  62. mv glade-window.c glade-window.c.orig
  63. sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
  64. glade-window.c.orig > glade-window.c
  65. popd
  66. %build
  67. %configure --disable-scrollkeeper --disable-static
  68. %__make %{_smp_mflags}
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. %makeinstall
  72. #desktop-file-install \
  73. # --vendor gnome \
  74. # --delete-original \
  75. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  76. # $RPM_BUILD_ROOT%{_datadir}/applications/*
  77. rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-2.la
  80. ## change gnome help directory
  81. mv $RPM_BUILD_ROOT%{_datadir}/gnome/help/glade $RPM_BUILD_ROOT%{_datadir}/gnome/help/%{helpdir}
  82. mv $RPM_BUILD_ROOT%{_datadir}/omf/glade $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
  83. pushd $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
  84. files=`ls *.omf`
  85. for omf in $files; do
  86. mv $omf $omf.orig
  87. sed "s|help/glade/|help/%{helpdir}/|g" $omf.orig > $omf
  88. rm $omf.orig
  89. done
  90. popd
  91. %find_lang glade
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post
  95. /sbin/ldconfig
  96. scrollkeeper-update -p /var/lib/scrollkeeper -o %{_datadir}/omf/%{helpdir}
  97. touch --no-create %{_datadir}/icons/hicolor
  98. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  99. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  100. fi
  101. %postun
  102. /sbin/ldconfig
  103. scrollkeeper-update > /dev/null 2>&1 || :
  104. touch --no-create %{_datadir}/icons/hicolor
  105. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  106. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  107. fi
  108. %files -f glade.lang
  109. %defattr(-,root,root)
  110. %{_bindir}/glade
  111. %{_bindir}/glade-previewer
  112. %{_libdir}/libgladeui-2.so.*
  113. %{_libdir}/glade/modules/*.so
  114. %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
  115. %{_datadir}/applications/glade.desktop
  116. %{_datadir}/glade
  117. %{_datadir}/gnome/help/%{helpdir}
  118. %{_datadir}/icons/hicolor/*/apps/glade.png
  119. %{_datadir}/omf/%{helpdir}
  120. %files devel
  121. %defattr(-,root,root)
  122. %{_includedir}/libgladeui-2.0/gladeui/*
  123. %{_libdir}/pkgconfig/*.pc
  124. %{_libdir}/libgladeui-2.so
  125. %{_datadir}/gir-1.0/Gladeui-2.0.gir
  126. %{_datadir}/gtk-doc/html/gladeui-2
  127. %changelog
  128. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  129. - new upstream release
  130. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
  131. - new upstream release
  132. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
  133. - new upstream release
  134. - change BuildRequires: gtk3-devel instead of gtk2-devel
  135. - delete BuildRequires: libgnomeui-devel, libbonoboui-devel
  136. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
  137. - rebuild with rpm-4.8.1 for pkg-config file
  138. - add BuildRequires: libSM-devel
  139. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
  140. - add gnome-doc-utils to BR
  141. - comment out desktop-file-install
  142. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
  143. - rebuild with gtk2-2.18.2
  144. * Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
  145. - new upstream release
  146. - care ld and icon cache
  147. - define helpdir
  148. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
  149. - new upstream release
  150. - spec in utf-8 (fixed)
  151. * Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
  152. - spec in utf-8
  153. * Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
  154. - new upstream release
  155. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
  156. - new upstream version.
  157. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
  158. - new upstream version.
  159. - update Requires.
  160. - update description.
  161. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
  162. - use macro for release
  163. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
  164. - apply new virsioning policy.
  165. - remove *.la
  166. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
  167. - new upstream version
  168. - added Requires: devhelp
  169. - added Prereq: scrollkeeper
  170. - added disable-scrollkeeper to configure
  171. - added scrollkeeper-update in %%post and %%postun sections
  172. - changed gnome help directory temporarily
  173. * Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
  174. - build for VineSeed