gnome-bluetooth-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400
  1. Summary: GNOME Bluetooth Subsystem
  2. Summary(ja): GNOME Bluetooth サブシステム
  3. Name: gnome-bluetooth
  4. Version: 3.4.0
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Libraries
  8. URL: http://live.gnome.org/GnomeBluetooth
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.4/%{name}-%{version}.tar.xz
  10. Source1: 61-gnome-bluetooth-rfkill.rules
  11. #----------------------------------------------------------------------------
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. #----------------------------------------------------------------------------
  14. #BuildRequires: autoconf >= 2.57
  15. BuildRequires: bluez-libs-devel >= 2.8
  16. #BuildRequires: bluez-utils
  17. BuildRequires: libbonobo-devel >= 2.32.0
  18. BuildRequires: libbonoboui-devel >= 2.24.4
  19. BuildRequires: hal-devel
  20. BuildRequires: unique3-devel
  21. BuildRequires: libnotify-devel
  22. BuildRequires: gnome-doc-utils
  23. BuildRequires: intltool, automake, libtool, gettext
  24. Requires: %{name}-libs = %{version}-%{release}
  25. Requires: bluez >= 4.42
  26. Requires: obexd
  27. Requires(post): desktop-file-utils
  28. Requires(postun): desktop-file-utils
  29. ExcludeArch: s390 s390x
  30. ## Patch1: gnome-bluetooth-0.8.0-desktop.patch
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: Takemikaduchi
  34. #----------------------------------------------------------------------------
  35. %description
  36. This package contains a library with widgets for Bluetooth applications.
  37. %description -l ja
  38. このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
  39. ライブラリが含まれます。
  40. #----------------------------------------------------------------------------
  41. %package libs
  42. Summary: Libraries for applications, which use gnome-bluetooth
  43. Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
  44. Group: Development/Libraries
  45. %description libs
  46. This package contains the libraries for applications,
  47. which use gnome-bluetooth.
  48. %description libs -l ja
  49. このパッケージには Gnome-bluetoothを使用するアプリケーション用の
  50. ライブラリが含まれています。
  51. #----------------------------------------------------------------------------
  52. %package devel
  53. Summary: Files for the development of applications, which use gnome-bluetooth
  54. Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
  55. Group: Development/Libraries
  56. License: LGPLv2+
  57. Requires: %{name}-libs = %{version}-%{release}
  58. Requires: gtk-doc pkgconfig
  59. Requires: glib2-devel
  60. Requires: libbtctl-devel
  61. %description devel
  62. This package contains the files for the development of applications,
  63. which will use gnome-bluetooth.
  64. %description devel -l ja
  65. このパッケージにはGnome-bluetoothを使用するアプリケーションを
  66. 開発するためのヘッダーファイルなどが含まれています(develパッケージ)
  67. #----------------------------------------------------------------------------
  68. %prep
  69. %setup -q -n gnome-bluetooth-%{version}
  70. ## %patch1 -p1 -b .dfix
  71. %build
  72. %configure \
  73. --disable-desktop-update \
  74. --disable-icon-update \
  75. --disable-nautilus-sendto \
  76. --enable-introspection=yes
  77. make %{?_smp_mflags}
  78. #----------------------------------------------------------------------------
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  82. make DESTDIR=$RPM_BUILD_ROOT install
  83. # we do not want .la files
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
  86. rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
  87. rm -f $RPM_BUILD_ROOT/%{_libdir}/control-center-1/panels/*.la
  88. install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  89. # Remove the gnome-obex-server
  90. # rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
  91. %find_lang gnome-bluetooth2
  92. %find_lang %{name} --with-gnome
  93. cat %{name}.lang >> gnome-bluetooth2.lang
  94. # save space by linking identical images in translated docs
  95. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  96. for f in $helpdir/C/figures/*.png; do
  97. b="$(basename $f)"
  98. for d in $helpdir/*; do
  99. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  100. g="$d/figures/$b"
  101. if [ -f "$g" ]; then
  102. if cmp -s $f $g; then
  103. rm "$g"; ln -s "../../C/figures/$b" "$g"
  104. fi
  105. fi
  106. fi
  107. done
  108. done
  109. %clean
  110. rm -rf $RPM_BUILD_ROOT
  111. %post
  112. update-desktop-database -q
  113. %postun
  114. update-desktop-database -q
  115. if [ $1 -eq 0 ] ; then
  116. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  117. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  118. fi
  119. %post libs
  120. /sbin/ldconfig
  121. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  122. %posttrans libs
  123. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  124. %postun libs
  125. /sbin/ldconfig
  126. if [ $1 -eq 0 ] ; then
  127. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  128. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  129. fi
  130. #----------------------------------------------------------------------------
  131. %files -f %{name}.lang
  132. %defattr(-, root, root)
  133. %doc README NEWS COPYING
  134. %{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
  135. %{_bindir}/bluetooth-*
  136. %{_libdir}/gnome-bluetooth/
  137. %{_datadir}/applications/*.desktop
  138. %{_datadir}/gnome-bluetooth/
  139. %{_datadir}/locale/*
  140. %{_mandir}/man1/*
  141. /lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  142. %files libs
  143. %defattr(-,root,root,-)
  144. %doc COPYING.LIB
  145. %{_libdir}/libgnome-bluetooth.so.*
  146. %{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
  147. %{_datadir}/icons/hicolor/*/apps/*
  148. %{_datadir}/icons/hicolor/*/status/*
  149. %files devel
  150. %defattr(-,root,root,-)
  151. %{_includedir}/gnome-bluetooth/
  152. %{_libdir}/libgnome-bluetooth.so
  153. %{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
  154. %{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
  155. %{_datadir}/gtk-doc/html/gnome-bluetooth/
  156. #----------------------------------------------------------------------------
  157. %changelog
  158. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
  159. - new upstream release
  160. - remove BuildRequires: GConf2-devel
  161. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  162. - new upstream release
  163. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  164. - new upstream release
  165. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  166. - new upstream release
  167. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  168. - new upstream release
  169. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  170. - new upstream release
  171. - change BuildRequires: unique3-devel instead of unique-devel
  172. - add BuildRequires: control-center-devel
  173. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  174. - new upstream release
  175. - remove BuildRequires: gir-repository-devel
  176. - add Requires(post) and Requires(postun): desktop-file-utils
  177. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
  178. - rebuild with rpm-4.8.1 for pkg-config file
  179. * Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  180. - new upstream release
  181. - add BuildRequires: gir-repository-devel
  182. - add configure option (--disable-nautilus-sendto)
  183. * Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  184. - new upstream release
  185. - merge spec file from FC package
  186. * Fri Oct 24 2008 Seiichirou Babasaki 0.11.0-6
  187. - Update to 0.11.0 (VineSeed)
  188. - added "# Maintainers: " comments.
  189. - changed UTF-8 encode at gnome-bluetooth.vsc.spec
  190. - FedoraCore - LOGS
  191. -- 0.11.0-5
  192. -- Rebuild against new bluez-libs
  193. -- 0.11.0-4
  194. -- Changed name of icon file(#444811)
  195. -- 0.11.0-3
  196. -- Remove gnome-obex-server, we should use gnome-user-share now
  197. -- 0.11.0-1
  198. -- gcc43 rebuild
  199. -- 0.11.0 - Update to 0.11.0
  200. -- 0.10.0 - Update to 0.10.0
  201. -- 0.9.1-4
  202. -- marked gnome-obex-server.schemas as config file
  203. -- changed upstream URL
  204. -- 0.9.1-3
  205. -- fixed wrong source URL
  206. -- 0.9.1-2
  207. -- rebuilt for F8
  208. -- changed license tag to GPLv2 and LGPLv2+
  209. -- 0.9.1-1
  210. -- Upgrade to 0.9.1 to fix a crasher in the server
  211. -- 0.9.0-1
  212. -- Update for 0.9.0
  213. -- Fix installation of the python bindings
  214. -- 0.8.0-4
  215. -- Remove unncessary gconfd killing from scripts (#224561)
  216. -- 0.8.0-3
  217. -- corrected BuildRoot
  218. -- smp flags added
  219. -- specfile cleanup
  220. -- fixed desktop file
  221. - Updated specfile
  222. * Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
  223. - Updated specfile
  224. * Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
  225. - Import gnome-bluetooth - Packager: Babasaki
  226. - Updated specfile (downgrade -> 0.8.0-0vl1)
  227. #----------------------------------------------------------------------------
  228. * Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
  229. - version 0.8.0
  230. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
  231. - rebuild
  232. * Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
  233. - bump for new openobex
  234. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
  235. - Missing automake, libtool, gettext BR
  236. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
  237. - Bump for new libbluetooth
  238. * Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
  239. - add dependency on bluez-utils, cosmetic tweaks (bug #190280)
  240. * Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
  241. - install schemata correctly (bug #193518)
  242. * Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
  243. - more build requires (bug #193374)
  244. * Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
  245. - pydir fixes for lib64
  246. * Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
  247. - version 0.7.0
  248. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
  249. - bump again for double-long bug on ppc(64)
  250. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
  251. - rebuilt for new gcc4.1 snapshot and glibc changes
  252. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  253. - rebuilt
  254. * Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
  255. - Fix relative path for the icons in desktop files which no longer works
  256. with the icon cache.
  257. * Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
  258. - new version 0.6.0
  259. * Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
  260. - rebuild for new cairo
  261. * Thu Jul 7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
  262. - Minor spec file cleanups.
  263. - Fix relative path for the icons in desktop files which no longer works
  264. with the icon cache.
  265. - Remove useless zero epochs.
  266. - Remove explicit python abi requirement, it's automatic for FC4 and up.
  267. * Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
  268. - removed base requirement from libs
  269. * Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
  270. - devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
  271. * Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
  272. - rebuilt
  273. * Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
  274. - added gnome hbox patch for bug rh#149215
  275. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
  276. - added requires for python-abi
  277. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
  278. - split package into app, libs and devel
  279. * Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
  280. - fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
  281. * Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
  282. - buildrequire pygtk2-devel (bug 135032)
  283. - fixed gnome-bluetooth-manager script for 64bit (bug 134864)
  284. - fixed segfault on file receive (bug 133041)
  285. * Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
  286. - buildrequire libbtctl-devel
  287. - buildrequire openobex-devel >= 1.0.1
  288. - pythondir -> pyexecdir
  289. * Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
  290. - added build dependency for librsvg2-devel
  291. * Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
  292. - added pydir patch
  293. * Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
  294. - version 0.5.1
  295. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  296. - rebuilt
  297. * Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
  298. - corrected BuildRequires
  299. * Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
  300. - added EggToolBar patch for gcc34
  301. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  302. - rebuilt
  303. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  304. - rebuilt
  305. * Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
  306. - added autofoo patch
  307. * Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
  308. - add .so to gnome-vfs module, if libtool does not!
  309. * Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
  310. - call libtool finish
  311. * Wed Aug 6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
  312. - new version 0.4.1
  313. * Wed Jun 5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
  314. - initial RPM