gnome-power-manager-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338
  1. %define dbus_version 1.4.16
  2. %define dbus_glib_version 0.96
  3. %define gnome_panel_version 3.4.0
  4. Summary: GNOME power management service
  5. Summary(ja): GNOME 電源管理ツール
  6. Name: gnome-power-manager
  7. Version: 3.4.0
  8. Release: 1%{?_dist_release}
  9. License: GPLv2+ and GFDL
  10. Group: Applications/System
  11. URL: http://projects.gnome.org/gnome-power-manager/
  12. Source0: http://download.gnome.org/sources/gnome-power-manager/3.4/gnome-power-manager-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: autoconf >= 2.65
  15. BuildRequires: gtk3-devel
  16. BuildRequires: libgnomeui-devel
  17. BuildRequires: libglade2-devel
  18. BuildRequires: libwnck-devel
  19. BuildRequires: dbus-devel >= %{dbus_version}
  20. BuildRequires: libnotify-devel
  21. BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
  22. BuildRequires: scrollkeeper
  23. BuildRequires: gnome-doc-utils >= 0.3.2
  24. BuildRequires: desktop-file-utils
  25. BuildRequires: gettext
  26. BuildRequires: libtool
  27. BuildRequires: cairo-devel
  28. BuildRequires: libcanberra-gtk3-devel
  29. BuildRequires: unique3-devel >= 3.0.0
  30. ## BuildRequires: DeviceKit-power-devel >= 008
  31. BuildRequires: upower-devel >= 0.9.0
  32. BuildRequires: control-center-devel
  33. BuildRequires: intltool
  34. BuildRequires: docbook-utils
  35. Requires: gtk3 >= 3.0.0
  36. Requires: gnome-mime-data
  37. Requires: gnome-icon-theme
  38. Requires: libnotify >= 0.4.3
  39. Requires: dbus-glib >= %{dbus_glib_version}
  40. Requires: dbus-x11 >= %{dbus_version}
  41. Requires: libcanberra-gtk3 >= 0.10
  42. Requires: unique3 >= 3.0.0
  43. Requires: upower >= 0.9.0
  44. Requires(post,postun): scrollkeeper
  45. Requires(post,pre,preun): GConf2
  46. Obsoletes: gnome-power-manager-extra < 3.0.0
  47. Provides: gnome-power-manager-extra
  48. Vendor: Project Vine
  49. Distribution: Vine Linux
  50. Packager: daisuke, Takemikaduchi
  51. %description
  52. GNOME Power Manager uses the information and facilities provided by HAL
  53. displaying icons and handling user callbacks in an interactive GNOME session.
  54. GNOME Power Preferences allows authorised users to set policy and
  55. change preferences.
  56. %prep
  57. %setup -q
  58. %build
  59. %configure \
  60. --disable-scrollkeeper
  61. make
  62. %install
  63. rm -rf $RPM_BUILD_ROOT
  64. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  65. make install DESTDIR=$RPM_BUILD_ROOT
  66. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  67. #desktop-file-install --vendor gnome --delete-original \
  68. # --dir $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart \
  69. # $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/gnome-power-manager.desktop
  70. # save space by linking identical images in translated docs
  71. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  72. for f in $helpdir/C/figures/*.png; do
  73. b="$(basename $f)"
  74. for d in $helpdir/*; do
  75. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  76. g="$d/figures/$b"
  77. if [ -f "$g" ]; then
  78. if cmp -s $f $g; then
  79. rm "$g"; ln -s "../../C/figures/$b" "$g"
  80. fi
  81. fi
  82. fi
  83. done
  84. done
  85. %find_lang %name --with-gnome
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post
  89. scrollkeeper-update -q &> /dev/null || :
  90. touch --no-create %{_datadir}/icons/hicolor
  91. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  92. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  93. fi
  94. %postun
  95. scrollkeeper-update -q &> /dev/null || :
  96. touch --no-create %{_datadir}/icons/hicolor
  97. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  98. gtk-update-icon-cache -q %{_datadir}/icons/hicolor &> /dev/null || :
  99. fi
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. %posttrans
  102. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  103. %files -f %{name}.lang
  104. %defattr(-,root,root)
  105. %doc AUTHORS COPYING README
  106. %{_bindir}/gnome-power-statistics
  107. %dir %{_datadir}/gnome-power-manager
  108. %{_datadir}/applications/gnome-power-statistics.desktop
  109. %{_datadir}/glib-2.0/schemas/*.xml
  110. %{_datadir}/gnome-power-manager/icons/hicolor/*/*/*.*
  111. %{_datadir}/icons/hicolor/*/apps/*
  112. %{_mandir}/man1/gnome-power-statistics.1.gz
  113. %changelog
  114. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
  115. - new upstream release
  116. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  117. - new upstream release
  118. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  119. - new upstream release
  120. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  121. - new upstream release
  122. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
  123. - new upstream release
  124. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.3-1
  125. - new upstream release
  126. - add BuildRequires: gtk3-devel, control-center-devel
  127. - change BuildRequires: libcanberra-gtk3-devel instead of licanberra-devel
  128. - change BuildRequires: unique3-devel instead of unique-devel
  129. - delete -extra sub package
  130. * Sat Oct 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
  131. - add Source101(gnome-power-manager.gnome-2-32.ja.po)
  132. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  133. - new upstream release
  134. - change BuildRequires: gnome-panel-devel instead of gnome-panel
  135. - fix %files
  136. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  137. - new upstream release
  138. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  139. - new upstream release
  140. - remove Patch1, Patch2, Patch3
  141. - change BuildRequires: DeviceKit-power-devel -> upower-devel
  142. - change Requires: DeviceKit-power -> upower
  143. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  144. - new upstream release
  145. - change BuildRequires: xmlto -> docbook-utils
  146. - remove BuildReuiqres: hal-devel
  147. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  148. - new upstream release
  149. * Tue Dec 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  150. - merge spec file from FC package
  151. - add Patch1, Patch2 and Patch3 from FC package
  152. - add Patch10 and Patch11 for Vine Linux
  153. - remove configure option --enable-policykit
  154. - add new package (extra)
  155. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.4-1
  156. - new upstream release
  157. * Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  158. - new upstream release
  159. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  160. - new upstream release
  161. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  162. - new upstream release
  163. * Sun Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.2-0vl1
  164. - new upstream release
  165. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl2
  166. - rebuild with new environment/toolchain
  167. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
  168. - new upstream release
  169. - drop Patch10 to enable suspend-to-ram.
  170. * Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-0vl1
  171. - new upstream release
  172. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.91-0vl1
  173. - new upstream release
  174. * Mon Jul 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.90-0vl1
  175. - new upstream release
  176. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.3-0vl1
  177. - new upstream release
  178. * Wed May 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.2-0vl1
  179. - new upstream release
  180. * Wed Apr 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.1-0vl1
  181. - new upstream release
  182. * Mon Apr 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-0vl1
  183. - new upstream release
  184. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  185. - new upstream release
  186. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  187. - add Patch10 to disable suspend-to-ram by default.
  188. * Thu Mar 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  189. - update ja.po from CVS head.
  190. * Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  191. - new upstream release
  192. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
  193. - initial build for Vine Linux based on FC package
  194. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-4
  195. - fix the fix in -2 and -3
  196. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-3
  197. - fix the fix in -2
  198. * Mon Mar 6 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-2
  199. - fix icon in bubbles (bug 184192).
  200. * Fri Mar 3 2006 Ray Strode <rstrode@redhat.com> - 2.13.93-1
  201. - Update to 2.13.93
  202. - ignore d-bus timeout errors
  203. * Thu Mar 2 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-3
  204. - Add patch from Richard Hughes to potentially fix a
  205. crasher bug (bug 183127)
  206. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.92-2
  207. - Buildrequires: gnome-doc-utils
  208. * Sun Feb 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.92-1
  209. - Update to 2.13.92
  210. * Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.91-1
  211. - Update to 2.13.91
  212. - Drop upstreamed patch
  213. * Wed Feb 15 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.90-1
  214. - Update to 2.13.90
  215. - Require dbus-x11 (#176656)
  216. * Sun Feb 13 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-2
  217. - remove Hibernate and Suspend from menus as part of
  218. panel/g-p-m integration effort
  219. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5.0.20060207-1.1
  220. - bump again for double-long bug on ppc(64)
  221. * Tue Feb 7 2006 Ray Strode <rstrode@redhat.com> - 2.13.5.0.20060207-1
  222. - pull cvs snapshot from HEAD and drop the patches caillon
  223. just added
  224. * Tue Feb 7 2006 Christopher Aillon <caillon@redhat.com> - 2.13.5-3
  225. - Install into the autostart directory
  226. - Don't suspend on lid close while on AC power
  227. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.13.5-2.1
  228. - rebuilt for new gcc4.1 snapshot and glibc changes
  229. * Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> - 2.13.5-2
  230. - rebuild
  231. * Thu Jan 26 2006 Ray Strode <rstrode@redhat.com> - 2.13.5-1
  232. - packaging tweaks
  233. * Thu Jan 26 2006 Christopher Aillon <caillon@redhat.com> 2.13.5-1
  234. - Update to 2.13.5
  235. * Tue Jan 24 2006 Christopher Aillon <caillon@redhat.com> - 0.3.4-2
  236. - Left clicking on the applet should bring up the menu
  237. * Tue Jan 17 2006 Ray Strode <rstrode@redhat.com> - 0.3.4-1
  238. - update to 0.3.4
  239. - disable updating scrollkeeper database in buildroot
  240. (move to %%post)
  241. * Fri Jan 6 2006 Jeremy Katz <katzj@redhat.com> - 0.3.3-0.cvs.20060106
  242. - update to a cvs snap so that it works with hal cvs snap
  243. - make sure we use libnotify
  244. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> - 0.3.1-2.1
  245. - rebuilt
  246. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.3.1-2
  247. - rebuild for new dbus
  248. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> 0.3.1-1
  249. - Update to 0.3.1
  250. * Fri Nov 25 2005 Christopher Aillon <caillon@redhat.com> 0.3.0-1
  251. - Update to 0.3.0
  252. * Wed Oct 19 2005 Ray Strode <rstrode@redhat.com> 0.2.8-1
  253. - update to 0.2.8
  254. * Wed Oct 3 2005 Ray Strode <rstrode@redhat.com> 0.2.6-1
  255. - update to 0.2.6
  256. * Wed Sep 28 2005 Ray Strode <rstrode@redhat.com> 0.2.4-1
  257. - update to 0.2.4
  258. * Fri Sep 02 2005 David Zeuthen <davidz@redhat.com> 0.2.3.1-1
  259. - Initial import based on an SRPM from Richard Hughes