gnome-shell-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206
  1. %define pkg_version 3.4.1
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.xz
  8. # settings for Vine
  9. Patch101: gnome-shell-vine-settings.patch
  10. Patch103: gnome-shell-ja.po-date.patch
  11. License: GPLv2+
  12. Group: User Interface/Desktops
  13. URL: http://live.gnome.org/GnomeShell
  14. Requires(post,postun): scrollkeeper >= 0.1.4
  15. Requires: mutter
  16. Requires: caribou
  17. Requires: openssl
  18. Requires: at-spi2-atk
  19. BuildRequires: gnome-common
  20. BuildRequires: libtool
  21. BuildRequires: automake
  22. BuildRequires: autoconf
  23. BuildRequires: pkgconfig
  24. BuildRequires: gtk2-devel
  25. BuildRequires: clutter-devel
  26. BuildRequires: mutter-devel
  27. BuildRequires: gjs-devel
  28. BuildRequires: gnome-desktop3-devel
  29. BuildRequires: gnome-menus-devel
  30. BuildRequires: libSM-devel
  31. BuildRequires: libffi-devel
  32. BuildRequires: startup-notification-devel
  33. BuildRequires: gnome-doc-utils
  34. BuildRequires: desktop-file-utils
  35. BuildRequires: libcroco-devel
  36. BuildRequires: librsvg2-devel
  37. BuildRequires: gobject-introspection-devel
  38. BuildRequires: gcr-devel
  39. BuildRequires: gstreamer-devel
  40. BuildRequires: dbus-glib-devel
  41. BuildRequires: telepathy-logger-devel
  42. BuildRequires: polkit-devel
  43. BuildRequires: pulseaudio-libs-devel
  44. BuildRequires: evolution-data-server-devel
  45. BuildRequires: folks-devel
  46. BuildRequires: NetworkManager-glib-devel
  47. BuildRequires: libgudev1-devel
  48. BuildRequires: openssl
  49. BuildRequires: intltool
  50. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  51. Vendor: Project Vine
  52. Distribution: Vine Linux
  53. Packager: Takemikaduchi
  54. %description
  55. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  56. It provides core interface functions like switching to windows and launching
  57. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  58. hardware and introduces innovative user interface concepts to provide a delightful
  59. and easy to use experience.
  60. %prep
  61. %setup -q
  62. %patch101 -p1 -b .vine
  63. %patch103 -p1 -b .old_po2
  64. %build
  65. libtoolize --copy --force
  66. autoreconf
  67. %configure \
  68. --disable-static \
  69. --with-ca-certificates=%{_datadir}/ssl/certs/ca-bundle.crt
  70. %{__make} %{?_smp_mflags}
  71. %install
  72. %{__rm} -rf ${RPM_BUILD_ROOT}
  73. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  74. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  75. %find_lang %{name}
  76. %clean
  77. %{__rm} -rf ${RPM_BUILD_ROOT}
  78. %post
  79. /sbin/ldconfig
  80. touch --no-create %{_datadir}/icons/hicolor
  81. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  82. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  83. fi
  84. %postun
  85. /sbin/ldconfig
  86. touch --no-create %{_datadir}/icons/hicolor
  87. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  88. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  89. fi
  90. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  91. %posttrans
  92. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  93. %files -f %{name}.lang
  94. %defattr(-,root,root)
  95. %doc COPYING NEWS README
  96. %{_bindir}/gnome-shell
  97. %{_bindir}/gnome-shell-extension-tool
  98. %{_bindir}/gnome-shell-extension-prefs
  99. %{_libdir}/gnome-shell/*
  100. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  101. %{_libexecdir}/gnome-shell-calendar-server
  102. %{_libexecdir}/gnome-shell-hotplug-sniffer
  103. %{_libexecdir}/gnome-shell-perf-helper
  104. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  105. %{_datadir}/applications/gnome-shell.desktop
  106. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  107. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  108. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  109. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  110. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  111. %{_datadir}/gnome-shell/*
  112. %{_datadir}/gtk-doc/html/shell
  113. %{_datadir}/gtk-doc/html/st
  114. %{_datadir}/man/man1/*.1.gz
  115. %changelog
  116. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  117. - new upstream release
  118. - update Patch101,103
  119. - remove Patch0,102
  120. - add BuildRequires: gcr-devel
  121. - remove BuildRequires: GConf2-devel
  122. - add Requires: at-spi2-atk
  123. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  124. - new upstream release
  125. - remove Patch1
  126. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  127. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  128. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  129. - rename Patch103 (gnome-shell-ja.po-date.patch)
  130. - drop Patch102
  131. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  132. - new upstream release
  133. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  134. - new upstream release
  135. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  136. - new upstream release
  137. - update Patch101
  138. - update Patch102
  139. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  140. - add BuildRequires: libgudev1-devel, openssl
  141. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  142. - new upstream release
  143. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  144. - add Requires: caribou
  145. - remove Patch0
  146. - update Patch101
  147. - update Patch102
  148. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  149. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  150. - rebuild with gnome-menus-3.1.5
  151. - add Patch0 (gnome-shell-git20110821.patch)
  152. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  153. - new upstream release
  154. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  155. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  156. - remove BuildRequires: xulrunner-devel
  157. - add Patch101 (gnome-shell-vine-settings.patch)
  158. - add Patch102 (gnome-shell-vine-customize.patch)
  159. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  160. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  161. - add Requires: mutter
  162. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  163. - new upstream release
  164. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  165. - initial build for Vine Linux