cpdf-vl.spec 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. %define pkg_name cpdf
  2. %define pkg_version 2.2
  3. %define patchlevel 1
  4. %define pkg_release 1%{?_dist_release}
  5. Summary: Command Line Tools allow you to manipulate existing PDF files
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}.p%{patchlevel}
  8. Release: %{pkg_release}
  9. License: Coherent Graphics Ltd Non-Commercial Use License Agreement
  10. Group: Applications/Publishing
  11. URL: http://community.coherentpdf.com/
  12. Source0: cpdf-source-%{pkg_version}-patchlevel%{patchlevel}.tar.gz
  13. # Source0: camlpdf-%{version}.tar.gz
  14. BuildRequires: readline-devel
  15. BuildRequires: ocaml
  16. BuildRequires: ocaml-findlib
  17. BuildRequires: ocaml-camlpdf
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. The Coherent PDF Command Line Tools allow you to manipulate
  22. existing PDF files in a variety of ways.
  23. For example:
  24. - Merge PDF files together, or split them apart Encrypt and decrypt
  25. - Scale, crop and rotate pages
  26. - Read and set document info and metadata
  27. - Copy, add or remove bookmarks
  28. - Stamp logos, text, dates, page numbers
  29. - Add or remove attachments
  30. - Losslessly compress PDF files
  31. [caution]
  32. Now we're releasing them for free, under a special not-for-commercial-use
  33. license If you like the tools and want to use them commercially,
  34. or need support, licenses are available from Coherent Graphics Ltd.
  35. #'
  36. %description -l ja
  37. Coherent PDF は PDF ファイルを操作するためのコマンドラインツールです。
  38. [注意1]
  39. このアプリケーションは「非商用に限り」フリーで使用できます。
  40. 詳しくは LICENCE を参照して下さい。
  41. %package libs
  42. Summary: OCaml library for Coherent PDF
  43. Group: Development/Languages
  44. Requires: ocaml
  45. Requires: ocaml-findlib
  46. Requires: ocaml-camlpdf
  47. %description libs
  48. %{summary}
  49. %prep
  50. %{__rm} -rf ${RPM_BUILD_ROOT}
  51. %setup -q -n %{name}-source-%{pkg_version}-patchlevel%{patchlevel}
  52. %build
  53. LDFLAGS="-ltinfo" %{__make}
  54. %install
  55. # for binary
  56. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_bindir}
  57. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_mandir}/man1
  58. %{__cp} cpdf ${RPM_BUILD_ROOT}%{_bindir}
  59. %{__cp} cpdf.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
  60. # for libs
  61. INSTALLDIR=${RPM_BUILD_ROOT}%{_libdir}/ocaml
  62. %{__mkdir_p} ${INSTALLDIR}
  63. %{__make} install \
  64. OCAMLFIND_INSTFLAGS="-destdir ${INSTALLDIR}"
  65. %clean
  66. %{__rm} -rf ${RPM_BUILD_ROOT}
  67. %post libs
  68. echo "%{_libdir}/ocaml/%{pkg_name}" >> %{_libdir}/ocaml/ld.conf
  69. %preun libs
  70. %{__perl} -pi -e "s|^%{_libdir}/ocaml/%{pkg_name}\n$||" \
  71. %{_libdir}/ocaml/ld.conf
  72. %files
  73. %doc doc/cpdf/html
  74. %doc Changes LICENSE cpdfmanual.pdf
  75. %{_bindir}/cpdf
  76. %{_mandir}/man1/*
  77. %files libs
  78. %{_libdir}/ocaml/cpdf
  79. %changelog
  80. * Sun Apr 15 2018 Toshiaki Ara <ara_t@384.jp> 2.2-pachlevel1
  81. - initial build for Vine Linux