zlib-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: The zlib compression and decompression library.
  3. Summary(ja): zlib 圧縮/展開ライブラリ
  4. Name: zlib
  5. Version: 1.2.11
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Source: http://www.zlib.net/zlib-%{version}.tar.xz
  9. # Patch0: zlib-1.2.5-lfs-decls.patch
  10. Requires(post): /sbin/ldconfig
  11. Requires(postun): /sbin/ldconfig
  12. URL: http://www.zlib.net/
  13. License: zlib and Boost
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. The zlib compression library provides in-memory compression and
  19. decompression functions, including integrity checks of the
  20. uncompressed data. This version of the library supports only one
  21. compression method (deflation), but other algorithms may be added
  22. later, which will have the same stream interface. The zlib library is
  23. used by many different system programs.
  24. %description -l ja
  25. zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
  26. のデータの整合性チェックを行う関数を提供します。今バージョンのラ
  27. イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
  28. ートしていますが、今後同じストリームインターフェースを持つ他の圧
  29. 縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
  30. 用されています。
  31. %package devel
  32. Summary: Header files and libraries for developing apps which will use zlib.
  33. Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. The zlib-devel package contains the header files and libraries needed
  38. to develop programs that use the zlib compression and decompression
  39. library.
  40. %package static
  41. Summary: Static libraries for %{name}
  42. Summary(ja): %{name} のスタティックライブラリ
  43. Group: Development/Libraries
  44. Requires: %{name}-devel = %{version}-%{release}
  45. %description static
  46. The zlib-static package contains the static library for %{name}
  47. ## to build compat32 for x86_64 architecture support
  48. %package -n compat32-%{name}
  49. Summary: The zlib compression and decompression library.
  50. Summary(ja): zlib 圧縮/展開ライブラリ
  51. Group: System Environment/Libraries
  52. Requires: %{name} = %{version}-%{release}
  53. Requires(post): /sbin/ldconfig
  54. Requires(postun): /sbin/ldconfig
  55. %description -n compat32-%{name}
  56. The zlib compression library provides in-memory compression and
  57. decompression functions, including integrity checks of the
  58. uncompressed data. This version of the library supports only one
  59. compression method (deflation), but other algorithms may be added
  60. later, which will have the same stream interface. The zlib library is
  61. used by many different system programs.
  62. %description -n compat32-%{name} -l ja
  63. zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
  64. のデータの整合性チェックを行う関数を提供します。今バージョンのラ
  65. イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
  66. ートしていますが、今後同じストリームインターフェースを持つ他の圧
  67. 縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
  68. 用されています。
  69. %package -n compat32-%{name}-devel
  70. Summary: Header files and libraries for developing apps which will use zlib.
  71. Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  72. Group: Development/Libraries
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: %{name}-devel = %{version}-%{release}
  75. %description -n compat32-%{name}-devel
  76. The zlib-devel package contains the header files and libraries needed
  77. to develop programs that use the zlib compression and decompression
  78. library.
  79. Install the zlib-devel package if you want to develop applications that
  80. will use the zlib library.
  81. %prep
  82. %setup -q
  83. # %patch0 -p1
  84. %build
  85. mkdir static shared
  86. # build shared lib
  87. CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
  88. make %{?_smp_mflags}
  89. mv -f Makefile zconf.h *.o *.so* shared/
  90. # build static lib
  91. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
  92. make %{?_smp_mflags}
  93. mv -f Makefile zconf.h *.o *.a static/
  94. %install
  95. rm -rf ${RPM_BUILD_ROOT}
  96. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
  97. mv -f shared/* .
  98. make install prefix=${RPM_BUILD_ROOT}%{_prefix}
  99. mv -f Makefile zconf.h *.o *.so* shared/
  100. mv -f static/* .
  101. make install prefix=${RPM_BUILD_ROOT}%{_prefix}
  102. install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
  103. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
  104. install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
  105. if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
  106. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  107. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
  108. rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
  109. fi
  110. cat %{buildroot}/usr/include/zlib.h | sed -n '1,/*\//p' > LICENSE
  111. %clean
  112. rm -rf ${RPM_BUILD_ROOT}
  113. %post -p /sbin/ldconfig
  114. %postun -p /sbin/ldconfig
  115. %post -n compat32-%{name} -p /sbin/ldconfig
  116. %postun -n compat32-%{name} -p /sbin/ldconfig
  117. %files
  118. %defattr(-,root,root)
  119. %license LICENSE
  120. %doc README
  121. %{_libdir}/*.so
  122. %{_libdir}/libz.so.*
  123. %files devel
  124. %defattr(-,root,root)
  125. %doc ChangeLog doc/algorithm.txt
  126. %{_libdir}/pkgconfig/zlib.pc
  127. %{_includedir}/*
  128. %{_mandir}/man3/zlib.3*
  129. %files static
  130. %defattr(-,root,root)
  131. %{_libdir}/*.a
  132. %if %{build_compat32}
  133. %files -n compat32-%{name}
  134. %defattr(-,root,root)
  135. %{_libdir}/libz.so.*
  136. %files -n compat32-%{name}-devel
  137. %defattr(-,root,root)
  138. %{_libdir}/*.so
  139. %{_libdir}/pkgconfig/zlib.pc
  140. %endif
  141. %changelog
  142. * Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-1
  143. - new upstream release.
  144. - added license text.
  145. - reverted moving libz.so for compat32 package.
  146. * Sat Mar 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.8-2
  147. - moved libz.so into the main package.
  148. * Fri Mar 21 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.8-1
  149. - new upstream release
  150. - changed archive type bz2 to xz
  151. * Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.2.7-1
  152. - new upstream release
  153. - drop patch0 (resolved by upstream)
  154. - use smp flag in make section
  155. * Fri Oct 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-2
  156. - added patch0 from gentoo to fix zlib.h errors on i686 compiling some applications
  157. * Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
  158. - new upstream release (built with rpm-4.8.1-1 for pkg-config file)
  159. - changed License: BSD to zlib and Boost
  160. - added %%{_libdir}/pkgconfig/zlib.pc in -devel package
  161. - fixed %%doc files in -devel package
  162. * Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
  163. - add Requires(post,pre): /sbin/ldconfig
  164. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
  165. - rebuilt with gcc-4.4.3-3 on ppc
  166. * Mon Feb 8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
  167. - rebuilt with new toolchain
  168. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
  169. - split static library to zlib-static
  170. - needed by tuxonice-userui
  171. * Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
  172. - change spec into UTF-8
  173. * Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
  174. - removed %%if !%%{build_compat32} case condition
  175. * Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
  176. - applied new versioning policy
  177. - rebuilt with new toolchains
  178. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
  179. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  180. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
  181. - added compat32-* packages for x86_64 architecture support
  182. * Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
  183. - added compat32- packages for x86_64 architecture support
  184. * Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
  185. - clean up specfile (do not build twice..)
  186. * Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  187. - new upstream release
  188. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
  189. - new upstream release
  190. - add Patch1 for CAN-2005-2096
  191. * Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  192. - new upstream version
  193. - add translated descriptions (thanks to spec file translation project)
  194. * Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
  195. - fixed buffer overrun on gzprintf
  196. -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
  197. * Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
  198. - changed URL to more preferable site
  199. * Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
  200. - upstream release
  201. * Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  202. - 1.1.3-14vl1
  203. - based on 1.1.3-14 from Rawhide
  204. - added Japanese summary
  205. * Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  206. - add -fPIC for shared libs (patch by Fritz Elfert)
  207. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  208. - on 64bit systems, make sure libraries are located correctly.
  209. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  210. - summaries from specspo.
  211. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  212. - automatic rebuild
  213. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  214. - rebuild
  215. * Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
  216. - FHS packaging to build on solaris2.5.1.
  217. * Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
  218. - use %%{_mandir} and %%{_tmppath}
  219. * Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
  220. - updated URL and source location
  221. - moved README to main package
  222. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  223. - compress man page.
  224. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  225. - auto rebuild in the new build environment (release 5)
  226. * Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
  227. - link against glibc
  228. * Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
  229. - upgrade to 1.1.3
  230. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  231. - translations modified for de, fr, tr
  232. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  233. - upgraded to 1.1.2
  234. - buildroot
  235. * Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
  236. - added URL tag (down at the moment so it may not be correct)
  237. - made zlib-devel require zlib
  238. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  239. - built against glibc