popt-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: C library for parsing command line parameters
  3. Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
  4. Name: popt
  5. Version: 1.16
  6. Release: 2%{?_dist_release}
  7. License: MIT
  8. Group: System Environment/Libraries
  9. URL: http://www.rpm5.org/
  10. Source0: http://www.rpm5.org/files/%{name}/%{name}-%{version}.tar.gz
  11. BuildRequires: gettext, doxygen, graphviz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. %description
  16. Popt is a C library for parsing command line parameters. Popt was
  17. heavily influenced by the getopt() and getopt_long() functions, but
  18. it improves on them by allowing more powerful argument expansion.
  19. Popt can parse arbitrary argv[] style arrays and automatically set
  20. variables based on command line arguments. Popt allows command line
  21. arguments to be aliased via configuration files and includes utility
  22. functions for parsing arbitrary strings into argv[] arrays using
  23. shell-like rules.
  24. %description -l ja
  25. Poptはコマンドパラメータを文法解析するためのCライブラリです。
  26. Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
  27. もっと強力な引数の拡張を施すことによって、それらをもっと進化
  28. させています。Poptは 任意の argv[]形式配列を解析して、コマンド
  29. ライン引数に基づいて変数を自動的に設定します。
  30. Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
  31. 許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
  32. てargv[]配列に変換したりするユーティリティ関数を含んでいます。
  33. %package devel
  34. Summary: Development files for the popt library
  35. Summary(ja): popt ライブラリの開発ファイル
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. %description devel
  39. The popt-devel package includes header files and libraries necessary
  40. for developing programs which use the popt C library. It contains the
  41. API documentation of the popt library, too.
  42. %package static
  43. Summary: Static library for %{name}
  44. Summary(ja): %{name} のスタティックライブラリ
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. %description static
  48. The %{name}-static package contains the static library for %{name}.
  49. %package -n compat32-%{name}
  50. Summary: A C library for parsing command line parameters.
  51. Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. %description -n compat32-%{name}
  55. Popt is a C library for parsing command line parameters. Popt was
  56. heavily influenced by the getopt() and getopt_long() functions, but it
  57. improves on them by allowing more powerful argument expansion. Popt
  58. can parse arbitrary argv[] style arrays and automatically set
  59. variables based on command line arguments. Popt allows command line
  60. arguments to be aliased via configuration files and includes utility
  61. functions for parsing arbitrary strings into argv[] arrays using
  62. shell-like rules.
  63. %description -n compat32-%{name} -l ja
  64. Poptはコマンドパラメータを文法解析するためのCライブラリです。
  65. Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
  66. もっと強力な引数の拡張を施すことによって、それらをもっと進化
  67. させています。Poptは 任意の argv[]形式配列を解析して、コマンド
  68. ライン引数に基づいて変数を自動的に設定します。
  69. Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
  70. 許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
  71. てargv[]配列に変換したりするユーティリティ関数を含んでいます。
  72. %package -n compat32-%{name}-devel
  73. Summary: Development files for the popt library
  74. Summary(ja): popt ライブラリの開発ファイル
  75. Group: Development/Libraries
  76. Requires: compat32-%{name} = %{version}-%{release}
  77. Requires: %{name}-devel = %{version}-%{release}
  78. %description -n compat32-%{name}-devel
  79. The popt-devel package includes header files and libraries necessary
  80. for developing programs which use the popt C library. It contains the
  81. API documentation of the popt library, too.
  82. %prep
  83. %setup -q
  84. sed -i "s|libdir=@libdir@|libdir=@prefix@@libdir@|" popt.pc.in
  85. %ifarch x86_64
  86. sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.am
  87. sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.in
  88. %endif
  89. %build
  90. %configure --libdir=/%{_lib}
  91. make %{?_smp_mflags}
  92. doxygen
  93. %install
  94. rm -rf $RPM_BUILD_ROOT
  95. make DESTDIR=$RPM_BUILD_ROOT install
  96. # Move libpopt.{so,a} to %{_libdir}
  97. rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
  98. pushd $RPM_BUILD_ROOT/%{_lib}
  99. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  100. ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
  101. popd
  102. mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
  103. # Multiple popt configurations are possible
  104. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
  105. %find_lang %{name}
  106. %clean
  107. rm -rf $RPM_BUILD_ROOT
  108. %post -p /sbin/ldconfig
  109. %postun -p /sbin/ldconfig
  110. %post -n compat32-%{name} -p /sbin/ldconfig
  111. %postun -n compat32-%{name} -p /sbin/ldconfig
  112. %files -f %{name}.lang
  113. %defattr(-,root,root)
  114. %doc CHANGES COPYING
  115. %{_sysconfdir}/popt.d
  116. /%{_lib}/libpopt.so.*
  117. %files devel
  118. %defattr(-,root,root)
  119. %doc README doxygen/html
  120. %{_libdir}/libpopt.so
  121. %{_libdir}/pkgconfig/popt.pc
  122. %{_includedir}/popt.h
  123. %{_mandir}/man3/popt.3*
  124. %files static
  125. %defattr(-,root,root)
  126. %{_libdir}/libpopt.a
  127. %if %{build_compat32}
  128. %files -n compat32-%{name}
  129. %defattr(-,root,root)
  130. /%{_lib}/libpopt.so.*
  131. %files -n compat32-%{name}-devel
  132. %defattr(-,root,root)
  133. %{_libdir}/libpopt.so
  134. %endif
  135. %changelog
  136. * Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-2
  137. - rebuild with VineSeed environment
  138. * Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-1
  139. - update to 1.16
  140. - create %{name}-static sub package
  141. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
  142. - rebuilt with rpm-4.8.1-3
  143. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
  144. - rebuilt with new toolchain
  145. * Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
  146. - updated Requires: and %%files section on compat32 subpackages
  147. * Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
  148. - added %%define build_compat32
  149. - fixed compat32 directories
  150. * Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
  151. - initial build for Vine Linux
  152. - splitted out from rpm, based on rpm5.org source.
  153. - move libpopt to /lib[64] from /usr/lib[64]
  154. - initscripts-8 uses libpopt.
  155. * Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
  156. - Solved multilib problems at doxygen generated files (#342921)
  157. * Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
  158. - Revert the broken bind_textdomain_codeset() patch (#433324)
  159. * Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
  160. - Added patch to work around missing bind_textdomain_codeset()
  161. * Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
  162. - Upgrade to 1.13 (#290531, #332201, #425803)
  163. - Solved multilib problems at doxygen generated files (#342921)
  164. * Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
  165. - Added buildrequirement to graphviz (#249352)
  166. - Backported bugfixes from CVS (#102254, #135428 and #178413)
  167. * Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
  168. - Move libpopt to /lib[64] (#249814)
  169. - Generate API documentation, added buildrequirement to doxygen
  170. * Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
  171. - Changes to match with Fedora Packaging Guidelines (#249352)
  172. * Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
  173. - release popt-1.12 through rpm5.org.
  174. * Sat Jun 9 2007 Jeff Johnson <jbj@rpm5.org>
  175. - release popt-1.11 through rpm5.org.
  176. * Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
  177. - released 1.2.2; see CHANGES
  178. * Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
  179. - added man page to default install
  180. * Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
  181. - see CHANGES file for 1.2
  182. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  183. - added ./configure step to spec file