texlive-macros-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352
  1. ## -*- coding: utf-8-unix -*-
  2. %define jlisting_ver 0.2
  3. %define bkmk2uni convert-bkmk2uni
  4. %define list_macros \
  5. jlisting-%{jlisting_ver}
  6. Summary: A collection of useful macro packages for TeX Live
  7. Summary(ja): TeX Live の便利なマクロパッケージ集
  8. Name: texlive-macros
  9. Version: 2014
  10. Release: 1%{?_dist_release}
  11. License: distributable
  12. Group: Applications/Publishing
  13. ## Vine Linux
  14. ## jlisting
  15. Source20: http://prdownloads.sourceforge.jp/mytexpert/26068/jlisting.sty.bz2
  16. ## misc
  17. Source101: http://auemath.aichi-edu.ac.jp/~khotta/ghost/disk1/jtygm.sty
  18. Source102: http://mirrors.ctan.org/obsolete/support/pdftexenc/cmex.enc
  19. #Requires: perl
  20. Requires: texlive-common = %{version}
  21. BuildRequires: texlive-vtlpkg = %{version}
  22. Buildroot: %{_tmppath}/%{name}-%{version}-root
  23. BuildArch: noarch
  24. Obsoletes: tetex-macros
  25. Obsoletes: pLaTeX2e_Macros
  26. Distribution: Vine Linux
  27. Vendor: Project Vine
  28. Packager: munepi
  29. %description
  30. A collection of useful macro packages for texlive package, including
  31. jlisting
  32. jtygm.sty
  33. cmex.enc
  34. # This package contained a perl script
  35. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  36. %description -l ja
  37. TeX Live の便利なマクロパッケージ集です。
  38. 以下のマクロを収録しています。
  39. jlisting
  40. jtygm.sty
  41. cmex.enc
  42. # このパッケージには prosper, powerdot 用に
  43. # PDF ブックマークの文字化けを修正するための perl スクリプト
  44. # http://www.rmatsumoto.org/tex-ps-pdf/convert-euc.txt
  45. # を同梱しています.
  46. %prep
  47. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && %__rm -rf $RPM_BUILD_ROOT
  48. %build
  49. %install
  50. %__rm -rf %{buildroot}
  51. # nkf --utf8 %{SOURCE25} | \
  52. # sed -e "s@^#!/usr/local/bin/perl5 -w@#!/usr/bin/perl -w@" > \
  53. # %{buildroot}%{_bindir}/%{bkmk2uni}
  54. # chmod 755 %{buildroot}%{_bindir}/%{bkmk2uni}
  55. ## install jlisting
  56. %__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting
  57. %__install -m 644 %{SOURCE20} %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/
  58. bunzip2 %{buildroot}%{_tl_texmfvine}/tex/latex/jlisting/jlisting.sty.bz2
  59. ## install jtygm.sty
  60. %__mkdir_p %{buildroot}%{_tl_texmfvine}/tex/platex/base
  61. %__install -m0644 %{SOURCE101} %{buildroot}%{_tl_texmfvine}/tex/platex/base/ || exit 1
  62. ## install cmex.enc
  63. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex
  64. %__install -m0644 %{SOURCE102} %{buildroot}%{_tl_texmfvine}/fonts/enc/pdftex/cmex/ || exit 1
  65. %post
  66. %_tl_touch_run texhash
  67. exit 0
  68. %postun
  69. if [ "$1" = 0 ]; then
  70. %_tl_touch_run texhash
  71. fi
  72. exit 0
  73. %posttrans
  74. %{_tl_exec_texhash}
  75. exit 0
  76. %clean
  77. %__rm -rf $RPM_BUILD_ROOT
  78. %files
  79. %defattr(-,root,root)
  80. #%{_bindir}/%{bkmk2uni}
  81. %{_tl_texmfvine}/tex/latex/jlisting
  82. %{_tl_texmfvine}/tex/platex/base/jtygm.sty
  83. %{_tl_texmfvine}/fonts/enc/pdftex/cmex/cmex.enc
  84. %changelog
  85. * Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
  86. - TeX Live 2014
  87. * Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
  88. - rebuilt
  89. * Sun Nov 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
  90. - s/%%{_tl_texmfmain}/%%{_tl_texmfvine}/g
  91. * Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
  92. - TeX Live 2013
  93. - dropped jsclasses: texlive-collection-langcjk provides jsclasses
  94. - dropped kanjifonts-3.1: obsolete
  95. * Sat Nov 24 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  96. - TeX Live 2012
  97. * Thu Feb 9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  98. - move jlisting package to %%{texmf}/tex/latex/jlisting
  99. * Thu Dec 1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  100. - updated jsclasses to 110510
  101. - mistook to change %%jsclasses_ver at 2011-1
  102. * Sun Nov 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  103. - TeX Live 2011
  104. - updated jsclasses to 110510
  105. * Fri Dec 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  106. - dropped BuildRequires: jvf
  107. - for vl5, added Conflicts: tetex-macros
  108. * Tue Aug 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  109. - removed %%{exec_updmap} in %%post and %%postun
  110. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  111. - ported from tetex-macros-3.0-7
  112. - TeX Live 2009
  113. * Mon Oct 12 2009 Munehiro Yamamoto <munepi@vinelinux.org> 3.0-7
  114. - added BuildRequires: unzip
  115. - updated jsclasses to 090826
  116. - updated pict2e to 0.2x
  117. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-6
  118. - dropped epsbox.sty, eclepsf.sty
  119. (bacause there style files for platex209 are obsolete)
  120. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-5
  121. - added jlisting v0.2
  122. - defined list_macros
  123. - used %%{list_macros} in %%description and %%description -l ja
  124. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-4
  125. - dropped convert-euc.txt
  126. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-3
  127. - updated prosper
  128. - added some contrib themes from CTAN
  129. - added prosper.cls v1.6 from CVS HEAD
  130. - added a perl script: convert-euc.txt
  131. - added powerdot v1.3
  132. - added xkeyval v2.5d
  133. - added beamer v3.07
  134. - added pgf v2.00
  135. - added pict2e v0.2w
  136. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.0-2
  137. - updated jsclasses to 20090222
  138. - updated jsclasses/index.html to 2009-02-22
  139. - removed /usr/share/texmf/dvips/config/extmap/morisawa.map (See [BTS:524])
  140. * Wed Sep 03 2008 Shu KONNO <owa@bg.wakwak.com> 3.0-1vl5
  141. - applied new versioning policy, spec in utf-8
  142. * Mon Oct 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl3
  143. - update jsclasses/index.html to 2006-11-06.
  144. * Fri May 19 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl2
  145. - update jsclasses/index.html to 2006-02-12.
  146. * Sun Nov 06 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl1
  147. - update jsclasses/index.html to 2005-10-26.
  148. * Sat Jun 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.0-0vl0.1
  149. - update jsclasses/index.html to 2005-4-30.
  150. - added breqn
  151. * Tue Jan 18 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl7
  152. - update jsclasses/index.html to 2004-12-29.
  153. * Mon Jan 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  154. - add missing files in kanjifonts-3.0
  155. * Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl6
  156. - update to kanjifonts.sty-3.0.
  157. * Mon Nov 29 2004 KOBAYASHI Taizo <tkoba@vinelinux.org> 2.0-0vl4
  158. - update jsclasses/index.html to 2004-11-03.
  159. * Sat Oct 16 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl3
  160. - update jsclasses/index.html to 2004-09-27.
  161. * Sat Apr 17 2004 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl2
  162. - update jsclasses/index.html to 2004-02-25.
  163. - added eclepsf.sty.
  164. - removed epsf.sty (symlink to epsbox.sty).
  165. - removed geometry, which is in tetex-2.0.
  166. * Fri Apr 18 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0vl1
  167. - update jsclasses/index.html to 2003-04-18.
  168. - added morisawa.dvi.
  169. * Fri Mar 14 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t2
  170. - update jsclasses/index.html to 2003-03-06
  171. * Mon Feb 3 2003 Nobuyuki Tsuchimura <tutimura@nn.iij4u.or.jp> 2.0-0t1
  172. - remove natbib, which is in tetex-2.0
  173. - let version number same as tetex
  174. - added Requires: tetex
  175. * Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl9
  176. - update jsclasses/index.html to 2003-01-16
  177. * Mon Jan 13 2003 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl8
  178. - update jsclasses to 2003-01-05
  179. - update index.html to 2003-01-12
  180. * Thu Nov 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl7
  181. - update jsclasses and index.html to 2002-11-27
  182. * Sun Nov 03 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl6
  183. - update jsclasses and index.html to 2002-11-01
  184. * Thu Oct 17 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl5
  185. - oops, packager was incorrect
  186. * Mon Jul 15 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl4
  187. - update jsclasses to 2002-06-29
  188. - update index.html to 2002-07-03
  189. * Sun Apr 28 2002 KAZUKI SHIMURA <rito@pos.to> 1.1-0vl3
  190. - update jsclasses to 2002-04-21
  191. - update index.html to 2002-04-09
  192. * Tue Apr 16 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.1-0vl2
  193. - added MORISAWA basic 5 fonts
  194. * Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 1.1-0vl1
  195. - update to kanjifonts-1.1
  196. * Thu Feb 07 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl11
  197. - update jsclasses and index.html to 2002-02-07
  198. * Thu Jan 31 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl10
  199. - update jsclasses and index.html to 2002-01-27
  200. - fix typo in changelog
  201. * Fri Jan 25 2002 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl9
  202. - update jsclasses and index.html to 2002-01-18
  203. * Tue Dec 18 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl8
  204. - update index.html (jsclasses)
  205. * Sat Dec 15 2001 KAZUKI SHIMURA <rito@pos.to> 1.0-0vl7
  206. - update jsclasses to 2001-11-29
  207. * Sun Sep 16 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.0-0vl6
  208. - fixed spec file for Prosper and jsclasses
  209. - use RPM macro in %files
  210. - added BuildPrereq: jvf
  211. * Mon Sep 10 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl5
  212. - move revtex4 to texmacro-aps package
  213. * Sun Sep 9 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl4
  214. - added prosper jsclasses
  215. * Thu Sep 6 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0-0vl3
  216. - added revtex4 natbib
  217. * Mon Sep 3 2001 Jun Nishii <jun@vinelinux.org> 1.0-0vl2
  218. - remove prereq tetex to avoid dependency-loop
  219. * Wed Aug 1 2001 Jun Nishii <jun@vinelinux.org>
  220. - tetex-macros-1.0-0vl1
  221. * Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
  222. - 2.0-2
  223. - added kanjifonts-1.0 and removed jisfontsmetric
  224. * Sun Jan 9 2000 Jun Nishii <jun@vinelinux.org>
  225. - 2.0-1
  226. - install ldf in babel
  227. * Sat Jan 8 2000 Jun Nishii <jun@vinelinux.org>
  228. - added jisfontmetric.tex
  229. * Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
  230. - change group.
  231. * Sun Oct 17 1999 Jun Nishii <jun@flatout.org>
  232. - added babel
  233. * Fri Aug 27 1999 Jun Nishii <jun@flatout.org>
  234. - added hoekwater
  235. * Tue Aug 3 1999 Jun Nishii <jun@flatout.org>
  236. - added psfrag
  237. * Mon Jun 21 1999 Jun Nishii <jun@flatout.org>
  238. - added psnfss
  239. - Change directory tree according to the suggestion by Dr.Okumura.
  240. - remove many files from packages directory except documentations
  241. - disable mktexlsr and erase ls-R
  242. * Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
  243. - added url.sty
  244. * Thu Dec 3 1998 Jun Nishii <jun@flatout.org>
  245. - pLaTeX2e_Macros-1-2
  246. - added fancyhdr.sty, boxedminipage.sty
  247. - added graphics.cfg, color.cfg (use dvips as default)
  248. - symlink from epsbox to epsf
  249. * Mon Nov 9 1998 Jun Nishii <jun@flatout.org>
  250. - pLaTeX2e_Macros-1-1
  251. (rename as pLaTeX2e_Macros from pLaTeX-Classes)
  252. - added def files of graphics
  253. - added tools and hyperref
  254. - check the existence of mktexlsr
  255. * Mon Oct 5 1998 Jun Nishii <jun@flatout.org>
  256. - buildarch: noarch
  257. - added requires
  258. * Tue Sep 29 1998 Jun Nishii <jun@flatout.org>
  259. - tiny bug fix and add %defattr
  260. * Wed Sep 23 1998 Jun Nishii <jun@flatout.org>
  261. - first version fo platex-19980901