ffmpeg-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366
  1. #TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. %define with_faac 1
  5. %define with_vaapi 1
  6. %define with_libvpx 1
  7. #% define enable_avconv 1
  8. %define use_prebuilt_man 1
  9. Summary: Digital VCR and streaming server
  10. Name: ffmpeg
  11. Version: 0.11
  12. Release: 1%{?svndate:.%svndate}%{?_dist_release}
  13. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  14. # pre-built man files
  15. #$ tar Jcvf ~/rpm/SOURCES/ffmpeg/ffmpeg-0.10-doc.tar.xz ffmpeg-0.10/doc/*.html ffmpeg-0.10/doc/*.pod ffmpeg-0.10/doc/*.1
  16. %{?use_prebuilt_man:Source90: ffmpeg-%{version}-doc.tar.xz}
  17. %if 0%{?_with_amr:1}
  18. License: GPLv3+
  19. %else
  20. License: GPLv2+
  21. %endif
  22. Group: Applications/Multimedia
  23. URL: http://ffmpeg.org/
  24. BuildRequires: bzip2-devel
  25. BuildRequires: celt-devel
  26. ##BuildRequires: dirac-devel
  27. BuildRequires: freetype2-devel
  28. BuildRequires: gsm-devel
  29. BuildRequires: imlib2-devel
  30. BuildRequires: libdc1394-devel
  31. BuildRequires: libogg-devel
  32. BuildRequires: libass-devel
  33. %{!?_without_cdio:BuildRequires: libcdio-devel}
  34. #libcrystalhd is currently broken
  35. %{?_with_crystalhd:BuildRequires: libcrystalhd-devel}
  36. BuildRequires: libraw1394-devel
  37. BuildRequires: librtmp-devel >= 2.3
  38. BuildRequires: libtheora-devel
  39. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  40. BuildRequires: libvdpau-devel
  41. BuildRequires: libvorbis-devel
  42. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.6}
  43. BuildRequires: libXvMC-devel
  44. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
  45. %{!?_without_openal:BuildRequires: openal-soft-devel}
  46. %{?_with_opencv:BuildRequires: opencv-devel}
  47. %{?_with_openjpeg:BuildRequires: openjpeg-devel}
  48. ##BuildRequires: schroedinger-devel
  49. BuildRequires: SDL-devel
  50. BuildRequires: speex-devel
  51. %{!?use_prebuilt_man:BuildRequires: texi2html}
  52. BuildRequires: zlib-devel
  53. BuildRequires: yasm
  54. # *-devel packages provided by other self-build-* should only be listed
  55. # in self-build-%{name}.spec as PreReq.
  56. #BuildRequires: a52dec-devel
  57. #BuildRequires: faac-devel
  58. #BuildRequires: lame-devel
  59. #BuildRequires: libdca-devel
  60. #BuildRequires: x264-devel >= 0.0.0-18.20111216
  61. #BuildRequires: xvidcore-devel
  62. Requires: %{name}-libs = %{version}-%{release}
  63. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  64. Obsoletes: ffmpeg < %{version}, ffmpeg-libs < %{version}, ffmpeg-devel < %{version}
  65. %description
  66. FFMpeg is a complete and free Internet live audio and video
  67. broadcasting solution for Linux/Unix. It also includes a digital
  68. VCR. It can encode in real time in many formats including MPEG1 audio
  69. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  70. %package libs
  71. Summary: Libraries for %{name}
  72. Group: System Environment/Libraries
  73. %description libs
  74. FFMpeg is a complete and free Internet live audio and video
  75. broadcasting solution for Linux/Unix. It also includes a digital
  76. VCR. It can encode in real time in many formats including MPEG1 audio
  77. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  78. This package contains the libraries for %{name}.
  79. %package devel
  80. Summary: Development package for %{name}
  81. Group: Development/Libraries
  82. Requires: %{name}-libs = %{version}-%{release}
  83. Requires: pkgconfig
  84. %description devel
  85. FFMpeg is a complete and free Internet live audio and video
  86. broadcasting solution for Linux/Unix. It also includes a digital
  87. VCR. It can encode in real time in many formats including MPEG1 audio
  88. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  89. This package contains development files for %{name}.
  90. %prep
  91. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  92. %{?use_prebuilt_man:tar -C .. -xf %{SOURCE90}}
  93. %build
  94. %ifarch ppc
  95. # compile with -mlongcall on ppc/ppc64 (rf804)
  96. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  97. %endif
  98. ./configure \
  99. --prefix=%{_prefix} \
  100. --incdir=%{_includedir}/%{name} \
  101. --shlibdir=%{_libdir} \
  102. --libdir=%{_libdir} \
  103. --mandir=%{_mandir} \
  104. --arch=%{_target_cpu} \
  105. %ifarch %{ix86}
  106. --cpu=%{_target_cpu} \
  107. %endif
  108. %ifarch ppc
  109. --cpu=g3 \
  110. --enable-pic \
  111. %endif
  112. --enable-runtime-cpudetect \
  113. --extra-cflags="$RPM_OPT_FLAGS" \
  114. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
  115. --enable-bzlib \
  116. %{!?_with_crystalhd:--disable-crystalhd} \
  117. --enable-zlib \
  118. %{?_with_frei0r:--enable-frei0r} \
  119. --enable-gnutls \
  120. --enable-libass \
  121. %{!?_without_cdio:--enable-libcdio} \
  122. --enable-libcelt \
  123. --enable-libdc1394 \
  124. %{?_with_libdirac:--enable-libdirac} \
  125. %{?with_faac:--enable-libfaac --enable-nonfree} \
  126. --enable-libfreetype \
  127. --enable-libgsm \
  128. --enable-libmp3lame \
  129. %{!?_without_openal:--enable-openal} \
  130. %{?_with_opencv:--enable-libopencv} \
  131. %{?_with_openjpeg:--enable-libopenjpeg} \
  132. --enable-librtmp \
  133. --enable-libspeex \
  134. --enable-libtheora \
  135. --enable-libvorbis \
  136. %{?with_libvpx:--enable-libvpx} \
  137. --enable-libx264 \
  138. --enable-libxvid \
  139. \
  140. --enable-x11grab \
  141. --enable-avfilter \
  142. --enable-postproc \
  143. --enable-pthreads \
  144. --disable-static \
  145. --enable-shared \
  146. --enable-gpl \
  147. %{?use_prebuilt_man:--disable-doc} \
  148. --disable-debug \
  149. --disable-stripping \
  150. \
  151. %{?enable_avconv:--enable-avconv} \
  152. ;
  153. %__make %{?_smp_mflags}
  154. %__make alltools
  155. %install
  156. %__make install DESTDIR=$RPM_BUILD_ROOT
  157. ## install tool/qt-faststart
  158. %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  159. ## install man
  160. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  161. %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  162. %clean
  163. %{__rm} -rf $RPM_BUILD_ROOT
  164. %post libs -p /sbin/ldconfig
  165. %postun libs -p /sbin/ldconfig
  166. %files
  167. %defattr(-,root,root,-)
  168. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  169. %{?enable_avconv:%{_bindir}/avconv}
  170. %{_bindir}/ffmpeg
  171. %{_bindir}/ffplay
  172. %{_bindir}/ffprobe
  173. %{_bindir}/ffserver
  174. %{_bindir}/qt-faststart
  175. %{?enable_avconv:%{_mandir}/man1/avconv.1*}
  176. %{_mandir}/man1/ffmpeg.1*
  177. %{_mandir}/man1/ffplay.1*
  178. %{_mandir}/man1/ffprobe.1*
  179. %{_mandir}/man1/ffserver.1*
  180. %{_datadir}/ffmpeg
  181. %files libs
  182. %defattr(-,root,root,-)
  183. %{_libdir}/lib*.so.*
  184. %files devel
  185. %defattr(-,root,root,-)
  186. %doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
  187. %{_includedir}/ffmpeg
  188. %{_libdir}/pkgconfig/lib*.pc
  189. %{_libdir}/lib*.so
  190. %changelog
  191. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  192. - new upstream release
  193. * Sat Feb 18 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10-1
  194. - new upstream release
  195. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  196. - new upstream release
  197. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  198. - new upstream release
  199. - enable CELT decoding via libcelt
  200. - enable FreeType support
  201. - drop faad2 support (dropped upstream)
  202. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  203. - change release to sync with self-build-ffmpeg-vl.spec
  204. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  205. - new upstream release
  206. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  207. - new upstream release
  208. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  209. - required latest x264 build
  210. - added BuildRequires: librtmp-devel >= 2.3
  211. - build PIC objects on PPC
  212. #- add qt-faststart tool
  213. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  214. - new upstream release
  215. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  216. - change release to sync with self-build-ffmpeg-vl.spec
  217. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  218. - added BuildRequires: libvpx-devel >= 0.9.1
  219. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  220. - new upstream release
  221. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  222. - bumped version to pre-0.6
  223. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  224. - updated source snapshot 20100410
  225. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  226. - change release to sync with self-build-ffmpeg-vl.spec
  227. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  228. - change release to sync with self-build-ffmpeg-vl.spec
  229. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  230. - updated source snapshot 20100401
  231. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  232. - updated source snapshot 20100326
  233. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  234. - change release to sync with self-build-ffmpeg
  235. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  236. - updated source snapshot 20100216
  237. - rebuild with recent x264-devel
  238. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  239. - added BuildRequires: libvdpau-devel
  240. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  241. - change release to sync with self-build-ffmpeg
  242. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  243. - change release to sync with self-build-ffmpeg
  244. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  245. - applied ffmpeg-0.5-disable-texi2html.patch
  246. - dropped BuildRequires: texi2html
  247. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  248. - change release to sync with self-build-ffmpeg
  249. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  250. - corrected release number
  251. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  252. - new upstream release
  253. - added BuildRequires:
  254. - speex-devel
  255. - bzip2-devel
  256. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  257. - 20090227 snapshot
  258. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  259. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  260. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  261. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  262. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  263. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  264. - 20090202 snapshot
  265. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  266. - 20090110 snapshot
  267. - dropped some patches
  268. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  269. - source updated (r15488)
  270. - fixed License: GPLv2+
  271. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  272. - added BuildRequires: yasm (only %%ix86)
  273. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  274. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  275. - spec in utf8
  276. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  277. - change release to sync with self-build-ffmpeg
  278. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  279. - drop "Patch100: ffmpeg-vine.patch".
  280. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  281. - build with new versioning policy
  282. - change to use svn export from svn checkout on post install
  283. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  284. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  285. - [self-build-ffmpeg.spec]
  286. For all pre-required package that is provied by self-build,
  287. changed to its self-build package
  288. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  289. - initial build for Vine Linux 4.2
  290. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  291. ### end of file