self-build-ffmpeg-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329
  1. %global gpac_postinstall \
  2. gpac_postinstall_sh=$(mktemp) && \
  3. rpm -q --scripts self-build-gpac | \
  4. /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
  5. /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
  6. %global pkgname ffmpeg
  7. %global name self-build-%{pkgname}
  8. %global version 0.11
  9. #% define svndate 20110326
  10. %global release 1%{?svndate:.%svndate}%{?_dist_release}
  11. %global sourceurl0 http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  12. %global with_faac 1
  13. %global with_vaapi 1
  14. %global with_libvpx 1
  15. #% define enable_avconv 1
  16. %define use_prebuilt_man 1
  17. Summary: Package to automatically build %{pkgname} rpm package
  18. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  19. Name: %{name}
  20. Version: %{version}
  21. Release: %{release}
  22. Source0: %{pkgname}-vl.spec
  23. #Source1: %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  24. # pre-built man files
  25. %{?use_prebuilt_man:Source90: ffmpeg-%{version}-doc.tar.xz}
  26. License: GPLv2+
  27. Group: Restricted Software
  28. Obsoletes: ffmpeg < %{version}, ffmpeg-libs < %{version}, ffmpeg-devel < %{version}
  29. Obsoletes: self-build-ffmpeg < %{version}
  30. Requires(post): self-build-setup >= 0.9.9
  31. #Requires(post): subversion
  32. # (build)requies of target package.
  33. Requires(post): bzip2-devel
  34. Requires(post): celt-devel
  35. ##Requires(post): dirac-devel
  36. Requires(post): freetype2-devel
  37. Requires(post): gsm-devel
  38. Requires(post): imlib2-devel
  39. Requires(post): libdc1394-devel
  40. Requires(post): libogg-devel
  41. Requires(post): libass-devel
  42. %{!?_without_cdio:Requires(post): libcdio-devel}
  43. #libcrystalhd is currently broken
  44. %{?_with_crystalhd:Requires(post): libcrystalhd-devel}
  45. Requires(post): libraw1394-devel
  46. Requires(post): librtmp-devel >= 2.3
  47. Requires(post): libtheora-devel
  48. %{?with_vaapi:Requires(post): libva-devel >= 0.31.0}
  49. Requires(post): libvdpau-devel
  50. Requires(post): libvorbis-devel
  51. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.6}
  52. Requires(post): libXvMC-devel
  53. %{?_with_opencore_amr:Requires(post): opencore-amr-devel vo-amrwbenc-devel}
  54. %{!?_without_openal:Requires(post): openal-soft-devel}
  55. %{?_with_opencv:Requires(post): opencv-devel}
  56. %{?_with_openjpeg:Requires(post): openjpeg-devel}
  57. ##Requires(post): schroedinger-devel
  58. Requires(post): SDL-devel
  59. Requires(post): speex-devel
  60. ##Requires(post): texi2html
  61. Requires(post): zlib-devel
  62. Requires(post): libogg-devel
  63. Requires(post): yasm
  64. Requires(post): self-build-a52dec
  65. Requires(post): self-build-faac
  66. Requires(post): self-build-faad2
  67. Requires(post): self-build-lame
  68. Requires(post): self-build-libdca
  69. Requires(post): self-build-x264 >= 0.120
  70. Requires(post): self-build-xvidcore
  71. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  72. BuildArch: noarch
  73. Packager: munepi
  74. %description
  75. FFMpeg is a complete and free Internet live audio and video
  76. broadcasting solution for Linux/Unix. It also includes a
  77. digital VCR. It can encode in real time in many formats
  78. including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
  79. real, mjpeg, and flash.
  80. If you install this package, it automaticaly downloads source
  81. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  82. And the created rpm packages are automatically installed
  83. if installation is executed by apt-get command or synaptic
  84. package manager.
  85. [Note]
  86. This package requires many other packages to compile
  87. target software. So it consume more disk space than usual.
  88. Also installation takes longer time because of compilation.
  89. (This will take a few minutes to quarter or half of an hour,
  90. depends on building environment)
  91. [About self-build package]
  92. For some kind of software, distributing of binary package
  93. may viorate the patent or law. Therefore we chose self-build
  94. packge, create binary package on your machine, for such kind
  95. of softwares instead of distributing binary package.
  96. Please obey the national law when you use the created binary
  97. packages. And if you want to use the softwares using patented
  98. thechnology, it may be required to get a permission, make an
  99. agreement or purchas a license. Please consider it with your
  100. purpose or way of use and take appropriate action.
  101. %description -l ja
  102. FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
  103. ブオーティオ・ビデオブロードキャスティングソリューションです.
  104. またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
  105. MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
  106. 多様なフォーマットをリアルタイムにエンコードすることができます.
  107. このパッケージをインストールすると、自動的にソースコードを
  108. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  109. の rpm パッケージを作成します。
  110. また apt-get コマンドや synaptic パッケージマネージャから実行
  111. した場合は、作成された rpm パッケージのインストールも自動的に
  112. 行います。
  113. [注意]
  114. コンパイルに必要な多くの関連パッケージを要求するので通常より
  115. ディスクの領域を多く消費します。
  116. またインストール時にコンパイルを行うため、通常より時間がかか
  117. る場合があります。(環境にもよりますが数分から数十分程度)
  118. [self-build パッケージについて]
  119. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  120. 違反する可能性があるものがあります。その為、このような問題が
  121. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  122. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  123. ジという方法を採っています。
  124. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  125. アのライセンス、および利用する国の各種法令に従ってください。
  126. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  127. センスの購入などが必要となる場合がありますので、利用する目的
  128. や形態に応じて各自で判断し適切な対応を取ってください。
  129. %prep
  130. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  131. %install
  132. %{__rm} -rf ${RPM_BUILD_ROOT}
  133. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  134. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  135. %{?use_prebuilt_man:%{__install} -m 644 %{SOURCE90} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}}
  136. %clean
  137. %{__rm} -rf ${RPM_BUILD_ROOT}
  138. %posttrans
  139. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 123000
  140. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  141. %{pkgname}-libs-%{version}-%{release} \
  142. %{pkgname}-devel-%{version}-%{release}
  143. ## Rebuild gpac with ffmpeg-devel
  144. # set locale
  145. case $LANG in
  146. ja*)LOCALE=ja ;;
  147. *) LOCALE=C ;;
  148. esac
  149. Rebuild_gpac_C(){
  150. echo -n " "
  151. echo "Rebuild gpac with ffmpeg-devel"
  152. }
  153. Rebuild_gpac_ja(){
  154. echo -n " "
  155. echo "ffmpeg-devel で gpac をリビルドします。"
  156. }
  157. Rebuild_gpac_$LOCALE
  158. %{gpac_postinstall}
  159. %files
  160. %defattr(-,root,root)
  161. %{_datadir}/%{name}
  162. %changelog
  163. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  164. - new upstream release
  165. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  166. - new upstream release
  167. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  168. - new upstream release
  169. - enable CELT decoding via libcelt
  170. - enable FreeType support
  171. - drop faad2 support (dropped upstream)
  172. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  173. - added BuildArch: noarch
  174. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  175. - new upstream release
  176. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  177. - new upstream release
  178. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  179. - required latest x264 build
  180. - added BuildRequires: librtmp-devel >= 2.3
  181. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  182. - new upstream release
  183. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  184. - unpacked source archives
  185. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  186. - fixed some dependencies
  187. - Requires(post): libva-devel
  188. - Requires(post): libvpx-devel >= 0.9.1
  189. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  190. - new upstream release
  191. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  192. - bumped version to pre-0.6
  193. - updated source snapshot 20100410
  194. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  195. - fixed self-build log size
  196. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  197. - added ffprobe.1.gz
  198. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  199. - updated source snapshot 20100401
  200. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  201. - renamed %%{Source0} to ffmpeg-vl.spec
  202. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  203. - updated source snapshot 20100216
  204. - rebuild with recent x264-devel
  205. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  206. - added BuildRequires: libvdpau-devel
  207. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  208. - dropped BuildArch: noarch
  209. - added ffmpeg.1, ffplay.1, ffserver.1
  210. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  211. - avoided to execute self-build-rpm.sh on RPM transaction
  212. - moved %%post actions to %%posttrans
  213. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  214. - added BuildArch: noarch
  215. - added ffmpeg-0.5-disable-texi2html.patch
  216. - dropped PreReq: texi2html
  217. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  218. - added %%{gpac_postinstall} in %%post
  219. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  220. - corrected release number
  221. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  222. - new upstream release
  223. - added PreReq:
  224. - speex-devel
  225. - bzip2-devel
  226. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  227. - change release to sync with ffmpeg
  228. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  229. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  230. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  231. - 20090202 snapshot
  232. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  233. - 20090110 snapshot
  234. - dropped some patches
  235. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  236. - source updated (r15488)
  237. - fixed License: GPLv2+
  238. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  239. - added BuildRequires: yasm (only %%ix86)
  240. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  241. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  242. - spec in utf8
  243. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  244. - run pre-allocate-rpm.sh in %%post
  245. - set PreReq: self-build-setup >= 0.8
  246. - change release number
  247. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  248. - add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
  249. include Source1 in the binary package.
  250. - drop "Source100: ffmpeg-vine.patch".
  251. - drop "PreReq: subversion".
  252. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  253. - build with new versioning policy
  254. - change to use svn export from svn checkout on post install
  255. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  256. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  257. - For all pre-required package that is provied by self-build,
  258. changed to its self-build package
  259. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  260. - initial build for Vine Linux 4.2
  261. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  262. ### end of file