gpac-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349
  1. %define svndate 20111217
  2. %define with_static 1
  3. Name: gpac
  4. Summary: MPEG-4 multimedia framework
  5. Version: 0.4.6
  6. Release: 2%{?svndate:.svn%svndate}%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://gpac.sourceforge.net/
  10. #Source0: http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
  11. Source0: gpac-%{svndate}.tar.bz2
  12. Source9: gpac-snapshot-vine.sh
  13. Patch1: gpac-0.4.6_15-soname.patch
  14. Patch2: gpac-0.4.6-amr.patch
  15. Patch5: gpac-0.4.6-js_cflags.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: ImageMagick
  18. BuildRequires: SDL-devel
  19. BuildRequires: librsvg2-devel >= 2.5.0
  20. BuildRequires: libGLU-devel
  21. BuildRequires: freeglut-devel
  22. BuildRequires: freetype2-devel >= 2.1.4
  23. BuildRequires: libjpeg-devel
  24. BuildRequires: libpng-devel >= 1.2.5
  25. BuildRequires: libxml2-devel
  26. BuildRequires: openssl-devel
  27. #BuildRequires: openjpeg-devel
  28. BuildRequires: pulseaudio-libs-devel
  29. BuildRequires: zlib-devel
  30. BuildRequires: libogg-devel libvorbis-devel libtheora-devel
  31. BuildRequires: libXt-devel
  32. BuildRequires: libXpm-devel
  33. BuildRequires: libXv-devel
  34. #BuildRequires: wxGTK-devel
  35. BuildRequires: xmlrpc-epi-devel
  36. %{?_with_mozilla:BuildRequires: gecko-devel}
  37. #BuildRequires: doxygen
  38. BuildRequires: desktop-file-utils
  39. %{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
  40. # *-devel packages provided by other self-build-* should only be listed
  41. # in self-build-%{name}.spec as PreReq.
  42. #BuildRequires: a52dec-devel
  43. #BuildRequires: faad2-devel
  44. #BuildRequires: libmad-devel
  45. #BuildRequires: xvidcore-devel >= 1.0.0
  46. ##BuildRequires: ffmpeg-devel
  47. %description
  48. GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
  49. from scratch in ANSI C. The original development goal is to provide a clean,
  50. small and flexible alternative to the MPEG-4 Systems reference software.
  51. GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
  52. X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
  53. MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
  54. for MP4 and 3GPP(2) files and many tools for scene descriptions
  55. (MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
  56. %package libs
  57. Summary: Library for %{name}
  58. Group: System Environment/Libraries
  59. %description libs
  60. The %{name}-libs package contains library for %{name}.
  61. %package devel
  62. Summary: Development libraries and files for %{name}
  63. Group: Development/Libraries
  64. Requires: %{name}-libs = %{version}-%{release}
  65. %description devel
  66. Development libraries and files for gpac.
  67. %if %{with_static}
  68. %package devel-static
  69. Summary: Development libraries and files for %{name}
  70. Group: Development/Libraries
  71. Requires: %{name}-devel = %{version}-%{release}
  72. %description devel-static
  73. Static library for gpac.
  74. %endif
  75. %prep
  76. %setup -q -n gpac
  77. ## remove extra_libs directory
  78. %__rm -rf extra_libs
  79. %patch1 -p1 -b .soname
  80. %patch2 -p1 -b .amr
  81. %patch5 -p1 -b .jscflags
  82. ## kwizart - enable dynamic mode - hardcoded with patch2
  83. # define SONAME number from the first number of gpac version.
  84. #define soname libgpac.so.0
  85. #sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
  86. # Fix encoding warnings
  87. %__cp -p Changelog Changelog.origine
  88. iconv -f ISO-8859-1 -t UTF8 Changelog.origine > Changelog
  89. touch -r Changelog.origine Changelog
  90. %__rm -rf Changelog.origine
  91. %__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
  92. iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine > doc/ipmpx_syntax.bt
  93. touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
  94. %__rm -rf doc/ipmpx_syntax.bt.origine
  95. # executable ./configure
  96. chmod +x configure
  97. %build
  98. %configure \
  99. --X11-path=%{_prefix} \
  100. %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
  101. --enable-pic \
  102. --disable-static \
  103. --disable-wx \
  104. --extra-cflags="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
  105. --disable-oss-audio \
  106. %{?_with_amr:--enable-amr} \
  107. --use-js=no \
  108. ;
  109. # --use-openjpeg=local \
  110. # Parallele build will fail
  111. %__make all OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
  112. #{?_smp_mflags}
  113. %__make sggen OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
  114. #{?_smp_mflags}
  115. # ## kwizart - build doxygen doc for devel
  116. # pushd doc
  117. # doxygen
  118. # popd
  119. %install
  120. %__rm -rf $RPM_BUILD_ROOT
  121. %__make DESTDIR=$RPM_BUILD_ROOT install install-lib
  122. #hack
  123. %if %{_lib} == "lib64"
  124. %__mv $RPM_BUILD_ROOT%{_prefix}/lib $RPM_BUILD_ROOT%{_libdir}
  125. %endif
  126. ## kwizart - rpmlint gpac no-ldconfig-symlink
  127. #%__ln_s -f libgpac.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
  128. %__ln_s -f libgpac.so.%{version}-DEV $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
  129. %__ln_s -f libgpac.so.0 $RPM_BUILD_ROOT%{_libdir}/libgpac.so
  130. #Install generated sggen binaries
  131. for b in MPEG4 SVG X3D; do
  132. pushd applications/generators/${b}
  133. %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir}
  134. popd
  135. done
  136. # #Fix doxygen timestamp
  137. # touch -r Changelog doc/html/*
  138. %clean
  139. %__rm -rf $RPM_BUILD_ROOT
  140. %post libs -p /sbin/ldconfig
  141. %postun libs -p /sbin/ldconfig
  142. %files
  143. %defattr(-,root,root,-)
  144. %doc AUTHORS BUGS Changelog COPYING README TODO
  145. %{_bindir}/MP4*
  146. %{_bindir}/*Gen
  147. %{_datadir}/gpac/
  148. %{_mandir}/man1/*.1.*
  149. %files libs
  150. %defattr(-,root,root)
  151. %{_libdir}/libgpac.so.*
  152. %{_libdir}/gpac/
  153. %files devel
  154. %doc doc/CODING_STYLE doc/ipmpx_syntax.bt
  155. %defattr(-,root,root)
  156. %{_includedir}/gpac/
  157. %{_libdir}/libgpac.so
  158. %if %{with_static}
  159. %files devel-static
  160. %defattr(-,root,root,-)
  161. %{_libdir}/libgpac_static.a
  162. %else
  163. %exclude %{_libdir}/libgpac_static.a
  164. %endif
  165. %changelog
  166. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
  167. - rebuild
  168. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
  169. - update snapshot svn20111217
  170. - removed upstreamed/obsolated patches
  171. * Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
  172. - rebuilt with internal openjpeg
  173. - added --use-openjpeg=local in configure options
  174. - added --enable-pic in configure options
  175. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
  176. - rebuild
  177. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
  178. - removed doxygen support
  179. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
  180. - change release to sync with self-build-gpac
  181. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
  182. - rebuild
  183. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
  184. - added --use-js=no in configure
  185. - added devel-static subpackage
  186. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
  187. - change release to sync with self-build-gpac
  188. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
  189. - change release to sync with self-build-gpac
  190. * Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
  191. - applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
  192. - corrected default %%defattr
  193. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
  194. - dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
  195. - rebuilt with ffmpeg-devel by self-build-ffmpeg
  196. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
  197. - initial build based on RPM Fusion
  198. - without Osmo4 and its plugins for Mozilla browsers
  199. - added --disable-wx in configure options
  200. - included %%{_libdir}/libgpac_static.a in devel subpackage
  201. * Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
  202. - Fix -devel doc timestamp which leads to multilib conflict
  203. ( RPM Fusion #270 )
  204. * Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
  205. - Fix for ppc64
  206. * Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
  207. - Update to 0.4.5 (final)
  208. - Drop upstreamed patches - Rewrite some
  209. - Add More BR.
  210. - Conditionalize --with mozilla amr
  211. * Mon Sep 8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
  212. - Fix for Large File Support (was livna #2075 )
  213. * Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
  214. - Enable devel-static
  215. - Conditionalize Osmo4 (buggy).
  216. - Clean the spec
  217. * Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
  218. - Update to 20080217.
  219. - Split libs.
  220. - Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
  221. - Add openjpeg-devel missing BR
  222. - Static patching instead of dyn patch when possible.
  223. - Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
  224. - Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
  225. - Exclude static lib
  226. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
  227. - Use %%{smp_mflags}
  228. - Oops, we're actually 0.4.5
  229. - Fix gpac so filenames
  230. - Only install nposmozilla when %%{with_firefox} is set
  231. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
  232. - Update to 20080211cvs
  233. - Disable osmozilla, doesn't build with xulrunner
  234. - Fix builds with gcc 4.3
  235. * Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
  236. - Rebuild for rawhide
  237. * Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
  238. - Update to v4.4
  239. * Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
  240. - Update to cvs 20070526
  241. - Enable conditional build ( 3gpp firefox )
  242. * Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
  243. - Update to cvs 20070411
  244. * Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
  245. - Update to 20061208
  246. - Uses firefox-devel (since fc6!)
  247. - Drop tutorial
  248. - Use version-DEV-date with libgpac.so
  249. - Disabled osmozilla
  250. - Fix soname
  251. - Enabled gprof
  252. * Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
  253. - gpac snapshot.sh
  254. - Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
  255. - TODO: - no-soname make option for libgpac.so
  256. - static lib in devel - needed ?
  257. - osmozilla - xpt link problem.
  258. - Osmo4: segmentation fault on exit.
  259. - MP4Client: segmentation fault on launch.
  260. - The program 'Osmo4' received an X Window System error:
  261. "The error was 'BadMatch (invalid parameter attributes)'.
  262. (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
  263. - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
  264. * Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
  265. - Update to 0.4.2cvs20061017
  266. - Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
  267. - Enable mozilla plugin: osmozilla.
  268. - Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
  269. - Provide documentation html in doc .
  270. - Provide tutorial from http://www.wildamerica.com/pages/Marty.html
  271. - Various corrections.
  272. * Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
  273. - lib64 fixes
  274. * Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
  275. - initial package